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IBM Cúram Archiving

IBM® Cúram Archiving provides the ability to archive historical data in its original
business context, as well as to query and restore the data. IBM Cúram Archiving
works with IBM InfoSphere® Optim™ Archive Enterprise Edition to provide a set of
Cúram templates for the archival of business and technical objects including tables
and relationships, and selection criteria to identify all records that should be
moved into an archiving environment.

Note: The IBM Cúram Archiving documentation refers to the Optim tool as IBM
InfoSphere Optim Archive Enterprise Edition. However, the documentation
includes links to generic Optim documentation where the Optim tool is referred to
as InfoSphere Optim Data Growth Solution.

Installing IBM Cúram Archiving
This topics in this section describe how to install IBM Cúram Archiving .

Introduction to IBM Cúram Archiving
This guide describes how to install and configure IBM Cúram Archiving for IBM
Cúram Social Program Management. As part of the installation and configuration
process, you must also install the IBM InfoSphere Optim Archive Enterprise
Edition solution, which is the core archiving technology used.

The Optim Archive solution uses the Graphical User Interface (GUI), which can
archive or process data in most platforms and data sources.

Solution components
IBM Cúram Archiving consists of two components, which are the Optim Archive
solution and the Optim access definitions.

You must install the Optim Archive solution, which provides the core archiving
technology, as part of the installation and configuration process. The Optim access
definition files are required to execute archive and restore processing.

See “Installing and configuring the Optim Archive solution components” on page
2.

For information about configuring the Optim Archive solution for IBM Cúram
Social Program Management, see Importing the Optim Access Definition files for
IBM Cúram Archiving.

Hardware and software requirements
The recommended configuration (for optimum performance) uses a server
dedicated to database processing.

For the hardware and software requirements related to all the supported operating
environments, see the Detailed System Requirements document.

Archiving in IBM Cúram Social Program Management
IBM Cúram Archiving archives and restores data within the Cúram database.

© Copyright IBM Corp. 2016, 2017 1

http://www.ibm.com/support/docview.wss?uid=swg27041700


IBM Cúram Archiving provides access definitions that define the data to be
archived for a set of Cúram templates.

The following is a list of the Cúram templates.
v AuthenticationLog
v AuthorisationLog
v CaseEvent
v CaseTransactionLog
v CREOLECaseDeterminationData
v CREOLEProgramRecommendationData
v PrecedentChangeSet
v ProcessInstance

Installing and configuring the Optim Archive solution
components

IBM Cúram Archiving provides capabilities to archive historical transaction records
from mission-critical database applications.

IBM Cúram Archiving allows you to do the following:
v Extract sets of relational data from one or more databases and store the data for

future use.
v Archive old data in a precise manner and optimize production databases for

peak performance.
v Browse or selectively restore archived data as needed.

For more information, see InfoSphere Optim Data Growth Solution.

Installing the Optim Archive solution components
To install the Optim Archive solution components, refer to the information in the
IBM InfoSphere Optim Archive Enterprise Edition product documentation. Note
the requirements that relate to the extraction of the installation files.

When you install IBM Cúram Archiving , extract the IBM Curam Archiving
Install.zip file so that the swidtag directory is copied directly into the
Optim_Root_Installation directory. If you extract the IBM Curam Archiving
Install.zip file to a different location, then you must manually copy the swidtag
directory to the Optim_Root_Installation directory. By default, the
Optim_Root_Installation directory is in the following directory:

Windows
C:\IBM\InfoSphere\Optim

Linux /opt/IBM/InfoSphere/Optim

InfoSphere Optim solution components

Installing InfoSphere Optim solution components

Configuring the Optim Archive solution components
To configure the Optim Archive solution components, refer to the information in
the IBM InfoSphere Optim Archive Enterprise Edition product documentation.

Configuring InfoSphere Optim solution components
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Configuring InfoSphere Optim Designer:

Refer to the IBM Knowledge Center for detailed information about how to
configure Optim Designer.

Configuring Optim Designer

Configuring the Optim Archive solution for an Optim directory:

Use the Configuration feature to configure the Optim Archive solution for an
Optim directory.

Optim Designer supports only those Optim directories that use Unicode characters
and the following DBMSs:
v IBM DB2® for Linux, UNIX, Windows v9.5 and above
v Oracle v11.1 and above
v Microsoft SQL Server v2008 and above

For detailed instructions about how to configure the Optim Archive solution for an
Optim directory, see Configuring IBM InfoSphere Optim for an Optim Directory.

Importing Optim access definitions and upgrading Optim directory objects:

Optim provides links to detailed information about how to import Optim access
definitions and upgrade Optim directory objects.

Importing the Optim Access Definition files for IBM Cúram Archiving

Upgrading Optim directory objects

Configuring the server:

The server processes the service requests made from the other components.

Before the server can accept service requests, you must configure the server for
your environment. The process through which you configure the server depends
on the operating system on which the server is installed.

See the detailed information about configuring the server.

Configuring InfoSphere Optim Connection Manager, InfoSphere Optim
Manager, and InfoSphere Optim Service Interface:

Optim Connection Manager, Optim Manager, and Optim Service Interface are the
web applications that must be deployed to a Java EE-compliant application server.

See the detailed information about configuring the connection manager, the
manager, and the service interface.

Managing the Optim Archive solution
The Optim Archive solution provides several functions.

The functions include the following:
v Archive the relationally intact data set subjected to business rules.
v Delete the data that are identified as candidate records during the archive

process.
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v Restore the data to production database if necessary.

See the detailed information about managing data growth.

Designing data management processes with Optim Designer:

You can use Optim Designer to define data sources, data models and data
management services.

See the detailed information about how to design data management processes with
Optim Designer.

Running test- or production-level services:

You can use Optim Manager with other Optim Archive solution components to run
test- or production-level services that are developed with Optim Designer.

See the detailed information about how to run test- or production-level services.

Installing and configuring the IBM Cúram Archiving solution
IBM Cúram Archiving uses the Optim Archive solution, which can archive or
process data in most platforms and data sources.

Before you install the IBM Cúram Archiving solution, ensure that you have
installed the Optim Archive solution from the Optim installation media. See
Installing InfoSphere Optim solution components.

As part of the configuration, you must create a DB alias for each Cúram database
or instance, giving the DB alias a name that is appropriate for your organization.

The Optim installation creates the Optim directory, a set of database tables that
contain the definitions used by the solution, including the access definitions
distributed with the solution and the relationship definitions developed specifically
for your Cúram environment.

Setting up Optim for IBM Cúram Archiving
The location for installing the Optim Archive solution varies according to the
environment for the Cúram Server.

If the Cúram Server resides on:
v A Windows Server, you must install Optim on the Enterprise Server or the

database server. Optionally, you can install Optim on additional workstations.
v A UNIX Server, you must first install Optim on a Windows workstation. In

addition, you must install and configure the Optim Server on a UNIX Server
(Enterprise Server or database server).

When installing Optim, elect to have the Optim Installation facility place the
product icons on your desktop.

Configuring Optim for IBM Cúram Archiving
This topic contains information about how to configure IBM Cúram Archiving .

Refer to “Installing and configuring the Optim Archive solution components” on
page 2 for more information about configuring the Optim Archive solution.
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Continue the Windows installation process using the Configuration Tool by doing
the following:
v Double-click the Optim Configuration icon on your desktop.
v Click Tasks > Configure the First Workstation on the main menu.

As you proceed through the Configuration dialogs, note the following:
v You must create a DB Alias for each Cúram database or instance.
v To restore data to a secondary archive database or reporting database, you must

create a DB Alias for that secondary database.
v Skip the Create Primary Keys step during configuration.
v Skip the Load/Drop Sample Data step that creates the Optim sample database

during configuration.
v Enable the Optim Server option when configuring the solution on the Cúram

Server.

Note: Do not enable the Optim Server option when configuring the solution on a
client workstation.
v To ensure that you can archive the required data, click Product Options, use the

password “Optim” and change Maximum Extract Rows to 999999999 on the
General tab, and then change Maximum Commit Frequency to 2000 or greater
on the Database tab.

v You must edit Personal Options to set up both a Temporary Work Directory and
a Data Directory.

v If the Cúram Server resides in a UNIX environment, you must install and
configure the Server on UNIX after the Windows installation and configuration
is complete. Follow the instructions in the Optim Installation and Configuration
Guide, Appendix A to install and configure the Optim Server on a UNIX machine.

Importing the Optim Access Definition files for IBM Cúram
Archiving

Access definitions delivered with IBM Cúram Archiving are needed to archive and
restore your Cúram data. The access definitions must be imported from the
Defs\jde_release\Module\DBMS directory on the Optim installation media for
Cúram. The variables in this path are described in the table below.

Note: The instructions on this page apply to all installations of IBM Cúram
Archiving .
AuthorisationLog
AuthenticationLog
CREOLECaseDeterminationData
CaseEvent
CREOLEProgramRecommendationData
CaseTransactionLog
PrecedentChangeSet
ProcessInstance

Table 1.

Parameter Version Description

Cúram_release 7.0 The installed Cúram release. The module for which
you want to archive data.

Template ASN AuthorisationLog

ATN AuthenticationLog
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Table 1. (continued)

Parameter Version Description

CCDD CREOLECaseDeterminationData

CE CaseEvent

CPR CREOLEProgramRecommendationData

CTL CaseTransactionLog

PCS PrecedentChangeSet

PI ProcessInstance

DBMS DB2 LUW IBM DB2 for Linux, Unix, and Windows

DB2 for z/OS IBM DB2 for Mainframe Systems

ORACLE Oracle Database

Note: See Archiving in IBM Cúram Social Program Management for details on
which templates are supported.

The name of the import file that contains the Access Definition files is based on the
template you want to use to archive data. For example, the name of the import file
for the CaseTransactionLog template is OCUSPM70_CTL.txt.

Using a database where foreign keys are not enabled

If you are using a database where foreign keys are not enabled, import the Access
Definition files for the following templates from the IBM Curam Archiving
Install\Defs\ForeignKeysDisabled directory:
v CREOLECaseDeterminationData

v ProcessInstance

v PrecedentChangeSet

v CREOLEProgramRecommendationData

Using a database where foreign keys are enabled

If you are using a database where foreign keys are enabled, import all Access
Definition files from the IBM Curam Archiving Install\Defs\ directory.

Things to do...

Before you import the Access Definition files, edit the import file that corresponds
to your environment, and then import the Access Definition files. See Editing the
import file and Importing the object definitions.

Editing the import file
Before you import the Optim templates for Cúram, you must edit each file.

About this task

Perform the following to edit the import file.
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Procedure
1. In a text editor, locate and open the IBM Curam Archiving Install\Defs\

OCUSPM70_MODULE_NAME.txt file for your environment, where MODULE_NAME
is the module name. For example, the module name might be OCUSPM70_CE.txt.

2. Replace all occurrences of SRCDBOWNER with the name of the owner or
schema for your database tables.

3. Replace all occurrences of PSTAPP with the name of the DB Alias used to
access your database tables.

4. Save the edited import file on your local machine, and close the file.
5. Note the path for the saved file.
6. Repeat the steps for each template file.

Importing the object definitions
After you edit the import file, import the object definitions.

About this task

Perform the following to import the object definitions.

Procedure
1. Double-click the Optim desktop icon to start the Optim solution.
2. Click Utilities > Import on the Optim main window to display the Optim

import window.
3. Click Input File on the import window and type the path and name of the

import file you saved on your local machine. This is the path you noted in step
6 of “Editing the import file” on page 6.

4. Based on the contents of the import file, the Optim solution enables the
appropriate check boxes in the Definitions tree on the import window to
import the objects. For each of the following check boxes, if the check box is
enabled, ensure that the check box is selected:
v Access Definition

v Archive Request

v Delete Request

v Restore Request

v Relationship

5. Click the Run icon or click File > Run > on the import window to begin the
import process.

Note: The imported definitions may require modification if your Cúram
database has been customized for your site.

6. Click Tools > Show Process Log on the import window to display the import
process log. If any errors are listed on the log, repeat the steps in “Editing the
import file” on page 6 to correct (if needed), and import the object definitions
again.

7. Close the import process log dialog.
8. When the import is completed successfully, close the import dialog.
9. Close the Optim main window.
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Archiving with IBM Cúram Archiving
The topics in this section describe how to archive your files with IBM Cúram
Archiving .

Introduction to IBM Cúram Archiving
IBM Cúram Social Program Management (SPM) users, like the users of most
applications, understand that performance can degrade significantly as database
size grows. Because it is also understood that, as it ages, a large percentage of data
in the database is unlikely to be accessed daily, performance can be greatly
improved if infrequently accessed data is removed from the production
environment.

However, because this older data has significant business value it cannot simply be
purged. The data is best archived and maintained in an active repository so that it
can be retrieved when necessary. This is precisely the value that is provided by
IBM Cúram Archiving .

As an example, a viewpoint that is commonly held by Cúram users is that the
current and previous year’s data must be maintained in the production tables,
while data that are older than two years can be removed. Because it is common for
business analysts to need access to the older data, it can be housed where analysts
can query it; that is, in a mirrored set of archive tables or in a reporting database.

IBM Cúram Archiving uses the IBM InfoSphere Optim Archive Enterprise Edition
as its core archiving technology, which can archive or process data in most
platforms and data sources.

Archiving methods
Archive requests can be performed by using either the Optim Designer or the
Optim Manager interface.

The Optim Archive solution performs all actual processing, with IBM Cúram
Archiving providing Cúram specific templates that are required to carry out
processing against the Cúram database. The Optim Archive solution allows for the
entry of input parameters to specify the data that is to be archived or restored

Archiving using the Optim Archiving Solution:

The Optim Archiving solution is the standard interface for archiving and restoring
data in Cúram.

“Archiving and Restoring data using Optim Archive” on page 9 explains how to
use the Optim Archiving Solution to both archive and restore Cúram data.

Archive processing overview
The Optim Archive solution uses access definitions to define the set of data to be
archived (that is, the set of tables and criteria that are used to select rows). This
document describes the access definitions that are available for a set of Cúram
templates that can be used to archive and restore Cúram business and technical
objects

Because the data for certain Cúram objects is spread across many tables and an
object must meet a number of conditions to be eligible for archival, the solution is
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preconfigured to capture the business rules for candidate objects. The appropriate
access definition is then combined with the user-supplied criteria and applied to
the candidate data.

The solution determines which objects are eligible for archiving and deletion from
the production database based on Cúram rules and the archive criteria you
specified. The solution then begins the extract phase. During that phase, it reads
the selected objects from the Cúram database and writes them to an archive file
before it deletes any data from the database.

After data is archived, an authorized user can access or restore it, as described in
Restore processing overview.

If necessary, you can modify the access definitions to accommodate site-specific
database customizations. Refer to the Optim product documentation for
information about how to customize templates at http://www.ibm.com/support/
knowledgecenter/SSMLNW_11.3.0/com.ibm.nex.optimd.common.doc/04acdefs/
opcommon-c-access_definitions.html. It is also advised that thorough testing be
completed to verify that the use of any customized templates with the Cúram
database will work correctly and not cause any problems within the Cúram
application.

For more information about the archive process, refer to the Optim product
documentation at http://www.ibm.com/support/knowledgecenter/
SSMLNW_11.3.0/com.ibm.nex.optimd.dg.doc/topics/opdg-c-archiving_data.html.

Delete processing overview
Use the delete process to remove subsets of related data from a database.
Specifications for the delete process can be stored as a delete request.

The source file does not change during the delete process and can be used to
reload or restore the deleted data. You can use the delete process in combination
with the archive or extract process to safely remove data from a database.

For more information about the delete process, refer to the Optim product
documentation at http://www.ibm.com/support/knowledgecenter/
SSMLNW_11.3.0/com.ibm.nex.optimd.dg.doc/topics/opdg-c-
defining_data_to_delete.html.

Restore processing overview
After data is archived, an authorized user can restore it to the production database
tables.

The restore process is a two step process. First, the archive file that contains the
data to be restored must be selected and criteria for a selective restore can be
specified. Second, the data is restored to the database with the insert or load
process.

For more information about the restore process, refer to the Optim product
documentation at http://www.ibm.com/support/knowledgecenter/
SSMLNW_11.3.0/com.ibm.nex.optimd.dg.doc/topics/opdg-c-
defining_data_to_restore.html.

Archiving and Restoring data using Optim Archive
The standard way of initiating archive or restore requests is through the use of
Optim Archive, which is the core archiving technology.
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Note: See Archiving methods for more information about the methods that are
available to archive and restore Cúram data.

Before you archive data, confirm that the required Cúram template access
definitions are installed, as described in Archiving by Cúram Template.

Archiving Cúram data by using Optim Archive
This task describes how to archive Cúram data by using Optim Archive.

About this task

For more information about how to archive by using Optim Designer, see the
Optim product documentation at http://www.ibm.com/support/
knowledgecenter/SSMLNW_11.3.0/com.ibm.nex.optimd.dg.doc/topics/opdg-c-
defining_data_to_archive.html

Procedure
1. Open Optim by double-clicking on the Optim icon on your desktop.
2. Click File > Open on the Optim menu bar.
3. When the Open an Archive Request window is displayed, double-click

Archive Request in the Identifier list, and then double-click OCUSPM70,
which is the supplied default value. If you changed that value, then click the
name that you specified. The available archive requests are displayed in the
Name column. Depending on the type of data you archive, the following
archive requests might be listed in the Name column:

Table 2.

Request Name Archive Request for:

OCUSPM70.ARASN AuthorisationLog

OCUSPM70.ARATN AuthenticationLog

OCUSPM70.ARCCDD CREOLECaseDeterminationData

OCUSPM70.ARCE CaseEvent

OCUSPM70.ARCPI ProcessInstance

OCUSPM70.ARCPR CREOLEProgramRecommendation

OCUSPM70.ARCTL CaseTransactionLog

OCUSPM70.ARPCS PrecedentChangeSet

Note: See “Archiving by Cúram Template” on page 13 for information about
the criteria that is used to archive rows for each of the request types.

4. To run one of the archive requests, double-click the appropriate Archive
Request Name. For example, to run the PrecedentChangeSet archive request,
double-click OCUSPM70.ARPCS to open the Archive Request Editor. When
the Archive Request Editor is displayed, confirm that the archive file name is
correct and Defer Delete After Archive option is checked.

5. Click on the Variables tab on the Archive Request Editor. When that tab is
displayed, confirm that the Always prompt for values at run time option is
checked if default values are specified in respective Access definitions
variables tab.

6. Click the Run icon on the Archive Request Editor to start the archive process.
7. When the Archive request displays variables window is displayed, enter the

value date parameter.
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8. When the values are entered, click the OK button for the archive process to
resume processing. The Archive Process Report shows the location of the
archive file, the number of rows that are archived and deleted, and other
information. See “Archive process report” on page 15 for more information
about this report.

9. After you review the Archive Process Report, click File > Close to close the
Archive Process Report, and then click File > Close to close the Archive
Request Editor.

10. If you changed any of the request’s previously saved parameters, a window
appears. Click Yes to save your changes or click No to discard those changes.

Deleting Cúram data by using Optim Archive
Use Optim Archive to delete Cúram data.

About this task

For more information about how to use Optim Designer to delete, see the Optim
documentation at http://www.ibm.com/support/knowledgecenter/
SSMLNW_11.3.0/com.ibm.nex.optimd.dg.doc/topics/opdg-c-
deleting_data_w_optim_designer.html.

Note: A Delete request is not applicable for the CREOLECaseDeterminationData
template due to the nature in which the information is archived. For more
information see “CREOLECaseDeterminationData” on page 13.

Procedure
1. Open Optim by double-clicking on the Optim icon on your desktop.
2. Click File > Open on the Optim menu bar.
3. When the Open Delete Request window is displayed, double-click Delete

Request in the Identifier list, and then double-click OCUSPM70, which is the
supplied default value (if you changed that value, click on the name that you
specified). The available delete requests will then be displayed in the Name
column. Depending on the type of data you archive, the following delete
requests might be listed in the Name column.

Table 3.

Request name Delete Request for ⌂

OCUSPM70.DRASN AuthorisationLog

OCUSPM70.DRATN AuthenticationLog

OCUSPM70.DRCE CaseEvent

OCUSPM70.DRCPI ProcessInstance

OCUSPM70.DRCPR CREOLEProgramRecommendation

OCUSPM70.DRCTL CaseTransactionLog

OCUSPM70.DRPCS PrecedentChangeSet

4. To run one of the above delete requests, double-click on the appropriate Delete
Request Name. To run the PrecedentChangeSet delete request, for example,
double-click OCUSPM70.DRPCS to open the Delete Request Editor. When the
Delete Request Editor is displayed, confirm that the archive file name is
correctly mapped with the delete request editor.
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5. Click the Run icon on the Delete Request Editor to start the Delete process. The
Delete Process Report shows the location of the archive file, the number of
rows deleted, and other information. See Delete Process Report for further
information on this report.

6. After you review the Delete Process Report, click File > Close to close the
Delete Process Report, and then click File > Close to close the Delete Request
Editor.

7. If you changed any of the request’s previously-saved parameters, a pop-up
window will appear. Click Yes to save your changes or click No to discard
those changes.

Restoring Cúram data by using Optim Archive
After data is archived and purged from the production database, you can use the
restore process to restore the archived data to your production database.

About this task

For more information about how to restore using Optim Designer, see the Optim
product documentation at http://www.ibm.com/support/knowledgecenter/
SSMLNW_11.3.0/com.ibm.nex.optimd.dg.doc/topics/opdg-c-
restoring_data_w_optim_designer.html.

Use this procedure to restore archived Cúram data using Optim Archive.

Procedure
1. Double-click OCUSPM70 under the Restore Request heading on the Open a

Restore Request window. (OCUSPM70 is the supplied default value; if you
changed that value, click the name you specified.) The available restore
requests are displayed in the Name column. Data can be restored to your
production database or an archive database. Depending on the type of data you
archive, the following restore requests are listed in the Name column:

Table 4.

Request name Used for this template To Restore data to⌂

OCUSPM70.RRASN_PRD/ AuthorisationLog Production

OCUSPM70.RRATN_PRD/ AuthenticationLog Production

OCUSPM70.RRCCDD_PRD/ CREOLECaseDeterminationDataProduction

OCUSPM70.RRCE_PRD/ CaseEvent Production

OCUSPM70.RRCPI_PRD/ ProcessInstance Production

OCUSPM70.RRCPR_PRD/ CREOLEProgramRecommendationProduction

OCUSPM70.RRCTL_PRD/ CaseTransactionLog Production

OCUSPM70.RRPCS_PRD/ PrecedentChangeSet Production

2. Double-click the PRD Restore Request Name to restore to the Production
database. For example, to run the PrecedentChangeSet restore request and
restore the data to production, double-click OCUSPM70.RRPCS_PRD to open
the Restore Request Editor. When the editor is displayed, right-click on the file
name that is displayed in the Archive File column, and then click Replace
Archive File > File System in the resulting menu.

3. When the Open file browser is displayed, click on the file you want to restore,
then click Open.
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4. When the Restore Request Editor is displayed again, right-click on the Request
Name column, and Add Insert Request in the resulting pop-up window.

5. Select the appropriate request from the Select an Insert Request window.
6. Click the Run icon on the Restore Request Editor to begin the restore process.

When the restore process starts, a Restore Process Progress window opens and
displays information about the status of the restore request.

7. When the restore is complete, a Restore Process Report is displayed. The
Restore Process Report contains general information and statistics about the
restore. See 4.4 Restore Process Report for more information about this report.

8. After you review the Restore Process Report, click File > Close to close the
Restore Process Report, then click File > Close to close the Restore Request
Editor.

9. If you changed any previously saved parameters for the request, a pop-up
window is displayed. Click Yes to save your changes or No to discard your
changes.

Archiving by Cúram Template
IBM Cúram Archiving provides access definitions that define the data to be
archived for a set of Cúram templates. These Cúram templates are available to
archive and restore data against the Cúram database.

CREOLECaseDeterminationData
The CREOLECaseDeterminationData archiving solution archives the Cúram
Express Rules (CER) rule object snapshot data that is stored when a new
determination record is created as a result of the reassessment of a case.

The records in the CREOLECaseDeterminationData table that are archived are only
those records that contain rule object snapshot data as opposed to those records
that store data for the overall determination result that is used in the display of
decision details information. For more information about the
CREOLECaseDeterminationData table and how overflow data is stored, see
https://www.ibm.com/support/knowledgecenter/SS8S5A_6.0.5/
com.ibm.curam.content.doc/InsideEligibilityAndEntitlementUsingCER/
c_INSEECER_Determinations1Creolecasedeterminationdata1.html.

CREOLECaseDeterminationData Archive Criteria

The CREOLEProgramRecommendation archiving solution accepts date as an input
parameter.

The CREOLECaseDeterminationData records that are archived are the records that
store the XML snapshot of the CER rule objects that are used in the calculation of
results for determinations. Only those records that are related to determinations
that do not have a status of Current that were created before the date specified as
an input parameter are archived. The records that are archived include the records
that hold overflow data.

Note: In this module, records are not deleted from the
CREOLECaseDeterminationData table. Instead, the data value is set to Null for the
creoleSnapshotData column.

ProcessInstance
The ProcessInstance archiving solution archives workflow process instance data,
including related tasks and alerts that are created by the workflow process.
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ProcessInstance archive criteria

The ProcessInstance archiving solution accepts date as an input parameter.

ProcessInstance records that meet the following conditions are archived:
v The status is Completed.
v The endDateTime value is before the date input parameter.
v The processType is not Synchronous, or the process type is Synchronous and

the process instance is a subflow of a parent process instance that has a status of
Completed.

PrecedentChangeSet
The PrecedentChangeSet archiving solution archives Precedent Change Set data
that are created by the Dependency Manager and then processed either in deferred
or batch mode.

For more information about the Dependency Manager and Precedent Change Sets,
see https://www.ibm.com/support/knowledgecenter/SS8S5A_6.0.5/
com.ibm.curam.content.doc/CERReference/
c_CERREF_Dependency1DependencyManager1.html.

PrecedentChangeSet archive criteria

The archiving solution accepts date as an input parameter.

PrecedentChangeSet records that meet the following conditions are archived.
v The status is Completed and the completedDateTime value is earlier than the

date input parameter.
v The status is Deferred to Batch and the submittedDateTime value is earlier

than the date input parameter.

CREOLEProgramRecommendation
The CREOLEProgramRecommendation archiving solution archives program
recommendation data that is created when eligibility is determined for programs
within an application or integrated case.

CREOLEProgramRecommendation archive criteria

The CREOLEProgramRecommendation archiving solution accepts date as an input
parameter.

All CreoleProgramRecommendation records with a dateTime value earlier than
the date input parameter, and that are not associated with a record of a simulated
determination that is authorized or declined, are archived.

CaseTransactionLog
The CaseTransactionLog archiving solution archives Case Transaction Log data that
is created when various events occur during the lifecycle of a case.

CaseTransactionLog Archive Criteria

The archiving solution accepts either date or a numeric value as an input
parameter.

14 IBM Cúram Social Program Management: IBM Cúram Archiving Guide

https://www.ibm.com/support/knowledgecenter/SS8S5A_6.0.5/com.ibm.curam.content.doc/CERReference/c_CERREF_Dependency1DependencyManager1.html
https://www.ibm.com/support/knowledgecenter/SS8S5A_6.0.5/com.ibm.curam.content.doc/CERReference/c_CERREF_Dependency1DependencyManager1.html
https://www.ibm.com/support/knowledgecenter/SS8S5A_6.0.5/com.ibm.curam.content.doc/CERReference/c_CERREF_Dependency1DependencyManager1.html


If date is used as the input parameter, then all CaseTransactionLog records
(associated to any case) that have a transactionDateTime value earlier than the
date input parameter are archived.

If a numeric value is used as the input parameter, then all CaseTransactionLog
records (associated to any case), except for the most current N records, per case are
archived.

The maximum number of transactions that are displayed on the Case home page is
controlled by the ‘curam.casetransactionlog.nooftransactions’ application property.
The value that is assigned to this application property setting should be considered
when you determine what value to provide as an input parameter.

CaseEvent
The CaseEvent archiving solution archives Case Event data that is created when
Case Decisions are generated as a result of determining eligibility and entitlement
within a case but have been superseded by later decisions.

CaseEvent archive criteria

CaseEvent records (associated to any case) that meet these criteria are archived.
v The case event type is Case Decision where the related Case Decision record

status is Superseded.

AuthenticationLog
The AuthenticationLog archiving solution archives Authentication Log data that is
created when users attempt to log in to the application.

AuthenticationLog archive criteria

The archiving solution accepts date as an input parameter.

AuthenticationLog records (associated to any user) that meet these criteria are
archived:
v The timeEntered value is earlier than the date input parameter.

AuthorisationLog
The AuthorisationLog archiving solution archives Authorisation Log data that is
created when users attempt to invoke a function for which they are not authorized.

AuthorisationLog archive criteria

AuthorisationLog records (associated to any user) that meet the following
condition are archived:
v The timeEntered value is earlier than the date input parameter.

Archive process report
The archive process generates an Archive Process Report that provides general
information and statistics about the archive process. The report contains data on
both the Archive and Delete processes in separate sections.

This is an example of an Archive report. An example of the Delete report is shown
in Delete Process Report.
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Report Details

The Archive Process Report is stored on the server where Optim is installed, as
shown in the Output File Path on the Archive Process Log. The report includes the
following information:
v The archive request’s Request Name
v The Server Name where processing occurred, or (Local) for a local workstation
v The name and full file path of the generated Archive File
v The name of the generated Access Definition for the request
v The Client and Server User IDs that requested the process
v The date and Time the process Started and Finished, and the Elapsed Time to

completion
v The Process Status for the archive process

Errors and warnings

If appropriate, a list of any errors or warnings that occurred during processing is
also provided.

Process summary

The following statistics are provided for the archived data.
v The number of tables that were processed.
v The number of rows that were archived.
v The number of rows that have errors.
v The number of first pass table rows.

Object details

The number and type of database objects that were copied to the archive file is
given, for example, Tables, PrimaryKeys, Relationships, and Indexes.

Row details

The following statistics are provided for each table.
v The number of rows that were archived from each table.
v The number of failed rows for each table.
v The table name of each table that was used in the archive process.

Delete process report
The Delete process generates a Delete Process Report that provides general
information and statistics about the Delete process. The report contains data on
both the Archive and Delete processes in separate sections.

This is an example of a Delete report. An example of the Archive report is shown
in Archive Process Report.

Report details

The Delete Process Report provides details of the delete or purge processing.
v The Server Name where processing occurred, or (Local) for local workstation.
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v The name of the Control File.
v The Client and Server User IDs that requested the process.
v The Date and Time the process Started and Finished.
v The Elapsed Time to completion of the process.
v The Process Status for the Delete Process.
v If appropriate, a list of any warnings or errors that occurred during processing is

also provided.

Process summary

These statistics are provided for the data that was deleted.
v The number of Tables that were Processed.
v The number of Rows that were Deleted.
v The number of Rows that were Not Found.
v The number of Rows that have Errors.
v The number of database connections (DB Connections).

Row details

These statistics are provided for each table.
v The number of rows that were Deleted from each table
v The number of rows that were Not Found in each table
v The number of rows that Failed in each table
v The Table Name of each table that was used in the process.

Restore process report
The Restore process generates a Restore Process Report that provides general
information and statistics about the restore.

This report is an example of a Restore report.

Report details

The Restore Process Report is stored on the server where the Optim Archive
solution is installed. The Restore Process Report contains the following information
v The Restore Request Name, which is Untitled if you did not save the request
v The Client User ID of the user that requested the process
v The Date and Time the process Started and Finished
v The Elapsed Time to complete the process
v The Process Status for the restore process
v A list of any warnings or errors that occurred during processing, if appropriate.

Process summary

The summary of the number of archive files that were processed and the number
of files that were successfully restored. The Status, number of Errors and Warnings,
and the name of each Archive File that is processed in the restore request are
displayed. The following are the possible status messages.
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Restore Complete
The restore process for the archive file (Insert or Load) that was completed
without errors.

Restore Failed
The restore process for the archive file (Insert or Load) encountered an
error.

Row Selection Complete
The Extract File subset that was completed successfully, but the restore
process was not attempted. Prior restore errors might cause this condition.

Row Selection Failed 
The Extract File subset was not created due to errors that were
encountered.

Aborted
The restore process (Insert/Load) was canceled by the user.

Insert Process

A summary of the insert process is given, as shown here.
v The Request Name and Server Name
v The name of the Source File
v The name of the generated Control File
v The name of the Table Map (or Local)
v The Client and Server User IDs that are requesting the process
v The Date and Time that the process Started and Finished
v The Elapsed Time to completion of the process
v Whether the Control File was Retained or Deleted
v The Process Status for the insert process

Process summary

The following statistics are provided for the data restored
v The total number of Tables that were Processed
v The total number of Rows that were Inserted
v The total number of Rows that were Updated
v The total number of Rows with Errors
v The total number of Rows that were Skipped (A row might be skipped because

the On Error Option was Selected for an archive action).

Row details

This information is provided for each table.
v The number of rows that were Inserted
v The number of rows that were Updated
v The number of Failed rows
v The number of rows that were Skipped
v The Table Name of each table that was used in the process
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Errors

If any errors occur during processing, an error list is provided. Review the list to
determine the reason for the error.

Status code

This table shows and defines the status codes that are returned by the restore
process.

Table 5.

Code Description

0 Successful: Restore Completed

4 Successful: Archive Completed (with informational messages)

8 Archive Completed with Warnings

11 Unsuccessful: Error Creating Override Text File

12 Unsuccessful: Error Could Not Load PST Information

16 Unsuccessful: Syntax Error on pr0cmnd Command Line Call

24 Unsuccessful: Could Not Open the File Specified in the Override
Output Parameter

99 Unsuccessful: Error Calling Custom Business Function
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Notices

This information was developed for products and services offered in the United
States.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing IBM Corporation North Castle Drive, MD-NC119 Armonk,
NY 10504-1785 US

For license inquiries regarding double-byte character set (DBCS) information,
contact the IBM Intellectual Property Department in your country or send
inquiries, in writing, to:

Intellectual Property Licensing Legal and Intellectual Property Law IBM Japan Ltd. 19-21,
Nihonbashi-Hakozakicho, Chuo-ku Tokyo 103-8510, Japan

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some jurisdictions do not allow disclaimer of
express or implied warranties in certain transactions, therefore, this statement may
not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM websites are provided for
convenience only and do not in any manner serve as an endorsement of those
websites. The materials at those websites are not part of the materials for this IBM
product and use of those websites is at your own risk.

IBM may use or distribute any of the information you provide in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
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programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Director of Licensing IBM Corporation North Castle Drive, MD-NC119 Armonk,
NY 10504-1785 US

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

The performance data and client examples cited are presented for illustrative
purposes only. Actual performance results may vary depending on specific
configurations and operating conditions.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBMproducts.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

Statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM's suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.

This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to actual people or business enterprises is entirely
coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.
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Privacy Policy considerations
IBM Software products, including software as a service solutions, (“Software
Offerings”) may use cookies or other technologies to collect product usage
information, to help improve the end user experience, to tailor interactions with
the end user or for other purposes. In many cases no personally identifiable
information is collected by the Software Offerings. Some of our Software Offerings
can help enable you to collect personally identifiable information. If this Software
Offering uses cookies to collect personally identifiable information, specific
information about this offering’s use of cookies is set forth below.

Depending upon the configurations deployed, this Software Offering may use
session cookies or other similar technologies that collect each user’s name, user
name, password, and/or other personally identifiable information for purposes of
session management, authentication, enhanced user usability, single sign-on
configuration and/or other usage tracking and/or functional purposes. These
cookies or other similar technologies cannot be disabled.

If the configurations deployed for this Software Offering provide you as customer
the ability to collect personally identifiable information from end users via cookies
and other technologies, you should seek your own legal advice about any laws
applicable to such data collection, including any requirements for notice and
consent.

For more information about the use of various technologies, including cookies, for
these purposes, see IBM’s Privacy Policy at http://www.ibm.com/privacy and
IBM’s Online Privacy Statement at http://www.ibm.com/privacy/details the
section entitled “Cookies, Web Beacons and Other Technologies” and the “IBM
Software Products and Software-as-a-Service Privacy Statement” at
http://www.ibm.com/software/info/product-privacy.

Trademarks
IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “ Copyright and
trademark information ” at http://www.ibm.com/legal/copytrade.shtml.

Adobe, the Adobe logo, PostScript, and the PostScript logo are either registered
trademarks or trademarks of Adobe Systems Incorporated in the United States,
and/or other countries.

Java™ and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.

Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.
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Other names may be trademarks of their respective owners. Other company,
product, and service names may be trademarks or service marks of others.
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