IBM Curam Social Program Management
8.0.2

Development Environment Installation
Guide

.||I




Note

Before using this information and the product it supports, read the information in “Notices” on page
31

Edition
This edition applies to IBM® Ciram Social Program Management 8.0.0, 8.0.1, and 8.0.2.
Licensed Materials - Property of IBM.

© Copyright International Business Machines Corporation 2012, 2022.
US Government Users Restricted Rights — Use, duplication or disclosure restricted by GSA ADP Schedule Contract with
IBM Corp.



Contents

Chapter 1. Installing a development environment.......c.cccceceiiniiniiniiecienienieccencnnnn 1

T L o= o Y =T o [N Y=Y 2
Installing and configuring APACHE ANt....c..eiii ittt e e e eree e s ebee e e bae e s bae e sraeeeaes 2
Installing and configuring Java SE and Java EE.........ccueiiiiiiiiicceeeeeee et 2

Installing IBM INStallation Mana@er.....c..uecciieiciieeiiieecieeectee et e et eeeteestee s teessaseessssae s sseesnnseesnseesnseean 3

Installing @an AP PliCALION SEIVET....ccc ittt e e e e et e e st e e et ba e e bae e sbeessstaeesabaeesnseeeanseeennsens 3
Installing and configuring IBM WebSphere Application SErver........vecceececeececeeecee e 4
Installing and configuring Oracle WebLOZIC SEIVET.........uiiiiieiciieeciee ettt vee e e e s 4

B e L == W PN €= o F= TR 5
H2 database. i ueeiiiiiceete ettt ettt st st e e s te e s be e sabe e baesaae e beesaaeentaene 5
IBM DD2 dat@base...cccuiiiiiiniieiieiieeieeste sttt ste st e steste e st e s be e saeesbeessaesabeesbaesabe e beesabeenbaesanesbaenaaesats 5
OracCle database. . .uiiiiiiieiececee e ettt a e st e et e e st e e nba e st e e baesateenbas 8

Installing IBM Clram Social Program Manag@emeENt........cecceeeeeeereeriieeireeneeeireesteesveesseesseesseesssessseesseenns 10
Installing LTS release or CD release UPAates......ccuiiiciieecieeicieeccieeeeteeesiee et e te e e tee e vee e baeesavee s 12
Installing the Editor Applications asset to remove browser Flash dependencies.......c.cccoeceercveriueene 13
Uninstalling IBM Clram Social Program Management..........cceeceeecieeeeeeireeneeeeeecreeseeeereesseesneesseenns 14

Social Program Management postinstallation configuration.........cccceeeeieeeeiecciee e 15
Setting the Social Program Management environment variables........ccoveecieeecieeccieecciee e 15
Configuring the H2 database.....cccuiieciiiiciieecee ettt te e e te e e e e et ae e ntaeeenraeeans 15
Configuring the IBM D2 databasSe.......cccciiieiiieeiiieccie ettt ettt ere e e ste e e sae e eaae e s aae e ssnteesnaaaeas 18
Configuring the Oracle Database........uiicuieiciieiciieeciie et et e et e e ete e e s aee e e taeeenaeeeensaeeeaes 19
Testing the CONTIGUIAtION....ccuii e te e e ate e e ate e s saae e snte e e seee e naeeennes 20
Running build commands for the server and client applications........ccceeeveeeecieeccieeccie e, 20
SEAMTING The XML SEIVET...ciiiiieeiieeetteeecte ettt e e e rte e et e et e e e bte e e abeeesateessseeesteeanssaesnnsaeannsaeennseesnnses 21
Configuring curam.referer.domains for Cross-Site Request Forgery (CSRF) protection........... 21

Installing and configuring Eclipse and TOMCAL........ccciiieciieeiiieccte et vr e e e rre e e are e e ea e e e aaee s 21
(07T ] 1= {0 a1 oY= Ko Tn  Uot= S5 22
Configuring the Java SE fOr ECLIPSE...uuii ittt ettt et e e e aee e s ree e e e e e s rae e naeas 23
Configuring the Eclipse class path variables and the Eclipse Tomcat Plugin.......ccccceveveeneerciiineennnen. 23
Importing and configuring the Social Program Management projects in ECLipSe .......cccceeeveeecuveenneen. 24
Starting the Tomcat server and the Social Program Management Servers.......cccccceecveeecvveesivveesnnen. 26
Using Eclipse to validate the tabbed configuration artifacts.......ccccceeeeeecieiccieicceece e, 26
Supported Eclipse text file @NCOUING......c.uiiiciiiieieecee et re e e rae e e ae e e e saaeeeaes 26

Installing and configuring Rational Software Architect DESISNEr.......ccevvveiviiriieiiieenieriecree e e e 27
Installing the IBM Clram Social Program Management plug-ins........ccceeceeeeeeieeecieeeeeecreeseeecveenneenns 27
Setting up your Rational Software Architect Designer WorkSpace.......ccceccueeeeceeeecieeecieeccee e 28

Getting started with the development enViroNMENT........c..eiiiiieiiiecceece e e e e 28
Starting the server, Tomcat, and the RMILOGINCLIENT.......cueeiiiiiiiiieeceeccee e 28
Logging on to Social Program ManagemeENt.......c.ueeccieeiciieeiiieeciieeeeeeecireeeteeeesreeeetaeeebaeesvaeessneesnns 29
Deploying Social Program ManagemMeNt........cccueeecieeeiieeeiiieeeireeesreeesteeesreeesseessseessseessssassssseessnses 30

Upgrading IBM Curam Social Program ManagemeNnt..........ccveeveeeieereeeireeneeeireenseesreesseesseesseesssessseesseens 30

(V0] 4 o= RRRRRC 3 |
Privacy POLICY CONSIAEIAtIONS. ...ccciiiieiieeciiecciee ettt et eeee et e e te e e et eeestaeesbeeessseeeensaeeensaseenseeesnseenan 32
IR e (=100 = T USSR 32






Chapter 1. Installing a development environment

You can install a light or a full IBM Curam Social Program Management development environment to
develop Social Program Management applications. Development is supported only on Microsoft Windows,
and you can build on both Microsoft Windows and Linux®.

Light Java™ development environment

A light development environment consists of Social Program Management, an Eclipse and Tomcat
IDE, the lightweight H2 database, and the IBM® Rational® Software Architect Designer UML modeling
tool.

Full Java development environment

A full development environment replaces H2 with a supported enterprise database and adds a
supported enterprise application server for full development and testing.

Java build environment

A build environment consists of Social Program Management, and a supported database and
application server.

Supplemental front-end development
Ll 8010 |

If you want to extend UIM with JavaScript and IBM Carbon Design System, install the open source
Social Program Management UI Addon Development Environment.

JavaScript IDE (Visual Studio Code, Atom) Java and UIM IDE (Eclipse and Tomcat)

Node.js Apache Tomcat
Source
SPM CDEJ
: JSPX Service Layer
Custom-carbon-addons package NOd_e script ) Compiled 3S 4
copies compiled
GraphQL and Apollo React JavaScript (JS) JavaScript I Dt
Client Service SASS (Scss) A:t:Zss
Calls Service
Renders JS JS request server
components to GraphQL facade E%
Source
Mapped
UIM Java Renderer GraphQL APIs

Figure 1. React and Java development environments for UI components

For more information, see https://ibm.github.io/spm-ui-addon-devenv.

« If you want to work with the IBM Universal Access Responsive Web Application, install the IBM
Universal Access Responsive Web Application asset.

Figure 2. React and Java lightweight application development environments for Universal Access

For more information about installing a React JavaScript development environment
for Universal Access development, see https://www.ibm.com/docs/en/spm/8.0.0?topic=access-
installing-application-development-environment-web-server.
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Installing prerequisites

You must install some prerequisites before you install the IBM Clram Social Program Management
software.

For the exact versions of prerequisites and supported software, see the IBM Ciram Social Program
Management Supported Prerequisites technote related link.

Related information
IBM Curam Social Program Management Supported Prerequisites

Installing and configuring Apache Ant

Apache Ant is a Java library and command-line tool for building Java applications.

Procedure

1. Download the Ant compressed file from the Apache website. For more information, see Installing
Apache Ant

2. Extract the file to a directory of your choice on your computer. By default the file extracts to the
apache-ant-version directory. The installation is now complete.

3. Create an ANT_HOME system environment variable with the value set to the Apache Ant installation
directory.

a)
Add %ANT_HOME%\bin to the PATH environment variable.
b)
Add $ANT_HOME /bin to the PATH environment variable.
4. Create an ANT_OPTS system environment variable with the value:

ANT_OPTS=-Xmx1400m -Dcmp.maxmemory=1400m

Installing and configuring Java SE and Java EE

You can install a stand-alone Java SE and Java EE, or use the ones that are included with the supported

application servers. The application server becomes a prerequisite if you use the included Java SE and
Java EE.

About this task

Follow the Oracle documentation to install the Oracle Java SE and Java EE. No further installation steps
are needed if you use the versions that are included with an application server.

Regardless of which Java SE and Java EE you use, you must complete the following configuration steps.

You might need multiple versions of Java SE and Java EE installed on a single computer. If so, you can
choose the scope for these Microsoft Windows environment variables. For example, system wide, or
through a script file or symbolic links.

Procedure

1. Create a JAVA_HOME environment variable that points to the installed Java SE.

. Place %JAVA_HOME%%\bin at the beginning of the PATH environment variable.
. Place $JAVA_HOME/bin at the beginning of the PATH environment variable.
2. Create a J2EE_JAR environment variable that points to the installed Java EE JAR file:

Refer to the application server documentation to find details of the Java EE JAR file that is provided
with that application server type and version.
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Installing IBM Installation Manager

IBM Installation Manager is used to install many IBM products. Install IBM Installation Manager if you
want to install IBM WebSphere® Application Server or IBM Db2°.

Procedure

1.

11.
12.

13.
14.

15.
16.

Download the IBM Installation Manager from
http://www-01.ibm.com/support/docview.wss?uid=swg27025142. The different versions of IBM

Installation Manager are available if you scroll down the page.

. Select the Download document hyperlink for the version of IBM Installation Manager that you want

to install.

. On the Installation Manager (version) page, scroll down to the 'Change History' section and select the

appropriate Fix Central (FC) link for Microsoft Windows.

. On the 'Select Fixes' page, select the version of IBM Installation Manager appropriate for the version

of Microsoft Windows.

. Click Continue to navigate to the download page.
. Download the IBM Installation Manager compressed file for your version of Microsoft Windows.
. Extract the downloaded file to a temporary location.

For example, C:\Temp

. After the IBM Installation Manager software is downloaded and extracted, navigate to the Install.exe

file.
For example, C:\Temp\IM\install.exe.

. Right-click on Install.exe and select the Run as adminstrator option.
10.

On the package selection, select the checkbox for the most recent version of the IBM Installation
Manager.

Click Next.

Review the International Program License Agreement and select the radio button to accept the terms
and continue with the installation.

Click Next.

Select a location for the IBM Installation Manager.
For example, C:\IBM\Installation Manager\eclipse.

Typically, IBM Installation Manager, IBM WebSphere Application Server, and IBM Db2 are installed
in the same folder, C: \IBM. Do not install these programs into C: \Program Files, orany other
location with a space in the name as it can cause problems later.

Click Install.
Click Finish.

Installing an application server

You can install an application server to give you a complete set of development tools or for a build
environment. The application server is a prerequisite if you want to use the Java SE and Java EE that are
bundled with IBM WebSphere Application Server or Oracle WebLogic Server.

Note: You must not install an application server on an environment where the hostname contains an
underscore.
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Installing and configuring IBM WebSphere Application Server

Install WebSphere Application Server or IBM WebSphere Application Server Network Deployment from
the installation media and set the required Microsoft Windows environment variable.

Before you begin
IBM Installation Manager is used to install IBM WebSphere Application Server. For more information
about installing IBM Installation Manager, see “Installing IBM Installation Manager” on page 3.

If you want to install WebSphere Application Server as a service, you must first create a user account with
administrator privileges to use as the credentials for the service.

Important:

- mEzA Do not install WebSphere Application Server in a directory that contains spaces in the name,
such as the default Program Files directory, as it can cause problems later.

« Do not install the WebSphere Application Server sample applications. The sample application Apache
Derby data source results in a class path conflict with the application web client use of Derby.

Setting the WebSphere Application Server environment variable

Set the WAS_HOME environment variable to the server directory of the WebSphere Application Server
installation.

W=z For example, C: IBM\WebSphere\AppServer
For example, /opt/IBM/WebSphere/AppServer

Installing and configuring Oracle WebLogic Server

Complete the following steps to install and configureOracle WebLogic Server.

Procedure
1. Run the Oracle installer. When prompted in the installation wizard, choose the following options:

« For the installation type, choose WebLogic Server.
- Deselect the Automatically Launch the Configuration Wizard checkbox.
2. Set the WLS_HOME environment variable to the server directory of the WebLogic Server installation.

mI=zAa For example, server_directory\wlserver_version\server

For example, /opt/wlsversion/wlserver/server.

3. Configure the WebLogic Server application transaction timeout settings, see “Configuring the Oracle
WebLogic Server application transaction timeout settings” on page 4.

Configuring the Oracle WebLogic Server application transaction timeout
settings

Set the minimum application transaction timeout settings for Oracle WebLogic Server to 120 seconds.

About this task

Q Warning: These settings are for testing or development and are not advised for production
systems where they represent minimum values. Tuning must be done to find the correct settings
for your environment. The minimum value is recommended for the following components:

« IBM Curam Child Welfare
« IBM Ctram Income Support
« IBM Curam Income Support for Medical Assistance
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« IBM Curam Workers Compensation
« IBM Curam Youth Services

Procedure

1. Log on to the localhost console from https://localhost:7002/console.
2. Select the domain name under the Domain Structure section.

3. Select the Configuration tab.

4. Select the JTA tab.

5. Set Timeout Seconds to be 120 seconds.

What to do next

To test these components on Oracle WebLogic Server during development cycles, you can use the same
steps to increase the JTA timeout settings.

Installing a database

The H2 database is supported as a development database. IBM Db2 and Oracle Database are supported
as database servers.

Note: No particular character set is required for the installation and setup of the DBMS. Configure a
character set that is appropriate for the character range that is needed in the application.

H2 database

H2 is an SQL database engine that is written in Java that implements the JDBC API. A browser-based
console application is included. The H2 database is preinstalled with the IBM Curam Social Program
Management software.

After you install the Social Program Management platform software, the self-contained database is in the
9%CURAMSDEJ%\drivers\h2.jar file.

If you plan to use the H2 database, select the IBM Db2 option during installation. Enter values for Db2

as you proceed through the wizard. After you complete the installation, you must edit the database
properties in the $CURAM_DIR%\EJBServer\project\properties\Bootstrap.properties file for
the H2 database instead. %CURAM_DIRY% is the Social Program Management installation directory, by
default C:\IBM\Curam\Development.

These limitations apply to the support of the H2 database:

For development use only.
« Not supported at run time.
EAR files cannot be built for the H2 database.

 You cannot run the configure target while the H2 database is in use. This target automatically
configures the application server.

Related information
H2 Database Engine User GuideTo see the H2 database user guide, click this link.

IBM Db2 database

IBM Db2 is supported as a database server.

Note: It is possible to use IBM Curam Social Program Management against a remote database with the
Db2 Universal Type 4 Driver. The driver is supplied with the Server Development Environment for Java
(SDEJ).
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Db2 database encoding options

If you plan to install IBM Db2, read this important background information about issues with Db2
database encoding and related sizing information. During a Db2 installation, you must identify your
requirement for SBCS or MBCS data. Depending on your choice, you might have to complete some extra
post-configuration steps before you build the IBM Curam Social Program Management database.

What is the issue?

For a multi-byte character set (MBCS) or encoding, Db2 processes columns by their byte size, not their
character length. Therefore, for multi-byte characters, a CHAR, VARCHAR, or CLOB column might store
fewer characters than the column length specification indicates, depending on the actual character
length.

Consider the following example:

« A CHAR or VARCHAR column that is modeled with a length of 16.

- The 16-character string, "Marge says hello" that does not have accented character, requires 16 bytes for
storage in a single-byte character set (SBCS).

« Asimilar 16-character string, but with accented characters, "Marge says héllo", requires 18 bytes for
storage in UTF-8, a multi-byte character set (MBCS).

For the single-byte data, the string fits and processing is successful. For the multi-byte data, the string
does not fit, resulting in overflow errors at run time. The Social Program Management web client usually
captures and reports field size errors in a user-friendly manner. In this case, the user receives an "un-
handled server exception" error, which is an underlying SQL Code =302 error. This is because the client
does not capture this size mismatch as it checks the number of characters, and not the byte length.

How Social Program Management addresses the issue

Social Program Management provides modeling and build-time capabilities to resize its database columns
to address this issue. These capabilities are described further in the Ciram Modeling Reference Guide and
Curam Server Developer's Guide.

As Social Program Management provides support for multiple languages, support for MBCS data is
enabled by default with the maximum expansion set. These expansion settings are appropriate to ensure
that new users, testing environments, and so on, do not encounter any errors because of their language,
encoding, and database sizing. Also, users can find they require MBCS data when they import or paste
data from other applications into their Social Program Management system. However, these defaults
might not be appropriate for all environments. The following section describes some considerations for
changing these expansion settings.

What you must consider

It is important to carefully consider your data encoding requirements regarding Db2 and Social Program
Management to avoid unexpected behavior with how the database stores characters.

The preceding example represents a boundary case in that the data length matches the maximum column
width. In many cases it is unlikely that, even with MBCS characters, an overflow situation will occur. Most
data does not reach the maximum defined size. However, you must be prepared for the possibility of
these error situations.

Use the database character set encoding appropriate to your application and environment. If possible,
consider using an SBCS and encoding that supports your requirements. For example, CP1252 supports
most Western European characters. However, CP1252 (or other SBCS encodings) might not support
characters from different or "broader" character sets or encodings (for example, UTF-8) that users might
copy and paste into their browser.

When installing your Db2 database, you must only identify your requirement for SBCS or MBCS data and
be prepared to take appropriate action before you build your Social Program Management database:
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« If you require characters that use multiple bytes, then you must consider whether the default Social
Program Management settings are appropriate. The necessary database space is dependent on various
factors such as the following factors.

— The specific character sizes. In Db2 and Db2 for z/OS, MBCS data can range from 1 to 4 bytes.

— The frequency of MBCS characters, which can depend on the application, language, locale, column
usage within the application, and so on.

— The information density of the language and locale. For example, while some languages can require
more bytes per character, each character can represent more information than, for instance, an
alphabetic character and might fit into a field without any size adjustment.

For more information about MBCS data sizing considerations, see the Cliram Server Developer's Guide
section, Planning for Db2 MBCS Data.

« If an SBCS is adequate, plan to disable database expansion as described in the Curam Server
Developer's Guide section: Planning for Db2 MBCS Data.

Installing IBM Db2

Ensure that your account has administrative privileges and then follow the Db2 installer instructions
to complete a default installation. You do not need to manually create a Db2 database. The platform
software provides Ant scripts that you can run as a postinstallation step to create a basic test database.

Note the following options that are presented during a default installation:

« The name and password of the administrator account. Use an account and password that meets the
standards and requirements of your site and Db2.

=T If it is an existing user, that user must be a member of the Administrator group.

The specified user must be a Linux user on your system.

- Certain editions of the Db2 installer support federated databases. If the installer presents an option that
is defaulted to This machine will be the instance-owning database partition server, then change this
option to This machine will be a single-partition database server.

« You must choose MBCS or SBCS, depending on your requirements. If you are unsure of what database
encoding option to select, see “Db2 database encoding options” on page 6.

For more information, see Installing Db2.

Configuring for circular transaction logging

When you use a database with circular transaction logging enabled, certain transactions can exceed the
available log file space and fail. To avoid this issue, either use archive logging or set the available log size
and quantity appropriately until it meets the needs of the transaction.

About this task

A common point for this failure is when the prepare.application.data Ant target is running, as this
target publishes all the CER rule sets on the system. This Ant target is typically run after a clean database
build. If the log is too small, it can result in an SQLCODE -964 error.

You can use the following example to help you to increase the Db2 log file size and quantity. The

exact amount of log file storage that is required varies from system to system. For more information
about increasing the number and size of the log files available, see the specific documentation for your
database.

Procedure

1. Open a command prompt and enter db2cmd.
2. Enter the following command:
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db2 connect to db_name user db_user_name using db_password

Where db_name, db_user_name, db_password are the credentials of the database.
3. Enter the following commands:

db2 update db cfg for db_name using logfilsiz log_file_size
db2 update db cfg for db_name using logprimary primary_log_files

db2 update db cfg for db_name using logsecond secondary_log_files

Where the temporary values are as follows:

« The log file size. Set Log_file_size to 1024.

« The number of primary log files. Set primary_log_files to 50.

« The number of secondary log files. Set secondary_log_files to 100.
4. Restart the database by entering the following commands:

db2stop
db2start

Oracle database
Oracle database is supported as a database server.

Note: You can use a remote database by using the Oracle Type 4 Driver that is supplied with the SDEJ.

Oracle database encoding options

If you plan to install Oracle, it is important to consider the character set for the data that you plan to store
in your database when you configure the database for use with IBM Curam Social Program Management.

For Oracle, there are two parameters to consider: NLS_CHARACTERSET and NLS_LENGTH_SEMANTICS.

« The NLS_CHARACTERSET parameter details the allowable character set of any data that is loaded to the
database, generally AL32UTF8 is recommended by Oracle.

« The NLS_LENGTH_SEMANTICS determines how Oracle interprets length specifiers on CHAR and
VARCHAR columns. To handle supplementary characters, for example, 15 in German, where the storage
of the character would be 2 bytes and might overrun the length of a defined column, set the
NLS_LENGTH_SEMANTICS parameter to CHAR. This setting directs the database to size columns with a
character length rather than byte length.

Oracle extended data types

Starting with Oracle Database 12c, the maximum value of the VARCHAR2 data type can be extended from
4000 to 32767 bytes by changing the MAX_STRING_SIZE initialization parameter from its default value
of STANDARD to EXTENDED. However, take care when enabling Oracle extended data types as there are
some important caveats that apply. For more information about setting and using extended data types,
see the Oracle documentation.

Important: The process of switching to use Oracle extended data types is a one-way operation. After you
switch to extended data types, you can't switch back without some form of database recovery. You must
ensure that extensive regression testing is performed before switching in production environments.
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Postinstallation configuration for the Oracle database

Complete the following postinstallation tasks on the Oracle Database.

Creating an Oracle role for application servers

The application needs certain privileges to use the Oracle XA interface. Later, when you configure the
application, the username under which the server connects to Oracle is specified. The appropriate
privileges must be assigned to this username for the server to work successfully.

About this task

To bundle together the various privileges that are needed, you can create an Oracle role. Privileges can
be granted to this role. Later this role can be granted to your users, granting all the privileges that are
associated with that role.

The following commands create a role that is called CURAM_SERVER and give it the necessary privileges.
A CURAM_USER user is then assigned that role and given the password PASSWORD. You run these
commands inside an Oracle SQL*Plus window.

Procedure

1. To run the commands from SQL*Plus, type the following command at a command line:
sqlplus ?/? as SYSDBA
2. Enter the following commands:

CREATE ROLE "CURAM_SERVER";
GRANT RESOURCE TO "CURAM_SERVER";

BT @%ORACLE_HOME?%\RDBMS\ADMIN\xaview.sql

@$ORACLE_HOME/rdbms/admin/xaview.sql

GRANT SELECT ON V$XATRANS$ TO PUBLIC;

GRANT SELECT ON PENDING_TRANS$ TO PUBLIC;

GRANT SELECT ON DBA_2PC_PENDING TO PUBLIC;

GRANT SELECT ON DBA_PENDING_TRANSACTIONS TO PUBLIC;

GRANT EXECUTE ON DBMS_SYSTEM TO CURAM_SERVER;

CREATE USER CURAM_USER IDENTIFIED BY

PASSWORD DEFAULT TABLESPACE "USERS" TEMPORARY TABLESPACE "TEMP";

GRANT "CONNECT", "CURAM_SERVER", UNLIMITED TABLESPACE TO <CURAM_USER>;

Where CURAM_USER and PASSWORD are the database user credentials.

Configuring for circular transaction logging

When you use a database with circular transaction logging enabled, certain transactions can exceed the
available log file space and fail. To avoid this issue, either use archive logging or set the available log size
and quantity appropriately until it meets the needs of the transaction.

A common point for this failure is when the prepare.application.data Ant target is running, as this
target publishes all the CER rule sets on the system. This Ant target is typically run after a clean database
build.

For information about increasing the number and size of the log files available, see the specific
documentation for your database. The exact amount of log file storage that is required varies from system
to system.
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Configuring redo log space
Certain Social Program Management transactions that have significant insert activity are affected by the
available redo log space. To avoid this issue, allocate the appropriate redo log space for your system.

A common point for this failure is when the prepare.application.data Ant target is running, as this
target publishes all the CER rule sets on the system. This Ant target is typically run after a clean database
build.

For information about allocating the appropriate size for the redo logs, see the Oracle documentation. The
exact amount of activity and the required redo log space varies from system to system.

Installing IBM Curam Social Program Management

Run the Social Program Management platform installer to install the base platform upon which all the
other modules are installed for a Long Term Support (LTS) or Continuous Delivery (CD) release. Then,
install each of the Social Program Management application modules that you are licensed for.

Before you begin

LTS releases contain the Social Program Management Platform and all of the Social Program Management
application modules. LTS releases are delivered as full installers on Passport Advantage. CD releases
must be installed on the applicable LTS release.

Ensure that you have the required installers and all of the required information before you start the
installation and review the Social Program Management release notes.

Note: The Structured Decision Making (SDM) Add-on module is not translated and must not be installed
with IBM Curam Child Welfare on a non-English language installation.

IBM Curam Income Support has a dependency on IBM Cdram Outcome Management. If you plan to install
IBM Cdram Income Support, you must install IBM Curam Outcome Management.

IBM Curam Income Support for Medical Assistance does not have a dependency on IBM Clram Outcome
Management.

Note: If you are installing a modification release, install it in a new installation location and not in a
previous installation location.

About this task

Download any of the software that you need from IBM Passport Advantage. For more information about
the IBM Clram Social Program Management components, see the related link to the download document.
You need the Social Program Management platform installer, plus individual installers for each component
you plan to install. Typically, you install application modules, and optional associated add-ons.

Before you start, you must have the following information:

« Alist of the components of the application for which you are licensed.

- The organization name and address.

« The database server name, port number, database name, database username, and database password.

If your project is stored in a source-controlled environment, you might take the following approach to the
installation, depending on your requirements:

« Install IBM Curam Social Program Management and any optional components.
» Place the installed code base under source control.

« To support future installations, the files in the /Installexr folder must also be maintained under
source control.

« Use your source-control procedures to distribute the environment to other developers.

During the installation, all installation process and the installation history are saved to the following log
files:
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e /Installer/CuramInstaller.log
« /Installer/Installhistory.txt

Procedure

1.
2.

00 3 o O

11.

12.

13.

14.

15.

Copy all of the installation files from the media to a temporary directory and change to that directory.

To run the installer wizard, enter the command java -jar <installername.jar>.If the installer
name includes spaces, put the name in quotation marks.
For example, java -jar "IBM Curam SPM Installer Development.jar".

By default, the platform installer also installs the following platform application modules:
« IBM Curam Verification Engine

« IBM Curam Evidence Broker

« IBM Curam Life Event Management

You must have a valid license to use the platform application modules.

. On the welcome page, click Next.
. Do not alter the default installation path. Accept the default installation path by clicking Next > OK to

create the directory.
If the target installation directory exists, you are prompted to overwrite the existing files.

. Select a language. If left blank, the language defaults to English - US.

. If you are licensed for Universal Access, select the checkbox for any extra languages needed.

. Click Next to accept the license type.

. The components that you are licensed for are displayed. Confirm the components that you require

are selected and click Next.

. Enter the Organization Name and Organization Address, and click Next.
10.

Select the Curam Database Platform that you plan to use with the application.
For example, DB2/UDB.

If you intend to use the H2 database, select DB2/UDB during the installation. Enter values for Db2 so
you can proceed through the wizard. After you complete the installation, you must edit the database
properties in the $CURAM_DIR%\EJBServer\project\properties\Bootstrap.properties
file for the H2 database instead. 8CURAM_DIR% is the Social Program Management installation
directory, which by default is C: \IBM\Curam\Development.

In the Database Account Logon and Database Account Password fields, enter the values as defined
during the database installation and click Next.

In the Database Server Name field, enter the fully qualified hostname of the computer on which
you installed the database. Enter a value for the Database Server Port field, such as 50000 for Db2.
Enter the database name in the Curam Database Name and click Next.

The installation files are extracted. This step can take several minutes.
When the extraction completes, click Next.
The installation files are configured based on the inputs that are provided in the previous steps.

Click Next > Done to complete the platform installation. Review the release notes and complete any
relevant postinstallation steps.

Run the installers for each of the application modules for which you have a valid license:
» IBM Curam Universal Access

» IBM Curam Outcome Management

« IBM Clram Provider Management

« IBM Curam Social Enterprise Collaboration

IBM Cdram Business Intelligence and Analytics

IBM Curam Appeals
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IBM Curam Workers Compensation - Do not install any further modules with this module.

« Either IBM Ctram Income Support or IBM Ciram Income Support for Medical Assistance (but not
both). You can then install these modules in this sequence:

a. IBM Curam Income Support Screening
b. IBM Curam Business Intelligence and Analytics Reports for Income Support
IBM Curam Child Welfare. You can then install:

a. IBM Curam Business Intelligence and Analytics Reports for Child Welfare

b. IBM Curam Child Welfare Structured Decision Making (SDM) Add-on

c. IBM Cdram Outcome Management Structured Decision Making (SDM) Add-on
» IBM Curam Youth Services
« Any additional assets such as demonstrations

16. Verify your installation by checking the installation history to determine what was installed. A text file
for each installer and the InstallHistory. txt file that lists all of the installers that ran are found
in the installation folder.

For example, C: \IBM\Curam\Development\Installer.

17. Review the release notes for each of the application modules and complete any postinstallation steps
that are relevant to your configuration.

18. If you plan to develop reports for IBM Cliram Business Intelligence and Analytics, complete any
additional installation steps to install your reporting development environment, see Installation and
Configuration.

19. If you plan to use IBM Citizen Engagement, you must also install the IBM Universal Access
Responsive Web Application development environment. For more information, see Installing the IBM
Universal Access Responsive Web Application development environment.

Related information

IBM Curam Social Program Management release notesTo see the IBM Clram Social Program Management
Platform Release Notes, click this link.

IBM Curam Social Program Management 8.0.0 Download Document

Installing LTS release or CD release updates

After you install a IBM Curam Social Program Management Long Time Support (LTS) or Continuous
Delivery (CD) release, install the most recent maintenance updates.

About this task

- Fix packs are maintenance releases on an LTS release that includes critical and significant defects
and security updates, and increments the fourth digit of the release number. They do not contain any
new features or enhancements. Updates to an LTS release do not force an upgrade impact unless it is
unavoidable for reasons of security or stability. Fix Packs are delivered in a delta installer on Fix Central.

« CD releases deliver maintenance updates, plus new optional features and functions. They are
cumulative and contain all the fixes and functions in the previous CD releases. New features and
functions in CD releases either have no impact, or are disabled by default. You can choose to benefit
only from the maintenance updates, without incurring any impact from the new features and functions.
Or, you can choose to enable new features and functions on a case-by-case basis, and handle the
associated impacts, if any. CD releases are delivered as delta installers on Fix Central. The delta installer
must be installed on the applicable LTS release, the installers for which are delivered on Passport
Advantage.

- Maintenance on a CD release is delivered in the next CD release along with new features and functions.
Critical defects and security patches are also delivered separately on the two most recent CD releases.

 Occasionally, obsolete JAR files can remain in your development environment after you install an
update from Fix Central. For example, if you upgrade from a Fix Pack to a later Fix Pack by using the
delta installers, JAR files that were removed in the later Fix Pack might remain in your environment.
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To avoid future issues with these files, we recommend that you manually remove them. For more
information about updated or removed JAR files, read the release notes for your version and Removed
functionality.

Procedure

1. Go to the IBM Fix Central website and search the site for your product and version to locate the update
for your installation.

2. Download and extract the installation image.

3. Read the IBM Cdram Social Program Management release notes for the version. Take note of any
preinstallation steps, requirements, restrictions, installation steps, and postinstallation steps that
might apply.

4. Run the installer, following the instructions in the documentation.

5. When prompted to move obsolete files, select Yes.

Moving the files can take some time, during which no progress indicator is displayed.

6. Click Finish to complete the installation.

7. Complete any postinstallation steps.

Related information

IBM Curam Social Program Management release notesTo see the IBM Cluram Social Program Management
Platform Release Notes, click this link.

Introduction of new delivery vehicle for IBM Curam Social Program ManagementFor more information
about refresh packs, click this link.

Removed functionality

Installing the Editor Applications asset to remove browser Flash
dependencies
As browsers no longer support Adobe Flash, you must replace the editors that depend on Adobe Flash in

the browser with stand-alone versions that run on Adobe Air. To replace the editors, you must download
and run the Editor Applications asset installer.

Before you begin

The server updates in the Editor Applications asset extend some of the core JAR files in Social Program
Management. To ensure that you have the appropriate server updates, you must reinstall the Editor
Applications asset if you upgrade Social Program Management through any of the following upgrades:

« Long Term Support release fix packs
« Continuous Delivery releases

About this task

The Editor Applications asset enables stand-alone versions of editors that previously required Adobe
Flash support in the browser for Social Program Management. A client installation registers the editors
so you can start them by using a URL. In addition, the Social Program Management development
environment is updated to automatically start the new stand-alone editors by default. The following
editors are updated:

« Curam Express Rules (CER) editor

Data Mapping editor

Data Store editor

Intelligent Evidence Gathering (IEG) editor
« Decision Matrix editor

Dynamic Evidence editor
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Procedure

1. Download the asset from Fix Central and extract the contents, which are described in this table.

Table 1. The Editor Applications asset contents

File Description

EditorApplications.jar The installer for the development environment
updates.

EditorApplicationsClient.msi The installer for the editors.

Readme. txt A brief description of the asset and how to install
it.

2. Install the development environment updates.

a) If Java is configured, double-click EditorApplications. jar. If Javais not configured, change
directory to the INSTALL folder and run java -jar EditorApplications.jar.

b) To use the new editors, you must deploy the newly built version to your development server.

3. You must run a separate client installation, the .ms1i file, on any client on which the editors are to run.
The installation is not available from a running server so the installation must be distributed. To install
the editors, complete the following steps on each client computer:

a) Copy EditorApplicationsClient.msi to the computer.
b) Double-click EditorApplicationsClient.msi.
c¢) Select the default location for the installation.
4. Validate that the editors are installed correctly.
a) Access the newly deployed development server.

b) Open any editor, for example the Data Mapping editor. The editor’s start tab displays as blank or
with a spinner. A dialog box is displayed to request that you want to start the editor.

¢) Indicate that you want to start the editor. The editor starts as a separate, full-screen application. In
your browser, the editor’s start tab shows that the editor started correctly.

Results

You can now use the new editors during development. For more information about accessibility for the
editors, see Accessible desktop alternatives.

Some known limitations are applicable to the stand-alone Cuiram Express Rules Editor, see the related
links.

Related concepts

The Curam Express Rule Editor

Related information

The Curam Express Rules Editor strips comments from XML in a rule set

Progress bar doesn't update during export of diagrams in the Clram Express Rules Editor
Diagram disappears after export of many diagrams in a large ruleset

Uninstalling IBM Curam Social Program Management

An uninstallation file is created in the <install>\Uninstaller\uninstallexr. jar directory during a
IBM Curam Social Program Management installation. You can use this file to uninstall the application.

About this task

JAR files might be recognized as executable by being associated with a suitable launcher, such as javaw.
If this is the case for your operating system, start the Social Program Management Uninstaller with the
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standard method that is supported by your operating system. For example, double-clicking the Social
Program Management Uninstaller file.

Note: The uninstaller does not reset any system variables that are set by a previous installation.

Procedure

1. Navigate to the <install>\Uninstaller\ directory.
2. Double-click the uninstallex. jar file to uninstall Social Program Management.

Social Program Management postinstallation configuration

Complete any required postinstallation configuration tasks after you install the IBM Curam Social Program
Management software.

Setting the Social Program Management environment variables

Before you proceed, you must run a script to set some required Social Program Management environment
variables.

Procedure

1. Change to the %CURAM_DIR% directory.

%CURAM_DIRY% is the Social Program Management installation directory, which by default is
C:\IBM\Curam\Development or opt/IBM/Curam/Development.

2. Run the following command:

SetEnvironment.bat

SetEnvironment.sh

Configuring the H2 database

Complete the following postinstallation steps for the H2 database. To use the H2 database, you must
update the Bootstrap.properties file with the correct credentials to connect to the H2 database.
Ensure that you encrypt the password.

About this task

For example, here is typical H2 database content from a Bootstrap.properties file.

curam.db.type=h2

curam.db.name=curamdb

curam.db.username=curam

curam.db.password=qqnscP4c4d+s=

# H2 directory.

# Default is home directory

# (i.e. C:/Documents and Settings/<username>). (Optional)
curam.db.h2.directory=C:/H2

# Mode remote|embedded

curam.db.h2.mode=embedded

# For remote mode also specify:

curam.db.serverport=9092

curam.db.servername=1localhost

# Lock Time Out in ms. Default is 1000, i.e. 1 second. (Optional)
curam.db.h2.locktimeout=20000

# Property to disable MVCC. Default: true. (Optional)
curam.db.h2.mvcc=true
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After you update the Bootstrap.properties file and rebuild the server and database, you can develop
in the same way as you would with Oracle or Db2.

For more information about the Bootstrap.properties file, see the Curam Server Developers Guide.

Procedure

1. Edit the Bootstrap.properties file.
2. Ensure that each of the database properties has the correct values for the H2 database.

Encrypting passwords

You must encrypt passwords before you put them in the Bootstrap.properties file.

Procedure

1. Open a command prompt and change to the %CURAM_DIR%\EJBServer directory.

9%CURAM_DIRY is the IBM Curam Social Program Management installation directory, which by default is
C:\IBM\Curam\Development.

2. Issue the following command:
build encrypt -Dpassword=password

where password is the password you want to encrypt.

3. Copy the encrypted string in the output to the correct location in the Bootstrap.properties file.
For example, the curam.db.passwoxd parameter.

Setting the H2 mode

Set your preferred mode for developing applications.

About this task

The following H2 modes are supported for application development:

Embedded mode
In embedded mode, an application opens the database from within the same JVM by using JDBC. This
mode is the fastest and easiest connection mode. The disadvantage is that a database can be openin
only one virtual machine (and class loader) at any time.

Remote mode
In remote mode, sometimes called client/server mode, an application opens the database remotely
by using the JDBC or the ODBC API. Many applications can connect to the same database at the

same time. The remote mode is slower than the embedded mode because all data is transferred over
TCP/IP.

Procedure

1. Edit the %CURAM_DIR%\EJBServer\project\properties\Bootstrap.properties file.

9%CURAM_DIR% is the IBM Curam Social Program Management installation directory, which by default is
C:\IBM\Curam\Development.

2. Specify the mode in the cuxram.db.h2.mode property.
For example:

# Mode remote|embedded
curam.db.h2.mode=embedded
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Setting Multi-Version Concurrency Control (MVCC)
You can enable or disable Multi-Version Concurrency Control (MVCC). MVCC is enabled by default.

About this task

The MVCC feature allows higher concurrency than using exclusive table level or row level locks. When
using MVCC in this database, delete, insert, and update operations only issue a shared lock on the table.
An exclusive lock is still used when adding or removing columns, when dropping the table, and when
using SELECT. .. FOR UPDATE. Connections only see committed data, and their own changes.

That means, if connection A updates a row but has not committed the change, connection B sees the
old value. Only when the change from connection A is committed, the new value is visible to other
connections (read committed). If multiple connections concurrently try to update the same row, the
database waits until it can apply the change, but at most until the lock timeout expires.

Procedure

1. Edit the %CURAM_DIR%\EJBServer\project\properties\Bootstrap.properties file.
%CURAM_DIR% is the Curam installation directory, which by default is C: \IBM\Curam\Development.

2. Specify true or false in the curam.db.h2.mvcc property.
For example:

# Property to disable MVCC. Default: true. (Optional)
curam.db.h2.mvcc=false

Starting the H2 Web Console

Start the H2 Web Console by running the org.h2.tools.Server classin h2. jar as follows:

java -cp %CuramSDEJ%\drivers\h2-1.3.176.jar org.h2.tools.Server -tcp -web

You can access the H2 Web Console at the following URL:

http://localhost:8082/

The JDBC connection URL that you specify in the login screen is based on the curam.db. name,
curam.db.username, and curam.db.h2.directory values in Bootstrap.properties. These
values define the database name, SCHEMA name, and the database location in the file system. So, if
your database name is curamdb, your user name is curam and curam.db.h2.directory defaults to
your home directory, then your JDBC string would look like this example:

jdbc:h2:tcp://localhost/~/curamdb; schema=curam; FILE_LOCK=SOCKET

For example, if the curam.db.h2.directory is C: /H2, then your JDBC string would look like this
example:

jdbc:h2:tcp://localhost/file:C:/H2/curamdb; schema=curam; FILE_LOCK=SOCKET

Specify the values for User Name and Password as in your Bootstrap.properties file and then click
the Connect button (or Test Connect button). When connected, a SQL text control is available.
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Configuring the IBM Db2 database

After you install IBM Curam Social Program Management, complete the following postinstallation
configuration steps on IBM Db2

Providing a Db2 License File

An empty db2jcc_license_cu. jar file exists to allow for Eclipse class path dependencies in
the CuramSDEJ project. The file is in the mEEEmE %CURAMSDEJ%\drivers or BCURAMSDE 3%
drivers directory, where $CURAMSDE J% is the root CuramSDEJ location directory.

You must overwrite this empty JAR file with a real license to access IBM Db2.
You can find the IBM Db2 license file in the following directory:

« mEETAE <Db2_directory>\java\db2jcc_license_cu.jar

. <Db2_directory>/java/db2jcc_license_cu.jar

where Db2_directory is the Db2 installation path, for example:

o muEza C:\IBM\SQLLIB.

. /opt/ibm/db2

Creating and configuring a Db2 database with scripts on Microsoft Windows
| Windaws |

Use the provided Ant scripts to create and configure a basic test database. The Ant scripts use the
database properties from your Bootstrap.properties file.

To create a database, issue the following commands:

ant -f %CURAMSDEJ%\util\db2_createdb.xml
ant -f %CURAMSDEJ®\util\db2_postconfig.xml -Ddb2.dir=db2_directory
ant -f %CURAMSDEJ%\util\db2_createdb.xml restart.db2

Note: The db2_createdb.xml restart.db2 script restarts your Db2 system.

ant -f %CURAMSDEJ%\util\db2_optimizedbrecreation.xml

where db2_directory is the Db2 installation path. By default, ¢ : \IBM\SQLLIB.

If you have any problems with creating the database, you can run the following script to drop the
database and try again:

ant -f %CURAMSDEJ%\util\db2_createdb.xml dropdb

Linux

To create a database, issue the following commands:

ant -f $CURAMSDEJ/util/db2_createdb.xml
ant -f $CURAMSDEJ/util/db2_postconfig.xml -Ddb2.dir=db2_directory
ant -f $CURAMSDEJ/util/db2_createdb.xml restart.db2

Note: The db2_createdb.xml restart.db2 script restarts your Db2 system.
ant -f $CURAMSDEJ/util/db2_optimizedbrecreation.xml

where db2_directory is the Db2 installation path. By default, /opt/ibm/db2.
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If you have any problems with creating the database, you can run the following script to drop the
database and try again:

ant -f $CURAMSDEJ/util/db2_createdb.xml dropdb

Replacing the packaged Db2 drivers

Usually the most recent JDBC drivers available at the time of release are packaged with IBM Curam
Social Program Management. However, if you want to replace the drivers that are included in IE==z
9%CURAMSDEJ%\drivers or $CURAMSDEJ/drivers, copy the following files from mzz=zs
<Db2_directory>\javaor $CURAMSDEJ/drivers and replace the existing files.

Where <Db2_directory> is the Db2 installation path. For example, mzzz C: \IBM\SQLLIB or
/IBM/SQLLIB.

« db2jcc.jar
« db2jcc_license_cu.jar
« sqlj.zip

Using Db2 pureScale

To use Db2 pureScale® with Social Program Management, you must complete the following steps to set
the necessary data source property or properties for using Db2 from the command line. For example,
with batch processing. See the IBM Db2 and IBM WebSphere Application Server documentation for their
specific pureScale settings.

You must generate a .bindings file based on your Bootstrap.properties file database settings,
which specify the Db2 pureScale connect member. To do this:

1. Inyour Bootstrap.propexrties file set property
curam.db.enable.bindings.generation=true and specify a valid
location value for property curam.environment.bindings.location. For
example, BMEETE curam.environment.bindings.location=C:/Temp or
curam.environment.bindings.location=/Cuzram.

2. Run the Ant configtest target, to generate the . bindings file in the specified location.

3. Inyour Bootstrap.properties file, remove curam.db.enable.bindings.generation=true
orsetitto false and set curam.db.disable.bindings.generation=tzrue.

4. Set the Content value for the relevant pureScale data source properties in the .bindings file. This is
easier if you sort it first. For example, set enableSysplexWLB to 'true'. Save the changes.

From this point onwards, the Social Program Management Db2 data source uses these properties when
used from the command line. Changes to the database properties in Bootstrap.properties must be
reflected in .bindings or by rerunning the procedure above. However, Ant scripts using the <sql> task
do not use these pureScale settings. These Ant scripts, for example the database target, are typically
not run frequently and don't have a processing profile that requires pureScale settings. However, you can
modify scripts as needed to specify these properties by using the Ant <connectionPropexrty> nested
element.

Configuring the Oracle Database

After you install IBM Curam Social Program Management, complete the following postinstallation
configuration steps on Oracle Database

Replacing the packaged Oracle JDBC drivers

Typically, the most recent JDBC drivers that are available at the time of release are packaged with IBM
Curam Social Program Management. However, you can replace the included JDBC drivers if needed.
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Complete the following steps to replace the included JDBC drivers in the <CURAMSDEJ>/drivers
directory.

1. Copy and rename the ojdbc<version>. jar driver from an installation of your Oracle Database
version to ojdbc<version>.jarin the <CURAMSDEJ>/drivers directory.

2. Replace the runtime<version>.jar and translator. jar driversin the drivers directory with
the drivers from your Oracle Database client installation.
Testing the configuration

IBM Curam Social Program Management includes a configuration test tool, which helps to confirm that
the installation and third-party tools are set up correctly. You can run this tool to detect problems with
your installation.

Before you begin

If you are using the H2 database, ensure that you complete these steps before you start this task.
« Build the server and the database.
- If you are using H2 in remote mode, ensure that the H2 Web Console is started.

Procedure

1. Open a command prompt.

2. Go to the %Curam?/EJBSexrver directory and issue the following command to check the application
server configuration and the database connectivity:

build configtest

3. Ensure that the build is successful before proceeding.

Running build commands for the server and client applications

Before you can log on to an IBM Curam Social Program Management application or to the Universal
Access home page, you must run a number of build commands.

About this task

Important:

Ensure that you are in the correct directory before you run each of these commands.

Procedure

1. Open a command line.
2. Go to the %Curam?/EJBServer directory and issue the following commands:

%CURAM_DIRY is the Curam installation directory, which by default is M=z
C:\IBM\Curam\Development or /opt/ibm/curam/development.

build clean server

build database

build prepare.application.data
build createClasspaths

3. Go to the %Curam¥%/webclient directory and issue the following command:

build clean client
build external-client -Dapp=CitizenPortal

4. Ensure that the builds are successful before proceeding.
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Starting the XML server

Before you start the Curam application, you must start the XML server in your ADE.

Procedure

1. Change to the %CURAM_DIR%\CuramSDEJ\xmlserver directory.

%CURAM_DIRY is the Clram installation directory, which by default is
C:\IBM\Curam\Development or opt/ibm/curam/development.

2. Run the following build target to start the XML server:

ant -f xmlserver.xml

Configuring curam.referer.domains for Cross-Site Request Forgery
(CSRF) protection

The IBM Cdram Social Program Management user interface (UI) infrastructure uses the HTTP referrer
header check to further protect Social Program Management against Cross-Site Request Forgery (CSRF).

Only requests from trusted domains are permitted. You configure trusted domains on the server as a
comma-separated list by using the dynamic system property curam.referer.domains. As the default
property is set to localhost, only an administrator who is logged on to the server host computer can
access the application. All other users are blocked.

Configuring curam.referer.domains after installation

The following list outlines the two ways that you can configure curam.referer.domains after
installation:

1. An administrator on the server host computer can access the Social Program Management
system administration application. An administrator can set the dynamic system property
curam.referer.domains directly to the required host domains to which the administrator wants
to grant access. For more information, see the Cross-Site Request Forgery (CSRF) protection for IBM
Curam Social Program Management web pages related link.

2. Developers and administrators can provide a custom component that overrides the default
Application.pxx and that sets the property curam.referer.domains to the required domains.
For more information, see the How to merge an application prx file related link.

Related tasks

Cross-Site Request Forgery (CSRF) protection for Ciram web pages
Related reference

How to merge an application prx file

Installing and configuring Eclipse and Tomcat

You need the following software for an Eclipse and Apache Tomcat IDE. You can download the software
from the web, as described in the IBM® Ciram Social Program Management Supported Prerequisites
technote, and follow the product installation instructions and these post-installation steps.
Eclipse IDE
An IDE that you can use to develop an application. If you are unsure about which Eclipse package to
download, you can download and install the Eclipse IDE for Java EE Developers.
Tomcat
A servlet container that you can use to run the client web application.

Eclipse Tomcat Plugin

An open source Eclipse plug-in that integrates with a Tomcat installation to start Tomcat from within
Eclipse.
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Install the plug-in by extracting the plug-in archive file to the Eclipse dropins folder. The default
eclipse/dropins folder is assumed.

Java SE and Java EE
You can use the Java SE and Java EE that were installed as prerequisites for the IBM Clram Social
Program Management software for the Eclipse IDE.

Related information

IBM Cudram Social Program Management Supported Prerequisites

Configuring Tomcat

After installation, you must update the default Tomcat configuration files with the appropriate settings.

About this task
UTF-8

By default, Tomcat assumes that requests are encoded with ISO-8859-1 instead of UTF-8. This
default setting can break string handling if request parameters contained UTF-8 extended characters.
For correct string handling, you must add the useBodyEncodingForURI="true" parameter to the
<Connector> element of the server.xml configuration file.

POST Data limit

By default Tomcat limits POST data to 2 MB. This limit can cause an issue when you use rule sets,
which can post data greater than this limit. To disable the POST limit in Tomcat, you can add the
maxPostSize="-1" attribute to the <Connector> element of the server.xml configuration file.

Non-ASCII characters in Java source files

Tomcat converts JSPs into servlets that are contained in UTF-8 encoded Java sources files by default
(for multi-byte character support). These files are generated into the work folder of the project.

The Sysdeo plug-in marks the work folder as an Eclipse source folder. If you use the Eclipse build
command, the Java compiler expects system encoding sources files by default. If any source file in
the work folder contains non-ASCII characters, such as U, an Invalid Character compiler erroris
generated and you cannot access the page in a web browser.

The keepgenerated attribute prevents Tomcat from saving the source files in the work folder and
avoids this problem. You can prevent this occurring by updating the Tomcat web . xm1 configuration
file with a new init-paramelement.

The Eclipse compiler cannot be changed to compile UTF-8 source files because of a second source
folder that is called JavaSouzrce that contains files that are not in UTF-8 encoding. Changing this
setting does not affect the use of the application in any way. The keepgenerated parameter can be
set to true if you want to view and debug through source files that are generated by Tomcat, but the
error and browser access problem then occurs.

Procedure
1. Edit the tomcat_install_dir\conf\server.xml configuration file and update the <Connector>
element as follows.
Where tomcat_install_dir\conf\server.xml is the directory where you installed Tomcat.
a) Change the default port number to port="9080".
b) Add the useBodyEncodingForURI="true" attribute.
¢) If you intend to use rule sets, add the maxPostSize="-1" attribute.

For example:
<Connector port="9080" maxThreads="150" minSpareThreads="25"
maxSpareThreads="75" enablelLookups="false" redirectPort="8443"

acceptCount="100" connectionTimeout="20000" disableUploadTimeout="true"
useBodyEncodingForURI="true" maxPostSize="-1" />
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2. Edit the tomcat_install_dir\conf\context.xml configuration file. Update the <Context>
element to include a reloadable="true" attribute.
For example:

<Context reloadable="true">

3. Editthe tomcat_install_dir\conf\web.xml configuration file. Update the

org.apache.jasper.servlet.JspServlet servlet with a new init-paramelement with the
value false.
For example:

<init-param>
<param-name>keepgenerated</param-name>
<param-value>false</param-value>
</init-param>

Configuring the Java SE for Eclipse

You must ensure that Eclipse always starts with the correct Java SE and set the default VM arguments.

Multiple Java SE installations can be present on your computer from other products that are based on
Java.

Before you begin
Ensure that Eclipse starts with the correct Java SE by using one of the following methods:

- Put the correct Java SE first on the Microsoft Windows system path.

e Use the =vm command-line argument with the eclipse.exe command. For more information about
Eclipse commands, see the Eclipse documentation.

Procedure

1. Start Eclipse by double-clicking the eclipse.exe executable file.

2. After you start Eclipse, select Window > Preferences > Java > Installed JREs. On the Installed JREs
page, ensure that the checkbox for the correct Java SE is selected as the default.

3. Add default VM arguments by selecting the Java SE and clicking Edit.
4. In the Default VM Arguments field, enter -Xmx4096M -Xms512m.
5. Click OK.

Configuring the Eclipse class path variables and the Eclipse Tomcat Plugin

In Eclipse, you must set the class path variables and configure the Eclipse Tomcat Plugin.

Procedure

Set the class path variables:
1. In Eclipse, go to Window > Preferences > Java > Build Path > class path Variables.
2. Click New, enter the following information, and click OK.
« Name J2EE_JAR
« Path
— The path to the JAR file of your Java EE implementation. For example, for WebSphere Application
Server, enter: C: \IBM\WebSphere\AppServer\lib\j2ee. jar

— For example, for Oracle WebLogic Server, enter:
C:\Oracle\Weblogic\wlserver\server\lib\weblogic.jar

3. Click New, enter the following information, and click OK.
« Name JAVAMAIL_HOME
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« Path The folder that contains mail.jar and activation. jar files for your Java EE
implementation.

Note:

If your version of Java EE does not contain these files, you can download JavaMail API and Java
Activation Framework (JAF) from the Oracle website and copy the files to any folder, for example
C:\Tools\JAVA_MAIL. Then, configure JAVAMAIL_HOME to point to that folder.

4. Click OK to save the preferences.
Configure the Eclipse Tomcat Plugin:

The plugin adds a toolbar and more menu options to Eclipse to configure and use Tomcat.

5. In Eclipse, go to Window > Preferences > Tomcat.
If you don't see Tomcat in the high-level preferences tree, you might have the wrong Tomcat plugin, it
might not be installed properly, or you might need a clean Eclipse start.

6. Select the appropriate Tomcat version, such as version 7.x.

7. Set Tomcat home to where you extracted the downloaded archive.
For example, C:\Tools\Tomcat\apache-tomcat-<version>.

8. Select JVM Settings and in the Append to JVM Parameters field, enter -Xmx1024m.

Importing and configuring the Social Program Management projects in
Eclipse

Import the IBM Cdram Social Program Management projects into Eclipse. The projects are automatically
built when you import them. After the projects are imported, you can configure them for use.

Procedure

Import the projects:
1. In Eclipse, click File > Import.
2. Expand General, select Existing Projects into Workspace, and click Next.
3. Set the Select root directory field field to, for example C: \IBM\Curam\Development.
Eclipse automatically searches for and identifies projects.
4. Ensure that Copy projects into workspace is NOT selected.
5. Click Finish.

Eclipse immediately starts building the workspace. The following error is displayed: Project
'CuramBITransforms' is missing required Java project: 'CuramBITools'
CuramBITransforms Build path Build Path Problem

6. Manually import the CuramBITransforms project. In Eclipse, click File > Import.
7. Expand General, select Existing Projects into Workspace, and click Next.

8. Set the Select root directory field field to
C:\IBM\Curam\Development\Reporting\components\BIBuildTools.

Eclipse automatically searches for and identifies projects.
9. Ensure that Copy projects into workspace is NOT selected.
10. Click Finish.
Configure the Curam project:

11. In Eclipse Package Explorer, right-click the Curam project, select Properties > Tomcat and confirm
the following settings.

« Is a Tomcat Project: Selected

+ Context Name: /Curam

« Can update server.xml file: Selected

- Mark this context as reloadable: Selected
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12.
13.

« Redirect context logger to Eclipse console: Selected
« Subdirectory to set as application root: /WebContent

+ Subdirectory to set as application work: /work
Click OK.

Update the Tomcat server.xml file with an entry for the Curam application by right-clicking the
CitizenPortal project and selecting Properties > Tomcat Project > Update context definition.

Configure the CitizenPortal project:

14.

15.
16.

In Eclipse Package Explorer, right-click the CitizenPortal project and select Properties > Tomcat and
confirm the following settings.

« Is a Tomcat Project: Selected

« Context Name: /CitizenPortal

« Can update server.xml file: Selected

« Mark this context as reloadable: Selected

« Redirect context logger to Eclipse console: Selected

« Subdirectory to set as application root: /WebContent

« Subdirectory to set as application work: /work
Click OK.

Update the Tomcat server.xml file with an entry for the CitizenPortal application by right-clicking the
CitizenPortal project and selecting Properties > Tomcat Project > Update context definition.

Configure the CuramBIRTViewer Project:

17.

18.

19.
20.

21.

In Eclipse Package Explorer, right-click the CuramBIRTViewer project and select Properties >
Tomcat and confirm the following settings.

« Is a Tomcat Project: Selected

« Context Name: /CuramBIRTViewer

« Can update server.xml file: Selected

« Mark this context as reloadable: Selected

« Redirect context logger to Eclipse console: Selected

« Subdirectory to set as application root: /WebContent
« Subdirectory to set as application work: /work

Update the Tomcat server.xml file with an entry for the CuramBIRTViewer application by right-
clicking the CuramBIRTViewer project and selecting Properties > Tomcat Project > Update context
definition.

Click OK.

In your Curam Development command window, enter:

cd %CURAM_DIR%\BIContent

Where %CURAM_DIR% is the Curam installation directory, which by default is
C:\IBM\Curam\Development.

Enter:

build client.birt

If you are developing new Curam Business Intelligence and Analytics content, see the BIRT
developer's information for more details on how to set up a development environment.
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Starting the Tomcat server and the Social Program Management servers

Start the Tomcat and Social Program Management servers by following the instructions in the related
links.

About this task
After the servers are started, applications are available at these URL:

« The Social Program Management client application is available at the following URL: http://
localhost:8080/Curam/AppController.do

« The CitizenPortal application is available at the following URL: http://localhost:8080/
CitizenPortal/application.do

« The Social Program Management Business Intelligence and Analytics Viewer application is available at
the following URL: http://localhost:8080/CuramBIRTViewer

Related tasks

Starting the server, Tomcat, and the RMILoginClient
Start the server, Tomcat, and the RMILoginClient so that you can log in and test the installation.

Using Eclipse to validate the tabbed configuration artifacts
You can set up Eclipse to validate the tabbed configuration files with the correct schema.

Open the Eclipse Preferences dialog by selecting Window > Preferences and complete the following
steps:

« Select XML > XML Catalog.

Click Add... to add an entry.

For the Location, point at the schema file (for example, tab.xsd) in the $CURAMSDEJ%\1ib
directory.

Leave the rest as defaults and click OK.

Repeat for each of the schema files for the tabbed configuration artifacts.

Click OK to exit the XML Catalog window.

- Select General > Editors > File Associations.
— Click Add... to add an entry: *. tab.
— Select the new x.tab entry and click Add to add the XML Editor as the Associated Editor.
— Repeat for all the tabbed configuration artifact file extensions.

« Select General > Content Types.

— Expand Text and select XML.

— Click Add to enter a file association for XML content and click OK. Do this step for each of the file
extensions.

« Click OK to save the preference changes.

Related reference
Configuration files

Supported Eclipse text file encoding

In Eclipse, you can set the default text file encoding at the project level. Changing the text file encoding
from the default is unsupported for IBM Curam Social Program Management projects within Eclipse.

This restriction does not affect your ability to save files in various encodings on a file-by-file basis.

Related concepts
Cdaram web client reference
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Related information
Curam Server Developer

Installing and configuring Rational Software Architect Designer

IBM Rational® Software Architect Designer is an Eclipse-based UML modeling tool that is required to do
server development. The exact installation steps for installing IBM Rational Software Architect Designer
can vary depending on the edition and version of your software.

Before you begin
IBM Installation Manager is used to install Rational Software Architect Designer. For more information
about installing IBM Installation Manager, see “Installing IBM Installation Manager” on page 3.

Procedure
1. Start the IBM Installation Manager by clicking Start > All Programs > IBM Installation Manager >
IBM Installation Manager.
2. From the File menu, select Preferences.
. From the Repositories window, select Add Repository.

. From the Add Repository window, select Browse to add an entry that points to your Rational
Software Architect Designer installation file and click OK.

. From the Repositories window, ensure that this entry is the only selected repository and click OK.
. From the IBM Installation Manager window, select Install.

. From the Install Packages window, select appropriate version check box and click Next.

. From the Prerequisite window, read the information that is displayed and click Next.

. From the Licenses window, read the information, select I accept the terms in the license
agreements, and click Next.

10. From the Location window, select Browse to select the installation directory or use the default value.
For Architecture Selection, update the default values if required. Click Next.

11. From the Features window, select the translations to install and click Next.

12. From the Features to install window, select the Rational Rose model import check box to install the
IBM Rational Rose profile that is required by migrated models in Eclipse. Click Next.

13. From the Summary window, click Install.

B~ W

O 00 g O Ol

Installing the IBM Curam Social Program Management plug-ins

You must install the IBM Cdram Social Program Management plug-ins to enable modeling support.

Procedure

1. From the Rational Software Architect Designer installation directory, for example, the C: \Program
Files\IBM\SDP directory, create a dropins directory.

2. From the dropins directory, create a new file called rsa_plugin.link that contains the path to the
plug-ins for Rational Software Architect Designer. Ensure that you use forward slashes.
For example,

path=C:/Curam/CuramSDEJ/rsa

3. Edit the Microsoft Windows shortcut that starts Rational Software Architect Designer to pass the
-clean option so that the plug-ins are picked up.
For example:

...\eclipse.exe -clean -product com.ibm.rational....

4. Start or restart Rational Software Architect Designer.
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Setting up your Rational Software Architect Designer workspace

Complete the following steps to set up your Eclipse workspace in Rational Software Architect Designer.

Procedure

1. Start Rational Software Architect Designer by clicking Start > All Programs > IBM Software Delivery
Platform > IBM Rational Software Architect Designer version > IBM Rational Software Architect
Designer.

2. From the Workspace Launcher, select Browse to navigate to the location where you want your
Rational Software Architect Designer workspace to be stored and click OK.

3. From the Overview window, hover over the top right icon to display Workbench. Select the
Workbench icon.

4. Select File > Import.

5. From the Import window, expand the General folder and select Existing Project into Workspace and
click Next.

6. From the Import Projects window, select Browse and select %CURAM_DIR%\EJBServer for the
Select root directory and click Finish.

9%CURAM_DIR% is the IBM Curam Social Program Management installation directory, which by default is
C:\IBM\Curam\Development.

7. Repeat steps 4-6 to import the %$CURAMSDE J% root directory. You are now ready to start using Rational
Software Architect Designer.

Getting started with the development environment

The installation is now complete. Start the server, Tomcat, and the RMILoginClient client so you can log in
to the application.

Starting the server, Tomcat, and the RMILoginClient

Start the server, Tomcat, and the RMILoginClient so that you can log in and test the installation.

About this task

The server is started as a Java process that starts three threads:

tnameserv
The Java Transient Name Server to facilitate a INDI lookup service for finding resources such as

Java classes. The Java tnameserv.exe is not stopped when you exit Eclipse. You can check for
tnameserv.exe in Windows Task Manager.

RMI Server
The RMILoginClient server application process, which provides login functionality.

JMSLite

JMS Message Engine, which provides JMS-like functionality. For more information about JMSLite, see
the JMSlite topic in the related link.

Procedure

1. Check that the database is running.

2. In Package Explorer, expand EJBServer > components > core > lib, right-click on core.jar, and select
Run As > Java Application.

3. In the Select Java Application window, select StartServer and click OK.

When a console window is displayed in Eclipse, check for messages like these:

tnameserv.exe started:
Initial Naming Context:
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IOR:00bdbdbd0000002b49444c3a6£6d672e6£72672£4361734€616d696e672f4e616d696e67436£6e74657874457
8743a312e

3000bd0OO0OOO10000000000000072000102bdOOEAOOOd392e3136312e39392e31333600bd04c5000000164c4d424
900000015

b3c2£20c00100000000400000000bdbdOOONOEE3000000010000001800bdbdbd00010001000000010001002000010
100000000
0049424d0a0000000800bd00111800000000000026000000020002
TransientNameServer: setting port for initial object references to: 1221
Ready.
JMSLite started:

FHHE ...
{HHE Custom RIDPSecondaryRequestMockService loaded iHHE

4. To start Tomcat, on the Eclipse menu, click the Start Tomcat button on the Eclipse Tomcat Plugin
toolbar.

Confirm a clean start in the Tomcat console window in Eclipse by waiting for a few moments until you
see a message like this:

INFO: Server startup in 61316 ms

5. In Package Explorer, expand the EJBServer > components > core > lib, right-click on core.jar, select
RMILoginClient and select Run as application

6. In the Select Java Application window, select RMILoginClient and click OK.
7. In the RMILoginClient window, enter your credentials.

Related concepts
JMSLite

Logging on to Social Program Management

You can access the IBM Curam Social Program Management application or the Citizen Portal application
from any supported browser. From here, you can access features that are based on your role. For
example, you can log on to administer the system.

Procedure
1. Enter one of the following URLs:

https://server_name:port/Curam/AppController.do

https://server_name:port/CitizenPortal/application.do

where:

- server_name is the name of the server where you installed the application.
« port is the port for the application. Default port numbers are as follows:

— Apache Tomcat: 9080

— IBM WebSphere Application Server: 9044

— Oracle Weblogic Server: 7002
2. Log on with the appropriate role.

Option Description

sysadmin The System Administrator user has access to technical administration features.

admin The Administrator user has access to administration features.

caseworker |The caseworker role has access to caseworker features.

supervisor | The supervisor role has access to supervisor features.
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Deploying Social Program Management

To test your applications with an enterprise application server, you can deploy the application and web
services application to one of the supported application server and database combinations.

« IBM WebSphere Application Server and IBM Db2.

- IBM WebSphere Application Server and Oracle Database.
 Oracle WebLogic Server and Oracle Database.

For more information about deployment, see:

 Deploying on

« Deploying on Oracle WebLogic Server

 Deploying on

Upgrading IBM Curam Social Program Management

Use the IBM Cdram Upgrade Helper Pack and the UI Upgrade Helper tool to help you to upgrade your
custom IBM Curam Social Program Management application.

IBM Curam Upgrade Helper Pack
The IBM Cdram Upgrade Helper Pack contains tools and an upgrade guide, which describes the
recommended process for upgrading IBM Clram Social Program Management applications and
details any significant migrations that might require upgrade effort. The tools are available to assist

with certain process steps. The IBM Clram Upgrade Helper Pack is available as a download from IBM
Fix Central.

1. Log in to IBM Fix Central.

2. Select the Curam Social Program Management product and enter a text search for IBM Curam
Upgrade Helper.

3. Download the IBM Curam Upgrade Helper pack.
UI Upgrade Helper

You can use the IBM Curam Social Program Management UI Upgrade Helper tool to help you to
upgrade your Social Program Management (UI) from version 7 to version 8. For more information
about the UI Upgrade Helper, see https://ibm.github.io/spm-ui-upgrade-helper/overview.
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Notices

This information was developed for products and services offered in the United States.

IBM may not offer the products, services, or features discussed in this document in other countries.
Consult your local IBM representative for information on the products and services currently available in
your area. Any reference to an IBM product, program, or service is not intended to state or imply that
only that IBM product, program, or service may be used. Any functionally equivalent product, program, or
service that does not infringe any IBM intellectual property right may be used instead. However, it is the
user's responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this
document. The furnishing of this document does not grant you any license to these patents. You can
send license inquiries, in writing, to:

IBM Director of Licensing IBM Corporation North Castle Drive, MD-NC119 Armonk, NY 10504-1785 US

For license inquiries regarding double-byte character set (DBCS) information, contact the IBM Intellectual
Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing Legal and Intellectual Property Law IBM Japan Ltd. 19-21, Nihonbashi-
Hakozakicho, Chuo-ku Tokyo 103-8510, Japan

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS"
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED
TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A
PARTICULAR PURPOSE. Some jurisdictions do not allow disclaimer of express or implied warranties in
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically
made to the information herein; these changes will be incorporated in new editions of the publication.
IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM websites are provided for convenience only and do not in
any manner serve as an endorsement of those websites. The materials at those websites are not part of
the materials for this IBM product and use of those websites is at your own risk.

IBM may use or distribute any of the information you provide in any way it believes appropriate without
incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the
exchange of information between independently created programs and other programs (including this
one) and (ii) the mutual use of the information which has been exchanged, should contact:

IBM Director of Licensing IBM Corporation North Castle Drive, MD-NC119 Armonk, NY 10504-1785 US

Such information may be available, subject to appropriate terms and conditions, including in some cases,
payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by
IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any
equivalent agreement between us.

The performance data and client examples cited are presented for illustrative purposes only. Actual
performance results may vary depending on specific configurations and operating conditions.

Information concerning non-IBM products was obtained from the suppliers of those products, their
published announcements or other publicly available sources. IBM has not tested those products

and cannot confirm the accuracy of performance, compatibility or any other claims related to non-
IBMproducts. Questions on the capabilities of non-IBM products should be addressed to the suppliers of
those products.
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Statements regarding IBM's future direction or intent are subject to change or withdrawal without notice,
and represent goals and objectives only.

AlLIBM prices shown are IBM's suggested retalil prices, are current and are subject to change without
notice. Dealer prices may vary.

This information is for planning purposes only. The information herein is subject to change before the
products described become available.

This information contains examples of data and reports used in daily business operations. To illustrate
them as completely as possible, the examples include the names of individuals, companies, brands, and
products. All of these names are fictitious and any similarity to actual people or business enterprises is
entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrate programming
techniques on various operating platforms. You may copy, modify, and distribute these sample programs
in any form without payment to IBM, for the purposes of developing, using, marketing or distributing
application programs conforming to the application programming interface for the operating platform

for which the sample programs are written. These examples have not been thoroughly tested under

all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these
programs. The sample programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

Privacy Policy considerations

IBM Software products, including software as a service solutions, (“Software Offerings”) may use cookies
or other technologies to collect product usage information, to help improve the end user experience,

to tailor interactions with the end user or for other purposes. In many cases no personally identifiable
information is collected by the Software Offerings. Some of our Software Offerings can help enable you
to collect personally identifiable information. If this Software Offering uses cookies to collect personally
identifiable information, specific information about this offering’s use of cookies is set forth below.

Depending upon the configurations deployed, this Software Offering may use session cookies or other
similar technologies that collect each user’s name, user name, password, and/or other personally
identifiable information for purposes of session management, authentication, enhanced user usability,
single sign-on configuration and/or other usage tracking and/or functional purposes. These cookies or
other similar technologies cannot be disabled.

If the configurations deployed for this Software Offering provide you as customer the ability to collect
personally identifiable information from end users via cookies and other technologies, you should seek
your own legal advice about any laws applicable to such data collection, including any requirements for
notice and consent.

For more information about the use of various technologies, including cookies, for these purposes,

see IBM’s Privacy Policy at http://www.ibm.com/privacy and IBM’s Online Privacy Statement at http://
www.ibm.com/privacy/details the section entitled “Cookies, Web Beacons and Other Technologies”

and the “IBM Software Products and Software-as-a-Service Privacy Statement” at http:/www.ibm.com/
software/info/product-privacy.

Trademarks

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business
Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be
trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at

“ Copyright and trademark information ” at http://www.ibm.com/legal/copytrade.shtml.

Adobe, the Adobe logo, PostScript, and the PostScript logo are either registered trademarks or
trademarks of Adobe Systems Incorporated in the United States, and/or other countries.
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Java and all Java-based trademarks and logos are trademarks or registered trademarks of Oracle and/or
its affiliates.

The registered trademark Linux is used pursuant to a sublicense from the Linux Foundation, the exclusive
licensee of Linus Torvalds, owner of the mark on a worldwide basis.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in the
United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Other names may be trademarks of their respective owners. Other company, product, and service names
may be trademarks or service marks of others.
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