Overview

[image]

Merge DICOM Web Services .NET/C# Toolkit
Overview
Send Feedback

Merge DICOM Web Services .NET/C# Toolkit

PS3.18 of the DICOM standard introduces the specifications and mechanisms for Web services to access and present DICOM objects through Http/Https protocols - Web Access of DICOM Persistent Objects (WADO).

The Merge DICOM Web Services Toolkit provides a flexible framework to handle WADO requests and DICOM service responses for the Web clients.

The Merge DICOM Web Services .NET toolkit supplies you with a powerful and simplified interface to DICOM Web Services. This functionality gives the user a simple way to parse a complex DICOM Http request into a set of Mergecom Toolkit DIMSE messages to be delivered to the DICOM service and then convert the DICOM service response back to an Http response message.

Development Platform Requirements

The Merge DICOM Web Services .NET/C# Toolkit supports Frameworks .NET 4.5, 4.8, 6.0, 8.0 and .NET Core and requires Windows OS supporting that frameworks.

The toolkit requires the .NET DICOM Toolkit (Mergecom.dll) and the 32- or 64-bit C toolkit run-time library depending on whether the application runs as a 32-bit or 64-bit process.

Send comments on this topic to MC3 Support

Copyright (c) Merge Healthcare Solutions Inc. 2025. All rights reserved.


Distribution Structure

[image]

Merge DICOM Web Services .NET/C# Toolkit
Distribution Structure
Send Feedback

Distribution Structure of the Merge DICOM .NET/C# Toolkit

The toolkit is distributed in the following folders and files:

  • bin folder - contains the toolkit assembly (Mergecomws.dll).
  • doc folder - contains the toolkit's HTML documentation (this help file).
  • samples folder - contains various sample C# source files and Microsoft Visual Studio project files for the samples.

The bin Folder

The bin folder contains the following files:

File | Description
Mergecomws.dll | The main Merge DICOM Web Services Toolkit assembly.
Mergecomws.xml | XML documentation files for Microsoft Visual Studio intellisense support.


Legal and Support

[image]

Merge DICOM Web Services .NET/C# Toolkit
Legal and Support
Send Feedback

Legal Information

This document has been prepared by Merge Healthcare for its customers. The content of this document is confidential. It may be reproduced only with written permission from Merge Healthcare. Specifications contained herein are subject to change, and these changes will be reported in subsequent revisions or editions.

DICOM is a registered trademark of National Electrical Manufacturers Association (NEMA). Merge DICOM Toolkit™ is a trademark of Merge Healthcare. The names of other products mentioned in this document may be the trademarks or registered trademarks of their respective companies.

Copyright © Merge Healthcare Solutions Inc. 2025.

All rights reserved. Unauthorized use, reproduction, or disclosure is prohibited.

Merge Healthcare Incorporated

900 Walnut Ridge Drive, Hartland, WI 53029

Customer Support

For application support or to report issues with user documentation, please contact Merge Healthcare Solutions Inc. Customer Support:

  • 1-877-741-5369 (North America)
  • +31.20.514.5073 (Europe, the Middle East and Africa)
  • 1800 316 746 (Australia)
  • Email: MC3Support@merative.com


Mergecomws.Dicom Namespace

[image]

Merge DICOM Web Services .NET/C# Toolkit
Mergecomws.Dicom Namespace
Send Feedback
Classes for the conversion of HTTP requests to DICOM requests and DICOM responses to HTTP responses.

Classes

 | Class | Description
Public class | MCactionType | Defines DICOM WADO-RS, QIDO-RS, STOW-RS, WADO-WS and UPS-RS action types.
Public class | MCbaseConverter | Abstract base class which implements IMChttpConverter interface
Public class | MCbaseRenderer | Abstract base class which implements IMCdicomRenderer interface
Public class | MCbaseResponder | Abstract base class which implements IMChttpResponder interface
Public class | MCdicomLevel | Defines DICOM C-FIND level
Public class | MCdicomRenderer | Converts DICOM service response into an array of Stream objects
Public class | MCdicomRequest | Converts and encapsulates HttpRequestMessage data
Public class | MCdicomResponse | Encapsulates and converts DICOM service response into HttpResponseMessage data
Public class | MCdicomRoot | Describes Root property of DICOM request model
Public class | MChttpConverter | Converts an arrays of Stream objects rendered from DICOM service response into an array of HttpContent objects
Public class | MChttpResponder | Constructs HttpResponseMessage object from an array of HttpContent objects
Public class | MCmediaType | Describes Media-Types used in Http protocol as defined in http://www.iana.org/assignments/media-types/media-types.xhtml
Public class | MCqidoRequest | Converts and encapsulates HttpRequestMessage data from QIDO-RS request
Public class | MCrsCapabilitiesDocument | MCrsCapabilitiesDocument class encapsulates WADL RS Capabilities document
Public class | MCrsCapabilitiesRequest | Converts and encapsulates HttpRequestMessage data from RS Capabilities request
Public class | MCrsNpiRequest | Converts and encapsulates HttpRequestMessage data from RS NPI request
Public class | MCstowCommitmentRequest | Converts and encapsulates HttpRequestMessage data from STOW-RS request
Public class | MCstowRequest | Converts and encapsulates HttpRequestMessage data from STOW-RS request
Public class | MCupsRequest | Converts and encapsulates HttpRequestMessage data from UPS-RS request
Public class | MCupsResponse | Encapsulates and converts UPS-RS DICOM service response into HttpResponseMessage data
Public class | MCupsResponse..::..Status | Describes UPS-RS response status
Public class | MCupsSopClass | Describes Unified Procedure Step Service Class and SOP Class UIDs, DICOM PS3.4 2015c, CC.3.1 Service Class and SOP Class UIDs
Public class | MCwado | Singleton class used to register DICOM services and WADO configuration settings
Public class | MCwado..::..Configuration | MCwado configuration settings
Public class | MCwadoRsRequest | Converts and encapsulates HttpRequestMessage data from WADO-RS request
Public class | MCwadoUriRequest | Converts and encapsulates HttpRequestMessage data from WADO-URI request
Public class | MCwadoWsDocument | Encapsulates and converts Soap WADO-WS message
Public class | MCwadoWsMessage | MCwadoWsMessage class to encapsulate the properties of Soap WADO-WS request/response
Public class | MCwadoWsMessage..::..Names | List of names used in WADO-WS XSD Schema PS3.18 2014c WebServices E.1 WADO WS XSD Schema (Informative)
Public class | MCwadoWsMessage..::..XopDocument | XOP (XML-binary Optimized Packaging) document
Public class | MCwadoWsRequest | Converts and encapsulates HttpRequestMessage data from WADO-WS request
Public class | MCwadoWsResponse | Encapsulates and converts WADO-WS DICOM service response into HttpResponseMessage data
Public class | MCwadoWsResponse..::..Error | Describes WADO-WS response errors
Public class | MCwadoWsResponse..::..Severity | Describes WADO-WS error severity
Public class | MCwadoWsResponse..::..Status | Describes WADO-WS response status

Interfaces

 | Interface | Description
Public interface | IMCbulkDataHandler | IMCbulkDataHandler interface used to provide the bulk data associated with the unique BulkDataUri for given DICOM attribute
Public interface | IMCcache | Defines the cache operations to store and retrieve the results of MCabstractMessage WADO requests
Public interface | IMCdicomRenderer | Defines the conversion operation of DICOM Service response to an array of Stream objects
Public interface | IMChttpConverter | Defines the conversion operation of rendered DICOM streams into an array of HttpContent objects
Public interface | IMChttpResponder | Defines the construction of HttpResponseMessage object from an array of HttpContent objects
Public interface | IMCservice | Defines the method of DICOM service to retrieve and store DICOM objects

Enumerations

 | Enumeration | Description
Public enumeration | MCwadlElementType | The enumeration lists the types of WADL elements.


IMCbulkDataHandler Interface

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMCbulkDataHandler Interface
Members See Also Send Feedback
IMCbulkDataHandler interface used to provide the bulk data associated with the unique BulkDataUri for given DICOM attribute

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public interface IMCbulkDataHandler
Visual Basic
Public Interface IMCbulkDataHandler
Visual C++
public interface class IMCbulkDataHandler

See Also

IMCbulkDataHandler Members
Mergecomws.Dicom Namespace


IMCbulkDataHandler Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
IMCbulkDataHandler Members
IMCbulkDataHandler Interface Methods See Also Send Feedback

The IMCbulkDataHandler type exposes the following members.

Methods

Name Description
Public method provideData
CopyC#
IMCbulkDataHandler
 is an extension of MCbulkDataUriHandler. The interface implementation should provide the data by returning an array of data according to the VR type (either by retrieving the data from the URI location or from the data associated with URI) If implementation returns null, the incoming attribute will contain a ValueLength of 0 (i.e. attribute in message but zero value length).

See Also

IMCbulkDataHandler Interface


IMCbulkDataHandler Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
IMCbulkDataHandler Methods
IMCbulkDataHandler Interface See Also Send Feedback

The IMCbulkDataHandler type exposes the following members.

Methods

Name Description
Public method provideData
CopyC#
IMCbulkDataHandler
 is an extension of MCbulkDataUriHandler. The interface implementation should provide the data by returning an array of data according to the VR type (either by retrieving the data from the URI location or from the data associated with URI) If implementation returns null, the incoming attribute will contain a ValueLength of 0 (i.e. attribute in message but zero value length).

See Also

IMCbulkDataHandler Interface


provideData Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMCbulkDataHandler..::..provideData Method
IMCbulkDataHandler Interface See Also Send Feedback
CopyC#
IMCbulkDataHandler
 is an extension of MCbulkDataUriHandler. The interface implementation should provide the data by returning an array of data according to the VR type (either by retrieving the data from the URI location or from the data associated with URI) If implementation returns null, the incoming attribute will contain a ValueLength of 0 (i.e. attribute in message but zero value length).

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
Object provideData(
    MCattributeSet attrSet,
    uint tag,
    MCvr vr,
    string uri,
    Object data
)
Visual Basic
Function provideData ( _
    attrSet As MCattributeSet, _
    tag As UInteger, _
    vr As MCvr, _
    uri As String, _
    data As Object _
) As Object
Visual C++
Object^ provideData(
    MCattributeSet^ attrSet,
    unsigned int tag,
    MCvr^ vr,
    String^ uri,
    Object^ data
)

Parameters

attrSet
Type: MCattributeSet
Identifies the current data set in process
tag
Type: System..::..UInt32
The attribute tag
vr
Type: MCvr
The value representation
uri
Type: System..::..String
The received URI
data
Type: System..::..Object
The data associated with the received bulk data URI

Return Value

The data according to VR type

See Also

IMCbulkDataHandler Interface
IMCbulkDataHandler Members


IMCcache Interface

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMCcache Interface
Members See Also Send Feedback
Defines the cache operations to store and retrieve the results of MCabstractMessage WADO requests

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public interface IMCcache
Visual Basic
Public Interface IMCcache
Visual C++
public interface class IMCcache

See Also

IMCcache Members


IMCcache Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
IMCcache Members
IMCcache Interface Methods See Also Send Feedback

The IMCcache type exposes the following members.

Methods

 | Name | Description
Public method | Exists | Checks if WADO request exists in the cache storage
Public method | Get | Retrieves DICOM service response for given WADO request
Public method | Put | Add WADO request and DICOM service response to the cache storage
Public method | Remove | Removes WADO request from the cache storage

See Also

IMCcache Interface


IMCcache Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
IMCcache Methods
IMCcache Interface See Also Send Feedback

The IMCcache type exposes the following members.

Methods

 | Name | Description
Public method | Exists | Checks if WADO request exists in the cache storage
Public method | Get | Retrieves DICOM service response for given WADO request
Public method | Put | Add WADO request and DICOM service response to the cache storage
Public method | Remove | Removes WADO request from the cache storage

See Also

IMCcache Interface


Exists Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMCcache..::..Exists Method
IMCcache Interface See Also Send Feedback
Checks if WADO request exists in the cache storage

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
bool Exists(
    MCabstractMessage[] request
)
Visual Basic
Function Exists ( _
    request As MCabstractMessage() _
) As Boolean
Visual C++
bool Exists(
    array<MCabstractMessage^>^ request
)

Parameters

request
Type: array<MCabstractMessage>[]()[][]
MCabstractMessage WADO request encoded as an array of MCabstractMessage

Return Value

Returns True if the request exists

See Also

IMCcache Interface
IMCcache Members


Get Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMCcache..::..Get Method
IMCcache Interface See Also Send Feedback
Retrieves DICOM service response for given WADO request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
bool Get(
    MCabstractMessage[] request,
    out MCabstractMessage[] response
)
Visual Basic
Function Get ( _
    request As MCabstractMessage(), _
    <OutAttribute> ByRef response As MCabstractMessage() _
) As Boolean
Visual C++
bool Get(
    array<MCabstractMessage^>^ request,
    [OutAttribute] array<MCabstractMessage^>^% response
)

Parameters

request
Type: array<MCabstractMessage>[]()[][]
WADO request encoded as an array of MCabstractMessage
response
Type: array<MCabstractMessage>[]()[][]%
DICOM service response encoded as an array of MCabstractMessage

Return Value

Returns True if the operation was successful

See Also

IMCcache Interface
IMCcache Members


Put Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMCcache..::..Put Method
IMCcache Interface See Also Send Feedback
Add WADO request and DICOM service response to the cache storage

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
bool Put(
    MCabstractMessage[] request,
    MCabstractMessage[] response
)
Visual Basic
Function Put ( _
    request As MCabstractMessage(), _
    response As MCabstractMessage() _
) As Boolean
Visual C++
bool Put(
    array<MCabstractMessage^>^ request,
    array<MCabstractMessage^>^ response
)

Parameters

request
Type: array<MCabstractMessage>[]()[][]
WADO request encoded as an array of MCabstractMessage
response
Type: array<MCabstractMessage>[]()[][]
DICOM service response encoded as an array of MCabstractMessage

Return Value

Returns True if the operation was successful

See Also

IMCcache Interface
IMCcache Members


Remove Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMCcache..::..Remove Method
IMCcache Interface See Also Send Feedback
Removes WADO request from the cache storage

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
bool Remove(
    MCabstractMessage[] request
)
Visual Basic
Function Remove ( _
    request As MCabstractMessage() _
) As Boolean
Visual C++
bool Remove(
    array<MCabstractMessage^>^ request
)

Parameters

request
Type: array<MCabstractMessage>[]()[][]
MCabstractMessage WADO request encoded as an array of MCabstractMessage

Return Value

Returns True if remove operation was successful

See Also

IMCcache Interface
IMCcache Members


IMCdicomRenderer Interface

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMCdicomRenderer Interface
Members See Also Send Feedback
Defines the conversion operation of DICOM Service response to an array of Stream objects

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public interface IMCdicomRenderer
Visual Basic
Public Interface IMCdicomRenderer
Visual C++
public interface class IMCdicomRenderer

See Also

IMCdicomRenderer Members


IMCdicomRenderer Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
IMCdicomRenderer Members
IMCdicomRenderer Interface Methods See Also Send Feedback

The IMCdicomRenderer type exposes the following members.

Methods

 | Name | Description
Public method | Render | Renders DICOM service response into Stream objects using an array of MCparameter

See Also

IMCdicomRenderer Interface


IMCdicomRenderer Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
IMCdicomRenderer Methods
IMCdicomRenderer Interface See Also Send Feedback

The IMCdicomRenderer type exposes the following members.

Methods

 | Name | Description
Public method | Render | Renders DICOM service response into Stream objects using an array of MCparameter

See Also

IMCdicomRenderer Interface


Render Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMCdicomRenderer..::..Render Method
IMCdicomRenderer Interface See Also Send Feedback
Renders DICOM service response into Stream objects using an array of MCparameter

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
Stream[] Render(
    MCabstractMessage[] response,
    string xmlRequestParameters,
    ref string xmlWadoResponse
)
Visual Basic
Function Render ( _
    response As MCabstractMessage(), _
    xmlRequestParameters As String, _
    ByRef xmlWadoResponse As String _
) As Stream()
Visual C++
array<Stream^>^ Render(
    array<MCabstractMessage^>^ response,
    String^ xmlRequestParameters,
    String^% xmlWadoResponse
)

Parameters

response
Type: array<MCabstractMessage>[]()[][]
DICOM service response encoded as an array of of MCabstractMessage
xmlRequestParameters
Type: System..::..String
XML string of MCparameter used for WADO request
xmlWadoResponse
Type: System..::..String%
WADO response from DICOM service encoded as XML String

Return Value

An array of Stream objects generated from DICOM service response

See Also

IMCdicomRenderer Interface
IMCdicomRenderer Members


IMChttpConverter Interface

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpConverter Interface
Members See Also Send Feedback
Defines the conversion operation of rendered DICOM streams into an array of HttpContent objects

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public interface IMChttpConverter
Visual Basic
Public Interface IMChttpConverter
Visual C++
public interface class IMChttpConverter

See Also

IMChttpConverter Members


IMChttpConverter Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpConverter Members
IMChttpConverter Interface Methods See Also Send Feedback

The IMChttpConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts an arrays of rendered DICOM stream into array of HttpContent objects based on request and response parameters

See Also

IMChttpConverter Interface


IMChttpConverter Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpConverter Methods
IMChttpConverter Interface See Also Send Feedback

The IMChttpConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts an arrays of rendered DICOM stream into array of HttpContent objects based on request and response parameters

See Also

IMChttpConverter Interface


Convert Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpConverter..::..Convert Method
IMChttpConverter Interface See Also Send Feedback
Converts an arrays of rendered DICOM stream into array of HttpContent objects based on request and response parameters

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
HttpContent[] Convert(
    Stream[] streams,
    string xmlRequestParameters,
    ref string xmlWadoResponse
)
Visual Basic
Function Convert ( _
    streams As Stream(), _
    xmlRequestParameters As String, _
    ByRef xmlWadoResponse As String _
) As HttpContent()
Visual C++
array<HttpContent^>^ Convert(
    array<Stream^>^ streams,
    String^ xmlRequestParameters,
    String^% xmlWadoResponse
)

Parameters

streams
Type: array<System.IO..::..Stream>[]()[][]
DICOM streams
xmlRequestParameters
Type: System..::..String
XML string of MCparameter used for WADO request
xmlWadoResponse
Type: System..::..String%
WADO response from DICOM service encoded as XML String

Return Value

A HttpResponseMessage object generated from DICOM service response

See Also

IMChttpConverter Interface
IMChttpConverter Members


IMChttpResponder Interface

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpResponder Interface
Members See Also Send Feedback
Defines the construction of HttpResponseMessage object from an array of HttpContent objects

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public interface IMChttpResponder
Visual Basic
Public Interface IMChttpResponder
Visual C++
public interface class IMChttpResponder

See Also

IMChttpResponder Members


IMChttpResponder Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpResponder Members
IMChttpResponder Interface Methods See Also Send Feedback

The IMChttpResponder type exposes the following members.

Methods

 | Name | Description
Public method | Response | Creates HttpResponseMessage object from an array of HttpContent objects based on request and response parameters

See Also

IMChttpResponder Interface


IMChttpResponder Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpResponder Methods
IMChttpResponder Interface See Also Send Feedback

The IMChttpResponder type exposes the following members.

Methods

 | Name | Description
Public method | Response | Creates HttpResponseMessage object from an array of HttpContent objects based on request and response parameters

See Also

IMChttpResponder Interface


Response Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpResponder..::..Response Method
IMChttpResponder Interface See Also Send Feedback
Creates HttpResponseMessage object from an array of HttpContent objects based on request and response parameters

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
HttpResponseMessage Response(
    HttpContent[] contents,
    string xmlRequestParameters,
    ref string xmlWadoResponse
)
Visual Basic
Function Response ( _
    contents As HttpContent(), _
    xmlRequestParameters As String, _
    ByRef xmlWadoResponse As String _
) As HttpResponseMessage
Visual C++
HttpResponseMessage^ Response(
    array<HttpContent^>^ contents,
    String^ xmlRequestParameters,
    String^% xmlWadoResponse
)

Parameters

contents
Type: array<HttpContent>[]()[][]
An array of HttpContent objects
xmlRequestParameters
Type: System..::..String
XML string of MCparameter used for WADO request
xmlWadoResponse
Type: System..::..String%
WADO response from DICOM service encoded as XML String

Return Value

HttpResponseMessage object

See Also

IMChttpResponder Interface
IMChttpResponder Members


IMCservice Interface

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMCservice Interface
Members See Also Send Feedback
Defines the method of DICOM service to retrieve and store DICOM objects

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public interface IMCservice
Visual Basic
Public Interface IMCservice
Visual C++
public interface class IMCservice

See Also

IMCservice Members


IMCservice Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
IMCservice Members
IMCservice Interface Methods See Also Send Feedback

The IMCservice type exposes the following members.

Methods

 | Name | Description
Public method | DcmOperation | Process WADO DICOM request to retrieve/store DICOM data from/to DICOM service

See Also

IMCservice Interface


IMCservice Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
IMCservice Methods
IMCservice Interface See Also Send Feedback

The IMCservice type exposes the following members.

Methods

 | Name | Description
Public method | DcmOperation | Process WADO DICOM request to retrieve/store DICOM data from/to DICOM service

See Also

IMCservice Interface


DcmOperation Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMCservice..::..DcmOperation Method
IMCservice Interface See Also Send Feedback
Process WADO DICOM request to retrieve/store DICOM data from/to DICOM service

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
bool DcmOperation(
    MCabstractMessage[] request,
    string xmlRequestParameters,
    out MCabstractMessage[] response,
    out string xmlWadoResponse
)
Visual Basic
Function DcmOperation ( _
    request As MCabstractMessage(), _
    xmlRequestParameters As String, _
    <OutAttribute> ByRef response As MCabstractMessage(), _
    <OutAttribute> ByRef xmlWadoResponse As String _
) As Boolean
Visual C++
bool DcmOperation(
    array<MCabstractMessage^>^ request,
    String^ xmlRequestParameters,
    [OutAttribute] array<MCabstractMessage^>^% response,
    [OutAttribute] String^% xmlWadoResponse
)

Parameters

request
Type: array<MCabstractMessage>[]()[][]
WADO request encoded as an array of MCabstractMessage objects
xmlRequestParameters
Type: System..::..String
XML String encoded from the list of MCparameter of WADO request
response
Type: array<MCabstractMessage>[]()[][]%
DICOM service response encoded as an array of MCabstractMessage
xmlWadoResponse
Type: System..::..String%
WADO response from DICOM service encoded as XML String

Return Value

Returns True if DICOM operation succeeded

See Also

IMCservice Interface
IMCservice Members


MCactionType Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType Class
Members See Also Send Feedback
Defines DICOM WADO-RS, QIDO-RS, STOW-RS, WADO-WS and UPS-RS action types.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCactionType
Visual Basic
Public Class MCactionType
Visual C++
public ref class MCactionType

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCactionType

See Also

MCactionType Members


MCactionType Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType Members
MCactionType Class Methods Fields Properties See Also Send Feedback

The MCactionType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Checks if MCactionType object is equal to Object (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode of MCactionType object (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns Name of MCactionType object (Overrides Object..::..ToString()()()().)

Fields

Name | Description
All | Returns all available MCactionType
ChangeUPSState | This action sets the state of a UPS Instance managed by the Origin-Server. It corresponds to the UPS DIMSE N-ACTION operation "Change UPS State".
CreateSubscription | This action subscribes to a UPS Instance or the Global Worklist managed by the Origin-Server. It corresponds to the UPS DIMSE N-ACTION operation "Subscribe to Receive UPS Event Reports".
CreateUPS | This action requests the creation of a UPS Instance on the Origin-Server. It corresponds to the UPS DIMSE N-CREATE operation.
DeleteSubscription | This action cancels an existing subscription to a UPS Instance or the Global Worklist managed by the Origin-Server. It corresponds to the UPS DIMSE N-ACTION operation "Unsubscribe from Receiving UPS Event Reports".
OpenEventChannel | This action initiates a WebSocket connection to allow the User-Agent to start receiving Event Report messages.
RequestUPSCancellation | This action requests the cancellation of a UPS Instance managed by the Origin-Server. It corresponds to the UPS DIMSE N-ACTION operation "Request UPS Cancel".
RetrieveFrames | This action retrieves the document(s) indicated in the request. In order to parse the bulk data items it is necessary to also retrieve the metadata for the Study. If the server cannot encode the pixel data using any of the requested media types, then an error status shall be returned. All response formats have a content type of multipart/related with a message boundary separator.
RetrieveImagingDocumentSet | This action retrieves a set of DICOM instances and other objects. This action corresponds to the IHE XDS-I.b transaction RAD-69. The DICOM instances are formatted in accordance with PS3.10, and encapsulated in a Web Services response.
RetrieveImagingDocumentSetInformation | This action retrieves a set of DICOM instances presented as an Infoset with the bulk data removed. This service can retrieve either the full metadata, or a subset selected by XPath arguments. The XML encoding for the DICOM attributes is defined in PS3.19.
RetrieveInstance | This action retrieves a single object for the specified SOP Instance UID or one or more bulk data items. In order to parse the bulk data items it is necessary to also retrieve the metadata for the Study. If the data cannot be converted to any of the requested media types, then an error code shall be returned, either a "Not Acceptable" response if no data is returned or a "Partial Content" response if only some data is returned. All response formats have a content type of multipart/related with a message boundary separator. The response format depends on the Accept header specified in the request.
RetrieveInstanceBulkdata |
RetrieveInstancePixeldata |
RetrieveMetadata | This action retrieves the DICOM instances presented as the full study metadata with the Pixel data removed. The response is metadata for the DICOM attributes. The full study metadata includes all attributes of the study; however, is permitted to replace the Value Field of an attribute with a BulkDataURI for attributes with Value Representations (VR) of FL, FD, IS, LT, OB, OD, OF, OW, OL, SL, SS, ST, UL, UN, US, and UT. The client can use the BulkDataURI with the RetrieveBulkData actions to retrieve the original Value Field of that attribute.
RetrieveRendered | This action retrieves the Rendered resource which references a rendered Study, Series, Instance or Frame within instance. in acceptable Rendered Media Type
RetrieveRenderedImagingDocumentSet | This action retrieves a set of DICOM instances that have been rendered into the requested format. For example, if rendering into JPEG was requested, these will be the JPEG renderings of the requested set of DICOM objects.
RetrieveSeries | This action retrieves the document(s) for the specified Study UID and Series Instance UID. If the data cannot be converted to any of the requested media types/Transfer Syntaxes, then an error code shall be returned, either a "Not Acceptable" response if no data is returned or a "Partial Content" response if only some data is returned. All response formats have a content type of multipart/related with a message boundary separator. The response format depends on the Accept header specified in the request.
RetrieveSeriesBulkdata |
RetrieveSeriesPixeldata |
RetrieveStudy | This action retrieves every instance for the specified Study UID. All response formats have a content type of multipart/related with a message boundary separator. The response format depends on the Accept header specified in the request.
RetrieveStudyBulkdata | These actions retrieve the document(s) indicated in the request. In order to parse the bulk data items it is necessary to also retrieve the metadata for the Study. If the server cannot encode the data using any of the requested media types, then an error status shall be returned. All response formats have a content type of multipart/related with a message boundary separator. The response format depends on the Accept header specified in the request.
RetrieveStudyPixeldata | These actions retrieve the pixel data indicated in the request. The pixeldata is a subset of bulkdata. In order to parse the bulk data items it is necessary to also retrieve the metadata for the Study. If the server cannot encode the data using any of the requested media types, then an error status shall be returned. All response formats have a content type of multipart/related with a message boundary separator. The response format depends on the Accept header specified in the request.
RetrieveThumbnail | This action retrieves the the Thumbnail resource which references a thumbnail image of a Study, Series, Instance or Frame within instance.
RetrieveUPS | This action retrieves a UPS Instances. It corresponds to the UPS DIMSE N-GET operation.
RsCapabilitiesRetrieve | Retrieves the full WADL resource tree from the WADO Retrieve RESTful resource endpoints
RsCapabilitiesSearch | Retrieves the full WADL resource tree from the QIDO Search RESTful resource endpoints
RsCapabilitiesStore | Retrieves the full WADL resource tree from the STOW Store RESTful resource endpoints
RsCapabilitiesSubscribe | Retrieves the full WADL resource tree from the Subscribe RESTful resource endpoints
RsCapabilitiesUpdate | Retrieves the full WADL resource tree from the Update RESTful resource endpoints
SearchForInstances | This action searches for DICOM Instances that match specified search parameters and returns a list of matching instances and the requested attributes for each instance.
SearchForSeries | This action searches for DICOM Series that match specified search parameters and returns a list of matching series and the requested attributes for each series.
SearchForStudies | This action searches for DICOM Studies that match specified search parameters and returns a list of matching studies and the requested attributes for each study.
SearchForUPS | This action searches for UPS Instances known to the Origin-Server. It corresponds to the UPS DIMSE C-FIND operation.
SendEventReport | This action sends an Event Report using an open WebSocket connection. It corresponds to the UPS DIMSE N-EVENT-REPORT operation.
StoreCommitment | This action request the safekeeping of Instances on an origin server. It corresponds to the DIMSE Storage Commitment Service Class as defined in Section J Storage Commitment Service Class (Normative) in PS3.4 and has the same semantics. As committing to storage of Instances is often a long-running operation on the origin server, the use of Storage Commitment service may be split into two transactions, at the discretion of the origin server, 1) requesting the commitment, and when the origin server cannot give the result yet 2) checking for the result, in line with the Asynchronous Request-Reply(ARR) pattern.
StoreCommitmentCheck |
StoreDicom | This action stores multipart DICOM SOP Instances and returns HTTP status line, including a status code and associated textual phrase for the entire set of stored SOP Instances, followed by a message body containing the Store Instances Response Module (DICOM PS3.18 Web Services)
StoreDicomXML | This action stores multipart DICOM XML metadata or a bulk data items and returns HTTP status line, including a status code and associated textual phrase for the entire set of stored SOP Instances, followed by a message body containing the Store Instances Response Module (DICOM PS3.18 Web Services)
StoreJson | This action stores multipart DICOM Json metadata or a bulk data items and returns HTTP status line, including a status code and associated textual phrase for the entire set of stored SOP Instances, followed by a message body containing the Store Instances Response Module (DICOM PS3.18 Web Services)
SuspendGlobalSubscription | This action suspends an existing subscription to the Global Worklist managed by the Origin-Server. It corresponds to the UPS DIMSE N-ACTION operation "Suspend Global Subscription".
Undefined | Undefined action type
UpdateUPS | This action sets the attributes of a UPS Instance managed by the Origin-Server. It corresponds to the UPS DIMSE N-SET operation.

Properties

 | Name | Description
Public property | Name | Returns the action's name of DICOM WADO operation

See Also

MCactionType Class


MCactionType Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType Fields
MCactionType Class See Also Send Feedback

The MCactionType type exposes the following members.

Fields

Name | Description
All | Returns all available MCactionType
ChangeUPSState | This action sets the state of a UPS Instance managed by the Origin-Server. It corresponds to the UPS DIMSE N-ACTION operation "Change UPS State".
CreateSubscription | This action subscribes to a UPS Instance or the Global Worklist managed by the Origin-Server. It corresponds to the UPS DIMSE N-ACTION operation "Subscribe to Receive UPS Event Reports".
CreateUPS | This action requests the creation of a UPS Instance on the Origin-Server. It corresponds to the UPS DIMSE N-CREATE operation.
DeleteSubscription | This action cancels an existing subscription to a UPS Instance or the Global Worklist managed by the Origin-Server. It corresponds to the UPS DIMSE N-ACTION operation "Unsubscribe from Receiving UPS Event Reports".
OpenEventChannel | This action initiates a WebSocket connection to allow the User-Agent to start receiving Event Report messages.
RequestUPSCancellation | This action requests the cancellation of a UPS Instance managed by the Origin-Server. It corresponds to the UPS DIMSE N-ACTION operation "Request UPS Cancel".
RetrieveFrames | This action retrieves the document(s) indicated in the request. In order to parse the bulk data items it is necessary to also retrieve the metadata for the Study. If the server cannot encode the pixel data using any of the requested media types, then an error status shall be returned. All response formats have a content type of multipart/related with a message boundary separator.
RetrieveImagingDocumentSet | This action retrieves a set of DICOM instances and other objects. This action corresponds to the IHE XDS-I.b transaction RAD-69. The DICOM instances are formatted in accordance with PS3.10, and encapsulated in a Web Services response.
RetrieveImagingDocumentSetInformation | This action retrieves a set of DICOM instances presented as an Infoset with the bulk data removed. This service can retrieve either the full metadata, or a subset selected by XPath arguments. The XML encoding for the DICOM attributes is defined in PS3.19.
RetrieveInstance | This action retrieves a single object for the specified SOP Instance UID or one or more bulk data items. In order to parse the bulk data items it is necessary to also retrieve the metadata for the Study. If the data cannot be converted to any of the requested media types, then an error code shall be returned, either a "Not Acceptable" response if no data is returned or a "Partial Content" response if only some data is returned. All response formats have a content type of multipart/related with a message boundary separator. The response format depends on the Accept header specified in the request.
RetrieveInstanceBulkdata |
RetrieveInstancePixeldata |
RetrieveMetadata | This action retrieves the DICOM instances presented as the full study metadata with the Pixel data removed. The response is metadata for the DICOM attributes. The full study metadata includes all attributes of the study; however, is permitted to replace the Value Field of an attribute with a BulkDataURI for attributes with Value Representations (VR) of FL, FD, IS, LT, OB, OD, OF, OW, OL, SL, SS, ST, UL, UN, US, and UT. The client can use the BulkDataURI with the RetrieveBulkData actions to retrieve the original Value Field of that attribute.
RetrieveRendered | This action retrieves the Rendered resource which references a rendered Study, Series, Instance or Frame within instance. in acceptable Rendered Media Type
RetrieveRenderedImagingDocumentSet | This action retrieves a set of DICOM instances that have been rendered into the requested format. For example, if rendering into JPEG was requested, these will be the JPEG renderings of the requested set of DICOM objects.
RetrieveSeries | This action retrieves the document(s) for the specified Study UID and Series Instance UID. If the data cannot be converted to any of the requested media types/Transfer Syntaxes, then an error code shall be returned, either a "Not Acceptable" response if no data is returned or a "Partial Content" response if only some data is returned. All response formats have a content type of multipart/related with a message boundary separator. The response format depends on the Accept header specified in the request.
RetrieveSeriesBulkdata |
RetrieveSeriesPixeldata |
RetrieveStudy | This action retrieves every instance for the specified Study UID. All response formats have a content type of multipart/related with a message boundary separator. The response format depends on the Accept header specified in the request.
RetrieveStudyBulkdata | These actions retrieve the document(s) indicated in the request. In order to parse the bulk data items it is necessary to also retrieve the metadata for the Study. If the server cannot encode the data using any of the requested media types, then an error status shall be returned. All response formats have a content type of multipart/related with a message boundary separator. The response format depends on the Accept header specified in the request.
RetrieveStudyPixeldata | These actions retrieve the pixel data indicated in the request. The pixeldata is a subset of bulkdata. In order to parse the bulk data items it is necessary to also retrieve the metadata for the Study. If the server cannot encode the data using any of the requested media types, then an error status shall be returned. All response formats have a content type of multipart/related with a message boundary separator. The response format depends on the Accept header specified in the request.
RetrieveThumbnail | This action retrieves the the Thumbnail resource which references a thumbnail image of a Study, Series, Instance or Frame within instance.
RetrieveUPS | This action retrieves a UPS Instances. It corresponds to the UPS DIMSE N-GET operation.
RsCapabilitiesRetrieve | Retrieves the full WADL resource tree from the WADO Retrieve RESTful resource endpoints
RsCapabilitiesSearch | Retrieves the full WADL resource tree from the QIDO Search RESTful resource endpoints
RsCapabilitiesStore | Retrieves the full WADL resource tree from the STOW Store RESTful resource endpoints
RsCapabilitiesSubscribe | Retrieves the full WADL resource tree from the Subscribe RESTful resource endpoints
RsCapabilitiesUpdate | Retrieves the full WADL resource tree from the Update RESTful resource endpoints
SearchForInstances | This action searches for DICOM Instances that match specified search parameters and returns a list of matching instances and the requested attributes for each instance.
SearchForSeries | This action searches for DICOM Series that match specified search parameters and returns a list of matching series and the requested attributes for each series.
SearchForStudies | This action searches for DICOM Studies that match specified search parameters and returns a list of matching studies and the requested attributes for each study.
SearchForUPS | This action searches for UPS Instances known to the Origin-Server. It corresponds to the UPS DIMSE C-FIND operation.
SendEventReport | This action sends an Event Report using an open WebSocket connection. It corresponds to the UPS DIMSE N-EVENT-REPORT operation.
StoreCommitment | This action request the safekeeping of Instances on an origin server. It corresponds to the DIMSE Storage Commitment Service Class as defined in Section J Storage Commitment Service Class (Normative) in PS3.4 and has the same semantics. As committing to storage of Instances is often a long-running operation on the origin server, the use of Storage Commitment service may be split into two transactions, at the discretion of the origin server, 1) requesting the commitment, and when the origin server cannot give the result yet 2) checking for the result, in line with the Asynchronous Request-Reply(ARR) pattern.
StoreCommitmentCheck |
StoreDicom | This action stores multipart DICOM SOP Instances and returns HTTP status line, including a status code and associated textual phrase for the entire set of stored SOP Instances, followed by a message body containing the Store Instances Response Module (DICOM PS3.18 Web Services)
StoreDicomXML | This action stores multipart DICOM XML metadata or a bulk data items and returns HTTP status line, including a status code and associated textual phrase for the entire set of stored SOP Instances, followed by a message body containing the Store Instances Response Module (DICOM PS3.18 Web Services)
StoreJson | This action stores multipart DICOM Json metadata or a bulk data items and returns HTTP status line, including a status code and associated textual phrase for the entire set of stored SOP Instances, followed by a message body containing the Store Instances Response Module (DICOM PS3.18 Web Services)
SuspendGlobalSubscription | This action suspends an existing subscription to the Global Worklist managed by the Origin-Server. It corresponds to the UPS DIMSE N-ACTION operation "Suspend Global Subscription".
Undefined | Undefined action type
UpdateUPS | This action sets the attributes of a UPS Instance managed by the Origin-Server. It corresponds to the UPS DIMSE N-SET operation.

See Also

MCactionType Class


All Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..All Field
MCactionType Class See Also Send Feedback
Returns all available MCactionType

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IEnumerable<MCactionType> All
Visual Basic
Public Shared All As IEnumerable(Of MCactionType)
Visual C++
public:
static IEnumerable<MCactionType^>^ All

See Also

MCactionType Class
MCactionType Members


ChangeUPSState Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..ChangeUPSState Field
MCactionType Class See Also Send Feedback
This action sets the state of a UPS Instance managed by the Origin-Server. It corresponds to the UPS DIMSE N-ACTION operation "Change UPS State".

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType ChangeUPSState
Visual Basic
Public Shared ChangeUPSState As MCactionType
Visual C++
public:
static MCactionType^ ChangeUPSState

See Also

MCactionType Class
MCactionType Members


CreateSubscription Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..CreateSubscription Field
MCactionType Class See Also Send Feedback
This action subscribes to a UPS Instance or the Global Worklist managed by the Origin-Server. It corresponds to the UPS DIMSE N-ACTION operation "Subscribe to Receive UPS Event Reports".

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType CreateSubscription
Visual Basic
Public Shared CreateSubscription As MCactionType
Visual C++
public:
static MCactionType^ CreateSubscription

See Also

MCactionType Class
MCactionType Members


CreateUPS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..CreateUPS Field
MCactionType Class See Also Send Feedback
This action requests the creation of a UPS Instance on the Origin-Server. It corresponds to the UPS DIMSE N-CREATE operation.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType CreateUPS
Visual Basic
Public Shared CreateUPS As MCactionType
Visual C++
public:
static MCactionType^ CreateUPS

See Also

MCactionType Class
MCactionType Members


DeleteSubscription Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..DeleteSubscription Field
MCactionType Class See Also Send Feedback
This action cancels an existing subscription to a UPS Instance or the Global Worklist managed by the Origin-Server. It corresponds to the UPS DIMSE N-ACTION operation "Unsubscribe from Receiving UPS Event Reports".

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType DeleteSubscription
Visual Basic
Public Shared DeleteSubscription As MCactionType
Visual C++
public:
static MCactionType^ DeleteSubscription

See Also

MCactionType Class
MCactionType Members


OpenEventChannel Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..OpenEventChannel Field
MCactionType Class See Also Send Feedback
This action initiates a WebSocket connection to allow the User-Agent to start receiving Event Report messages.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType OpenEventChannel
Visual Basic
Public Shared OpenEventChannel As MCactionType
Visual C++
public:
static MCactionType^ OpenEventChannel

See Also

MCactionType Class
MCactionType Members


RequestUPSCancellation Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RequestUPSCancellation Field
MCactionType Class See Also Send Feedback
This action requests the cancellation of a UPS Instance managed by the Origin-Server. It corresponds to the UPS DIMSE N-ACTION operation "Request UPS Cancel".

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RequestUPSCancellation
Visual Basic
Public Shared RequestUPSCancellation As MCactionType
Visual C++
public:
static MCactionType^ RequestUPSCancellation

See Also

MCactionType Class
MCactionType Members


RetrieveFrames Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveFrames Field
MCactionType Class See Also Send Feedback
This action retrieves the document(s) indicated in the request. In order to parse the bulk data items it is necessary to also retrieve the metadata for the Study. If the server cannot encode the pixel data using any of the requested media types, then an error status shall be returned. All response formats have a content type of multipart/related with a message boundary separator.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveFrames
Visual Basic
Public Shared RetrieveFrames As MCactionType
Visual C++
public:
static MCactionType^ RetrieveFrames

See Also

MCactionType Class
MCactionType Members


RetrieveImagingDocumentSet Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveImagingDocumentSet Field
MCactionType Class See Also Send Feedback
This action retrieves a set of DICOM instances and other objects. This action corresponds to the IHE XDS-I.b transaction RAD-69. The DICOM instances are formatted in accordance with PS3.10, and encapsulated in a Web Services response.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveImagingDocumentSet
Visual Basic
Public Shared RetrieveImagingDocumentSet As MCactionType
Visual C++
public:
static MCactionType^ RetrieveImagingDocumentSet

See Also

MCactionType Class
MCactionType Members


RetrieveImagingDocumentSetInformation Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveImagingDocumentSetInformation Field
MCactionType Class See Also Send Feedback
This action retrieves a set of DICOM instances presented as an Infoset with the bulk data removed. This service can retrieve either the full metadata, or a subset selected by XPath arguments. The XML encoding for the DICOM attributes is defined in PS3.19.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveImagingDocumentSetInformation
Visual Basic
Public Shared RetrieveImagingDocumentSetInformation As MCactionType
Visual C++
public:
static MCactionType^ RetrieveImagingDocumentSetInformation

See Also

MCactionType Class
MCactionType Members


RetrieveInstance Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveInstance Field
MCactionType Class See Also Send Feedback
This action retrieves a single object for the specified SOP Instance UID or one or more bulk data items. In order to parse the bulk data items it is necessary to also retrieve the metadata for the Study. If the data cannot be converted to any of the requested media types, then an error code shall be returned, either a "Not Acceptable" response if no data is returned or a "Partial Content" response if only some data is returned. All response formats have a content type of multipart/related with a message boundary separator. The response format depends on the Accept header specified in the request.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveInstance
Visual Basic
Public Shared RetrieveInstance As MCactionType
Visual C++
public:
static MCactionType^ RetrieveInstance

See Also

MCactionType Class
MCactionType Members


RetrieveInstanceBulkdata Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveInstanceBulkdata Field
MCactionType Class See Also Send Feedback

[Missing <summary> documentation for "F:Mergecomws.Dicom.MCactionType.RetrieveInstanceBulkdata"]

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveInstanceBulkdata
Visual Basic
Public Shared RetrieveInstanceBulkdata As MCactionType
Visual C++
public:
static MCactionType^ RetrieveInstanceBulkdata

See Also

MCactionType Class
MCactionType Members


RetrieveInstancePixeldata Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveInstancePixeldata Field
MCactionType Class See Also Send Feedback

[Missing <summary> documentation for "F:Mergecomws.Dicom.MCactionType.RetrieveInstancePixeldata"]

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveInstancePixeldata
Visual Basic
Public Shared RetrieveInstancePixeldata As MCactionType
Visual C++
public:
static MCactionType^ RetrieveInstancePixeldata

See Also

MCactionType Class
MCactionType Members


RetrieveMetadata Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveMetadata Field
MCactionType Class See Also Send Feedback
This action retrieves the DICOM instances presented as the full study metadata with the Pixel data removed. The response is metadata for the DICOM attributes. The full study metadata includes all attributes of the study; however, is permitted to replace the Value Field of an attribute with a BulkDataURI for attributes with Value Representations (VR) of FL, FD, IS, LT, OB, OD, OF, OW, OL, SL, SS, ST, UL, UN, US, and UT. The client can use the BulkDataURI with the RetrieveBulkData actions to retrieve the original Value Field of that attribute.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveMetadata
Visual Basic
Public Shared RetrieveMetadata As MCactionType
Visual C++
public:
static MCactionType^ RetrieveMetadata

See Also

MCactionType Class
MCactionType Members


RetrieveRendered Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveRendered Field
MCactionType Class See Also Send Feedback
This action retrieves the Rendered resource which references a rendered Study, Series, Instance or Frame within instance. in acceptable Rendered Media Type

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveRendered
Visual Basic
Public Shared RetrieveRendered As MCactionType
Visual C++
public:
static MCactionType^ RetrieveRendered

See Also

MCactionType Class
MCactionType Members


RetrieveRenderedImagingDocumentSet Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveRenderedImagingDocumentSet Field
MCactionType Class See Also Send Feedback
This action retrieves a set of DICOM instances that have been rendered into the requested format. For example, if rendering into JPEG was requested, these will be the JPEG renderings of the requested set of DICOM objects.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveRenderedImagingDocumentSet
Visual Basic
Public Shared RetrieveRenderedImagingDocumentSet As MCactionType
Visual C++
public:
static MCactionType^ RetrieveRenderedImagingDocumentSet

See Also

MCactionType Class
MCactionType Members


RetrieveSeries Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveSeries Field
MCactionType Class See Also Send Feedback
This action retrieves the document(s) for the specified Study UID and Series Instance UID. If the data cannot be converted to any of the requested media types/Transfer Syntaxes, then an error code shall be returned, either a "Not Acceptable" response if no data is returned or a "Partial Content" response if only some data is returned. All response formats have a content type of multipart/related with a message boundary separator. The response format depends on the Accept header specified in the request.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveSeries
Visual Basic
Public Shared RetrieveSeries As MCactionType
Visual C++
public:
static MCactionType^ RetrieveSeries

See Also

MCactionType Class
MCactionType Members


RetrieveSeriesBulkdata Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveSeriesBulkdata Field
MCactionType Class See Also Send Feedback

[Missing <summary> documentation for "F:Mergecomws.Dicom.MCactionType.RetrieveSeriesBulkdata"]

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveSeriesBulkdata
Visual Basic
Public Shared RetrieveSeriesBulkdata As MCactionType
Visual C++
public:
static MCactionType^ RetrieveSeriesBulkdata

See Also

MCactionType Class
MCactionType Members


RetrieveSeriesPixeldata Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveSeriesPixeldata Field
MCactionType Class See Also Send Feedback

[Missing <summary> documentation for "F:Mergecomws.Dicom.MCactionType.RetrieveSeriesPixeldata"]

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveSeriesPixeldata
Visual Basic
Public Shared RetrieveSeriesPixeldata As MCactionType
Visual C++
public:
static MCactionType^ RetrieveSeriesPixeldata

See Also

MCactionType Class
MCactionType Members


RetrieveStudy Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveStudy Field
MCactionType Class See Also Send Feedback
This action retrieves every instance for the specified Study UID. All response formats have a content type of multipart/related with a message boundary separator. The response format depends on the Accept header specified in the request.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveStudy
Visual Basic
Public Shared RetrieveStudy As MCactionType
Visual C++
public:
static MCactionType^ RetrieveStudy

See Also

MCactionType Class
MCactionType Members


RetrieveStudyBulkdata Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveStudyBulkdata Field
MCactionType Class See Also Send Feedback
These actions retrieve the document(s) indicated in the request. In order to parse the bulk data items it is necessary to also retrieve the metadata for the Study. If the server cannot encode the data using any of the requested media types, then an error status shall be returned. All response formats have a content type of multipart/related with a message boundary separator. The response format depends on the Accept header specified in the request.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveStudyBulkdata
Visual Basic
Public Shared RetrieveStudyBulkdata As MCactionType
Visual C++
public:
static MCactionType^ RetrieveStudyBulkdata

See Also

MCactionType Class
MCactionType Members


RetrieveStudyPixeldata Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveStudyPixeldata Field
MCactionType Class See Also Send Feedback
These actions retrieve the pixel data indicated in the request. The pixeldata is a subset of bulkdata. In order to parse the bulk data items it is necessary to also retrieve the metadata for the Study. If the server cannot encode the data using any of the requested media types, then an error status shall be returned. All response formats have a content type of multipart/related with a message boundary separator. The response format depends on the Accept header specified in the request.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveStudyPixeldata
Visual Basic
Public Shared RetrieveStudyPixeldata As MCactionType
Visual C++
public:
static MCactionType^ RetrieveStudyPixeldata

See Also

MCactionType Class
MCactionType Members


RetrieveThumbnail Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveThumbnail Field
MCactionType Class See Also Send Feedback
This action retrieves the the Thumbnail resource which references a thumbnail image of a Study, Series, Instance or Frame within instance.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveThumbnail
Visual Basic
Public Shared RetrieveThumbnail As MCactionType
Visual C++
public:
static MCactionType^ RetrieveThumbnail

See Also

MCactionType Class
MCactionType Members


RetrieveUPS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RetrieveUPS Field
MCactionType Class See Also Send Feedback
This action retrieves a UPS Instances. It corresponds to the UPS DIMSE N-GET operation.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RetrieveUPS
Visual Basic
Public Shared RetrieveUPS As MCactionType
Visual C++
public:
static MCactionType^ RetrieveUPS

See Also

MCactionType Class
MCactionType Members


RsCapabilitiesRetrieve Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RsCapabilitiesRetrieve Field
MCactionType Class See Also Send Feedback
Retrieves the full WADL resource tree from the WADO Retrieve RESTful resource endpoints

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RsCapabilitiesRetrieve
Visual Basic
Public Shared RsCapabilitiesRetrieve As MCactionType
Visual C++
public:
static MCactionType^ RsCapabilitiesRetrieve

See Also

MCactionType Class
MCactionType Members


RsCapabilitiesSearch Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RsCapabilitiesSearch Field
MCactionType Class See Also Send Feedback
Retrieves the full WADL resource tree from the QIDO Search RESTful resource endpoints

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RsCapabilitiesSearch
Visual Basic
Public Shared RsCapabilitiesSearch As MCactionType
Visual C++
public:
static MCactionType^ RsCapabilitiesSearch

See Also

MCactionType Class
MCactionType Members


RsCapabilitiesStore Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RsCapabilitiesStore Field
MCactionType Class See Also Send Feedback
Retrieves the full WADL resource tree from the STOW Store RESTful resource endpoints

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RsCapabilitiesStore
Visual Basic
Public Shared RsCapabilitiesStore As MCactionType
Visual C++
public:
static MCactionType^ RsCapabilitiesStore

See Also

MCactionType Class
MCactionType Members


RsCapabilitiesSubscribe Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RsCapabilitiesSubscribe Field
MCactionType Class See Also Send Feedback
Retrieves the full WADL resource tree from the Subscribe RESTful resource endpoints

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RsCapabilitiesSubscribe
Visual Basic
Public Shared RsCapabilitiesSubscribe As MCactionType
Visual C++
public:
static MCactionType^ RsCapabilitiesSubscribe

See Also

MCactionType Class
MCactionType Members


RsCapabilitiesUpdate Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..RsCapabilitiesUpdate Field
MCactionType Class See Also Send Feedback
Retrieves the full WADL resource tree from the Update RESTful resource endpoints

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType RsCapabilitiesUpdate
Visual Basic
Public Shared RsCapabilitiesUpdate As MCactionType
Visual C++
public:
static MCactionType^ RsCapabilitiesUpdate

See Also

MCactionType Class
MCactionType Members


SearchForInstances Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..SearchForInstances Field
MCactionType Class See Also Send Feedback
This action searches for DICOM Instances that match specified search parameters and returns a list of matching instances and the requested attributes for each instance.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType SearchForInstances
Visual Basic
Public Shared SearchForInstances As MCactionType
Visual C++
public:
static MCactionType^ SearchForInstances

See Also

MCactionType Class
MCactionType Members


SearchForSeries Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..SearchForSeries Field
MCactionType Class See Also Send Feedback
This action searches for DICOM Series that match specified search parameters and returns a list of matching series and the requested attributes for each series.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType SearchForSeries
Visual Basic
Public Shared SearchForSeries As MCactionType
Visual C++
public:
static MCactionType^ SearchForSeries

See Also

MCactionType Class
MCactionType Members


SearchForStudies Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..SearchForStudies Field
MCactionType Class See Also Send Feedback
This action searches for DICOM Studies that match specified search parameters and returns a list of matching studies and the requested attributes for each study.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType SearchForStudies
Visual Basic
Public Shared SearchForStudies As MCactionType
Visual C++
public:
static MCactionType^ SearchForStudies

See Also

MCactionType Class
MCactionType Members


SearchForUPS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..SearchForUPS Field
MCactionType Class See Also Send Feedback
This action searches for UPS Instances known to the Origin-Server. It corresponds to the UPS DIMSE C-FIND operation.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType SearchForUPS
Visual Basic
Public Shared SearchForUPS As MCactionType
Visual C++
public:
static MCactionType^ SearchForUPS

See Also

MCactionType Class
MCactionType Members


SendEventReport Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..SendEventReport Field
MCactionType Class See Also Send Feedback
This action sends an Event Report using an open WebSocket connection. It corresponds to the UPS DIMSE N-EVENT-REPORT operation.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType SendEventReport
Visual Basic
Public Shared SendEventReport As MCactionType
Visual C++
public:
static MCactionType^ SendEventReport

See Also

MCactionType Class
MCactionType Members


StoreCommitment Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..StoreCommitment Field
MCactionType Class See Also Send Feedback
This action request the safekeeping of Instances on an origin server. It corresponds to the DIMSE Storage Commitment Service Class as defined in Section J Storage Commitment Service Class (Normative) in PS3.4 and has the same semantics. As committing to storage of Instances is often a long-running operation on the origin server, the use of Storage Commitment service may be split into two transactions, at the discretion of the origin server, 1) requesting the commitment, and when the origin server cannot give the result yet 2) checking for the result, in line with the Asynchronous Request-Reply(ARR) pattern.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType StoreCommitment
Visual Basic
Public Shared StoreCommitment As MCactionType
Visual C++
public:
static MCactionType^ StoreCommitment

See Also

MCactionType Class
MCactionType Members


StoreCommitmentCheck Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..StoreCommitmentCheck Field
MCactionType Class See Also Send Feedback

[Missing <summary> documentation for "F:Mergecomws.Dicom.MCactionType.StoreCommitmentCheck"]

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType StoreCommitmentCheck
Visual Basic
Public Shared StoreCommitmentCheck As MCactionType
Visual C++
public:
static MCactionType^ StoreCommitmentCheck

See Also

MCactionType Class
MCactionType Members


StoreDicom Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..StoreDicom Field
MCactionType Class See Also Send Feedback
This action stores multipart DICOM SOP Instances and returns HTTP status line, including a status code and associated textual phrase for the entire set of stored SOP Instances, followed by a message body containing the Store Instances Response Module (DICOM PS3.18 Web Services)

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType StoreDicom
Visual Basic
Public Shared StoreDicom As MCactionType
Visual C++
public:
static MCactionType^ StoreDicom

See Also

MCactionType Class
MCactionType Members


StoreDicomXML Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..StoreDicomXML Field
MCactionType Class See Also Send Feedback
This action stores multipart DICOM XML metadata or a bulk data items and returns HTTP status line, including a status code and associated textual phrase for the entire set of stored SOP Instances, followed by a message body containing the Store Instances Response Module (DICOM PS3.18 Web Services)

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType StoreDicomXML
Visual Basic
Public Shared StoreDicomXML As MCactionType
Visual C++
public:
static MCactionType^ StoreDicomXML

See Also

MCactionType Class
MCactionType Members


StoreJson Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..StoreJson Field
MCactionType Class See Also Send Feedback
This action stores multipart DICOM Json metadata or a bulk data items and returns HTTP status line, including a status code and associated textual phrase for the entire set of stored SOP Instances, followed by a message body containing the Store Instances Response Module (DICOM PS3.18 Web Services)

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType StoreJson
Visual Basic
Public Shared StoreJson As MCactionType
Visual C++
public:
static MCactionType^ StoreJson

See Also

MCactionType Class
MCactionType Members


SuspendGlobalSubscription Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..SuspendGlobalSubscription Field
MCactionType Class See Also Send Feedback
This action suspends an existing subscription to the Global Worklist managed by the Origin-Server. It corresponds to the UPS DIMSE N-ACTION operation "Suspend Global Subscription".

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType SuspendGlobalSubscription
Visual Basic
Public Shared SuspendGlobalSubscription As MCactionType
Visual C++
public:
static MCactionType^ SuspendGlobalSubscription

See Also

MCactionType Class
MCactionType Members


Undefined Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..Undefined Field
MCactionType Class See Also Send Feedback
Undefined action type

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType Undefined
Visual Basic
Public Shared Undefined As MCactionType
Visual C++
public:
static MCactionType^ Undefined

See Also

MCactionType Class
MCactionType Members


UpdateUPS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..UpdateUPS Field
MCactionType Class See Also Send Feedback
This action sets the attributes of a UPS Instance managed by the Origin-Server. It corresponds to the UPS DIMSE N-SET operation.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType UpdateUPS
Visual Basic
Public Shared UpdateUPS As MCactionType
Visual C++
public:
static MCactionType^ UpdateUPS

See Also

MCactionType Class
MCactionType Members


MCactionType Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType Methods
MCactionType Class See Also Send Feedback

The MCactionType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Checks if MCactionType object is equal to Object (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode of MCactionType object (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns Name of MCactionType object (Overrides Object..::..ToString()()()().)

See Also

MCactionType Class


Equals Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..Equals Method
MCactionType Class See Also Send Feedback
Checks if MCactionType object is equal to Object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare with the current object.

Return Value

Returns True if objects Name are the same

See Also

MCactionType Class
MCactionType Members


GetHashCode Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..GetHashCode Method
MCactionType Class See Also Send Feedback
Gets the hashcode of MCactionType object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

Returns a hashcode generated from Name

See Also

MCactionType Class
MCactionType Members


ToString Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..ToString Method
MCactionType Class See Also Send Feedback
Returns Name of MCactionType object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string that represents the current object.

See Also

MCactionType Class
MCactionType Members


MCactionType Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType Properties
MCactionType Class See Also Send Feedback

The MCactionType type exposes the following members.

Properties

 | Name | Description
Public property | Name | Returns the action's name of DICOM WADO operation

See Also

MCactionType Class


Name Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCactionType..::..Name Property
MCactionType Class See Also Send Feedback
Returns the action's name of DICOM WADO operation

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set
Visual C++
public:
property String^ Name {
    String^ get ();
    private: void set (String^ value);
}

See Also

MCactionType Class
MCactionType Members


MCbaseConverter Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseConverter Class
Members See Also Send Feedback
Abstract base class which implements IMChttpConverter interface

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public abstract class MCbaseConverter : IMChttpConverter
Visual Basic
Public MustInherit Class MCbaseConverter _
    Implements IMChttpConverter
Visual C++
public ref class MCbaseConverter abstract : IMChttpConverter

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCbaseConverter
Mergecomws.Dicom..::..MChttpConverter

See Also

MCbaseConverter Members


MCbaseConverter Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseConverter Members
MCbaseConverter Class Constructors Methods Fields Properties See Also Send Feedback

The MCbaseConverter type exposes the following members.

Constructors

 | Name | Description
Protected method | MCbaseConverter()()()() | Class Constructor
Protected method | MCbaseConverter(MCrequestType) | Class Constructor

Methods

 | Name | Description
Public method | Convert | Converts an array of rendered DICOM streams into an array of HttpContent objects based on request parameters
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
EMPTY_CONTENTS | Empty array of HttpContent objects.

Properties

 | Name | Description
Public property | RequestParameters | List of MCparameter parameters used for WADO request
Public property | RequestType | MCrequestType type of WADO request
Public property | ResponseParameters | List of MCparameter parameters returned from DICOM service
Public property | Streams | An array of Stream of rendered DICOM stream data
Public property | XmlOptions | MCxmlOptions options used in writeToXMLNative(TextWriter, MCxmlOptions) method of MCabstractMessage object

See Also

MCbaseConverter Class


MCbaseConverter Constructor

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseConverter Constructor
MCbaseConverter Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MCbaseConverter()()()() | Class Constructor
Protected method | MCbaseConverter(MCrequestType) | Class Constructor

See Also

MCbaseConverter Class
MCbaseConverter Members


MCbaseConverter Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseConverter Constructor
MCbaseConverter Class See Also Send Feedback
Class Constructor

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected MCbaseConverter()
Visual Basic
Protected Sub New
Visual C++
protected:
MCbaseConverter()

See Also

MCbaseConverter Class
MCbaseConverter Members
MCbaseConverter Overload


MCbaseConverter Constructor (MCrequestType)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseConverter Constructor (MCrequestType)
MCbaseConverter Class See Also Send Feedback
Class Constructor

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected MCbaseConverter(
    MCrequestType requestType
)
Visual Basic
Protected Sub New ( _
    requestType As MCrequestType _
)
Visual C++
protected:
MCbaseConverter(
    MCrequestType^ requestType
)

Parameters

requestType
Type: Mergecomws.Web..::..MCrequestType
Type of WADO request

See Also

MCbaseConverter Class
MCbaseConverter Members
MCbaseConverter Overload


MCbaseConverter Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseConverter Fields
MCbaseConverter Class See Also Send Feedback

The MCbaseConverter type exposes the following members.

Fields

Name | Description
EMPTY_CONTENTS | Empty array of HttpContent objects.

See Also

MCbaseConverter Class


EMPTY_CONTENTS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseConverter..::..EMPTY_CONTENTS Field
MCbaseConverter Class See Also Send Feedback
Empty array of HttpContent objects.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected static readonly HttpContent[] EMPTY_CONTENTS
Visual Basic
Protected Shared ReadOnly EMPTY_CONTENTS As HttpContent()
Visual C++
protected:
static initonly array<HttpContent^>^ EMPTY_CONTENTS

See Also

MCbaseConverter Class
MCbaseConverter Members


MCbaseConverter Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseConverter Methods
MCbaseConverter Class See Also Send Feedback

The MCbaseConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts an array of rendered DICOM streams into an array of HttpContent objects based on request parameters
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCbaseConverter Class


Convert Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseConverter..::..Convert Method
MCbaseConverter Class See Also Send Feedback
Converts an array of rendered DICOM streams into an array of HttpContent objects based on request parameters

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public abstract HttpContent[] Convert(
    Stream[] streams,
    string xmlRequestParameters,
    ref string xmlWadoResponse
)
Visual Basic
Public MustOverride Function Convert ( _
    streams As Stream(), _
    xmlRequestParameters As String, _
    ByRef xmlWadoResponse As String _
) As HttpContent()
Visual C++
public:
virtual array<HttpContent^>^ Convert(
    array<Stream^>^ streams,
    String^ xmlRequestParameters,
    String^% xmlWadoResponse
) abstract

Parameters

streams
Type: array<System.IO..::..Stream>[]()[][]
DICOM streams
xmlRequestParameters
Type: System..::..String
XML string of MCparameter parameters used for WADO request
xmlWadoResponse
Type: System..::..String%
WADO response from DICOM service encoded as XML String

Return Value

HttpResponseMessage object

Implements

IMChttpConverter..::..Convert(array<Stream>[]()[][], String, String%)

See Also

MCbaseConverter Class
MCbaseConverter Members


MCbaseConverter Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseConverter Properties
MCbaseConverter Class See Also Send Feedback

The MCbaseConverter type exposes the following members.

Properties

 | Name | Description
Public property | RequestParameters | List of MCparameter parameters used for WADO request
Public property | RequestType | MCrequestType type of WADO request
Public property | ResponseParameters | List of MCparameter parameters returned from DICOM service
Public property | Streams | An array of Stream of rendered DICOM stream data
Public property | XmlOptions | MCxmlOptions options used in writeToXMLNative(TextWriter, MCxmlOptions) method of MCabstractMessage object

See Also

MCbaseConverter Class


RequestParameters Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseConverter..::..RequestParameters Property
MCbaseConverter Class See Also Send Feedback
List of MCparameter parameters used for WADO request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public List<MCparameter> RequestParameters { get; protected set; }
Visual Basic
Public Property RequestParameters As List(Of MCparameter)
    Get
    Protected Set
Visual C++
public:
property List<MCparameter^>^ RequestParameters {
    List<MCparameter^>^ get ();
    protected: void set (List<MCparameter^>^ value);
}

See Also

MCbaseConverter Class
MCbaseConverter Members


RequestType Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseConverter..::..RequestType Property
MCbaseConverter Class See Also Send Feedback
MCrequestType type of WADO request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrequestType RequestType { get; protected set; }
Visual Basic
Public Property RequestType As MCrequestType
    Get
    Protected Set
Visual C++
public:
property MCrequestType^ RequestType {
    MCrequestType^ get ();
    protected: void set (MCrequestType^ value);
}

See Also

MCbaseConverter Class
MCbaseConverter Members


ResponseParameters Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseConverter..::..ResponseParameters Property
MCbaseConverter Class See Also Send Feedback
List of MCparameter parameters returned from DICOM service

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public List<MCparameter> ResponseParameters { get; protected set; }
Visual Basic
Public Property ResponseParameters As List(Of MCparameter)
    Get
    Protected Set
Visual C++
public:
property List<MCparameter^>^ ResponseParameters {
    List<MCparameter^>^ get ();
    protected: void set (List<MCparameter^>^ value);
}

See Also

MCbaseConverter Class
MCbaseConverter Members


Streams Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseConverter..::..Streams Property
MCbaseConverter Class See Also Send Feedback
An array of Stream of rendered DICOM stream data

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public Stream[] Streams { get; protected set; }
Visual Basic
Public Property Streams As Stream()
    Get
    Protected Set
Visual C++
public:
property array<Stream^>^ Streams {
    array<Stream^>^ get ();
    protected: void set (array<Stream^>^ value);
}

See Also

MCbaseConverter Class
MCbaseConverter Members


XmlOptions Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseConverter..::..XmlOptions Property
MCbaseConverter Class See Also Send Feedback
MCxmlOptions options used in writeToXMLNative(TextWriter, MCxmlOptions) method of MCabstractMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCxmlOptions XmlOptions { get; set; }
Visual Basic
Public Property XmlOptions As MCxmlOptions
    Get
    Set
Visual C++
public:
property MCxmlOptions XmlOptions {
    MCxmlOptions get ();
    void set (MCxmlOptions value);
}

See Also

MCbaseConverter Class
MCbaseConverter Members


MCbaseRenderer Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseRenderer Class
Members See Also Send Feedback
Abstract base class which implements IMCdicomRenderer interface

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public abstract class MCbaseRenderer : IMCdicomRenderer
Visual Basic
Public MustInherit Class MCbaseRenderer _
    Implements IMCdicomRenderer
Visual C++
public ref class MCbaseRenderer abstract : IMCdicomRenderer

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCbaseRenderer
Mergecomws.Dicom..::..MCdicomRenderer

See Also

MCbaseRenderer Members


MCbaseRenderer Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseRenderer Members
MCbaseRenderer Class Constructors Methods Fields Properties See Also Send Feedback

The MCbaseRenderer type exposes the following members.

Constructors

 | Name | Description
Protected method | MCbaseRenderer()()()() | Class Constructor
Protected method | MCbaseRenderer(MCrequestType) | Class Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render | Converts DICOM service response into an array of Stream objects using the list of MCparameter
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
EMPTY_STREAMS | Empty array of Stream objects.

Properties

 | Name | Description
Public property | RequestParameters | List of MCparameter parameters used for WADO request
Public property | RequestType | MCrequestType type of WADO request
Public property | Response | DICOM service response
Public property | ResponseParameters | List of MCparameter parameters returned from DICOM service
Public property | XmlOptions | MCxmlOptions options used in writeToXMLNative(TextWriter, MCxmlOptions) method of MCabstractMessage object

See Also

MCbaseRenderer Class


MCbaseRenderer Constructor

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseRenderer Constructor
MCbaseRenderer Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MCbaseRenderer()()()() | Class Constructor
Protected method | MCbaseRenderer(MCrequestType) | Class Constructor

See Also

MCbaseRenderer Class
MCbaseRenderer Members


MCbaseRenderer Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseRenderer Constructor
MCbaseRenderer Class See Also Send Feedback
Class Constructor

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected MCbaseRenderer()
Visual Basic
Protected Sub New
Visual C++
protected:
MCbaseRenderer()

See Also

MCbaseRenderer Class
MCbaseRenderer Members
MCbaseRenderer Overload


MCbaseRenderer Constructor (MCrequestType)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseRenderer Constructor (MCrequestType)
MCbaseRenderer Class See Also Send Feedback
Class Constructor

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected MCbaseRenderer(
    MCrequestType requestType
)
Visual Basic
Protected Sub New ( _
    requestType As MCrequestType _
)
Visual C++
protected:
MCbaseRenderer(
    MCrequestType^ requestType
)

Parameters

requestType
Type: Mergecomws.Web..::..MCrequestType
Type of WADO request

See Also

MCbaseRenderer Class
MCbaseRenderer Members
MCbaseRenderer Overload


MCbaseRenderer Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseRenderer Fields
MCbaseRenderer Class See Also Send Feedback

The MCbaseRenderer type exposes the following members.

Fields

Name | Description
EMPTY_STREAMS | Empty array of Stream objects.

See Also

MCbaseRenderer Class


EMPTY_STREAMS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseRenderer..::..EMPTY_STREAMS Field
MCbaseRenderer Class See Also Send Feedback
Empty array of Stream objects.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected static Stream[] EMPTY_STREAMS
Visual Basic
Protected Shared EMPTY_STREAMS As Stream()
Visual C++
protected:
static array<Stream^>^ EMPTY_STREAMS

See Also

MCbaseRenderer Class
MCbaseRenderer Members


MCbaseRenderer Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseRenderer Methods
MCbaseRenderer Class See Also Send Feedback

The MCbaseRenderer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render | Converts DICOM service response into an array of Stream objects using the list of MCparameter
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCbaseRenderer Class


Render Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseRenderer..::..Render Method
MCbaseRenderer Class See Also Send Feedback
Converts DICOM service response into an array of Stream objects using the list of MCparameter

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public abstract Stream[] Render(
    MCabstractMessage[] response,
    string xmlRequestParameters,
    ref string xmlWadoResponse
)
Visual Basic
Public MustOverride Function Render ( _
    response As MCabstractMessage(), _
    xmlRequestParameters As String, _
    ByRef xmlWadoResponse As String _
) As Stream()
Visual C++
public:
virtual array<Stream^>^ Render(
    array<MCabstractMessage^>^ response,
    String^ xmlRequestParameters,
    String^% xmlWadoResponse
) abstract

Parameters

response
Type: array<MCabstractMessage>[]()[][]
DICOM service response encoded as an array of MCabstractMessage
xmlRequestParameters
Type: System..::..String
XML string of MCparameter parameters used for WADO request
xmlWadoResponse
Type: System..::..String%
WADO response from DICOM service encoded as XML String

Return Value

An array of Stream objects

Implements

IMCdicomRenderer..::..Render(array<MCabstractMessage>[]()[][], String, String%)

See Also

MCbaseRenderer Class
MCbaseRenderer Members


MCbaseRenderer Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseRenderer Properties
MCbaseRenderer Class See Also Send Feedback

The MCbaseRenderer type exposes the following members.

Properties

 | Name | Description
Public property | RequestParameters | List of MCparameter parameters used for WADO request
Public property | RequestType | MCrequestType type of WADO request
Public property | Response | DICOM service response
Public property | ResponseParameters | List of MCparameter parameters returned from DICOM service
Public property | XmlOptions | MCxmlOptions options used in writeToXMLNative(TextWriter, MCxmlOptions) method of MCabstractMessage object

See Also

MCbaseRenderer Class


RequestParameters Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseRenderer..::..RequestParameters Property
MCbaseRenderer Class See Also Send Feedback
List of MCparameter parameters used for WADO request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public List<MCparameter> RequestParameters { get; protected set; }
Visual Basic
Public Property RequestParameters As List(Of MCparameter)
    Get
    Protected Set
Visual C++
public:
property List<MCparameter^>^ RequestParameters {
    List<MCparameter^>^ get ();
    protected: void set (List<MCparameter^>^ value);
}

See Also

MCbaseRenderer Class
MCbaseRenderer Members


RequestType Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseRenderer..::..RequestType Property
MCbaseRenderer Class See Also Send Feedback
MCrequestType type of WADO request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrequestType RequestType { get; protected set; }
Visual Basic
Public Property RequestType As MCrequestType
    Get
    Protected Set
Visual C++
public:
property MCrequestType^ RequestType {
    MCrequestType^ get ();
    protected: void set (MCrequestType^ value);
}

See Also

MCbaseRenderer Class
MCbaseRenderer Members


Response Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseRenderer..::..Response Property
MCbaseRenderer Class See Also Send Feedback
DICOM service response

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCabstractMessage[] Response { get; protected set; }
Visual Basic
Public Property Response As MCabstractMessage()
    Get
    Protected Set
Visual C++
public:
property array<MCabstractMessage^>^ Response {
    array<MCabstractMessage^>^ get ();
    protected: void set (array<MCabstractMessage^>^ value);
}

See Also

MCbaseRenderer Class
MCbaseRenderer Members


ResponseParameters Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseRenderer..::..ResponseParameters Property
MCbaseRenderer Class See Also Send Feedback
List of MCparameter parameters returned from DICOM service

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public List<MCparameter> ResponseParameters { get; protected set; }
Visual Basic
Public Property ResponseParameters As List(Of MCparameter)
    Get
    Protected Set
Visual C++
public:
property List<MCparameter^>^ ResponseParameters {
    List<MCparameter^>^ get ();
    protected: void set (List<MCparameter^>^ value);
}

See Also

MCbaseRenderer Class
MCbaseRenderer Members


XmlOptions Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseRenderer..::..XmlOptions Property
MCbaseRenderer Class See Also Send Feedback
MCxmlOptions options used in writeToXMLNative(TextWriter, MCxmlOptions) method of MCabstractMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCxmlOptions XmlOptions { get; set; }
Visual Basic
Public Property XmlOptions As MCxmlOptions
    Get
    Set
Visual C++
public:
property MCxmlOptions XmlOptions {
    MCxmlOptions get ();
    void set (MCxmlOptions value);
}

See Also

MCbaseRenderer Class
MCbaseRenderer Members


MCbaseResponder Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseResponder Class
Members See Also Send Feedback
Abstract base class which implements IMChttpResponder interface

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public abstract class MCbaseResponder : IMChttpResponder
Visual Basic
Public MustInherit Class MCbaseResponder _
    Implements IMChttpResponder
Visual C++
public ref class MCbaseResponder abstract : IMChttpResponder

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCbaseResponder
Mergecomws.Dicom..::..MChttpResponder

See Also

MCbaseResponder Members


MCbaseResponder Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseResponder Members
MCbaseResponder Class Constructors Methods Properties See Also Send Feedback

The MCbaseResponder type exposes the following members.

Constructors

 | Name | Description
Protected method | MCbaseResponder()()()() | Class Constructor
Protected method | MCbaseResponder(MCrequestType) | Class Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Response | Converts DICOM service response into an array of Stream objects using the list of MCparameter
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Contents | List of HttpContent objects
Public property | RequestParameters | List of MCparameter parameters used for WADO request
Public property | RequestType | MCrequestType type of WADO request
Public property | ResponseParameters | List of MCparameter parameters returned from DICOM service

See Also

MCbaseResponder Class


MCbaseResponder Constructor

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseResponder Constructor
MCbaseResponder Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MCbaseResponder()()()() | Class Constructor
Protected method | MCbaseResponder(MCrequestType) | Class Constructor

See Also

MCbaseResponder Class
MCbaseResponder Members


MCbaseResponder Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseResponder Constructor
MCbaseResponder Class See Also Send Feedback
Class Constructor

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected MCbaseResponder()
Visual Basic
Protected Sub New
Visual C++
protected:
MCbaseResponder()

See Also

MCbaseResponder Class
MCbaseResponder Members
MCbaseResponder Overload


MCbaseResponder Constructor (MCrequestType)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseResponder Constructor (MCrequestType)
MCbaseResponder Class See Also Send Feedback
Class Constructor

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected MCbaseResponder(
    MCrequestType requestType
)
Visual Basic
Protected Sub New ( _
    requestType As MCrequestType _
)
Visual C++
protected:
MCbaseResponder(
    MCrequestType^ requestType
)

Parameters

requestType
Type: Mergecomws.Web..::..MCrequestType
Type of WADO request

See Also

MCbaseResponder Class
MCbaseResponder Members
MCbaseResponder Overload


MCbaseResponder Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseResponder Methods
MCbaseResponder Class See Also Send Feedback

The MCbaseResponder type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Response | Converts DICOM service response into an array of Stream objects using the list of MCparameter
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCbaseResponder Class


Response Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseResponder..::..Response Method
MCbaseResponder Class See Also Send Feedback
Converts DICOM service response into an array of Stream objects using the list of MCparameter

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public abstract HttpResponseMessage Response(
    HttpContent[] contents,
    string xmlRequestParameters,
    ref string xmlWadoResponse
)
Visual Basic
Public MustOverride Function Response ( _
    contents As HttpContent(), _
    xmlRequestParameters As String, _
    ByRef xmlWadoResponse As String _
) As HttpResponseMessage
Visual C++
public:
virtual HttpResponseMessage^ Response(
    array<HttpContent^>^ contents,
    String^ xmlRequestParameters,
    String^% xmlWadoResponse
) abstract

Parameters

contents
Type: array<HttpContent>[]()[][]
An array of HttpContent objects
xmlRequestParameters
Type: System..::..String
XML string of MCparameter parameters used for WADO request
xmlWadoResponse
Type: System..::..String%
WADO response from DICOM service encoded as XML String

Return Value

An array of Stream objects

Implements

IMChttpResponder..::..Response(array<HttpContent>[]()[][], String, String%)

See Also

MCbaseResponder Class
MCbaseResponder Members


MCbaseResponder Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseResponder Properties
MCbaseResponder Class See Also Send Feedback

The MCbaseResponder type exposes the following members.

Properties

 | Name | Description
Public property | Contents | List of HttpContent objects
Public property | RequestParameters | List of MCparameter parameters used for WADO request
Public property | RequestType | MCrequestType type of WADO request
Public property | ResponseParameters | List of MCparameter parameters returned from DICOM service

See Also

MCbaseResponder Class


Contents Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseResponder..::..Contents Property
MCbaseResponder Class See Also Send Feedback
List of HttpContent objects

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpContent[] Contents { get; protected set; }
Visual Basic
Public Property Contents As HttpContent()
    Get
    Protected Set
Visual C++
public:
property array<HttpContent^>^ Contents {
    array<HttpContent^>^ get ();
    protected: void set (array<HttpContent^>^ value);
}

See Also

MCbaseResponder Class
MCbaseResponder Members


RequestParameters Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseResponder..::..RequestParameters Property
MCbaseResponder Class See Also Send Feedback
List of MCparameter parameters used for WADO request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public List<MCparameter> RequestParameters { get; protected set; }
Visual Basic
Public Property RequestParameters As List(Of MCparameter)
    Get
    Protected Set
Visual C++
public:
property List<MCparameter^>^ RequestParameters {
    List<MCparameter^>^ get ();
    protected: void set (List<MCparameter^>^ value);
}

See Also

MCbaseResponder Class
MCbaseResponder Members


RequestType Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseResponder..::..RequestType Property
MCbaseResponder Class See Also Send Feedback
MCrequestType type of WADO request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrequestType RequestType { get; protected set; }
Visual Basic
Public Property RequestType As MCrequestType
    Get
    Protected Set
Visual C++
public:
property MCrequestType^ RequestType {
    MCrequestType^ get ();
    protected: void set (MCrequestType^ value);
}

See Also

MCbaseResponder Class
MCbaseResponder Members


ResponseParameters Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCbaseResponder..::..ResponseParameters Property
MCbaseResponder Class See Also Send Feedback
List of MCparameter parameters returned from DICOM service

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public List<MCparameter> ResponseParameters { get; protected set; }
Visual Basic
Public Property ResponseParameters As List(Of MCparameter)
    Get
    Protected Set
Visual C++
public:
property List<MCparameter^>^ ResponseParameters {
    List<MCparameter^>^ get ();
    protected: void set (List<MCparameter^>^ value);
}

See Also

MCbaseResponder Class
MCbaseResponder Members


MCdicomLevel Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel Class
Members See Also Send Feedback
Defines DICOM C-FIND level

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCdicomLevel
Visual Basic
Public Class MCdicomLevel
Visual C++
public ref class MCdicomLevel

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCdicomLevel

See Also

MCdicomLevel Members


MCdicomLevel Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel Members
MCdicomLevel Class Methods Fields Properties See Also Send Feedback

The MCdicomLevel type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Checks if MCdicomLevel object is equal to Object (Overrides Object..::..Equals(Object).)
Public method | Equals(MCdicomLevel) | Checks if MCdicomLevel objects are equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode of MCdicomLevel object (Overrides Object..::..GetHashCode()()()().)
 | GetLevel | Gets MCdicomLevel object for a given name
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns Name of MCdicomLevel object (Overrides Object..::..ToString()()()().)

Fields

Name | Description
Frame | Frame level of DICOM model
Image | Image level of DICOM model
Patient | Patient level of DICOM model
Series | Series level of DICOM model
Study | Study level of DICOM model

Properties

 | Name | Description
Public property | Name | Gets MCdicomLevel name

See Also

MCdicomLevel Class


MCdicomLevel Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel Fields
MCdicomLevel Class See Also Send Feedback

The MCdicomLevel type exposes the following members.

Fields

Name | Description
Frame | Frame level of DICOM model
Image | Image level of DICOM model
Patient | Patient level of DICOM model
Series | Series level of DICOM model
Study | Study level of DICOM model

See Also

MCdicomLevel Class


Frame Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel..::..Frame Field
MCdicomLevel Class See Also Send Feedback
Frame level of DICOM model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCdicomLevel Frame
Visual Basic
Public Shared Frame As MCdicomLevel
Visual C++
public:
static MCdicomLevel^ Frame

See Also

MCdicomLevel Class
MCdicomLevel Members


Image Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel..::..Image Field
MCdicomLevel Class See Also Send Feedback
Image level of DICOM model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCdicomLevel Image
Visual Basic
Public Shared Image As MCdicomLevel
Visual C++
public:
static MCdicomLevel^ Image

See Also

MCdicomLevel Class
MCdicomLevel Members


Patient Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel..::..Patient Field
MCdicomLevel Class See Also Send Feedback
Patient level of DICOM model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCdicomLevel Patient
Visual Basic
Public Shared Patient As MCdicomLevel
Visual C++
public:
static MCdicomLevel^ Patient

See Also

MCdicomLevel Class
MCdicomLevel Members


Series Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel..::..Series Field
MCdicomLevel Class See Also Send Feedback
Series level of DICOM model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCdicomLevel Series
Visual Basic
Public Shared Series As MCdicomLevel
Visual C++
public:
static MCdicomLevel^ Series

See Also

MCdicomLevel Class
MCdicomLevel Members


Study Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel..::..Study Field
MCdicomLevel Class See Also Send Feedback
Study level of DICOM model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCdicomLevel Study
Visual Basic
Public Shared Study As MCdicomLevel
Visual C++
public:
static MCdicomLevel^ Study

See Also

MCdicomLevel Class
MCdicomLevel Members


MCdicomLevel Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel Methods
MCdicomLevel Class See Also Send Feedback

The MCdicomLevel type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Checks if MCdicomLevel object is equal to Object (Overrides Object..::..Equals(Object).)
Public method | Equals(MCdicomLevel) | Checks if MCdicomLevel objects are equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode of MCdicomLevel object (Overrides Object..::..GetHashCode()()()().)
 | GetLevel | Gets MCdicomLevel object for a given name
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns Name of MCdicomLevel object (Overrides Object..::..ToString()()()().)

See Also

MCdicomLevel Class


Equals Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel..::..Equals Method
MCdicomLevel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Checks if MCdicomLevel object is equal to Object (Overrides Object..::..Equals(Object).)
Public method | Equals(MCdicomLevel) | Checks if MCdicomLevel objects are equal

See Also

MCdicomLevel Class
MCdicomLevel Members


Equals Method (Object)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel..::..Equals Method (Object)
MCdicomLevel Class See Also Send Feedback
Checks if MCdicomLevel object is equal to Object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare with the current object.

Return Value

Returns True if objects Name are the same

See Also

MCdicomLevel Class
MCdicomLevel Members
Equals Overload


Equals Method (MCdicomLevel)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel..::..Equals Method (MCdicomLevel)
MCdicomLevel Class See Also Send Feedback
Checks if MCdicomLevel objects are equal

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public bool Equals(
    MCdicomLevel level
)
Visual Basic
Public Function Equals ( _
    level As MCdicomLevel _
) As Boolean
Visual C++
public:
bool Equals(
    MCdicomLevel^ level
)

Parameters

level
Type: Mergecomws.Dicom..::..MCdicomLevel
MCdicomLevel object

Return Value

Returns True if objects Name are the same

See Also

MCdicomLevel Class
MCdicomLevel Members
Equals Overload


GetHashCode Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel..::..GetHashCode Method
MCdicomLevel Class See Also Send Feedback
Gets the hashcode of MCdicomLevel object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

Returns a hashcode generated from Name

See Also

MCdicomLevel Class
MCdicomLevel Members


GetLevel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel..::..GetLevel Method
MCdicomLevel Class See Also Send Feedback
Gets MCdicomLevel object for a given name

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCdicomLevel GetLevel(
    string name
)
Visual Basic
Public Shared Function GetLevel ( _
    name As String _
) As MCdicomLevel
Visual C++
public:
static MCdicomLevel^ GetLevel(
    String^ name
)

Parameters

name
Type: System..::..String
MCdicomLevel name

Return Value

MCdicomLevel object

See Also

MCdicomLevel Class
MCdicomLevel Members


ToString Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel..::..ToString Method
MCdicomLevel Class See Also Send Feedback
Returns Name of MCdicomLevel object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string that represents the current object.

See Also

MCdicomLevel Class
MCdicomLevel Members


MCdicomLevel Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel Properties
MCdicomLevel Class See Also Send Feedback

The MCdicomLevel type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets MCdicomLevel name

See Also

MCdicomLevel Class


Name Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomLevel..::..Name Property
MCdicomLevel Class See Also Send Feedback
Gets MCdicomLevel name

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set
Visual C++
public:
property String^ Name {
    String^ get ();
    private: void set (String^ value);
}

See Also

MCdicomLevel Class
MCdicomLevel Members


MCdicomRenderer Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRenderer Class
Members See Also Send Feedback
Converts DICOM service response into an array of Stream objects

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCdicomRenderer : MCbaseRenderer
Visual Basic
Public Class MCdicomRenderer _
    Inherits MCbaseRenderer
Visual C++
public ref class MCdicomRenderer : public MCbaseRenderer

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCbaseRenderer
Mergecomws.Dicom..::..MCdicomRenderer

See Also

MCdicomRenderer Members


MCdicomRenderer Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRenderer Members
MCdicomRenderer Class Constructors Methods Properties See Also Send Feedback

The MCdicomRenderer type exposes the following members.

Constructors

 | Name | Description
Public method | MCdicomRenderer()()()() | Class constructor
Public method | MCdicomRenderer(MCrequestType) | Class constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render | Renders DICOM service response into Stream objects using an array of MCparameter (Overrides MCbaseRenderer..::..Render(array<MCabstractMessage>[]()[][], String, String%).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RequestParameters | List of MCparameter parameters used for WADO request (Inherited from MCbaseRenderer.)
Public property | RequestType | MCrequestType type of WADO request (Inherited from MCbaseRenderer.)
Public property | Response | DICOM service response (Inherited from MCbaseRenderer.)
Public property | ResponseParameters | List of MCparameter parameters returned from DICOM service (Inherited from MCbaseRenderer.)
Public property | XmlOptions | MCxmlOptions options used in writeToXMLNative(TextWriter, MCxmlOptions) method of MCabstractMessage object (Inherited from MCbaseRenderer.)

See Also

MCdicomRenderer Class


MCdicomRenderer Constructor

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRenderer Constructor
MCdicomRenderer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCdicomRenderer()()()() | Class constructor
Public method | MCdicomRenderer(MCrequestType) | Class constructor

See Also

MCdicomRenderer Class
MCdicomRenderer Members


MCdicomRenderer Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRenderer Constructor
MCdicomRenderer Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCdicomRenderer()
Visual Basic
Public Sub New
Visual C++
public:
MCdicomRenderer()

See Also

MCdicomRenderer Class
MCdicomRenderer Members
MCdicomRenderer Overload


MCdicomRenderer Constructor (MCrequestType)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRenderer Constructor (MCrequestType)
MCdicomRenderer Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCdicomRenderer(
    MCrequestType requestType
)
Visual Basic
Public Sub New ( _
    requestType As MCrequestType _
)
Visual C++
public:
MCdicomRenderer(
    MCrequestType^ requestType
)

Parameters

requestType
Type: Mergecomws.Web..::..MCrequestType
Type of WADO request

See Also

MCdicomRenderer Class
MCdicomRenderer Members
MCdicomRenderer Overload


MCdicomRenderer Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRenderer Methods
MCdicomRenderer Class See Also Send Feedback

The MCdicomRenderer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render | Renders DICOM service response into Stream objects using an array of MCparameter (Overrides MCbaseRenderer..::..Render(array<MCabstractMessage>[]()[][], String, String%).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCdicomRenderer Class


Render Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRenderer..::..Render Method
MCdicomRenderer Class See Also Send Feedback
Renders DICOM service response into Stream objects using an array of MCparameter

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override Stream[] Render(
    MCabstractMessage[] response,
    string xmlRequestParameters,
    ref string xmlWadoResponse
)
Visual Basic
Public Overrides Function Render ( _
    response As MCabstractMessage(), _
    xmlRequestParameters As String, _
    ByRef xmlWadoResponse As String _
) As Stream()
Visual C++
public:
virtual array<Stream^>^ Render(
    array<MCabstractMessage^>^ response,
    String^ xmlRequestParameters,
    String^% xmlWadoResponse
) override

Parameters

response
Type: array<MCabstractMessage>[]()[][]
DICOM service response
xmlRequestParameters
Type: System..::..String
XML string of MCparameter parameters used for WADO request
xmlWadoResponse
Type: System..::..String%
WADO response from DICOM service encoded as XML String

Return Value

HttpResponseMessage object

Implements

IMCdicomRenderer..::..Render(array<MCabstractMessage>[]()[][], String, String%)

See Also

MCdicomRenderer Class
MCdicomRenderer Members


MCdicomRenderer Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRenderer Properties
MCdicomRenderer Class See Also Send Feedback

The MCdicomRenderer type exposes the following members.

Properties

 | Name | Description
Public property | RequestParameters | List of MCparameter parameters used for WADO request (Inherited from MCbaseRenderer.)
Public property | RequestType | MCrequestType type of WADO request (Inherited from MCbaseRenderer.)
Public property | Response | DICOM service response (Inherited from MCbaseRenderer.)
Public property | ResponseParameters | List of MCparameter parameters returned from DICOM service (Inherited from MCbaseRenderer.)
Public property | XmlOptions | MCxmlOptions options used in writeToXMLNative(TextWriter, MCxmlOptions) method of MCabstractMessage object (Inherited from MCbaseRenderer.)

See Also

MCdicomRenderer Class


MCdicomRequest Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest Class
Members See Also Send Feedback
Converts and encapsulates HttpRequestMessage data

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public abstract class MCdicomRequest
Visual Basic
Public MustInherit Class MCdicomRequest
Visual C++
public ref class MCdicomRequest abstract

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCdicomRequest
Mergecomws.Dicom..::..MCqidoRequest
Mergecomws.Dicom..::..MCrsCapabilitiesRequest
Mergecomws.Dicom..::..MCrsNpiRequest
Mergecomws.Dicom..::..MCstowCommitmentRequest
Mergecomws.Dicom..::..MCstowRequest
Mergecomws.Dicom..::..MCupsRequest
Mergecomws.Dicom..::..MCwadoRsRequest
Mergecomws.Dicom..::..MCwadoUriRequest
Mergecomws.Dicom..::..MCwadoWsRequest

See Also

MCdicomRequest Members


MCdicomRequest Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest Members
MCdicomRequest Class Methods Fields Properties See Also Send Feedback

The MCdicomRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model
 | CreateInstance | Creates an instance of MCdicomRequest
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined.
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves MCactionType from HttpRequestMessage object
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model
Public method | GetMessages | Generates a list of MCabstractMessage based on MCparameter data
Public method | GetModel | Gets the list of MCparameter of request model
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object
 | GetRequestModel | Returns a request model for specific request type
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object
Public method | ValidateRequest | Validates DICOM request

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header
Protected property | HttpCharset | Gets the content of Charset field in Http header
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header
Protected property | HttpContentType | Gets the content of content-Type field in Http Header
Protected property | HttpProvider | Gets IMChttpProvider object of current request
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning.
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header
Public property | RequestActionType | Gets MCactionType of current request
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model
Public property | RequestParameters | Gets the list of MCparameter of current request
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model
Public property | RequestType | Gets MCrequestType of current request

See Also

MCdicomRequest Class


MCdicomRequest Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest Fields
MCdicomRequest Class See Also Send Feedback

The MCdicomRequest type exposes the following members.

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data

See Also

MCdicomRequest Class


httpContents Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..httpContents Field
MCdicomRequest Class See Also Send Feedback
Contains the list of HttpContent objects of Http message

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected IEnumerable<HttpContent> httpContents
Visual Basic
Protected httpContents As IEnumerable(Of HttpContent)
Visual C++
protected:
IEnumerable<HttpContent^>^ httpContents

See Also

MCdicomRequest Class
MCdicomRequest Members


messages Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..messages Field
MCdicomRequest Class See Also Send Feedback
Generates a list of request MCabstractMessage based on HttpRequestMessage data

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected List<MCabstractMessage> messages
Visual Basic
Protected messages As List(Of MCabstractMessage)
Visual C++
protected:
List<MCabstractMessage^>^ messages

See Also

MCdicomRequest Class
MCdicomRequest Members


MCdicomRequest Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest Methods
MCdicomRequest Class See Also Send Feedback

The MCdicomRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model
 | CreateInstance | Creates an instance of MCdicomRequest
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined.
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves MCactionType from HttpRequestMessage object
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model
Public method | GetMessages | Generates a list of MCabstractMessage based on MCparameter data
Public method | GetModel | Gets the list of MCparameter of request model
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object
 | GetRequestModel | Returns a request model for specific request type
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object
Public method | ValidateRequest | Validates DICOM request

See Also

MCdicomRequest Class


CheckStudyInstanceUID Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..CheckStudyInstanceUID Method
MCdicomRequest Class See Also Send Feedback
Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected void CheckStudyInstanceUID()
Visual Basic
Protected Sub CheckStudyInstanceUID
Visual C++
protected:
void CheckStudyInstanceUID()

See Also

MCdicomRequest Class
MCdicomRequest Members


CompleteRequest Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..CompleteRequest Method
MCdicomRequest Class See Also Send Feedback
Updates and completes MCdimseMessage object from DICOM request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected virtual MCdimseMessage CompleteRequest(
    MCdimseMessage request
)
Visual Basic
Protected Overridable Function CompleteRequest ( _
    request As MCdimseMessage _
) As MCdimseMessage
Visual C++
protected:
virtual MCdimseMessage^ CompleteRequest(
    MCdimseMessage^ request
)

Parameters

request
Type: MCdimseMessage
MCdimseMessage object

Return Value

MCdimseMessage object

See Also

MCdicomRequest Class
MCdicomRequest Members


CreateInstance Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..CreateInstance Method
MCdicomRequest Class See Also Send Feedback
Creates an instance of MCdicomRequest

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCdicomRequest CreateInstance(
    MCrequestType type,
    IMChttpProvider httpProvider,
    MCparameter[] parms
)
Visual Basic
Public Shared Function CreateInstance ( _
    type As MCrequestType, _
    httpProvider As IMChttpProvider, _
    parms As MCparameter() _
) As MCdicomRequest
Visual C++
public:
static MCdicomRequest^ CreateInstance(
    MCrequestType^ type,
    IMChttpProvider^ httpProvider,
    array<MCparameter^>^ parms
)

Parameters

type
Type: Mergecomws.Web..::..MCrequestType
MCrequestType object
httpProvider
Type: Mergecomws.Web..::..IMChttpProvider
IMChttpProvider object
parms
Type: array< Mergecomws.Web..::..MCparameter >[]()[][]
List of MCparameter

Return Value

MCdicomRequest object

See Also

MCdicomRequest Class
MCdicomRequest Members


FailRequest Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..FailRequest Method
MCdicomRequest Class See Also Send Feedback
Sets the error and status code of the current request, RequestActionType is set to Undefined.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected void FailRequest(
    string error,
    HttpStatusCode code
)
Visual Basic
Protected Sub FailRequest ( _
    error As String, _
    code As HttpStatusCode _
)
Visual C++
protected:
void FailRequest(
    String^ error,
    HttpStatusCode code
)

Parameters

error
Type: System..::..String
String error
code
Type: System.Net..::..HttpStatusCode
HttpStatusCode value

See Also

MCdicomRequest Class
MCdicomRequest Members


FillParameterAttributes Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..FillParameterAttributes Method
MCdicomRequest Class See Also Send Feedback
Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected virtual void FillParameterAttributes(
    MCdimseMessage message
)
Visual Basic
Protected Overridable Sub FillParameterAttributes ( _
    message As MCdimseMessage _
)
Visual C++
protected:
virtual void FillParameterAttributes(
    MCdimseMessage^ message
)

Parameters

message
Type: MCdimseMessage
request message

See Also

MCdicomRequest Class
MCdicomRequest Members


GetActionType Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetActionType Method
MCdicomRequest Class See Also Send Feedback
Retrieves MCactionType from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected virtual void GetActionType()
Visual Basic
Protected Overridable Sub GetActionType
Visual C++
protected:
virtual void GetActionType()

See Also

MCdicomRequest Class
MCdicomRequest Members


GetAttribute Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetAttribute Method
MCdicomRequest Class See Also Send Feedback
Gets MCrequestAttribute instance for given Attribute ID string

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected virtual MCrequestAttribute GetAttribute(
    string attributeID
)
Visual Basic
Protected Overridable Function GetAttribute ( _
    attributeID As String _
) As MCrequestAttribute
Visual C++
protected:
virtual MCrequestAttribute^ GetAttribute(
    String^ attributeID
)

Parameters

attributeID
Type: System..::..String
Attribute ID

Return Value

MCrequestAttribute object

See Also

MCdicomRequest Class
MCdicomRequest Members


GetContent Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetContent Method
MCdicomRequest Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) |

See Also

MCdicomRequest Class
MCdicomRequest Members


GetContent Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetContent Method
MCdicomRequest Class See Also Send Feedback
Retrieves Http Content from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected virtual void GetContent()
Visual Basic
Protected Overridable Sub GetContent
Visual C++
protected:
virtual void GetContent()

See Also

MCdicomRequest Class
MCdicomRequest Members
GetContent Overload


GetContent Method (HttpContent, IEnumerable(MCmediaType))

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetContent Method (HttpContent, IEnumerable<(Of <(<'MCmediaType>)>)>)
MCdicomRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Mergecomws.Dicom.MCdicomRequest.GetContent(System.Net.Http.HttpContent,System.Collections.Generic.IEnumerable{Mergecomws.Dicom.MCmediaType})"]

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected bool GetContent(
    HttpContent content,
    IEnumerable<MCmediaType> mediaTypes
)
Visual Basic
Protected Function GetContent ( _
    content As HttpContent, _
    mediaTypes As IEnumerable(Of MCmediaType) _
) As Boolean
Visual C++
protected:
bool GetContent(
    HttpContent^ content,
    IEnumerable<MCmediaType^>^ mediaTypes
)

Parameters

content
Type: HttpContent

[Missing <param name="content"/> documentation for "M:Mergecomws.Dicom.MCdicomRequest.GetContent(System.Net.Http.HttpContent,System.Collections.Generic.IEnumerable{Mergecomws.Dicom.MCmediaType})"]

mediaTypes
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' MCmediaType >)>)>

[Missing <param name="mediaTypes"/> documentation for "M:Mergecomws.Dicom.MCdicomRequest.GetContent(System.Net.Http.HttpContent,System.Collections.Generic.IEnumerable{Mergecomws.Dicom.MCmediaType})"]

Return Value

[Missing <returns> documentation for "M:Mergecomws.Dicom.MCdicomRequest.GetContent(System.Net.Http.HttpContent,System.Collections.Generic.IEnumerable{Mergecomws.Dicom.MCmediaType})"]

See Also

MCdicomRequest Class
MCdicomRequest Members
GetContent Overload


GetHeaders Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetHeaders Method
MCdicomRequest Class See Also Send Feedback
Retrieves Http Header data from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected virtual void GetHeaders()
Visual Basic
Protected Overridable Sub GetHeaders
Visual C++
protected:
virtual void GetHeaders()

See Also

MCdicomRequest Class
MCdicomRequest Members


GetLevel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetLevel Method
MCdicomRequest Class See Also Send Feedback
Gets MCdicomLevel value of DICOM request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected virtual void GetLevel()
Visual Basic
Protected Overridable Sub GetLevel
Visual C++
protected:
virtual void GetLevel()

See Also

MCdicomRequest Class
MCdicomRequest Members


GetMessages Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetMessages Method
MCdicomRequest Class See Also Send Feedback
Generates a list of MCabstractMessage based on MCparameter data

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public virtual IEnumerable<MCabstractMessage> GetMessages()
Visual Basic
Public Overridable Function GetMessages As IEnumerable(Of MCabstractMessage)
Visual C++
public:
virtual IEnumerable<MCabstractMessage^>^ GetMessages()

Return Value

Collection of MCabstractMessage objects.

See Also

MCdicomRequest Class
MCdicomRequest Members


GetModel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetModel Method
MCdicomRequest Class See Also Send Feedback
Gets the list of MCparameter of request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public abstract IList<MCparameter> GetModel()
Visual Basic
Public MustOverride Function GetModel As IList(Of MCparameter)
Visual C++
public:
virtual IList<MCparameter^>^ GetModel() abstract

Return Value

A list of MCparameter objects

See Also

MCdicomRequest Class
MCdicomRequest Members


GetParameter Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetParameter Method
MCdicomRequest Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects

See Also

MCdicomRequest Class
MCdicomRequest Members


GetParameter Method (KeyValuePair(String, IEnumerable(String)))

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetParameter Method (KeyValuePair<(Of <(<'String, IEnumerable<(Of <(<'String>)>)>>)>)>)
MCdicomRequest Class See Also Send Feedback
Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected virtual MCparameter GetParameter(
    KeyValuePair<string, IEnumerable<string>> pair
)
Visual Basic
Protected Overridable Function GetParameter ( _
    pair As KeyValuePair(Of String, IEnumerable(Of String)) _
) As MCparameter
Visual C++
protected:
virtual MCparameter^ GetParameter(
    KeyValuePair<String^, IEnumerable<String^>^> pair
)

Parameters

pair
Type: System.Collections.Generic..::..KeyValuePair<(Of <(<'String, IEnumerable<(Of <(<'String>)>)>>)>)>
Key-Value pair

Return Value

An MCparameter object

See Also

MCdicomRequest Class
MCdicomRequest Members
GetParameter Overload


GetParameter Method (MCrequestAttribute)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetParameter Method (MCrequestAttribute)
MCdicomRequest Class See Also Send Feedback
Gets MCparameter instance with given MCrequestAttribute objects

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected virtual MCparameter GetParameter(
    MCrequestAttribute attr
)
Visual Basic
Protected Overridable Function GetParameter ( _
    attr As MCrequestAttribute _
) As MCparameter
Visual C++
protected:
virtual MCparameter^ GetParameter(
    MCrequestAttribute^ attr
)

Parameters

attr
Type: Mergecomws.Web..::..MCrequestAttribute
MCrequestAttribute object

Return Value

An MCparameter object

See Also

MCdicomRequest Class
MCdicomRequest Members
GetParameter Overload


GetQueries Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetQueries Method
MCdicomRequest Class See Also Send Feedback
Retrieves Http Query from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected virtual void GetQueries()
Visual Basic
Protected Overridable Sub GetQueries
Visual C++
protected:
virtual void GetQueries()

See Also

MCdicomRequest Class
MCdicomRequest Members


GetRequestModel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetRequestModel Method
MCdicomRequest Class See Also Send Feedback
Returns a request model for specific request type

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected static IEnumerable<MCparameter> GetRequestModel(
    string name
)
Visual Basic
Protected Shared Function GetRequestModel ( _
    name As String _
) As IEnumerable(Of MCparameter)
Visual C++
protected:
static IEnumerable<MCparameter^>^ GetRequestModel(
    String^ name
)

Parameters

name
Type: System..::..String
Request name

Return Value

List of request parameters for the request with given name

See Also

MCdicomRequest Class
MCdicomRequest Members


GetResponseTypeParameter Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetResponseTypeParameter Method
MCdicomRequest Class See Also Send Feedback
Gets MCparameter instance for given MCdicomRequest

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected MCparameter GetResponseTypeParameter(
    string[] parms
)
Visual Basic
Protected Function GetResponseTypeParameter ( _
    parms As String() _
) As MCparameter
Visual C++
protected:
MCparameter^ GetResponseTypeParameter(
    array<String^>^ parms
)

Parameters

parms
Type: array<System..::..String>[]()[][]
parameter names

Return Value

An MCparameter object

See Also

MCdicomRequest Class
MCdicomRequest Members


GetRoot Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetRoot Method
MCdicomRequest Class See Also Send Feedback
Gets MCdicomRoot value of DICOM request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected virtual void GetRoot()
Visual Basic
Protected Overridable Sub GetRoot
Visual C++
protected:
virtual void GetRoot()

See Also

MCdicomRequest Class
MCdicomRequest Members


GetSegments Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetSegments Method
MCdicomRequest Class See Also Send Feedback
Retrieves MCparameter from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected virtual void GetSegments()
Visual Basic
Protected Overridable Sub GetSegments
Visual C++
protected:
virtual void GetSegments()

See Also

MCdicomRequest Class
MCdicomRequest Members


GetXmlParameters Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..GetXmlParameters Method
MCdicomRequest Class See Also Send Feedback
Encodes the list of MCparameter of current request into XML String

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public virtual string GetXmlParameters()
Visual Basic
Public Overridable Function GetXmlParameters As String
Visual C++
public:
virtual String^ GetXmlParameters()

Return Value

XML String

See Also

MCdicomRequest Class
MCdicomRequest Members


ParseContent Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..ParseContent Method
MCdicomRequest Class See Also Send Feedback
Parses HTTP multipart content

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected MCabstractMessage ParseContent(
    HttpContent hc
)
Visual Basic
Protected Function ParseContent ( _
    hc As HttpContent _
) As MCabstractMessage
Visual C++
protected:
MCabstractMessage^ ParseContent(
    HttpContent^ hc
)

Parameters

hc
Type: HttpContent
HttpContent object

Return Value

CopyC#
True
 if succeeded

See Also

MCdicomRequest Class
MCdicomRequest Members


Populate Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..Populate Method
MCdicomRequest Class See Also Send Feedback
Populates MCdicomRequest internal data with HttpRequestMessage object data

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public virtual void Populate()
Visual Basic
Public Overridable Sub Populate
Visual C++
public:
virtual void Populate()

See Also

MCdicomRequest Class
MCdicomRequest Members


PopulateParameter Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..PopulateParameter Method
MCdicomRequest Class See Also Send Feedback
Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected virtual bool PopulateParameter(
    MCparameter parm,
    KeyValuePair<string, IEnumerable<string>> pair
)
Visual Basic
Protected Overridable Function PopulateParameter ( _
    parm As MCparameter, _
    pair As KeyValuePair(Of String, IEnumerable(Of String)) _
) As Boolean
Visual C++
protected:
virtual bool PopulateParameter(
    MCparameter^ parm,
    KeyValuePair<String^, IEnumerable<String^>^> pair
)

Parameters

parm
Type: Mergecomws.Web..::..MCparameter
MCparameter object
pair
Type: System.Collections.Generic..::..KeyValuePair<(Of <(<'String, IEnumerable<(Of <(<'String>)>)>>)>)>
KeyValuePair<(Of <(<'TKey, TValue>)>)> pair

Return Value

CopyC#
True
 is successful

See Also

MCdicomRequest Class
MCdicomRequest Members


ReadContentAsync Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..ReadContentAsync Method
MCdicomRequest Class See Also Send Feedback
Asynchronously reads HTTP multi-part content

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected Task<Object> ReadContentAsync()
Visual Basic
Protected Function ReadContentAsync As Task(Of Object)
Visual C++
protected:
Task<Object^>^ ReadContentAsync()

Return Value

MultipartMemoryStreamProvider object

See Also

MCdicomRequest Class
MCdicomRequest Members


SetAttribute Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..SetAttribute Method
MCdicomRequest Class See Also Send Feedback
Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected virtual bool SetAttribute(
    MCrequestAttribute attr,
    KeyValuePair<string, IEnumerable<string>> pair
)
Visual Basic
Protected Overridable Function SetAttribute ( _
    attr As MCrequestAttribute, _
    pair As KeyValuePair(Of String, IEnumerable(Of String)) _
) As Boolean
Visual C++
protected:
virtual bool SetAttribute(
    MCrequestAttribute^ attr,
    KeyValuePair<String^, IEnumerable<String^>^> pair
)

Parameters

attr
Type: Mergecomws.Web..::..MCrequestAttribute
MCrequestAttribute object
pair
Type: System.Collections.Generic..::..KeyValuePair<(Of <(<'String, IEnumerable<(Of <(<'String>)>)>>)>)>
KeyValuePair<(Of <(<'TKey, TValue>)>)> pair

Return Value

CopyC#
True
 if succeeded

See Also

MCdicomRequest Class
MCdicomRequest Members


supportedMediaTypes Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..supportedMediaTypes Method
MCdicomRequest Class See Also Send Feedback
Gets the list of supported MCmediaType of the current request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected abstract IEnumerable<MCmediaType> supportedMediaTypes()
Visual Basic
Protected MustOverride Function supportedMediaTypes As IEnumerable(Of MCmediaType)
Visual C++
protected:
virtual IEnumerable<MCmediaType^>^ supportedMediaTypes() abstract

Return Value

List of MCmediaType objects

See Also

MCdicomRequest Class
MCdicomRequest Members


ValidateParameter Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..ValidateParameter Method
MCdicomRequest Class See Also Send Feedback
Validates MCparameter object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected bool ValidateParameter(
    uint tag
)
Visual Basic
Protected Function ValidateParameter ( _
    tag As UInteger _
) As Boolean
Visual C++
protected:
bool ValidateParameter(
    unsigned int tag
)

Parameters

tag
Type: System..::..UInt32
DICOM attribute tag

Return Value

Returns True if MCparameter object contains MCrequestAttribute with a given tag and valid value

See Also

MCdicomRequest Class
MCdicomRequest Members


ValidateRequest Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..ValidateRequest Method
MCdicomRequest Class See Also Send Feedback
Validates DICOM request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public virtual bool ValidateRequest()
Visual Basic
Public Overridable Function ValidateRequest As Boolean
Visual C++
public:
virtual bool ValidateRequest()

Return Value

Returns True if MCdicomRequest has valid data and MCactionType

See Also

MCdicomRequest Class
MCdicomRequest Members


MCdicomRequest Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest Properties
MCdicomRequest Class See Also Send Feedback

The MCdicomRequest type exposes the following members.

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header
Protected property | HttpCharset | Gets the content of Charset field in Http header
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header
Protected property | HttpContentType | Gets the content of content-Type field in Http Header
Protected property | HttpProvider | Gets IMChttpProvider object of current request
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning.
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header
Public property | RequestActionType | Gets MCactionType of current request
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model
Public property | RequestParameters | Gets the list of MCparameter of current request
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model
Public property | RequestType | Gets MCrequestType of current request

See Also

MCdicomRequest Class


HttpAccept Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..HttpAccept Property
MCdicomRequest Class See Also Send Feedback
Gets the content of Accept field in Http Header

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected string[] HttpAccept { get; private set; }
Visual Basic
Protected Property HttpAccept As String()
    Get
    Private Set
Visual C++
protected:
property array<String^>^ HttpAccept {
    array<String^>^ get ();
    private: void set (array<String^>^ value);
}

See Also

MCdicomRequest Class
MCdicomRequest Members


HttpCacheControl Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..HttpCacheControl Property
MCdicomRequest Class See Also Send Feedback
Gets the content of Cache-Control field in Http Header

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected string[] HttpCacheControl { get; private set; }
Visual Basic
Protected Property HttpCacheControl As String()
    Get
    Private Set
Visual C++
protected:
property array<String^>^ HttpCacheControl {
    array<String^>^ get ();
    private: void set (array<String^>^ value);
}

See Also

MCdicomRequest Class
MCdicomRequest Members


HttpCharset Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..HttpCharset Property
MCdicomRequest Class See Also Send Feedback
Gets the content of Charset field in Http header

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected string[] HttpCharset { get; private set; }
Visual Basic
Protected Property HttpCharset As String()
    Get
    Private Set
Visual C++
protected:
property array<String^>^ HttpCharset {
    array<String^>^ get ();
    private: void set (array<String^>^ value);
}

See Also

MCdicomRequest Class
MCdicomRequest Members


HttpContentLength Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..HttpContentLength Property
MCdicomRequest Class See Also Send Feedback
Gets the value of Content-Length field in Http Header

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected string[] HttpContentLength { get; private set; }
Visual Basic
Protected Property HttpContentLength As String()
    Get
    Private Set
Visual C++
protected:
property array<String^>^ HttpContentLength {
    array<String^>^ get ();
    private: void set (array<String^>^ value);
}

See Also

MCdicomRequest Class
MCdicomRequest Members


HttpContentType Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..HttpContentType Property
MCdicomRequest Class See Also Send Feedback
Gets the content of content-Type field in Http Header

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected string[] HttpContentType { get; private set; }
Visual Basic
Protected Property HttpContentType As String()
    Get
    Private Set
Visual C++
protected:
property array<String^>^ HttpContentType {
    array<String^>^ get ();
    private: void set (array<String^>^ value);
}

See Also

MCdicomRequest Class
MCdicomRequest Members


HttpProvider Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..HttpProvider Property
MCdicomRequest Class See Also Send Feedback
Gets IMChttpProvider object of current request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected IMChttpProvider HttpProvider { get; private set; }
Visual Basic
Protected Property HttpProvider As IMChttpProvider
    Get
    Private Set
Visual C++
protected:
property IMChttpProvider^ HttpProvider {
    IMChttpProvider^ get ();
    private: void set (IMChttpProvider^ value);
}

See Also

MCdicomRequest Class
MCdicomRequest Members


HttpStatusCode Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..HttpStatusCode Property
MCdicomRequest Class See Also Send Feedback
Gets and sets HttpStatusCode of current request to report any of the associated error and warning.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpStatusCode HttpStatusCode { get; protected set; }
Visual Basic
Public Property HttpStatusCode As HttpStatusCode
    Get
    Protected Set
Visual C++
public:
property HttpStatusCode HttpStatusCode {
    HttpStatusCode get ();
    protected: void set (HttpStatusCode value);
}

See Also

MCdicomRequest Class
MCdicomRequest Members


HttpStatusMessage Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..HttpStatusMessage Property
MCdicomRequest Class See Also Send Feedback
Gets and sets the error String content for HttpResponseMessage of current request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string HttpStatusMessage { get; protected set; }
Visual Basic
Public Property HttpStatusMessage As String
    Get
    Protected Set
Visual C++
public:
property String^ HttpStatusMessage {
    String^ get ();
    protected: void set (String^ value);
}

See Also

MCdicomRequest Class
MCdicomRequest Members


HttpTransferEncoding Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..HttpTransferEncoding Property
MCdicomRequest Class See Also Send Feedback
Gets the content of Transfer-Encoding field in Http Header

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected string[] HttpTransferEncoding { get; private set; }
Visual Basic
Protected Property HttpTransferEncoding As String()
    Get
    Private Set
Visual C++
protected:
property array<String^>^ HttpTransferEncoding {
    array<String^>^ get ();
    private: void set (array<String^>^ value);
}

See Also

MCdicomRequest Class
MCdicomRequest Members


RequestActionType Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..RequestActionType Property
MCdicomRequest Class See Also Send Feedback
Gets MCactionType of current request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCactionType RequestActionType { get; protected set; }
Visual Basic
Public Property RequestActionType As MCactionType
    Get
    Protected Set
Visual C++
public:
property MCactionType^ RequestActionType {
    MCactionType^ get ();
    protected: void set (MCactionType^ value);
}

See Also

MCdicomRequest Class
MCdicomRequest Members


RequestLevel Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..RequestLevel Property
MCdicomRequest Class See Also Send Feedback
Gets and sets MCdicomLevel of DICOM request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCdicomLevel RequestLevel { get; set; }
Visual Basic
Public Property RequestLevel As MCdicomLevel
    Get
    Set
Visual C++
public:
property MCdicomLevel^ RequestLevel {
    MCdicomLevel^ get ();
    void set (MCdicomLevel^ value);
}

See Also

MCdicomRequest Class
MCdicomRequest Members


RequestParameters Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..RequestParameters Property
MCdicomRequest Class See Also Send Feedback
Gets the list of MCparameter of current request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public List<MCparameter> RequestParameters { get; protected set; }
Visual Basic
Public Property RequestParameters As List(Of MCparameter)
    Get
    Protected Set
Visual C++
public:
property List<MCparameter^>^ RequestParameters {
    List<MCparameter^>^ get ();
    protected: void set (List<MCparameter^>^ value);
}

See Also

MCdicomRequest Class
MCdicomRequest Members


RequestRoot Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..RequestRoot Property
MCdicomRequest Class See Also Send Feedback
Gets and sets MCdicomRoot of DICOM request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCdicomRoot RequestRoot { get; set; }
Visual Basic
Public Property RequestRoot As MCdicomRoot
    Get
    Set
Visual C++
public:
property MCdicomRoot^ RequestRoot {
    MCdicomRoot^ get ();
    void set (MCdicomRoot^ value);
}

See Also

MCdicomRequest Class
MCdicomRequest Members


RequestType Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRequest..::..RequestType Property
MCdicomRequest Class See Also Send Feedback
Gets MCrequestType of current request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrequestType RequestType { get; private set; }
Visual Basic
Public Property RequestType As MCrequestType
    Get
    Private Set
Visual C++
public:
property MCrequestType^ RequestType {
    MCrequestType^ get ();
    private: void set (MCrequestType^ value);
}

See Also

MCdicomRequest Class
MCdicomRequest Members


MCdicomResponse Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomResponse Class
Members See Also Send Feedback
Encapsulates and converts DICOM service response into HttpResponseMessage data

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCdicomResponse
Visual Basic
Public Class MCdicomResponse
Visual C++
public ref class MCdicomResponse

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCdicomResponse
Mergecomws.Dicom..::..MCupsResponse
Mergecomws.Dicom..::..MCwadoWsResponse

See Also

MCdicomResponse Members


MCdicomResponse Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomResponse Members
MCdicomResponse Class Methods Fields Properties See Also Send Feedback

The MCdicomResponse type exposes the following members.

Methods

 | Name | Description
Public method | CreateHttpResponseMessage | Creates internal HttpResponseMessage object from DICOM service response
 | CreateInstance(MCrequestType) | Creates an instance of MCdicomResponse object
 | CreateInstance(MCrequestType, IMCdicomRenderer, IMChttpConverter, IMChttpResponder) | Creates an instance of MCdicomResponse object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHttpResponseMessage | Returns internal HttpResponseMessage object created from DICOM service response with CreateHttpResponseMessage(array<MCabstractMessage>[]()[][], String, String)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name Description
Protected field httpResponseMessage
Internal HttpResponseMessage object created by
CopyC#
CreateHttpResponseMessage
 method

Properties

 | Name | Description
Public property | DicomRenderer | Gets and sets DICOM renderer of DICOM service response
Public property | HttpConverter | Gets and sets Http converter of DICOM stream data from IMCdicomRenderer object
Public property | HttpResponder | Gets and sets Http response message creator which uses Http multipart content from IMChttpConverter object
Public property | RequestType | Gets MCrequestType for the current response

See Also

MCdicomResponse Class


MCdicomResponse Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomResponse Fields
MCdicomResponse Class See Also Send Feedback

The MCdicomResponse type exposes the following members.

Fields

Name Description
Protected field httpResponseMessage
Internal HttpResponseMessage object created by
CopyC#
CreateHttpResponseMessage
 method

See Also

MCdicomResponse Class


httpResponseMessage Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomResponse..::..httpResponseMessage Field
MCdicomResponse Class See Also Send Feedback
Internal HttpResponseMessage object created by
CopyC#
CreateHttpResponseMessage
 method

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected HttpResponseMessage httpResponseMessage
Visual Basic
Protected httpResponseMessage As HttpResponseMessage
Visual C++
protected:
HttpResponseMessage^ httpResponseMessage

See Also

MCdicomResponse Class
MCdicomResponse Members


MCdicomResponse Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomResponse Methods
MCdicomResponse Class See Also Send Feedback

The MCdicomResponse type exposes the following members.

Methods

 | Name | Description
Public method | CreateHttpResponseMessage | Creates internal HttpResponseMessage object from DICOM service response
 | CreateInstance(MCrequestType) | Creates an instance of MCdicomResponse object
 | CreateInstance(MCrequestType, IMCdicomRenderer, IMChttpConverter, IMChttpResponder) | Creates an instance of MCdicomResponse object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHttpResponseMessage | Returns internal HttpResponseMessage object created from DICOM service response with CreateHttpResponseMessage(array<MCabstractMessage>[]()[][], String, String)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCdicomResponse Class


CreateHttpResponseMessage Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomResponse..::..CreateHttpResponseMessage Method
MCdicomResponse Class See Also Send Feedback
Creates internal HttpResponseMessage object from DICOM service response

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public virtual void CreateHttpResponseMessage(
    MCabstractMessage[] response,
    string xmlRequestParameters,
    string xmlWadoResponse
)
Visual Basic
Public Overridable Sub CreateHttpResponseMessage ( _
    response As MCabstractMessage(), _
    xmlRequestParameters As String, _
    xmlWadoResponse As String _
)
Visual C++
public:
virtual void CreateHttpResponseMessage(
    array<MCabstractMessage^>^ response,
    String^ xmlRequestParameters,
    String^ xmlWadoResponse
)

Parameters

response
Type: array<MCabstractMessage>[]()[][]
DICOM service response
xmlRequestParameters
Type: System..::..String
XML string of MCparameter parameters used for WADO request
xmlWadoResponse
Type: System..::..String
WADO response from DICOM service encoded as XML String

See Also

MCdicomResponse Class
MCdicomResponse Members


CreateInstance Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomResponse..::..CreateInstance Method
MCdicomResponse Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(MCrequestType) | Creates an instance of MCdicomResponse object
CreateInstance(MCrequestType, IMCdicomRenderer, IMChttpConverter, IMChttpResponder) | Creates an instance of MCdicomResponse object

See Also

MCdicomResponse Class
MCdicomResponse Members


CreateInstance Method (MCrequestType)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomResponse..::..CreateInstance Method (MCrequestType)
MCdicomResponse Class See Also Send Feedback
Creates an instance of MCdicomResponse object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCdicomResponse CreateInstance(
    MCrequestType type
)
Visual Basic
Public Shared Function CreateInstance ( _
    type As MCrequestType _
) As MCdicomResponse
Visual C++
public:
static MCdicomResponse^ CreateInstance(
    MCrequestType^ type
)

Parameters

type
Type: Mergecomws.Web..::..MCrequestType
Request type

Return Value

MCdicomResponse object

See Also

MCdicomResponse Class
MCdicomResponse Members
CreateInstance Overload


CreateInstance Method (MCrequestType, IMCdicomRenderer, IMChttpConverter, IMChttpResponder)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomResponse..::..CreateInstance Method (MCrequestType, IMCdicomRenderer, IMChttpConverter, IMChttpResponder)
MCdicomResponse Class See Also Send Feedback
Creates an instance of MCdicomResponse object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCdicomResponse CreateInstance(
    MCrequestType type,
    IMCdicomRenderer renderer,
    IMChttpConverter converter,
    IMChttpResponder responder
)
Visual Basic
Public Shared Function CreateInstance ( _
    type As MCrequestType, _
    renderer As IMCdicomRenderer, _
    converter As IMChttpConverter, _
    responder As IMChttpResponder _
) As MCdicomResponse
Visual C++
public:
static MCdicomResponse^ CreateInstance(
    MCrequestType^ type,
    IMCdicomRenderer^ renderer,
    IMChttpConverter^ converter,
    IMChttpResponder^ responder
)

Parameters

type
Type: Mergecomws.Web..::..MCrequestType
Request type
renderer
Type: Mergecomws.Dicom..::..IMCdicomRenderer
IMCdicomRenderer object
converter
Type: Mergecomws.Dicom..::..IMChttpConverter
IMChttpConverter object
responder
Type: Mergecomws.Dicom..::..IMChttpResponder
IMChttpResponder object

Return Value

MCdicomResponse object

See Also

MCdicomResponse Class
MCdicomResponse Members
CreateInstance Overload


GetHttpResponseMessage Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomResponse..::..GetHttpResponseMessage Method
MCdicomResponse Class See Also Send Feedback
Returns internal HttpResponseMessage object created from DICOM service response with CreateHttpResponseMessage(array<MCabstractMessage>[]()[][], String, String)

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage GetHttpResponseMessage()
Visual Basic
Public Function GetHttpResponseMessage As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ GetHttpResponseMessage()

Return Value

HttpResponseMessage object.

See Also

MCdicomResponse Class
MCdicomResponse Members


MCdicomResponse Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomResponse Properties
MCdicomResponse Class See Also Send Feedback

The MCdicomResponse type exposes the following members.

Properties

 | Name | Description
Public property | DicomRenderer | Gets and sets DICOM renderer of DICOM service response
Public property | HttpConverter | Gets and sets Http converter of DICOM stream data from IMCdicomRenderer object
Public property | HttpResponder | Gets and sets Http response message creator which uses Http multipart content from IMChttpConverter object
Public property | RequestType | Gets MCrequestType for the current response

See Also

MCdicomResponse Class


DicomRenderer Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomResponse..::..DicomRenderer Property
MCdicomResponse Class See Also Send Feedback
Gets and sets DICOM renderer of DICOM service response

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public IMCdicomRenderer DicomRenderer { get; set; }
Visual Basic
Public Property DicomRenderer As IMCdicomRenderer
    Get
    Set
Visual C++
public:
property IMCdicomRenderer^ DicomRenderer {
    IMCdicomRenderer^ get ();
    void set (IMCdicomRenderer^ value);
}

See Also

MCdicomResponse Class
MCdicomResponse Members


HttpConverter Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomResponse..::..HttpConverter Property
MCdicomResponse Class See Also Send Feedback
Gets and sets Http converter of DICOM stream data from IMCdicomRenderer object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public IMChttpConverter HttpConverter { get; set; }
Visual Basic
Public Property HttpConverter As IMChttpConverter
    Get
    Set
Visual C++
public:
property IMChttpConverter^ HttpConverter {
    IMChttpConverter^ get ();
    void set (IMChttpConverter^ value);
}

See Also

MCdicomResponse Class
MCdicomResponse Members


HttpResponder Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomResponse..::..HttpResponder Property
MCdicomResponse Class See Also Send Feedback
Gets and sets Http response message creator which uses Http multipart content from IMChttpConverter object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public IMChttpResponder HttpResponder { get; set; }
Visual Basic
Public Property HttpResponder As IMChttpResponder
    Get
    Set
Visual C++
public:
property IMChttpResponder^ HttpResponder {
    IMChttpResponder^ get ();
    void set (IMChttpResponder^ value);
}

See Also

MCdicomResponse Class
MCdicomResponse Members


RequestType Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomResponse..::..RequestType Property
MCdicomResponse Class See Also Send Feedback
Gets MCrequestType for the current response

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrequestType RequestType { get; private set; }
Visual Basic
Public Property RequestType As MCrequestType
    Get
    Private Set
Visual C++
public:
property MCrequestType^ RequestType {
    MCrequestType^ get ();
    private: void set (MCrequestType^ value);
}

See Also

MCdicomResponse Class
MCdicomResponse Members


MCdicomRoot Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRoot Class
Members See Also Send Feedback
Describes Root property of DICOM request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCdicomRoot
Visual Basic
Public Class MCdicomRoot
Visual C++
public ref class MCdicomRoot

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCdicomRoot

See Also

MCdicomRoot Members


MCdicomRoot Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRoot Members
MCdicomRoot Class Methods Fields Properties See Also Send Feedback

The MCdicomRoot type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Checks if MCdicomRoot object is equal to Object (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode of MCdicomRoot object (Overrides Object..::..GetHashCode()()()().)
 | GetRoot | Gets MCdicomRoot object for a given name
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns Name of MCdicomRoot object (Overrides Object..::..ToString()()()().)

Fields

Name | Description
Composite | Composite root of DICOM model
Patient | Patient root of DICOM model
Study | Study root of DICOM model

Properties

 | Name | Description
Public property | Name | Gets MCdicomRoot name

See Also

MCdicomRoot Class


MCdicomRoot Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRoot Fields
MCdicomRoot Class See Also Send Feedback

The MCdicomRoot type exposes the following members.

Fields

Name | Description
Composite | Composite root of DICOM model
Patient | Patient root of DICOM model
Study | Study root of DICOM model

See Also

MCdicomRoot Class


Composite Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRoot..::..Composite Field
MCdicomRoot Class See Also Send Feedback
Composite root of DICOM model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCdicomRoot Composite
Visual Basic
Public Shared Composite As MCdicomRoot
Visual C++
public:
static MCdicomRoot^ Composite

See Also

MCdicomRoot Class
MCdicomRoot Members


Patient Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRoot..::..Patient Field
MCdicomRoot Class See Also Send Feedback
Patient root of DICOM model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCdicomRoot Patient
Visual Basic
Public Shared Patient As MCdicomRoot
Visual C++
public:
static MCdicomRoot^ Patient

See Also

MCdicomRoot Class
MCdicomRoot Members


Study Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRoot..::..Study Field
MCdicomRoot Class See Also Send Feedback
Study root of DICOM model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCdicomRoot Study
Visual Basic
Public Shared Study As MCdicomRoot
Visual C++
public:
static MCdicomRoot^ Study

See Also

MCdicomRoot Class
MCdicomRoot Members


MCdicomRoot Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRoot Methods
MCdicomRoot Class See Also Send Feedback

The MCdicomRoot type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Checks if MCdicomRoot object is equal to Object (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode of MCdicomRoot object (Overrides Object..::..GetHashCode()()()().)
 | GetRoot | Gets MCdicomRoot object for a given name
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns Name of MCdicomRoot object (Overrides Object..::..ToString()()()().)

See Also

MCdicomRoot Class


Equals Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRoot..::..Equals Method
MCdicomRoot Class See Also Send Feedback
Checks if MCdicomRoot object is equal to Object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare with the current object.

Return Value

Returns True if objects Name are the same

See Also

MCdicomRoot Class
MCdicomRoot Members


GetHashCode Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRoot..::..GetHashCode Method
MCdicomRoot Class See Also Send Feedback
Gets the hashcode of MCdicomRoot object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

Returns a hashcode generated from Name

See Also

MCdicomRoot Class
MCdicomRoot Members


GetRoot Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRoot..::..GetRoot Method
MCdicomRoot Class See Also Send Feedback
Gets MCdicomRoot object for a given name

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCdicomRoot GetRoot(
    string name
)
Visual Basic
Public Shared Function GetRoot ( _
    name As String _
) As MCdicomRoot
Visual C++
public:
static MCdicomRoot^ GetRoot(
    String^ name
)

Parameters

name
Type: System..::..String
MCdicomRoot name

Return Value

MCdicomRoot object

See Also

MCdicomRoot Class
MCdicomRoot Members


ToString Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRoot..::..ToString Method
MCdicomRoot Class See Also Send Feedback
Returns Name of MCdicomRoot object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string that represents the current object.

See Also

MCdicomRoot Class
MCdicomRoot Members


MCdicomRoot Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRoot Properties
MCdicomRoot Class See Also Send Feedback

The MCdicomRoot type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets MCdicomRoot name

See Also

MCdicomRoot Class


Name Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCdicomRoot..::..Name Property
MCdicomRoot Class See Also Send Feedback
Gets MCdicomRoot name

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set
Visual C++
public:
property String^ Name {
    String^ get ();
    private: void set (String^ value);
}

See Also

MCdicomRoot Class
MCdicomRoot Members


MChttpConverter Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpConverter Class
Members See Also Send Feedback
Converts an arrays of Stream objects rendered from DICOM service response into an array of HttpContent objects

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MChttpConverter : MCbaseConverter
Visual Basic
Public Class MChttpConverter _
    Inherits MCbaseConverter
Visual C++
public ref class MChttpConverter : public MCbaseConverter

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCbaseConverter
Mergecomws.Dicom..::..MChttpConverter

See Also

MChttpConverter Members


MChttpConverter Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpConverter Members
MChttpConverter Class Constructors Methods Properties See Also Send Feedback

The MChttpConverter type exposes the following members.

Constructors

 | Name | Description
Public method | MChttpConverter()()()() | Class constructor
Public method | MChttpConverter(MCrequestType) | Class constructor

Methods

 | Name | Description
Public method | Convert | Converts an array of rendered DICOM streams into an array of HttpContent objects based on request parameters (Overrides MCbaseConverter..::..Convert(array<Stream>[]()[][], String, String%).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RequestParameters | List of MCparameter parameters used for WADO request (Inherited from MCbaseConverter.)
Public property | RequestType | MCrequestType type of WADO request (Inherited from MCbaseConverter.)
Public property | ResponseParameters | List of MCparameter parameters returned from DICOM service (Inherited from MCbaseConverter.)
Public property | Streams | An array of Stream of rendered DICOM stream data (Inherited from MCbaseConverter.)
Public property | XmlOptions | MCxmlOptions options used in writeToXMLNative(TextWriter, MCxmlOptions) method of MCabstractMessage object (Inherited from MCbaseConverter.)

See Also

MChttpConverter Class


MChttpConverter Constructor

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpConverter Constructor
MChttpConverter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MChttpConverter()()()() | Class constructor
Public method | MChttpConverter(MCrequestType) | Class constructor

See Also

MChttpConverter Class
MChttpConverter Members


MChttpConverter Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpConverter Constructor
MChttpConverter Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MChttpConverter()
Visual Basic
Public Sub New
Visual C++
public:
MChttpConverter()

See Also

MChttpConverter Class
MChttpConverter Members
MChttpConverter Overload


MChttpConverter Constructor (MCrequestType)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpConverter Constructor (MCrequestType)
MChttpConverter Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MChttpConverter(
    MCrequestType requestType
)
Visual Basic
Public Sub New ( _
    requestType As MCrequestType _
)
Visual C++
public:
MChttpConverter(
    MCrequestType^ requestType
)

Parameters

requestType
Type: Mergecomws.Web..::..MCrequestType
Type of WADO request

See Also

MChttpConverter Class
MChttpConverter Members
MChttpConverter Overload


MChttpConverter Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpConverter Methods
MChttpConverter Class See Also Send Feedback

The MChttpConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts an array of rendered DICOM streams into an array of HttpContent objects based on request parameters (Overrides MCbaseConverter..::..Convert(array<Stream>[]()[][], String, String%).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MChttpConverter Class


Convert Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpConverter..::..Convert Method
MChttpConverter Class See Also Send Feedback
Converts an array of rendered DICOM streams into an array of HttpContent objects based on request parameters

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override HttpContent[] Convert(
    Stream[] streams,
    string xmlRequestParameters,
    ref string xmlWadoResponse
)
Visual Basic
Public Overrides Function Convert ( _
    streams As Stream(), _
    xmlRequestParameters As String, _
    ByRef xmlWadoResponse As String _
) As HttpContent()
Visual C++
public:
virtual array<HttpContent^>^ Convert(
    array<Stream^>^ streams,
    String^ xmlRequestParameters,
    String^% xmlWadoResponse
) override

Parameters

streams
Type: array<System.IO..::..Stream>[]()[][]
DICOM streams
xmlRequestParameters
Type: System..::..String
XML string of MCparameter parameters used for WADO request
xmlWadoResponse
Type: System..::..String%
WADO response from DICOM service encoded as XML String

Return Value

An array of HttpContent objects

Implements

IMChttpConverter..::..Convert(array<Stream>[]()[][], String, String%)

See Also

MChttpConverter Class
MChttpConverter Members


MChttpConverter Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpConverter Properties
MChttpConverter Class See Also Send Feedback

The MChttpConverter type exposes the following members.

Properties

 | Name | Description
Public property | RequestParameters | List of MCparameter parameters used for WADO request (Inherited from MCbaseConverter.)
Public property | RequestType | MCrequestType type of WADO request (Inherited from MCbaseConverter.)
Public property | ResponseParameters | List of MCparameter parameters returned from DICOM service (Inherited from MCbaseConverter.)
Public property | Streams | An array of Stream of rendered DICOM stream data (Inherited from MCbaseConverter.)
Public property | XmlOptions | MCxmlOptions options used in writeToXMLNative(TextWriter, MCxmlOptions) method of MCabstractMessage object (Inherited from MCbaseConverter.)

See Also

MChttpConverter Class


MChttpResponder Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpResponder Class
Members See Also Send Feedback
Constructs HttpResponseMessage object from an array of HttpContent objects

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MChttpResponder : MCbaseResponder
Visual Basic
Public Class MChttpResponder _
    Inherits MCbaseResponder
Visual C++
public ref class MChttpResponder : public MCbaseResponder

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCbaseResponder
Mergecomws.Dicom..::..MChttpResponder

See Also

MChttpResponder Members


MChttpResponder Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpResponder Members
MChttpResponder Class Constructors Methods Properties See Also Send Feedback

The MChttpResponder type exposes the following members.

Constructors

 | Name | Description
Public method | MChttpResponder()()()() | Class constructor
Public method | MChttpResponder(MCrequestType) | Class constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Response | Converts an array of HttpContent objects into HttpResponseMessage object (Overrides MCbaseResponder..::..Response(array<HttpContent>[]()[][], String, String%).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Contents | List of HttpContent objects (Inherited from MCbaseResponder.)
Public property | RequestParameters | List of MCparameter parameters used for WADO request (Inherited from MCbaseResponder.)
Public property | RequestType | MCrequestType type of WADO request (Inherited from MCbaseResponder.)
Public property | ResponseParameters | List of MCparameter parameters returned from DICOM service (Inherited from MCbaseResponder.)

See Also

MChttpResponder Class


MChttpResponder Constructor

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpResponder Constructor
MChttpResponder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MChttpResponder()()()() | Class constructor
Public method | MChttpResponder(MCrequestType) | Class constructor

See Also

MChttpResponder Class
MChttpResponder Members


MChttpResponder Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpResponder Constructor
MChttpResponder Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MChttpResponder()
Visual Basic
Public Sub New
Visual C++
public:
MChttpResponder()

See Also

MChttpResponder Class
MChttpResponder Members
MChttpResponder Overload


MChttpResponder Constructor (MCrequestType)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpResponder Constructor (MCrequestType)
MChttpResponder Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MChttpResponder(
    MCrequestType requestType
)
Visual Basic
Public Sub New ( _
    requestType As MCrequestType _
)
Visual C++
public:
MChttpResponder(
    MCrequestType^ requestType
)

Parameters

requestType
Type: Mergecomws.Web..::..MCrequestType
Type of WADO request

See Also

MChttpResponder Class
MChttpResponder Members
MChttpResponder Overload


MChttpResponder Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpResponder Methods
MChttpResponder Class See Also Send Feedback

The MChttpResponder type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Response | Converts an array of HttpContent objects into HttpResponseMessage object (Overrides MCbaseResponder..::..Response(array<HttpContent>[]()[][], String, String%).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MChttpResponder Class


Response Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpResponder..::..Response Method
MChttpResponder Class See Also Send Feedback
Converts an array of HttpContent objects into HttpResponseMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override HttpResponseMessage Response(
    HttpContent[] contents,
    string xmlRequestParameters,
    ref string xmlWadoResponse
)
Visual Basic
Public Overrides Function Response ( _
    contents As HttpContent(), _
    xmlRequestParameters As String, _
    ByRef xmlWadoResponse As String _
) As HttpResponseMessage
Visual C++
public:
virtual HttpResponseMessage^ Response(
    array<HttpContent^>^ contents,
    String^ xmlRequestParameters,
    String^% xmlWadoResponse
) override

Parameters

contents
Type: array<HttpContent>[]()[][]
An array of HttpContent objects
xmlRequestParameters
Type: System..::..String
XML string of MCparameter parameters used for WADO request
xmlWadoResponse
Type: System..::..String%
WADO response from DICOM service encoded as XML String

Return Value

HttpResponseMessage object

Implements

IMChttpResponder..::..Response(array<HttpContent>[]()[][], String, String%)

See Also

MChttpResponder Class
MChttpResponder Members


MChttpResponder Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpResponder Properties
MChttpResponder Class See Also Send Feedback

The MChttpResponder type exposes the following members.

Properties

 | Name | Description
Public property | Contents | List of HttpContent objects (Inherited from MCbaseResponder.)
Public property | RequestParameters | List of MCparameter parameters used for WADO request (Inherited from MCbaseResponder.)
Public property | RequestType | MCrequestType type of WADO request (Inherited from MCbaseResponder.)
Public property | ResponseParameters | List of MCparameter parameters returned from DICOM service (Inherited from MCbaseResponder.)

See Also

MChttpResponder Class


MCmediaType Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType Class
Members See Also Send Feedback
Describes Media-Types used in Http protocol as defined in http://www.iana.org/assignments/media-types/media-types.xhtml

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCmediaType
Visual Basic
Public Class MCmediaType
Visual C++
public ref class MCmediaType

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCmediaType

See Also

MCmediaType Members


MCmediaType Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType Members
MCmediaType Class Methods Fields Properties See Also Send Feedback

The MCmediaType type exposes the following members.

Methods

 | Name | Description
 | CreateInstance(MCmediaType) | Creates aMCmediaType instance of given Media type
 | CreateInstance(MCmediaType, MCtransferSyntaxList) | Creates aMCmediaType instance of given Media type with given MCtransferSyntaxList
Public method | Equals(Object) | Checks if MCmediaType object is equal to Object (Overrides Object..::..Equals(Object).)
Public method | Equals(MCmediaType) | Checks if Media Types are equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode of MCmediaType object (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseCharset | Returns Charset string value of Media-Type object
 | ParseContentType | Parse a Media-Type string and returns a MCmediaType object
 | ParseContentTypes | Parse a string with a list of Media-Types and returns the list of MCmediaType objects
 | ParseParameter | Returns a parameter string value of Media-Type object
 | ParseTransferSyntax | Returns TransferSyntax string value of Media-Type object
Public method | ToString | Returns Media Type string (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
 | All | Returns all available Media Types
 | Any | Media-Type */*
 | Application | Media-Type application/*
 | ApplicationDicom | Media-Type application/dicom
 | ApplicationDicomJson | Media-Type application/dicom+json
 | ApplicationDicomXml | Media-Type application/dicom+xml
 | ApplicationJson | Media-Type application/json
 | ApplicationOctetStream | Media-Type application/octet-stream
 | ApplicationPdf | Media-Type application/pdf
 | ApplicationSoapXml | Media-Type application/soap+xml
 | ApplicationWadlXml | Media-Type application/vnd.sun.wadl+xml​
 | ApplicationXopXml | Media-Type application/xop+xml
 | ApplicationZip | Media-Type application/zip
 | Image | Media-Type image/*
 | ImageDicom | Media-Type image/dicom
 | ImageDicomJp2imageDicomJpx | Media-Type image/dicom+jp2image/dicom+jpx
 | ImageDicomJpeg | Media-Type image/dicom+jpeg
 | ImageDicomJpegLs | Media-Type image/dicom+jpeg-ls
 | ImageDicomJpx | Media-Type image/dicom+jpx
 | ImageDicomRle | Media-Type image/dicom-rle
 | ImageG3Fax | Media-Type image/g3fax
 | ImageGif | Media-Type image/gif
 | ImageJls | Media-Type image/dicom+jpeg-ls
 | ImageJp2 | Media-Type image/jp2
 | ImageJpeg | Media-Type image/jpeg
 | ImageJph | Media-Type image/jphc
 | ImageJphc | Media-Type image/jphc
 | ImageJpm | Media-Type image/jpm
 | ImageJpx | Media-Type image/jpx
 | ImagePng | Media-Type image/png
 | MultipartRelated | Media-Type multipart/related
Public field | Parameters | Contains a collection of parameters for given MCmediaType instance
 | Text | Media-Type text/*
 | TextHtml | Media-Type text/html
 | TextPlain | Media-Type text/plain
 | TextRtf | Media-Type text/rtf
 | TextXlatex | Media-Type text/x-latex
 | TextXml | Media-Type text/xml
 | Unknown | Media-Type unknown
 | Video | Media-Type video/*
 | VideoH265 | Media-Type video/H265
 | VideoMp4 | Media-Type video/mp4
 | VideoMpeg | Media-Type video/mpeg

Properties

 | Name | Description
Public property | Name | Media Type name
 | Names | Returns all available Media Type names
Public property | TransferSyntaxList | List of MCtransferSyntax supported by Media Type, might be empty

See Also

MCmediaType Class


MCmediaType Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType Fields
MCmediaType Class See Also Send Feedback

The MCmediaType type exposes the following members.

Fields

 | Name | Description
 | All | Returns all available Media Types
 | Any | Media-Type */*
 | Application | Media-Type application/*
 | ApplicationDicom | Media-Type application/dicom
 | ApplicationDicomJson | Media-Type application/dicom+json
 | ApplicationDicomXml | Media-Type application/dicom+xml
 | ApplicationJson | Media-Type application/json
 | ApplicationOctetStream | Media-Type application/octet-stream
 | ApplicationPdf | Media-Type application/pdf
 | ApplicationSoapXml | Media-Type application/soap+xml
 | ApplicationWadlXml | Media-Type application/vnd.sun.wadl+xml​
 | ApplicationXopXml | Media-Type application/xop+xml
 | ApplicationZip | Media-Type application/zip
 | Image | Media-Type image/*
 | ImageDicom | Media-Type image/dicom
 | ImageDicomJp2imageDicomJpx | Media-Type image/dicom+jp2image/dicom+jpx
 | ImageDicomJpeg | Media-Type image/dicom+jpeg
 | ImageDicomJpegLs | Media-Type image/dicom+jpeg-ls
 | ImageDicomJpx | Media-Type image/dicom+jpx
 | ImageDicomRle | Media-Type image/dicom-rle
 | ImageG3Fax | Media-Type image/g3fax
 | ImageGif | Media-Type image/gif
 | ImageJls | Media-Type image/dicom+jpeg-ls
 | ImageJp2 | Media-Type image/jp2
 | ImageJpeg | Media-Type image/jpeg
 | ImageJph | Media-Type image/jphc
 | ImageJphc | Media-Type image/jphc
 | ImageJpm | Media-Type image/jpm
 | ImageJpx | Media-Type image/jpx
 | ImagePng | Media-Type image/png
 | MultipartRelated | Media-Type multipart/related
Public field | Parameters | Contains a collection of parameters for given MCmediaType instance
 | Text | Media-Type text/*
 | TextHtml | Media-Type text/html
 | TextPlain | Media-Type text/plain
 | TextRtf | Media-Type text/rtf
 | TextXlatex | Media-Type text/x-latex
 | TextXml | Media-Type text/xml
 | Unknown | Media-Type unknown
 | Video | Media-Type video/*
 | VideoH265 | Media-Type video/H265
 | VideoMp4 | Media-Type video/mp4
 | VideoMpeg | Media-Type video/mpeg

See Also

MCmediaType Class


All Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..All Field
MCmediaType Class See Also Send Feedback
Returns all available Media Types

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IEnumerable<MCmediaType> All
Visual Basic
Public Shared All As IEnumerable(Of MCmediaType)
Visual C++
public:
static IEnumerable<MCmediaType^>^ All

See Also

MCmediaType Class
MCmediaType Members


Any Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..Any Field
MCmediaType Class See Also Send Feedback
Media-Type */*

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType Any
Visual Basic
Public Shared Any As MCmediaType
Visual C++
public:
static MCmediaType^ Any

See Also

MCmediaType Class
MCmediaType Members


Application Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..Application Field
MCmediaType Class See Also Send Feedback
Media-Type application/*

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType Application
Visual Basic
Public Shared Application As MCmediaType
Visual C++
public:
static MCmediaType^ Application

See Also

MCmediaType Class
MCmediaType Members


ApplicationDicom Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ApplicationDicom Field
MCmediaType Class See Also Send Feedback
Media-Type application/dicom

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ApplicationDicom
Visual Basic
Public Shared ApplicationDicom As MCmediaType
Visual C++
public:
static MCmediaType^ ApplicationDicom

See Also

MCmediaType Class
MCmediaType Members


ApplicationDicomJson Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ApplicationDicomJson Field
MCmediaType Class See Also Send Feedback
Media-Type application/dicom+json

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ApplicationDicomJson
Visual Basic
Public Shared ApplicationDicomJson As MCmediaType
Visual C++
public:
static MCmediaType^ ApplicationDicomJson

See Also

MCmediaType Class
MCmediaType Members


ApplicationDicomXml Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ApplicationDicomXml Field
MCmediaType Class See Also Send Feedback
Media-Type application/dicom+xml

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ApplicationDicomXml
Visual Basic
Public Shared ApplicationDicomXml As MCmediaType
Visual C++
public:
static MCmediaType^ ApplicationDicomXml

See Also

MCmediaType Class
MCmediaType Members


ApplicationJson Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ApplicationJson Field
MCmediaType Class See Also Send Feedback
Media-Type application/json

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ApplicationJson
Visual Basic
Public Shared ApplicationJson As MCmediaType
Visual C++
public:
static MCmediaType^ ApplicationJson

See Also

MCmediaType Class
MCmediaType Members


ApplicationOctetStream Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ApplicationOctetStream Field
MCmediaType Class See Also Send Feedback
Media-Type application/octet-stream

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ApplicationOctetStream
Visual Basic
Public Shared ApplicationOctetStream As MCmediaType
Visual C++
public:
static MCmediaType^ ApplicationOctetStream

See Also

MCmediaType Class
MCmediaType Members


ApplicationPdf Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ApplicationPdf Field
MCmediaType Class See Also Send Feedback
Media-Type application/pdf

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ApplicationPdf
Visual Basic
Public Shared ApplicationPdf As MCmediaType
Visual C++
public:
static MCmediaType^ ApplicationPdf

See Also

MCmediaType Class
MCmediaType Members


ApplicationSoapXml Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ApplicationSoapXml Field
MCmediaType Class See Also Send Feedback
Media-Type application/soap+xml

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ApplicationSoapXml
Visual Basic
Public Shared ApplicationSoapXml As MCmediaType
Visual C++
public:
static MCmediaType^ ApplicationSoapXml

See Also

MCmediaType Class
MCmediaType Members


ApplicationWadlXml Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ApplicationWadlXml Field
MCmediaType Class See Also Send Feedback
Media-Type application/vnd.sun.wadl+xml​

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ApplicationWadlXml
Visual Basic
Public Shared ApplicationWadlXml As MCmediaType
Visual C++
public:
static MCmediaType^ ApplicationWadlXml

See Also

MCmediaType Class
MCmediaType Members


ApplicationXopXml Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ApplicationXopXml Field
MCmediaType Class See Also Send Feedback
Media-Type application/xop+xml

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ApplicationXopXml
Visual Basic
Public Shared ApplicationXopXml As MCmediaType
Visual C++
public:
static MCmediaType^ ApplicationXopXml

See Also

MCmediaType Class
MCmediaType Members


ApplicationZip Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ApplicationZip Field
MCmediaType Class See Also Send Feedback
Media-Type application/zip

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ApplicationZip
Visual Basic
Public Shared ApplicationZip As MCmediaType
Visual C++
public:
static MCmediaType^ ApplicationZip

See Also

MCmediaType Class
MCmediaType Members


Image Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..Image Field
MCmediaType Class See Also Send Feedback
Media-Type image/*

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType Image
Visual Basic
Public Shared Image As MCmediaType
Visual C++
public:
static MCmediaType^ Image

See Also

MCmediaType Class
MCmediaType Members


ImageDicom Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImageDicom Field
MCmediaType Class See Also Send Feedback
Media-Type image/dicom

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImageDicom
Visual Basic
Public Shared ImageDicom As MCmediaType
Visual C++
public:
static MCmediaType^ ImageDicom

See Also

MCmediaType Class
MCmediaType Members


ImageDicomJp2imageDicomJpx Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImageDicomJp2imageDicomJpx Field
MCmediaType Class See Also Send Feedback
Media-Type image/dicom+jp2image/dicom+jpx

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImageDicomJp2imageDicomJpx
Visual Basic
Public Shared ImageDicomJp2imageDicomJpx As MCmediaType
Visual C++
public:
static MCmediaType^ ImageDicomJp2imageDicomJpx

See Also

MCmediaType Class
MCmediaType Members


ImageDicomJpeg Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImageDicomJpeg Field
MCmediaType Class See Also Send Feedback
Media-Type image/dicom+jpeg

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImageDicomJpeg
Visual Basic
Public Shared ImageDicomJpeg As MCmediaType
Visual C++
public:
static MCmediaType^ ImageDicomJpeg

See Also

MCmediaType Class
MCmediaType Members


ImageDicomJpegLs Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImageDicomJpegLs Field
MCmediaType Class See Also Send Feedback
Media-Type image/dicom+jpeg-ls

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImageDicomJpegLs
Visual Basic
Public Shared ImageDicomJpegLs As MCmediaType
Visual C++
public:
static MCmediaType^ ImageDicomJpegLs

See Also

MCmediaType Class
MCmediaType Members


ImageDicomJpx Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImageDicomJpx Field
MCmediaType Class See Also Send Feedback
Media-Type image/dicom+jpx

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImageDicomJpx
Visual Basic
Public Shared ImageDicomJpx As MCmediaType
Visual C++
public:
static MCmediaType^ ImageDicomJpx

See Also

MCmediaType Class
MCmediaType Members


ImageDicomRle Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImageDicomRle Field
MCmediaType Class See Also Send Feedback
Media-Type image/dicom-rle

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImageDicomRle
Visual Basic
Public Shared ImageDicomRle As MCmediaType
Visual C++
public:
static MCmediaType^ ImageDicomRle

See Also

MCmediaType Class
MCmediaType Members


ImageG3Fax Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImageG3Fax Field
MCmediaType Class See Also Send Feedback
Media-Type image/g3fax

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImageG3Fax
Visual Basic
Public Shared ImageG3Fax As MCmediaType
Visual C++
public:
static MCmediaType^ ImageG3Fax

See Also

MCmediaType Class
MCmediaType Members


ImageGif Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImageGif Field
MCmediaType Class See Also Send Feedback
Media-Type image/gif

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImageGif
Visual Basic
Public Shared ImageGif As MCmediaType
Visual C++
public:
static MCmediaType^ ImageGif

See Also

MCmediaType Class
MCmediaType Members


ImageJls Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImageJls Field
MCmediaType Class See Also Send Feedback
Media-Type image/dicom+jpeg-ls

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImageJls
Visual Basic
Public Shared ImageJls As MCmediaType
Visual C++
public:
static MCmediaType^ ImageJls

See Also

MCmediaType Class
MCmediaType Members


ImageJp2 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImageJp2 Field
MCmediaType Class See Also Send Feedback
Media-Type image/jp2

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImageJp2
Visual Basic
Public Shared ImageJp2 As MCmediaType
Visual C++
public:
static MCmediaType^ ImageJp2

See Also

MCmediaType Class
MCmediaType Members


ImageJpeg Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImageJpeg Field
MCmediaType Class See Also Send Feedback
Media-Type image/jpeg

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImageJpeg
Visual Basic
Public Shared ImageJpeg As MCmediaType
Visual C++
public:
static MCmediaType^ ImageJpeg

See Also

MCmediaType Class
MCmediaType Members


ImageJph Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImageJph Field
MCmediaType Class See Also Send Feedback
Media-Type image/jphc

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImageJph
Visual Basic
Public Shared ImageJph As MCmediaType
Visual C++
public:
static MCmediaType^ ImageJph

See Also

MCmediaType Class
MCmediaType Members


ImageJphc Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImageJphc Field
MCmediaType Class See Also Send Feedback
Media-Type image/jphc

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImageJphc
Visual Basic
Public Shared ImageJphc As MCmediaType
Visual C++
public:
static MCmediaType^ ImageJphc

See Also

MCmediaType Class
MCmediaType Members


ImageJpm Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImageJpm Field
MCmediaType Class See Also Send Feedback
Media-Type image/jpm

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImageJpm
Visual Basic
Public Shared ImageJpm As MCmediaType
Visual C++
public:
static MCmediaType^ ImageJpm

See Also

MCmediaType Class
MCmediaType Members


ImageJpx Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImageJpx Field
MCmediaType Class See Also Send Feedback
Media-Type image/jpx

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImageJpx
Visual Basic
Public Shared ImageJpx As MCmediaType
Visual C++
public:
static MCmediaType^ ImageJpx

See Also

MCmediaType Class
MCmediaType Members


ImagePng Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ImagePng Field
MCmediaType Class See Also Send Feedback
Media-Type image/png

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ImagePng
Visual Basic
Public Shared ImagePng As MCmediaType
Visual C++
public:
static MCmediaType^ ImagePng

See Also

MCmediaType Class
MCmediaType Members


MultipartRelated Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..MultipartRelated Field
MCmediaType Class See Also Send Feedback
Media-Type multipart/related

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType MultipartRelated
Visual Basic
Public Shared MultipartRelated As MCmediaType
Visual C++
public:
static MCmediaType^ MultipartRelated

See Also

MCmediaType Class
MCmediaType Members


Parameters Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..Parameters Field
MCmediaType Class See Also Send Feedback
Contains a collection of parameters for given MCmediaType instance

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public Dictionary<string, string> Parameters
Visual Basic
Public Parameters As Dictionary(Of String, String)
Visual C++
public:
Dictionary<String^, String^>^ Parameters

See Also

MCmediaType Class
MCmediaType Members


Text Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..Text Field
MCmediaType Class See Also Send Feedback
Media-Type text/*

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType Text
Visual Basic
Public Shared Text As MCmediaType
Visual C++
public:
static MCmediaType^ Text

See Also

MCmediaType Class
MCmediaType Members


TextHtml Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..TextHtml Field
MCmediaType Class See Also Send Feedback
Media-Type text/html

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType TextHtml
Visual Basic
Public Shared TextHtml As MCmediaType
Visual C++
public:
static MCmediaType^ TextHtml

See Also

MCmediaType Class
MCmediaType Members


TextPlain Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..TextPlain Field
MCmediaType Class See Also Send Feedback
Media-Type text/plain

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType TextPlain
Visual Basic
Public Shared TextPlain As MCmediaType
Visual C++
public:
static MCmediaType^ TextPlain

See Also

MCmediaType Class
MCmediaType Members


TextRtf Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..TextRtf Field
MCmediaType Class See Also Send Feedback
Media-Type text/rtf

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType TextRtf
Visual Basic
Public Shared TextRtf As MCmediaType
Visual C++
public:
static MCmediaType^ TextRtf

See Also

MCmediaType Class
MCmediaType Members


TextXlatex Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..TextXlatex Field
MCmediaType Class See Also Send Feedback
Media-Type text/x-latex

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType TextXlatex
Visual Basic
Public Shared TextXlatex As MCmediaType
Visual C++
public:
static MCmediaType^ TextXlatex

See Also

MCmediaType Class
MCmediaType Members


TextXml Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..TextXml Field
MCmediaType Class See Also Send Feedback
Media-Type text/xml

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType TextXml
Visual Basic
Public Shared TextXml As MCmediaType
Visual C++
public:
static MCmediaType^ TextXml

See Also

MCmediaType Class
MCmediaType Members


Unknown Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..Unknown Field
MCmediaType Class See Also Send Feedback
Media-Type unknown

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType Unknown
Visual Basic
Public Shared Unknown As MCmediaType
Visual C++
public:
static MCmediaType^ Unknown

See Also

MCmediaType Class
MCmediaType Members


Video Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..Video Field
MCmediaType Class See Also Send Feedback
Media-Type video/*

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType Video
Visual Basic
Public Shared Video As MCmediaType
Visual C++
public:
static MCmediaType^ Video

See Also

MCmediaType Class
MCmediaType Members


VideoH265 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..VideoH265 Field
MCmediaType Class See Also Send Feedback
Media-Type video/H265

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType VideoH265
Visual Basic
Public Shared VideoH265 As MCmediaType
Visual C++
public:
static MCmediaType^ VideoH265

See Also

MCmediaType Class
MCmediaType Members


VideoMp4 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..VideoMp4 Field
MCmediaType Class See Also Send Feedback
Media-Type video/mp4

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType VideoMp4
Visual Basic
Public Shared VideoMp4 As MCmediaType
Visual C++
public:
static MCmediaType^ VideoMp4

See Also

MCmediaType Class
MCmediaType Members


VideoMpeg Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..VideoMpeg Field
MCmediaType Class See Also Send Feedback
Media-Type video/mpeg

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType VideoMpeg
Visual Basic
Public Shared VideoMpeg As MCmediaType
Visual C++
public:
static MCmediaType^ VideoMpeg

See Also

MCmediaType Class
MCmediaType Members


MCmediaType Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType Methods
MCmediaType Class See Also Send Feedback

The MCmediaType type exposes the following members.

Methods

 | Name | Description
 | CreateInstance(MCmediaType) | Creates aMCmediaType instance of given Media type
 | CreateInstance(MCmediaType, MCtransferSyntaxList) | Creates aMCmediaType instance of given Media type with given MCtransferSyntaxList
Public method | Equals(Object) | Checks if MCmediaType object is equal to Object (Overrides Object..::..Equals(Object).)
Public method | Equals(MCmediaType) | Checks if Media Types are equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode of MCmediaType object (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseCharset | Returns Charset string value of Media-Type object
 | ParseContentType | Parse a Media-Type string and returns a MCmediaType object
 | ParseContentTypes | Parse a string with a list of Media-Types and returns the list of MCmediaType objects
 | ParseParameter | Returns a parameter string value of Media-Type object
 | ParseTransferSyntax | Returns TransferSyntax string value of Media-Type object
Public method | ToString | Returns Media Type string (Overrides Object..::..ToString()()()().)

See Also

MCmediaType Class


CreateInstance Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..CreateInstance Method
MCmediaType Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(MCmediaType) | Creates aMCmediaType instance of given Media type
CreateInstance(MCmediaType, MCtransferSyntaxList) | Creates aMCmediaType instance of given Media type with given MCtransferSyntaxList

See Also

MCmediaType Class
MCmediaType Members


CreateInstance Method (MCmediaType)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..CreateInstance Method (MCmediaType)
MCmediaType Class See Also Send Feedback
Creates aMCmediaType instance of given Media type

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType CreateInstance(
    MCmediaType type
)
Visual Basic
Public Shared Function CreateInstance ( _
    type As MCmediaType _
) As MCmediaType
Visual C++
public:
static MCmediaType^ CreateInstance(
    MCmediaType^ type
)

Parameters

type
Type: Mergecomws.Dicom..::..MCmediaType
MCmediaType object

Return Value

MCmediaType object

See Also

MCmediaType Class
MCmediaType Members
CreateInstance Overload


CreateInstance Method (MCmediaType, MCtransferSyntaxList)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..CreateInstance Method (MCmediaType, MCtransferSyntaxList)
MCmediaType Class See Also Send Feedback
Creates aMCmediaType instance of given Media type with given MCtransferSyntaxList

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType CreateInstance(
    MCmediaType type,
    MCtransferSyntaxList tsList
)
Visual Basic
Public Shared Function CreateInstance ( _
    type As MCmediaType, _
    tsList As MCtransferSyntaxList _
) As MCmediaType
Visual C++
public:
static MCmediaType^ CreateInstance(
    MCmediaType^ type,
    MCtransferSyntaxList^ tsList
)

Parameters

type
Type: Mergecomws.Dicom..::..MCmediaType
MCmediaType object
tsList
Type: MCtransferSyntaxList
MCtransferSyntaxList object

Return Value

MCmediaType object

See Also

MCmediaType Class
MCmediaType Members
CreateInstance Overload


Equals Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..Equals Method
MCmediaType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Checks if MCmediaType object is equal to Object (Overrides Object..::..Equals(Object).)
Public method | Equals(MCmediaType) | Checks if Media Types are equal

See Also

MCmediaType Class
MCmediaType Members


Equals Method (Object)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..Equals Method (Object)
MCmediaType Class See Also Send Feedback
Checks if MCmediaType object is equal to Object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare with the current object.

Return Value

Returns True if objects are equal

See Also

MCmediaType Class
MCmediaType Members
Equals Overload


Equals Method (MCmediaType)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..Equals Method (MCmediaType)
MCmediaType Class See Also Send Feedback
Checks if Media Types are equal

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public bool Equals(
    MCmediaType type
)
Visual Basic
Public Function Equals ( _
    type As MCmediaType _
) As Boolean
Visual C++
public:
bool Equals(
    MCmediaType^ type
)

Parameters

type
Type: Mergecomws.Dicom..::..MCmediaType
MCmediaType object

Return Value

Returns True if Name of both objects are the same

See Also

MCmediaType Class
MCmediaType Members
Equals Overload


GetHashCode Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..GetHashCode Method
MCmediaType Class See Also Send Feedback
Gets the hashcode of MCmediaType object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

Returns a hashcode generated from Name

See Also

MCmediaType Class
MCmediaType Members


ParseCharset Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ParseCharset Method
MCmediaType Class See Also Send Feedback
Returns Charset string value of Media-Type object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static string ParseCharset(
    MCmediaType mt
)
Visual Basic
Public Shared Function ParseCharset ( _
    mt As MCmediaType _
) As String
Visual C++
public:
static String^ ParseCharset(
    MCmediaType^ mt
)

Parameters

mt
Type: Mergecomws.Dicom..::..MCmediaType
MCmediaType object

Return Value

Charset string

Remarks

Examples: image/dicom+jpx; charset=US-ASCII

See Also

MCmediaType Class
MCmediaType Members


ParseContentType Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ParseContentType Method
MCmediaType Class See Also Send Feedback
Parse a Media-Type string and returns a MCmediaType object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCmediaType ParseContentType(
    string ct
)
Visual Basic
Public Shared Function ParseContentType ( _
    ct As String _
) As MCmediaType
Visual C++
public:
static MCmediaType^ ParseContentType(
    String^ ct
)

Parameters

ct
Type: System..::..String
Media-Type string

Return Value

MCmediaType object with parameters

Remarks

Examples: multipart/related; type=application/dicom; transfer-syntax=1.2.840.10008.1.2.4.92; charset=US-ASCII; q=0.4

See Also

MCmediaType Class
MCmediaType Members


ParseContentTypes Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ParseContentTypes Method
MCmediaType Class See Also Send Feedback
Parse a string with a list of Media-Types and returns the list of MCmediaType objects

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IList<MCmediaType> ParseContentTypes(
    string ct
)
Visual Basic
Public Shared Function ParseContentTypes ( _
    ct As String _
) As IList(Of MCmediaType)
Visual C++
public:
static IList<MCmediaType^>^ ParseContentTypes(
    String^ ct
)

Parameters

ct
Type: System..::..String
Media-Type string

Return Value

List of MCmediaType objects

Remarks

Examples: multipart/related; type=application/dicom; transfer-syntax=1.2.840.10008.1.2.4.92, image/dicom+jpx; transfer-syntax=1.2.840.10008.1.2.4.92; charset=US-ASCII, image/dicom+jpx; transfer-syntax=1.2.840.10008.1.2.4.93, image/dicom+jpeg

See Also

MCmediaType Class
MCmediaType Members


ParseParameter Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ParseParameter Method
MCmediaType Class See Also Send Feedback
Returns a parameter string value of Media-Type object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static string ParseParameter(
    MCmediaType mt,
    string key
)
Visual Basic
Public Shared Function ParseParameter ( _
    mt As MCmediaType, _
    key As String _
) As String
Visual C++
public:
static String^ ParseParameter(
    MCmediaType^ mt,
    String^ key
)

Parameters

mt
Type: Mergecomws.Dicom..::..MCmediaType
MCmediaType object
key
Type: System..::..String
Parameter name

Return Value

A parameter string value

Remarks

Examples: image/dicom+jpx; q=1.0; level=2

See Also

MCmediaType Class
MCmediaType Members


ParseTransferSyntax Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ParseTransferSyntax Method
MCmediaType Class See Also Send Feedback
Returns TransferSyntax string value of Media-Type object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static string ParseTransferSyntax(
    MCmediaType mt
)
Visual Basic
Public Shared Function ParseTransferSyntax ( _
    mt As MCmediaType _
) As String
Visual C++
public:
static String^ ParseTransferSyntax(
    MCmediaType^ mt
)

Parameters

mt
Type: Mergecomws.Dicom..::..MCmediaType
MCmediaType object

Return Value

TransferSyntax string

Remarks

Examples: multipart/related; type=application/dicom; transfer-syntax=1.2.840.10008.1.2.4.92

See Also

MCmediaType Class
MCmediaType Members


ToString Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..ToString Method
MCmediaType Class See Also Send Feedback
Returns Media Type string

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string that represents the current object.

See Also

MCmediaType Class
MCmediaType Members


MCmediaType Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType Properties
MCmediaType Class See Also Send Feedback

The MCmediaType type exposes the following members.

Properties

 | Name | Description
Public property | Name | Media Type name
 | Names | Returns all available Media Type names
Public property | TransferSyntaxList | List of MCtransferSyntax supported by Media Type, might be empty

See Also

MCmediaType Class


Name Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..Name Property
MCmediaType Class See Also Send Feedback
Media Type name

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set
Visual C++
public:
property String^ Name {
    String^ get ();
    private: void set (String^ value);
}

See Also

MCmediaType Class
MCmediaType Members


Names Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..Names Property
MCmediaType Class See Also Send Feedback
Returns all available Media Type names

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IList<string> Names { get; }
Visual Basic
Public Shared ReadOnly Property Names As IList(Of String)
    Get
Visual C++
public:
static property IList<String^>^ Names {
    IList<String^>^ get ();
}

See Also

MCmediaType Class
MCmediaType Members


TransferSyntaxList Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCmediaType..::..TransferSyntaxList Property
MCmediaType Class See Also Send Feedback
List of MCtransferSyntax supported by Media Type, might be empty

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCtransferSyntaxList TransferSyntaxList { get; private set; }
Visual Basic
Public Property TransferSyntaxList As MCtransferSyntaxList
    Get
    Private Set
Visual C++
public:
property MCtransferSyntaxList^ TransferSyntaxList {
    MCtransferSyntaxList^ get ();
    private: void set (MCtransferSyntaxList^ value);
}

See Also

MCmediaType Class
MCmediaType Members


MCqidoRequest Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoRequest Class
Members See Also Send Feedback
Converts and encapsulates HttpRequestMessage data from QIDO-RS request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCqidoRequest : MCdicomRequest
Visual Basic
Public Class MCqidoRequest _
    Inherits MCdicomRequest
Visual C++
public ref class MCqidoRequest : public MCdicomRequest

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCdicomRequest
Mergecomws.Dicom..::..MCqidoRequest

See Also

MCqidoRequest Members


MCqidoRequest Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoRequest Members
MCqidoRequest Class Methods Fields Properties See Also Send Feedback

The MCqidoRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Overrides MCdicomRequest..::..CompleteRequest(MCdimseMessage).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves QIDO-RS MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Overrides MCdicomRequest..::..GetLevel()()()().)
Public method | GetMessages | Generates a list of MCabstractMessage based on MCparameter data (Inherited from MCdicomRequest.)
Public method | GetModel | Gets MCparameter list of QIDO-RS model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Overrides MCdicomRequest..::..GetRoot()()()().)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Inherited from MCdicomRequest.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM request (Inherited from MCdicomRequest.)

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCqidoRequest Class


MCqidoRequest Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoRequest Fields
MCqidoRequest Class See Also Send Feedback

The MCqidoRequest type exposes the following members.

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

See Also

MCqidoRequest Class


MCqidoRequest Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoRequest Methods
MCqidoRequest Class See Also Send Feedback

The MCqidoRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Overrides MCdicomRequest..::..CompleteRequest(MCdimseMessage).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves QIDO-RS MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Overrides MCdicomRequest..::..GetLevel()()()().)
Public method | GetMessages | Generates a list of MCabstractMessage based on MCparameter data (Inherited from MCdicomRequest.)
Public method | GetModel | Gets MCparameter list of QIDO-RS model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Overrides MCdicomRequest..::..GetRoot()()()().)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Inherited from MCdicomRequest.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM request (Inherited from MCdicomRequest.)

See Also

MCqidoRequest Class


CompleteRequest Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoRequest..::..CompleteRequest Method
MCqidoRequest Class See Also Send Feedback
Updates and completes MCdimseMessage object from DICOM request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override MCdimseMessage CompleteRequest(
    MCdimseMessage request
)
Visual Basic
Protected Overrides Function CompleteRequest ( _
    request As MCdimseMessage _
) As MCdimseMessage
Visual C++
protected:
virtual MCdimseMessage^ CompleteRequest(
    MCdimseMessage^ request
) override

Parameters

request
Type: MCdimseMessage
MCdimseMessage object

Return Value

MCdimseMessage object

See Also

MCqidoRequest Class
MCqidoRequest Members


GetActionType Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoRequest..::..GetActionType Method
MCqidoRequest Class See Also Send Feedback
Retrieves QIDO-RS MCactionType from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetActionType()
Visual Basic
Protected Overrides Sub GetActionType
Visual C++
protected:
virtual void GetActionType() override

See Also

MCqidoRequest Class
MCqidoRequest Members


GetHeaders Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoRequest..::..GetHeaders Method
MCqidoRequest Class See Also Send Feedback
Retrieves Http Header data from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetHeaders()
Visual Basic
Protected Overrides Sub GetHeaders
Visual C++
protected:
virtual void GetHeaders() override

See Also

MCqidoRequest Class
MCqidoRequest Members


GetLevel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoRequest..::..GetLevel Method
MCqidoRequest Class See Also Send Feedback
Gets MCdicomLevel value of DICOM request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetLevel()
Visual Basic
Protected Overrides Sub GetLevel
Visual C++
protected:
virtual void GetLevel() override

See Also

MCqidoRequest Class
MCqidoRequest Members


GetModel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoRequest..::..GetModel Method
MCqidoRequest Class See Also Send Feedback
Gets MCparameter list of QIDO-RS model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override IList<MCparameter> GetModel()
Visual Basic
Public Overrides Function GetModel As IList(Of MCparameter)
Visual C++
public:
virtual IList<MCparameter^>^ GetModel() override

Return Value

MCparameter list

See Also

MCqidoRequest Class
MCqidoRequest Members


GetQueries Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoRequest..::..GetQueries Method
MCqidoRequest Class See Also Send Feedback
Retrieves Http Query from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetQueries()
Visual Basic
Protected Overrides Sub GetQueries
Visual C++
protected:
virtual void GetQueries() override

See Also

MCqidoRequest Class
MCqidoRequest Members


GetRoot Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoRequest..::..GetRoot Method
MCqidoRequest Class See Also Send Feedback
Gets MCdicomRoot value of DICOM request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetRoot()
Visual Basic
Protected Overrides Sub GetRoot
Visual C++
protected:
virtual void GetRoot() override

See Also

MCqidoRequest Class
MCqidoRequest Members


supportedMediaTypes Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoRequest..::..supportedMediaTypes Method
MCqidoRequest Class See Also Send Feedback
Gets the list of supported MCmediaType of the current request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override IEnumerable<MCmediaType> supportedMediaTypes()
Visual Basic
Protected Overrides Function supportedMediaTypes As IEnumerable(Of MCmediaType)
Visual C++
protected:
virtual IEnumerable<MCmediaType^>^ supportedMediaTypes() override

Return Value

List of MCmediaType objects

See Also

MCqidoRequest Class
MCqidoRequest Members


MCqidoRequest Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoRequest Properties
MCqidoRequest Class See Also Send Feedback

The MCqidoRequest type exposes the following members.

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCqidoRequest Class


SupportedMediaTypes Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoRequest..::..SupportedMediaTypes Property
MCqidoRequest Class See Also Send Feedback
Gets and sets the list of supported MCmediaType for specific MCrequestType request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IEnumerable<MCmediaType> SupportedMediaTypes { get; protected set; }
Visual Basic
Public Shared Property SupportedMediaTypes As IEnumerable(Of MCmediaType)
    Get
    Protected Set
Visual C++
public:
static property IEnumerable<MCmediaType^>^ SupportedMediaTypes {
    IEnumerable<MCmediaType^>^ get ();
    protected: void set (IEnumerable<MCmediaType^>^ value);
}

See Also

MCqidoRequest Class
MCqidoRequest Members


MCrsCapabilitiesDocument Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesDocument Class
Members See Also Send Feedback
MCrsCapabilitiesDocument class encapsulates WADL RS Capabilities document

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCrsCapabilitiesDocument
Visual Basic
Public Class MCrsCapabilitiesDocument
Visual C++
public ref class MCrsCapabilitiesDocument

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCrsCapabilitiesDocument

See Also

MCrsCapabilitiesDocument Members


MCrsCapabilitiesDocument Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesDocument Members
MCrsCapabilitiesDocument Class Constructors Methods See Also Send Feedback

The MCrsCapabilitiesDocument type exposes the following members.

Constructors

 | Name | Description
Public method | MCrsCapabilitiesDocument | MCrsCapabilitiesDocument constructor

Methods

Name Description
CreateInstance
Creates MCrsCapabilitiesDocument object
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasApplicationElement
Is internal WADL Application element null or not?
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ParseDocumentToXml
Converts MCrsCapabilitiesDocument object to WADL
CopyC#
string
ParseXmlToDocument
Parses WADL document encoded as XML
CopyC#
string
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)

See Also

MCrsCapabilitiesDocument Class


MCrsCapabilitiesDocument Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesDocument Constructor
MCrsCapabilitiesDocument Class See Also Send Feedback
MCrsCapabilitiesDocument constructor

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrsCapabilitiesDocument()
Visual Basic
Public Sub New
Visual C++
public:
MCrsCapabilitiesDocument()

See Also

MCrsCapabilitiesDocument Class
MCrsCapabilitiesDocument Members


MCrsCapabilitiesDocument Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesDocument Methods
MCrsCapabilitiesDocument Class See Also Send Feedback

The MCrsCapabilitiesDocument type exposes the following members.

Methods

Name Description
CreateInstance
Creates MCrsCapabilitiesDocument object
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasApplicationElement
Is internal WADL Application element null or not?
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ParseDocumentToXml
Converts MCrsCapabilitiesDocument object to WADL
CopyC#
string
ParseXmlToDocument
Parses WADL document encoded as XML
CopyC#
string
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)

See Also

MCrsCapabilitiesDocument Class


CreateInstance Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesDocument..::..CreateInstance Method
MCrsCapabilitiesDocument Class See Also Send Feedback
Creates MCrsCapabilitiesDocument object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCrsCapabilitiesDocument CreateInstance()
Visual Basic
Public Shared Function CreateInstance As MCrsCapabilitiesDocument
Visual C++
public:
static MCrsCapabilitiesDocument^ CreateInstance()

Return Value

MCrsCapabilitiesDocument object

See Also

MCrsCapabilitiesDocument Class
MCrsCapabilitiesDocument Members


HasApplicationElement Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesDocument..::..HasApplicationElement Method
MCrsCapabilitiesDocument Class See Also Send Feedback
Is internal WADL Application element null or not?

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public bool HasApplicationElement()
Visual Basic
Public Function HasApplicationElement As Boolean
Visual C++
public:
bool HasApplicationElement()

Return Value

CopyC#
true
 if object is non-null,
CopyC#
false
 otherwise

See Also

MCrsCapabilitiesDocument Class
MCrsCapabilitiesDocument Members


ParseDocumentToXml Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesDocument..::..ParseDocumentToXml Method
MCrsCapabilitiesDocument Class See Also Send Feedback
Converts MCrsCapabilitiesDocument object to WADL
CopyC#
string

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string ParseDocumentToXml(
    XmlWriterSettings settings
)
Visual Basic
Public Function ParseDocumentToXml ( _
    settings As XmlWriterSettings _
) As String
Visual C++
public:
String^ ParseDocumentToXml(
    XmlWriterSettings^ settings
)

Parameters

settings
Type: System.Xml..::..XmlWriterSettings
XmlWriterSettings object

Return Value

WADL
CopyC#
string

See Also

MCrsCapabilitiesDocument Class
MCrsCapabilitiesDocument Members


ParseXmlToDocument Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesDocument..::..ParseXmlToDocument Method
MCrsCapabilitiesDocument Class See Also Send Feedback
Parses WADL document encoded as XML
CopyC#
string

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCrsCapabilitiesDocument ParseXmlToDocument(
    string xmlWadlDocument
)
Visual Basic
Public Shared Function ParseXmlToDocument ( _
    xmlWadlDocument As String _
) As MCrsCapabilitiesDocument
Visual C++
public:
static MCrsCapabilitiesDocument^ ParseXmlToDocument(
    String^ xmlWadlDocument
)

Parameters

xmlWadlDocument
Type: System..::..String
WADL document encoded as XML
CopyC#
string

Return Value

MCrsCapabilitiesDocument object

See Also

MCrsCapabilitiesDocument Class
MCrsCapabilitiesDocument Members


MCrsCapabilitiesRequest Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesRequest Class
Members See Also Send Feedback
Converts and encapsulates HttpRequestMessage data from RS Capabilities request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCrsCapabilitiesRequest : MCdicomRequest
Visual Basic
Public Class MCrsCapabilitiesRequest _
    Inherits MCdicomRequest
Visual C++
public ref class MCrsCapabilitiesRequest : public MCdicomRequest

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCdicomRequest
Mergecomws.Dicom..::..MCrsCapabilitiesRequest

See Also

MCrsCapabilitiesRequest Members


MCrsCapabilitiesRequest Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesRequest Members
MCrsCapabilitiesRequest Class Methods Fields Properties See Also Send Feedback

The MCrsCapabilitiesRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Inherited from MCdicomRequest.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves RS RsCapabilities MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Inherited from MCdicomRequest.)
Public method | GetMessages | Generates a list of MCabstractMessage based on MCparameter data (Inherited from MCdicomRequest.)
Public method | GetModel | Gets MCparameter list of RSCAPABILITIES model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Inherited from MCdicomRequest.)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Inherited from MCdicomRequest.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM request (Inherited from MCdicomRequest.)

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCrsCapabilitiesRequest Class


MCrsCapabilitiesRequest Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesRequest Fields
MCrsCapabilitiesRequest Class See Also Send Feedback

The MCrsCapabilitiesRequest type exposes the following members.

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

See Also

MCrsCapabilitiesRequest Class


MCrsCapabilitiesRequest Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesRequest Methods
MCrsCapabilitiesRequest Class See Also Send Feedback

The MCrsCapabilitiesRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Inherited from MCdicomRequest.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves RS RsCapabilities MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Inherited from MCdicomRequest.)
Public method | GetMessages | Generates a list of MCabstractMessage based on MCparameter data (Inherited from MCdicomRequest.)
Public method | GetModel | Gets MCparameter list of RSCAPABILITIES model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Inherited from MCdicomRequest.)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Inherited from MCdicomRequest.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM request (Inherited from MCdicomRequest.)

See Also

MCrsCapabilitiesRequest Class


GetActionType Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesRequest..::..GetActionType Method
MCrsCapabilitiesRequest Class See Also Send Feedback
Retrieves RS RsCapabilities MCactionType from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetActionType()
Visual Basic
Protected Overrides Sub GetActionType
Visual C++
protected:
virtual void GetActionType() override

See Also

MCrsCapabilitiesRequest Class
MCrsCapabilitiesRequest Members


GetHeaders Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesRequest..::..GetHeaders Method
MCrsCapabilitiesRequest Class See Also Send Feedback
Retrieves Http Header data from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetHeaders()
Visual Basic
Protected Overrides Sub GetHeaders
Visual C++
protected:
virtual void GetHeaders() override

See Also

MCrsCapabilitiesRequest Class
MCrsCapabilitiesRequest Members


GetModel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesRequest..::..GetModel Method
MCrsCapabilitiesRequest Class See Also Send Feedback
Gets MCparameter list of RSCAPABILITIES model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override IList<MCparameter> GetModel()
Visual Basic
Public Overrides Function GetModel As IList(Of MCparameter)
Visual C++
public:
virtual IList<MCparameter^>^ GetModel() override

Return Value

MCparameter list

See Also

MCrsCapabilitiesRequest Class
MCrsCapabilitiesRequest Members


GetQueries Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesRequest..::..GetQueries Method
MCrsCapabilitiesRequest Class See Also Send Feedback
Retrieves Http Query from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetQueries()
Visual Basic
Protected Overrides Sub GetQueries
Visual C++
protected:
virtual void GetQueries() override

See Also

MCrsCapabilitiesRequest Class
MCrsCapabilitiesRequest Members


supportedMediaTypes Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesRequest..::..supportedMediaTypes Method
MCrsCapabilitiesRequest Class See Also Send Feedback
Gets the list of supported MCmediaType of the current request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override IEnumerable<MCmediaType> supportedMediaTypes()
Visual Basic
Protected Overrides Function supportedMediaTypes As IEnumerable(Of MCmediaType)
Visual C++
protected:
virtual IEnumerable<MCmediaType^>^ supportedMediaTypes() override

Return Value

List of MCmediaType objects

See Also

MCrsCapabilitiesRequest Class
MCrsCapabilitiesRequest Members


MCrsCapabilitiesRequest Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesRequest Properties
MCrsCapabilitiesRequest Class See Also Send Feedback

The MCrsCapabilitiesRequest type exposes the following members.

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCrsCapabilitiesRequest Class


SupportedMediaTypes Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesRequest..::..SupportedMediaTypes Property
MCrsCapabilitiesRequest Class See Also Send Feedback
Gets and sets the list of supported MCmediaType for specific MCrequestType request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IEnumerable<MCmediaType> SupportedMediaTypes { get; protected set; }
Visual Basic
Public Shared Property SupportedMediaTypes As IEnumerable(Of MCmediaType)
    Get
    Protected Set
Visual C++
public:
static property IEnumerable<MCmediaType^>^ SupportedMediaTypes {
    IEnumerable<MCmediaType^>^ get ();
    protected: void set (IEnumerable<MCmediaType^>^ value);
}

See Also

MCrsCapabilitiesRequest Class
MCrsCapabilitiesRequest Members


MCrsNpiRequest Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiRequest Class
Members See Also Send Feedback
Converts and encapsulates HttpRequestMessage data from RS NPI request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCrsNpiRequest : MCdicomRequest
Visual Basic
Public Class MCrsNpiRequest _
    Inherits MCdicomRequest
Visual C++
public ref class MCrsNpiRequest : public MCdicomRequest

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCdicomRequest
Mergecomws.Dicom..::..MCrsNpiRequest

See Also

MCrsNpiRequest Members


MCrsNpiRequest Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiRequest Members
MCrsNpiRequest Class Methods Fields Properties See Also Send Feedback

The MCrsNpiRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Inherited from MCdicomRequest.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves RS NPI MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Inherited from MCdicomRequest.)
Public method | GetMessages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Overrides MCdicomRequest..::..GetMessages()()()().)
Public method | GetModel | Gets MCparameter list of RS NPI model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Inherited from MCdicomRequest.)
Protected method | GetSegments | Retrieves RS NPI MCrequestType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetSegments()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM request (Inherited from MCdicomRequest.)

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCrsNpiRequest Class


MCrsNpiRequest Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiRequest Fields
MCrsNpiRequest Class See Also Send Feedback

The MCrsNpiRequest type exposes the following members.

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

See Also

MCrsNpiRequest Class


MCrsNpiRequest Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiRequest Methods
MCrsNpiRequest Class See Also Send Feedback

The MCrsNpiRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Inherited from MCdicomRequest.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves RS NPI MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Inherited from MCdicomRequest.)
Public method | GetMessages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Overrides MCdicomRequest..::..GetMessages()()()().)
Public method | GetModel | Gets MCparameter list of RS NPI model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Inherited from MCdicomRequest.)
Protected method | GetSegments | Retrieves RS NPI MCrequestType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetSegments()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM request (Inherited from MCdicomRequest.)

See Also

MCrsNpiRequest Class


GetActionType Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiRequest..::..GetActionType Method
MCrsNpiRequest Class See Also Send Feedback
Retrieves RS NPI MCactionType from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetActionType()
Visual Basic
Protected Overrides Sub GetActionType
Visual C++
protected:
virtual void GetActionType() override

See Also

MCrsNpiRequest Class
MCrsNpiRequest Members


GetHeaders Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiRequest..::..GetHeaders Method
MCrsNpiRequest Class See Also Send Feedback
Retrieves Http Header data from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetHeaders()
Visual Basic
Protected Overrides Sub GetHeaders
Visual C++
protected:
virtual void GetHeaders() override

See Also

MCrsNpiRequest Class
MCrsNpiRequest Members


GetMessages Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiRequest..::..GetMessages Method
MCrsNpiRequest Class See Also Send Feedback
Generates a list of request MCabstractMessage based on HttpRequestMessage data

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override IEnumerable<MCabstractMessage> GetMessages()
Visual Basic
Public Overrides Function GetMessages As IEnumerable(Of MCabstractMessage)
Visual C++
public:
virtual IEnumerable<MCabstractMessage^>^ GetMessages() override

Return Value

A collection of MCabstractMessage objects.

See Also

MCrsNpiRequest Class
MCrsNpiRequest Members


GetModel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiRequest..::..GetModel Method
MCrsNpiRequest Class See Also Send Feedback
Gets MCparameter list of RS NPI model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override IList<MCparameter> GetModel()
Visual Basic
Public Overrides Function GetModel As IList(Of MCparameter)
Visual C++
public:
virtual IList<MCparameter^>^ GetModel() override

Return Value

MCparameter list

See Also

MCrsNpiRequest Class
MCrsNpiRequest Members


GetQueries Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiRequest..::..GetQueries Method
MCrsNpiRequest Class See Also Send Feedback
Retrieves Http Query from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetQueries()
Visual Basic
Protected Overrides Sub GetQueries
Visual C++
protected:
virtual void GetQueries() override

See Also

MCrsNpiRequest Class
MCrsNpiRequest Members


GetSegments Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiRequest..::..GetSegments Method
MCrsNpiRequest Class See Also Send Feedback
Retrieves RS NPI MCrequestType from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetSegments()
Visual Basic
Protected Overrides Sub GetSegments
Visual C++
protected:
virtual void GetSegments() override

See Also

MCrsNpiRequest Class
MCrsNpiRequest Members


supportedMediaTypes Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiRequest..::..supportedMediaTypes Method
MCrsNpiRequest Class See Also Send Feedback
Gets the list of supported MCmediaType of the current request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override IEnumerable<MCmediaType> supportedMediaTypes()
Visual Basic
Protected Overrides Function supportedMediaTypes As IEnumerable(Of MCmediaType)
Visual C++
protected:
virtual IEnumerable<MCmediaType^>^ supportedMediaTypes() override

Return Value

List of MCmediaType objects

See Also

MCrsNpiRequest Class
MCrsNpiRequest Members


MCrsNpiRequest Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiRequest Properties
MCrsNpiRequest Class See Also Send Feedback

The MCrsNpiRequest type exposes the following members.

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCrsNpiRequest Class


SupportedMediaTypes Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiRequest..::..SupportedMediaTypes Property
MCrsNpiRequest Class See Also Send Feedback
Gets and sets the list of supported MCmediaType for specific MCrequestType request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IEnumerable<MCmediaType> SupportedMediaTypes { get; protected set; }
Visual Basic
Public Shared Property SupportedMediaTypes As IEnumerable(Of MCmediaType)
    Get
    Protected Set
Visual C++
public:
static property IEnumerable<MCmediaType^>^ SupportedMediaTypes {
    IEnumerable<MCmediaType^>^ get ();
    protected: void set (IEnumerable<MCmediaType^>^ value);
}

See Also

MCrsNpiRequest Class
MCrsNpiRequest Members


MCstowCommitmentRequest Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest Class
Members See Also Send Feedback
Converts and encapsulates HttpRequestMessage data from STOW-RS request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCstowCommitmentRequest : MCdicomRequest
Visual Basic
Public Class MCstowCommitmentRequest _
    Inherits MCdicomRequest
Visual C++
public ref class MCstowCommitmentRequest : public MCdicomRequest

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCdicomRequest
Mergecomws.Dicom..::..MCstowCommitmentRequest

See Also

MCstowCommitmentRequest Members


MCstowCommitmentRequest Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest Members
MCstowCommitmentRequest Class Methods Fields Properties See Also Send Feedback

The MCstowCommitmentRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Inherited from MCdicomRequest.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves STOW-COMMITMENT MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Overrides MCdicomRequest..::..GetLevel()()()().)
Public method | GetMessages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Overrides MCdicomRequest..::..GetMessages()()()().)
Public method | GetModel | Gets MCparameter list of STOW-RS model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Inherited from MCdicomRequest.)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Overrides MCdicomRequest..::..GetSegments()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM request (Inherited from MCdicomRequest.)

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCstowCommitmentRequest Class


MCstowCommitmentRequest Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest Fields
MCstowCommitmentRequest Class See Also Send Feedback

The MCstowCommitmentRequest type exposes the following members.

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

See Also

MCstowCommitmentRequest Class


MCstowCommitmentRequest Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest Methods
MCstowCommitmentRequest Class See Also Send Feedback

The MCstowCommitmentRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Inherited from MCdicomRequest.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves STOW-COMMITMENT MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Overrides MCdicomRequest..::..GetLevel()()()().)
Public method | GetMessages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Overrides MCdicomRequest..::..GetMessages()()()().)
Public method | GetModel | Gets MCparameter list of STOW-RS model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Inherited from MCdicomRequest.)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Overrides MCdicomRequest..::..GetSegments()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM request (Inherited from MCdicomRequest.)

See Also

MCstowCommitmentRequest Class


GetActionType Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest..::..GetActionType Method
MCstowCommitmentRequest Class See Also Send Feedback
Retrieves STOW-COMMITMENT MCactionType from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetActionType()
Visual Basic
Protected Overrides Sub GetActionType
Visual C++
protected:
virtual void GetActionType() override

See Also

MCstowCommitmentRequest Class
MCstowCommitmentRequest Members


GetContent Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest..::..GetContent Method
MCstowCommitmentRequest Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) |

See Also

MCstowCommitmentRequest Class
MCstowCommitmentRequest Members


GetContent Method (HttpContent, IEnumerable(MCmediaType))

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest..::..GetContent Method (HttpContent, IEnumerable<(Of <(<'MCmediaType>)>)>)
MCstowCommitmentRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:Mergecomws.Dicom.MCstowCommitmentRequest.GetContent(System.Net.Http.HttpContent,System.Collections.Generic.IEnumerable{Mergecomws.Dicom.MCmediaType})"]

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected bool GetContent(
    HttpContent content,
    IEnumerable<MCmediaType> mediaTypes
)
Visual Basic
Protected Function GetContent ( _
    content As HttpContent, _
    mediaTypes As IEnumerable(Of MCmediaType) _
) As Boolean
Visual C++
protected:
bool GetContent(
    HttpContent^ content,
    IEnumerable<MCmediaType^>^ mediaTypes
)

Parameters

content
Type: HttpContent

[Missing <param name="content"/> documentation for "M:Mergecomws.Dicom.MCstowCommitmentRequest.GetContent(System.Net.Http.HttpContent,System.Collections.Generic.IEnumerable{Mergecomws.Dicom.MCmediaType})"]

mediaTypes
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' MCmediaType >)>)>

[Missing <param name="mediaTypes"/> documentation for "M:Mergecomws.Dicom.MCstowCommitmentRequest.GetContent(System.Net.Http.HttpContent,System.Collections.Generic.IEnumerable{Mergecomws.Dicom.MCmediaType})"]

Return Value

[Missing <returns> documentation for "M:Mergecomws.Dicom.MCstowCommitmentRequest.GetContent(System.Net.Http.HttpContent,System.Collections.Generic.IEnumerable{Mergecomws.Dicom.MCmediaType})"]

See Also

MCstowCommitmentRequest Class
MCstowCommitmentRequest Members
GetContent Overload


GetHeaders Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest..::..GetHeaders Method
MCstowCommitmentRequest Class See Also Send Feedback
Retrieves Http Header data from HttpRequestMessage

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetHeaders()
Visual Basic
Protected Overrides Sub GetHeaders
Visual C++
protected:
virtual void GetHeaders() override

See Also

MCstowCommitmentRequest Class
MCstowCommitmentRequest Members


GetLevel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest..::..GetLevel Method
MCstowCommitmentRequest Class See Also Send Feedback
Gets MCdicomLevel value of DICOM request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetLevel()
Visual Basic
Protected Overrides Sub GetLevel
Visual C++
protected:
virtual void GetLevel() override

See Also

MCstowCommitmentRequest Class
MCstowCommitmentRequest Members


GetMessages Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest..::..GetMessages Method
MCstowCommitmentRequest Class See Also Send Feedback
Generates a list of request MCabstractMessage based on HttpRequestMessage data

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override IEnumerable<MCabstractMessage> GetMessages()
Visual Basic
Public Overrides Function GetMessages As IEnumerable(Of MCabstractMessage)
Visual C++
public:
virtual IEnumerable<MCabstractMessage^>^ GetMessages() override

Return Value

A collection of MCabstractMessage objects.

See Also

MCstowCommitmentRequest Class
MCstowCommitmentRequest Members


GetModel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest..::..GetModel Method
MCstowCommitmentRequest Class See Also Send Feedback
Gets MCparameter list of STOW-RS model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override IList<MCparameter> GetModel()
Visual Basic
Public Overrides Function GetModel As IList(Of MCparameter)
Visual C++
public:
virtual IList<MCparameter^>^ GetModel() override

Return Value

MCparameter list

See Also

MCstowCommitmentRequest Class
MCstowCommitmentRequest Members


GetQueries Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest..::..GetQueries Method
MCstowCommitmentRequest Class See Also Send Feedback
Retrieves Http Query from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetQueries()
Visual Basic
Protected Overrides Sub GetQueries
Visual C++
protected:
virtual void GetQueries() override

See Also

MCstowCommitmentRequest Class
MCstowCommitmentRequest Members


GetSegments Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest..::..GetSegments Method
MCstowCommitmentRequest Class See Also Send Feedback
Retrieves MCparameter from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetSegments()
Visual Basic
Protected Overrides Sub GetSegments
Visual C++
protected:
virtual void GetSegments() override

See Also

MCstowCommitmentRequest Class
MCstowCommitmentRequest Members


supportedMediaTypes Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest..::..supportedMediaTypes Method
MCstowCommitmentRequest Class See Also Send Feedback
Gets the list of supported MCmediaType of the current request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override IEnumerable<MCmediaType> supportedMediaTypes()
Visual Basic
Protected Overrides Function supportedMediaTypes As IEnumerable(Of MCmediaType)
Visual C++
protected:
virtual IEnumerable<MCmediaType^>^ supportedMediaTypes() override

Return Value

List of MCmediaType objects

See Also

MCstowCommitmentRequest Class
MCstowCommitmentRequest Members


MCstowCommitmentRequest Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest Properties
MCstowCommitmentRequest Class See Also Send Feedback

The MCstowCommitmentRequest type exposes the following members.

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCstowCommitmentRequest Class


SupportedMediaTypes Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowCommitmentRequest..::..SupportedMediaTypes Property
MCstowCommitmentRequest Class See Also Send Feedback
Gets and sets the list of supported MCmediaType for specific MCrequestType request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IEnumerable<MCmediaType> SupportedMediaTypes { get; protected set; }
Visual Basic
Public Shared Property SupportedMediaTypes As IEnumerable(Of MCmediaType)
    Get
    Protected Set
Visual C++
public:
static property IEnumerable<MCmediaType^>^ SupportedMediaTypes {
    IEnumerable<MCmediaType^>^ get ();
    protected: void set (IEnumerable<MCmediaType^>^ value);
}

See Also

MCstowCommitmentRequest Class
MCstowCommitmentRequest Members


MCstowRequest Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowRequest Class
Members See Also Send Feedback
Converts and encapsulates HttpRequestMessage data from STOW-RS request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCstowRequest : MCdicomRequest
Visual Basic
Public Class MCstowRequest _
    Inherits MCdicomRequest
Visual C++
public ref class MCstowRequest : public MCdicomRequest

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCdicomRequest
Mergecomws.Dicom..::..MCstowRequest

See Also

MCstowRequest Members


MCstowRequest Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowRequest Members
MCstowRequest Class Methods Fields Properties See Also Send Feedback

The MCstowRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Inherited from MCdicomRequest.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves STOW-RS MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Overrides MCdicomRequest..::..GetLevel()()()().)
Public method | GetMessages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Overrides MCdicomRequest..::..GetMessages()()()().)
Public method | GetModel | Gets MCparameter list of STOW-RS model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Inherited from MCdicomRequest.)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Overrides MCdicomRequest..::..GetSegments()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM request (Inherited from MCdicomRequest.)

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCstowRequest Class


MCstowRequest Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowRequest Fields
MCstowRequest Class See Also Send Feedback

The MCstowRequest type exposes the following members.

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

See Also

MCstowRequest Class


MCstowRequest Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowRequest Methods
MCstowRequest Class See Also Send Feedback

The MCstowRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Inherited from MCdicomRequest.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves STOW-RS MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Overrides MCdicomRequest..::..GetLevel()()()().)
Public method | GetMessages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Overrides MCdicomRequest..::..GetMessages()()()().)
Public method | GetModel | Gets MCparameter list of STOW-RS model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Inherited from MCdicomRequest.)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Overrides MCdicomRequest..::..GetSegments()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM request (Inherited from MCdicomRequest.)

See Also

MCstowRequest Class


GetActionType Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowRequest..::..GetActionType Method
MCstowRequest Class See Also Send Feedback
Retrieves STOW-RS MCactionType from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetActionType()
Visual Basic
Protected Overrides Sub GetActionType
Visual C++
protected:
virtual void GetActionType() override

See Also

MCstowRequest Class
MCstowRequest Members


GetHeaders Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowRequest..::..GetHeaders Method
MCstowRequest Class See Also Send Feedback
Retrieves Http Header data from HttpRequestMessage

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetHeaders()
Visual Basic
Protected Overrides Sub GetHeaders
Visual C++
protected:
virtual void GetHeaders() override

See Also

MCstowRequest Class
MCstowRequest Members


GetLevel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowRequest..::..GetLevel Method
MCstowRequest Class See Also Send Feedback
Gets MCdicomLevel value of DICOM request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetLevel()
Visual Basic
Protected Overrides Sub GetLevel
Visual C++
protected:
virtual void GetLevel() override

See Also

MCstowRequest Class
MCstowRequest Members


GetMessages Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowRequest..::..GetMessages Method
MCstowRequest Class See Also Send Feedback
Generates a list of request MCabstractMessage based on HttpRequestMessage data

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override IEnumerable<MCabstractMessage> GetMessages()
Visual Basic
Public Overrides Function GetMessages As IEnumerable(Of MCabstractMessage)
Visual C++
public:
virtual IEnumerable<MCabstractMessage^>^ GetMessages() override

Return Value

A collection of MCabstractMessage objects.

See Also

MCstowRequest Class
MCstowRequest Members


GetModel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowRequest..::..GetModel Method
MCstowRequest Class See Also Send Feedback
Gets MCparameter list of STOW-RS model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override IList<MCparameter> GetModel()
Visual Basic
Public Overrides Function GetModel As IList(Of MCparameter)
Visual C++
public:
virtual IList<MCparameter^>^ GetModel() override

Return Value

MCparameter list

See Also

MCstowRequest Class
MCstowRequest Members


GetQueries Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowRequest..::..GetQueries Method
MCstowRequest Class See Also Send Feedback
Retrieves Http Query from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetQueries()
Visual Basic
Protected Overrides Sub GetQueries
Visual C++
protected:
virtual void GetQueries() override

See Also

MCstowRequest Class
MCstowRequest Members


GetSegments Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowRequest..::..GetSegments Method
MCstowRequest Class See Also Send Feedback
Retrieves MCparameter from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetSegments()
Visual Basic
Protected Overrides Sub GetSegments
Visual C++
protected:
virtual void GetSegments() override

See Also

MCstowRequest Class
MCstowRequest Members


supportedMediaTypes Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowRequest..::..supportedMediaTypes Method
MCstowRequest Class See Also Send Feedback
Gets the list of supported MCmediaType of the current request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override IEnumerable<MCmediaType> supportedMediaTypes()
Visual Basic
Protected Overrides Function supportedMediaTypes As IEnumerable(Of MCmediaType)
Visual C++
protected:
virtual IEnumerable<MCmediaType^>^ supportedMediaTypes() override

Return Value

List of MCmediaType objects

See Also

MCstowRequest Class
MCstowRequest Members


MCstowRequest Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowRequest Properties
MCstowRequest Class See Also Send Feedback

The MCstowRequest type exposes the following members.

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCstowRequest Class


SupportedMediaTypes Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowRequest..::..SupportedMediaTypes Property
MCstowRequest Class See Also Send Feedback
Gets and sets the list of supported MCmediaType for specific MCrequestType request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IEnumerable<MCmediaType> SupportedMediaTypes { get; protected set; }
Visual Basic
Public Shared Property SupportedMediaTypes As IEnumerable(Of MCmediaType)
    Get
    Protected Set
Visual C++
public:
static property IEnumerable<MCmediaType^>^ SupportedMediaTypes {
    IEnumerable<MCmediaType^>^ get ();
    protected: void set (IEnumerable<MCmediaType^>^ value);
}

See Also

MCstowRequest Class
MCstowRequest Members


MCupsRequest Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsRequest Class
Members See Also Send Feedback
Converts and encapsulates HttpRequestMessage data from UPS-RS request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCupsRequest : MCdicomRequest
Visual Basic
Public Class MCupsRequest _
    Inherits MCdicomRequest
Visual C++
public ref class MCupsRequest : public MCdicomRequest

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCdicomRequest
Mergecomws.Dicom..::..MCupsRequest

See Also

MCupsRequest Members


MCupsRequest Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsRequest Members
MCupsRequest Class Methods Fields Properties See Also Send Feedback

The MCupsRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object using DICOM model (Overrides MCdicomRequest..::..CompleteRequest(MCdimseMessage).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves UPS-RS MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Overrides MCdicomRequest..::..GetContent()()()().)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Inherited from MCdicomRequest.)
Public method | GetMessages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Overrides MCdicomRequest..::..GetMessages()()()().)
Public method | GetModel | Gets MCparameter list of UPS-RS model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Inherited from MCdicomRequest.)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Inherited from MCdicomRequest.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM request (Inherited from MCdicomRequest.)

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCupsRequest Class


MCupsRequest Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsRequest Fields
MCupsRequest Class See Also Send Feedback

The MCupsRequest type exposes the following members.

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

See Also

MCupsRequest Class


MCupsRequest Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsRequest Methods
MCupsRequest Class See Also Send Feedback

The MCupsRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object using DICOM model (Overrides MCdicomRequest..::..CompleteRequest(MCdimseMessage).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves UPS-RS MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Overrides MCdicomRequest..::..GetContent()()()().)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Inherited from MCdicomRequest.)
Public method | GetMessages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Overrides MCdicomRequest..::..GetMessages()()()().)
Public method | GetModel | Gets MCparameter list of UPS-RS model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Inherited from MCdicomRequest.)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Inherited from MCdicomRequest.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM request (Inherited from MCdicomRequest.)

See Also

MCupsRequest Class


CompleteRequest Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsRequest..::..CompleteRequest Method
MCupsRequest Class See Also Send Feedback
Updates and completes MCdimseMessage object using DICOM model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override MCdimseMessage CompleteRequest(
    MCdimseMessage request
)
Visual Basic
Protected Overrides Function CompleteRequest ( _
    request As MCdimseMessage _
) As MCdimseMessage
Visual C++
protected:
virtual MCdimseMessage^ CompleteRequest(
    MCdimseMessage^ request
) override

Parameters

request
Type: MCdimseMessage
MCdimseMessage object

Return Value

MCdimseMessage object

See Also

MCupsRequest Class
MCupsRequest Members


GetActionType Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsRequest..::..GetActionType Method
MCupsRequest Class See Also Send Feedback
Retrieves UPS-RS MCactionType from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetActionType()
Visual Basic
Protected Overrides Sub GetActionType
Visual C++
protected:
virtual void GetActionType() override

See Also

MCupsRequest Class
MCupsRequest Members


GetContent Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsRequest..::..GetContent Method
MCupsRequest Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Overrides MCdicomRequest..::..GetContent()()()().)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)

See Also

MCupsRequest Class
MCupsRequest Members


GetContent Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsRequest..::..GetContent Method
MCupsRequest Class See Also Send Feedback
Retrieves Http Content from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetContent()
Visual Basic
Protected Overrides Sub GetContent
Visual C++
protected:
virtual void GetContent() override

See Also

MCupsRequest Class
MCupsRequest Members
GetContent Overload


GetHeaders Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsRequest..::..GetHeaders Method
MCupsRequest Class See Also Send Feedback
Retrieves Http Header data from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetHeaders()
Visual Basic
Protected Overrides Sub GetHeaders
Visual C++
protected:
virtual void GetHeaders() override

See Also

MCupsRequest Class
MCupsRequest Members


GetMessages Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsRequest..::..GetMessages Method
MCupsRequest Class See Also Send Feedback
Generates a list of request MCabstractMessage based on HttpRequestMessage data

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override IEnumerable<MCabstractMessage> GetMessages()
Visual Basic
Public Overrides Function GetMessages As IEnumerable(Of MCabstractMessage)
Visual C++
public:
virtual IEnumerable<MCabstractMessage^>^ GetMessages() override

Return Value

A collection of MCabstractMessage objects.

See Also

MCupsRequest Class
MCupsRequest Members


GetModel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsRequest..::..GetModel Method
MCupsRequest Class See Also Send Feedback
Gets MCparameter list of UPS-RS model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override IList<MCparameter> GetModel()
Visual Basic
Public Overrides Function GetModel As IList(Of MCparameter)
Visual C++
public:
virtual IList<MCparameter^>^ GetModel() override

Return Value

MCparameter list

See Also

MCupsRequest Class
MCupsRequest Members


GetQueries Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsRequest..::..GetQueries Method
MCupsRequest Class See Also Send Feedback
Retrieves Http Query from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetQueries()
Visual Basic
Protected Overrides Sub GetQueries
Visual C++
protected:
virtual void GetQueries() override

See Also

MCupsRequest Class
MCupsRequest Members


supportedMediaTypes Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsRequest..::..supportedMediaTypes Method
MCupsRequest Class See Also Send Feedback
Gets the list of supported MCmediaType of the current request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override IEnumerable<MCmediaType> supportedMediaTypes()
Visual Basic
Protected Overrides Function supportedMediaTypes As IEnumerable(Of MCmediaType)
Visual C++
protected:
virtual IEnumerable<MCmediaType^>^ supportedMediaTypes() override

Return Value

List of MCmediaType objects

See Also

MCupsRequest Class
MCupsRequest Members


MCupsRequest Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsRequest Properties
MCupsRequest Class See Also Send Feedback

The MCupsRequest type exposes the following members.

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCupsRequest Class


SupportedMediaTypes Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsRequest..::..SupportedMediaTypes Property
MCupsRequest Class See Also Send Feedback
Gets and sets the list of supported MCmediaType for specific MCrequestType request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IEnumerable<MCmediaType> SupportedMediaTypes { get; protected set; }
Visual Basic
Public Shared Property SupportedMediaTypes As IEnumerable(Of MCmediaType)
    Get
    Protected Set
Visual C++
public:
static property IEnumerable<MCmediaType^>^ SupportedMediaTypes {
    IEnumerable<MCmediaType^>^ get ();
    protected: void set (IEnumerable<MCmediaType^>^ value);
}

See Also

MCupsRequest Class
MCupsRequest Members


MCupsResponse Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse Class
Members See Also Send Feedback
Encapsulates and converts UPS-RS DICOM service response into HttpResponseMessage data

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCupsResponse : MCdicomResponse
Visual Basic
Public Class MCupsResponse _
    Inherits MCdicomResponse
Visual C++
public ref class MCupsResponse : public MCdicomResponse

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCdicomResponse
Mergecomws.Dicom..::..MCupsResponse

See Also

MCupsResponse Members


MCupsResponse Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse Members
MCupsResponse Class Methods Fields Properties See Also Send Feedback

The MCupsResponse type exposes the following members.

Methods

 | Name | Description
Public method | CreateHttpResponseMessage | Creates internal HttpResponseMessage object from DICOM service response (Inherited from MCdicomResponse.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHttpResponseMessage | Returns internal HttpResponseMessage object created from DICOM service response with CreateHttpResponseMessage(array<MCabstractMessage>[]()[][], String, String) (Inherited from MCdicomResponse.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name Description
Protected field httpResponseMessage
Internal HttpResponseMessage object created by
CopyC#
CreateHttpResponseMessage
 method
(Inherited from MCdicomResponse.)

Properties

 | Name | Description
Public property | DicomRenderer | Gets and sets DICOM renderer of DICOM service response (Inherited from MCdicomResponse.)
Public property | HttpConverter | Gets and sets Http converter of DICOM stream data from IMCdicomRenderer object (Inherited from MCdicomResponse.)
Public property | HttpResponder | Gets and sets Http response message creator which uses Http multipart content from IMChttpConverter object (Inherited from MCdicomResponse.)
Public property | RequestType | Gets MCrequestType for the current response (Inherited from MCdicomResponse.)

See Also

MCupsResponse Class


MCupsResponse Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse Fields
MCupsResponse Class See Also Send Feedback

The MCupsResponse type exposes the following members.

Fields

Name Description
Protected field httpResponseMessage
Internal HttpResponseMessage object created by
CopyC#
CreateHttpResponseMessage
 method
(Inherited from MCdicomResponse.)

See Also

MCupsResponse Class


MCupsResponse Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse Methods
MCupsResponse Class See Also Send Feedback

The MCupsResponse type exposes the following members.

Methods

 | Name | Description
Public method | CreateHttpResponseMessage | Creates internal HttpResponseMessage object from DICOM service response (Inherited from MCdicomResponse.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHttpResponseMessage | Returns internal HttpResponseMessage object created from DICOM service response with CreateHttpResponseMessage(array<MCabstractMessage>[]()[][], String, String) (Inherited from MCdicomResponse.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCupsResponse Class


MCupsResponse Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse Properties
MCupsResponse Class See Also Send Feedback

The MCupsResponse type exposes the following members.

Properties

 | Name | Description
Public property | DicomRenderer | Gets and sets DICOM renderer of DICOM service response (Inherited from MCdicomResponse.)
Public property | HttpConverter | Gets and sets Http converter of DICOM stream data from IMCdicomRenderer object (Inherited from MCdicomResponse.)
Public property | HttpResponder | Gets and sets Http response message creator which uses Http multipart content from IMChttpConverter object (Inherited from MCdicomResponse.)
Public property | RequestType | Gets MCrequestType for the current response (Inherited from MCdicomResponse.)

See Also

MCupsResponse Class


MCupsResponse.Status Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status Class
MCupsResponse Class Members See Also Send Feedback
Describes UPS-RS response status

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class Status
Visual Basic
Public Class Status
Visual C++
public ref class Status

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCupsResponse..::..Status

See Also

MCupsResponse..::..Status Members


MCupsResponse.Status Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status Members
MCupsResponse..::..Status Class Methods Fields Properties See Also Send Feedback

The MCupsResponse..::..Status type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
CANCEL_FE00 | Cancel FE00: Matching terminated due to Cancel request
FAILURE_0122 | Failure 0122: SOP Class not Supported
FAILURE_A700 | Failure A700: Refused: Out of Resources
FAILURE_A701 | Failure A701: Out of Resources - Unable to calculate number of matches
FAILURE_A702 | Failure A702: Refused: Out of Resources - Unable to perform sub-operations
FAILURE_A900 | Failure A900: Identifier Does Not Match SOP Class
FAILURE_C300 | Failure C300: The UPS may no longer be updated
FAILURE_C301 | Failure C301: Refused: The correct Transaction UID was not provided
FAILURE_C302 | Failure C302: Refused: The UPS is already IN PROGRESS
FAILURE_C303 | Failure C303: Refused: The UPS may only become SCHEDULED via N-CREATE, not N-SET or N-ACTION
FAILURE_C304 | Failure C304: Refused: The UPS has not met final state requirements for the requested state change
FAILURE_C307 | Failure C307: Specified SOP Instance UID does not exist or is not a UPS Instance managed by this SCP
FAILURE_C308 | Failure C308: Receiving AE-TITLE is Unknown to this SCP
FAILURE_C309 | Failure C309: Refused: The provided value of UPS State was not SCHEDULED
FAILURE_C310 | Failure C310: Refused: The UPS is not yet in the IN PROGRESS state
FAILURE_C311 | Failure C311: Refused: The UPS is already COMPLETED
FAILURE_C312 | Failure C312: Refused: The performer cannot be contacted
FAILURE_C313 | Failure C313: Refused: Performer chooses not to cancel
FAILURE_C314 | Failure C314: Refused: Specified action not appropriate for specified instance
FAILURE_C315 | Failure C315: Refused: SCP does not support Event Reports
FAILURE_CXXX | Failure CXXX: Unable to process
PENDING_FF00 | Pending FF00: Matches are continuing. Current Match is supplied and any Optional Keys were supported in the same manner as Required Keys
PENDING_FF01 | Pending FF01: Matches are continuing. Warning that one or more Optional Keys were not supported for existence for this Identifier
SUCCESS | Success
WARNING_0001 | Warning 0001: Requested optional Attributes are not supported
WARNING_B000 | Warning B000: Sub-operations Complete - One or more Failures
WARNING_B300 | Warning B300: The UPS was created with modifications
WARNING_B301 | Warning B301: Deletion Lock not granted
WARNING_B304 | Warning B304: The UPS is already in the requested state of CANCELED
WARNING_B305 | Warning B305: Coerced invalid values to valid values
WARNING_B306 | Warning B306: The UPS is already in the requested state of COMPLETED

Properties

 | Name | Description
Public property | Code | Status code
Public property | Meaning | Status meaning

See Also

MCupsResponse..::..Status Class


MCupsResponse.Status Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status Fields
MCupsResponse..::..Status Class See Also Send Feedback

The MCupsResponse..::..Status type exposes the following members.

Fields

Name | Description
CANCEL_FE00 | Cancel FE00: Matching terminated due to Cancel request
FAILURE_0122 | Failure 0122: SOP Class not Supported
FAILURE_A700 | Failure A700: Refused: Out of Resources
FAILURE_A701 | Failure A701: Out of Resources - Unable to calculate number of matches
FAILURE_A702 | Failure A702: Refused: Out of Resources - Unable to perform sub-operations
FAILURE_A900 | Failure A900: Identifier Does Not Match SOP Class
FAILURE_C300 | Failure C300: The UPS may no longer be updated
FAILURE_C301 | Failure C301: Refused: The correct Transaction UID was not provided
FAILURE_C302 | Failure C302: Refused: The UPS is already IN PROGRESS
FAILURE_C303 | Failure C303: Refused: The UPS may only become SCHEDULED via N-CREATE, not N-SET or N-ACTION
FAILURE_C304 | Failure C304: Refused: The UPS has not met final state requirements for the requested state change
FAILURE_C307 | Failure C307: Specified SOP Instance UID does not exist or is not a UPS Instance managed by this SCP
FAILURE_C308 | Failure C308: Receiving AE-TITLE is Unknown to this SCP
FAILURE_C309 | Failure C309: Refused: The provided value of UPS State was not SCHEDULED
FAILURE_C310 | Failure C310: Refused: The UPS is not yet in the IN PROGRESS state
FAILURE_C311 | Failure C311: Refused: The UPS is already COMPLETED
FAILURE_C312 | Failure C312: Refused: The performer cannot be contacted
FAILURE_C313 | Failure C313: Refused: Performer chooses not to cancel
FAILURE_C314 | Failure C314: Refused: Specified action not appropriate for specified instance
FAILURE_C315 | Failure C315: Refused: SCP does not support Event Reports
FAILURE_CXXX | Failure CXXX: Unable to process
PENDING_FF00 | Pending FF00: Matches are continuing. Current Match is supplied and any Optional Keys were supported in the same manner as Required Keys
PENDING_FF01 | Pending FF01: Matches are continuing. Warning that one or more Optional Keys were not supported for existence for this Identifier
SUCCESS | Success
WARNING_0001 | Warning 0001: Requested optional Attributes are not supported
WARNING_B000 | Warning B000: Sub-operations Complete - One or more Failures
WARNING_B300 | Warning B300: The UPS was created with modifications
WARNING_B301 | Warning B301: Deletion Lock not granted
WARNING_B304 | Warning B304: The UPS is already in the requested state of CANCELED
WARNING_B305 | Warning B305: Coerced invalid values to valid values
WARNING_B306 | Warning B306: The UPS is already in the requested state of COMPLETED

See Also

MCupsResponse..::..Status Class


CANCEL_FE00 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..CANCEL_FE00 Field
MCupsResponse..::..Status Class See Also Send Feedback
Cancel FE00: Matching terminated due to Cancel request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status CANCEL_FE00
Visual Basic
Public Shared ReadOnly CANCEL_FE00 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ CANCEL_FE00

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_0122 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_0122 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure 0122: SOP Class not Supported

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_0122
Visual Basic
Public Shared ReadOnly FAILURE_0122 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_0122

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_A700 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_A700 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure A700: Refused: Out of Resources

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_A700
Visual Basic
Public Shared ReadOnly FAILURE_A700 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_A700

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_A701 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_A701 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure A701: Out of Resources - Unable to calculate number of matches

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_A701
Visual Basic
Public Shared ReadOnly FAILURE_A701 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_A701

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_A702 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_A702 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure A702: Refused: Out of Resources - Unable to perform sub-operations

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_A702
Visual Basic
Public Shared ReadOnly FAILURE_A702 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_A702

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_A900 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_A900 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure A900: Identifier Does Not Match SOP Class

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_A900
Visual Basic
Public Shared ReadOnly FAILURE_A900 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_A900

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_C300 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_C300 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure C300: The UPS may no longer be updated

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_C300
Visual Basic
Public Shared ReadOnly FAILURE_C300 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_C300

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_C301 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_C301 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure C301: Refused: The correct Transaction UID was not provided

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_C301
Visual Basic
Public Shared ReadOnly FAILURE_C301 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_C301

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_C302 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_C302 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure C302: Refused: The UPS is already IN PROGRESS

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_C302
Visual Basic
Public Shared ReadOnly FAILURE_C302 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_C302

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_C303 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_C303 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure C303: Refused: The UPS may only become SCHEDULED via N-CREATE, not N-SET or N-ACTION

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_C303
Visual Basic
Public Shared ReadOnly FAILURE_C303 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_C303

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_C304 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_C304 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure C304: Refused: The UPS has not met final state requirements for the requested state change

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_C304
Visual Basic
Public Shared ReadOnly FAILURE_C304 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_C304

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_C307 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_C307 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure C307: Specified SOP Instance UID does not exist or is not a UPS Instance managed by this SCP

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_C307
Visual Basic
Public Shared ReadOnly FAILURE_C307 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_C307

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_C308 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_C308 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure C308: Receiving AE-TITLE is Unknown to this SCP

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_C308
Visual Basic
Public Shared ReadOnly FAILURE_C308 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_C308

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_C309 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_C309 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure C309: Refused: The provided value of UPS State was not SCHEDULED

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_C309
Visual Basic
Public Shared ReadOnly FAILURE_C309 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_C309

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_C310 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_C310 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure C310: Refused: The UPS is not yet in the IN PROGRESS state

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_C310
Visual Basic
Public Shared ReadOnly FAILURE_C310 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_C310

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_C311 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_C311 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure C311: Refused: The UPS is already COMPLETED

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_C311
Visual Basic
Public Shared ReadOnly FAILURE_C311 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_C311

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_C312 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_C312 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure C312: Refused: The performer cannot be contacted

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_C312
Visual Basic
Public Shared ReadOnly FAILURE_C312 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_C312

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_C313 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_C313 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure C313: Refused: Performer chooses not to cancel

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_C313
Visual Basic
Public Shared ReadOnly FAILURE_C313 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_C313

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_C314 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_C314 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure C314: Refused: Specified action not appropriate for specified instance

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_C314
Visual Basic
Public Shared ReadOnly FAILURE_C314 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_C314

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_C315 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_C315 Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure C315: Refused: SCP does not support Event Reports

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_C315
Visual Basic
Public Shared ReadOnly FAILURE_C315 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_C315

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


FAILURE_CXXX Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..FAILURE_CXXX Field
MCupsResponse..::..Status Class See Also Send Feedback
Failure CXXX: Unable to process

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status FAILURE_CXXX
Visual Basic
Public Shared ReadOnly FAILURE_CXXX As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ FAILURE_CXXX

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


PENDING_FF00 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..PENDING_FF00 Field
MCupsResponse..::..Status Class See Also Send Feedback
Pending FF00: Matches are continuing. Current Match is supplied and any Optional Keys were supported in the same manner as Required Keys

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status PENDING_FF00
Visual Basic
Public Shared ReadOnly PENDING_FF00 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ PENDING_FF00

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


PENDING_FF01 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..PENDING_FF01 Field
MCupsResponse..::..Status Class See Also Send Feedback
Pending FF01: Matches are continuing. Warning that one or more Optional Keys were not supported for existence for this Identifier

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status PENDING_FF01
Visual Basic
Public Shared ReadOnly PENDING_FF01 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ PENDING_FF01

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


SUCCESS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..SUCCESS Field
MCupsResponse..::..Status Class See Also Send Feedback
Success

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status SUCCESS
Visual Basic
Public Shared ReadOnly SUCCESS As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ SUCCESS

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


WARNING_0001 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..WARNING_0001 Field
MCupsResponse..::..Status Class See Also Send Feedback
Warning 0001: Requested optional Attributes are not supported

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status WARNING_0001
Visual Basic
Public Shared ReadOnly WARNING_0001 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ WARNING_0001

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


WARNING_B000 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..WARNING_B000 Field
MCupsResponse..::..Status Class See Also Send Feedback
Warning B000: Sub-operations Complete - One or more Failures

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status WARNING_B000
Visual Basic
Public Shared ReadOnly WARNING_B000 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ WARNING_B000

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


WARNING_B300 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..WARNING_B300 Field
MCupsResponse..::..Status Class See Also Send Feedback
Warning B300: The UPS was created with modifications

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status WARNING_B300
Visual Basic
Public Shared ReadOnly WARNING_B300 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ WARNING_B300

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


WARNING_B301 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..WARNING_B301 Field
MCupsResponse..::..Status Class See Also Send Feedback
Warning B301: Deletion Lock not granted

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status WARNING_B301
Visual Basic
Public Shared ReadOnly WARNING_B301 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ WARNING_B301

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


WARNING_B304 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..WARNING_B304 Field
MCupsResponse..::..Status Class See Also Send Feedback
Warning B304: The UPS is already in the requested state of CANCELED

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status WARNING_B304
Visual Basic
Public Shared ReadOnly WARNING_B304 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ WARNING_B304

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


WARNING_B305 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..WARNING_B305 Field
MCupsResponse..::..Status Class See Also Send Feedback
Warning B305: Coerced invalid values to valid values

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status WARNING_B305
Visual Basic
Public Shared ReadOnly WARNING_B305 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ WARNING_B305

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


WARNING_B306 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..WARNING_B306 Field
MCupsResponse..::..Status Class See Also Send Feedback
Warning B306: The UPS is already in the requested state of COMPLETED

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsResponse..::..Status WARNING_B306
Visual Basic
Public Shared ReadOnly WARNING_B306 As MCupsResponse..::..Status
Visual C++
public:
static initonly MCupsResponse..::..Status^ WARNING_B306

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


MCupsResponse.Status Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status Methods
MCupsResponse..::..Status Class See Also Send Feedback

The MCupsResponse..::..Status type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCupsResponse..::..Status Class


MCupsResponse.Status Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status Properties
MCupsResponse..::..Status Class See Also Send Feedback

The MCupsResponse..::..Status type exposes the following members.

Properties

 | Name | Description
Public property | Code | Status code
Public property | Meaning | Status meaning

See Also

MCupsResponse..::..Status Class


Code Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..Code Property
MCupsResponse..::..Status Class See Also Send Feedback
Status code

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Code { get; private set; }
Visual Basic
Public Property Code As String
    Get
    Private Set
Visual C++
public:
property String^ Code {
    String^ get ();
    private: void set (String^ value);
}

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


Meaning Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsResponse..::..Status..::..Meaning Property
MCupsResponse..::..Status Class See Also Send Feedback
Status meaning

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Meaning { get; private set; }
Visual Basic
Public Property Meaning As String
    Get
    Private Set
Visual C++
public:
property String^ Meaning {
    String^ get ();
    private: void set (String^ value);
}

See Also

MCupsResponse..::..Status Class
MCupsResponse..::..Status Members


MCupsSopClass Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsSopClass Class
Members See Also Send Feedback
Describes Unified Procedure Step Service Class and SOP Class UIDs, DICOM PS3.4 2015c, CC.3.1 Service Class and SOP Class UIDs

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCupsSopClass
Visual Basic
Public Class MCupsSopClass
Visual C++
public ref class MCupsSopClass

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCupsSopClass

See Also

MCupsSopClass Members


MCupsSopClass Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsSopClass Members
MCupsSopClass Class Methods Fields Properties See Also Send Feedback

The MCupsSopClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
EVENT | UPS Event SOP Class
PULL | UPS Pull SOP Class
PUSH | UPS Push SOP Class
UPS_SOP_INSTANCE_UID | UPS SOP Instance UID
WATCH | UPS Watch SOP Class

Properties

 | Name | Description
Public property | Name | UPS SOP Class name
Public property | Number | UPS SOP Class number
Public property | Uid | UPS SOP Class UID

See Also

MCupsSopClass Class


MCupsSopClass Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsSopClass Fields
MCupsSopClass Class See Also Send Feedback

The MCupsSopClass type exposes the following members.

Fields

Name | Description
EVENT | UPS Event SOP Class
PULL | UPS Pull SOP Class
PUSH | UPS Push SOP Class
UPS_SOP_INSTANCE_UID | UPS SOP Instance UID
WATCH | UPS Watch SOP Class

See Also

MCupsSopClass Class


EVENT Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsSopClass..::..EVENT Field
MCupsSopClass Class See Also Send Feedback
UPS Event SOP Class

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsSopClass EVENT
Visual Basic
Public Shared ReadOnly EVENT As MCupsSopClass
Visual C++
public:
static initonly MCupsSopClass^ EVENT

See Also

MCupsSopClass Class
MCupsSopClass Members


PULL Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsSopClass..::..PULL Field
MCupsSopClass Class See Also Send Feedback
UPS Pull SOP Class

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsSopClass PULL
Visual Basic
Public Shared ReadOnly PULL As MCupsSopClass
Visual C++
public:
static initonly MCupsSopClass^ PULL

See Also

MCupsSopClass Class
MCupsSopClass Members


PUSH Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsSopClass..::..PUSH Field
MCupsSopClass Class See Also Send Feedback
UPS Push SOP Class

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsSopClass PUSH
Visual Basic
Public Shared ReadOnly PUSH As MCupsSopClass
Visual C++
public:
static initonly MCupsSopClass^ PUSH

See Also

MCupsSopClass Class
MCupsSopClass Members


UPS_SOP_INSTANCE_UID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsSopClass..::..UPS_SOP_INSTANCE_UID Field
MCupsSopClass Class See Also Send Feedback
UPS SOP Instance UID

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string UPS_SOP_INSTANCE_UID
Visual Basic
Public Shared ReadOnly UPS_SOP_INSTANCE_UID As String
Visual C++
public:
static initonly String^ UPS_SOP_INSTANCE_UID

See Also

MCupsSopClass Class
MCupsSopClass Members


WATCH Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsSopClass..::..WATCH Field
MCupsSopClass Class See Also Send Feedback
UPS Watch SOP Class

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCupsSopClass WATCH
Visual Basic
Public Shared ReadOnly WATCH As MCupsSopClass
Visual C++
public:
static initonly MCupsSopClass^ WATCH

See Also

MCupsSopClass Class
MCupsSopClass Members


MCupsSopClass Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsSopClass Methods
MCupsSopClass Class See Also Send Feedback

The MCupsSopClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCupsSopClass Class


MCupsSopClass Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsSopClass Properties
MCupsSopClass Class See Also Send Feedback

The MCupsSopClass type exposes the following members.

Properties

 | Name | Description
Public property | Name | UPS SOP Class name
Public property | Number | UPS SOP Class number
Public property | Uid | UPS SOP Class UID

See Also

MCupsSopClass Class


Name Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsSopClass..::..Name Property
MCupsSopClass Class See Also Send Feedback
UPS SOP Class name

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

MCupsSopClass Class
MCupsSopClass Members


Number Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsSopClass..::..Number Property
MCupsSopClass Class See Also Send Feedback
UPS SOP Class number

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public int Number { get; }
Visual Basic
Public ReadOnly Property Number As Integer
    Get
Visual C++
public:
property int Number {
    int get ();
}

See Also

MCupsSopClass Class
MCupsSopClass Members


Uid Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsSopClass..::..Uid Property
MCupsSopClass Class See Also Send Feedback
UPS SOP Class UID

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Uid { get; }
Visual Basic
Public ReadOnly Property Uid As String
    Get
Visual C++
public:
property String^ Uid {
    String^ get ();
}

See Also

MCupsSopClass Class
MCupsSopClass Members


MCwadlElementType Enumeration

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadlElementType Enumeration
See Also Send Feedback
The enumeration lists the types of WADL elements.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public enum MCwadlElementType
Visual Basic
Public Enumeration MCwadlElementType
Visual C++
public enum class MCwadlElementType

Members

Member name | Value | Description
APPLICATION | 0 | WADL application element
DOC | 1 | WADL documentation element
GRAMMARS | 2 | WADL Grammars element
METHOD | 3 | WADL Method element
OPTION | 4 | WADL Option element
PARAM | 5 | WADL Parameter element
REPRESENTATION | 6 | WADL Representation element
REQUEST | 7 | WADL Request element
RESOURCE | 8 | WADL Resource element
RESOURCES | 9 | WADL Resources element
RESPONSE | 10 | WADL Response element

See Also


MCwado Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado Class
Members See Also Send Feedback
Singleton class used to register DICOM services and WADO configuration settings

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static class MCwado
Visual Basic
Public NotInheritable Class MCwado
Visual C++
public ref class MCwado abstract sealed

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCwado

See Also

MCwado Members


MCwado Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado Members
MCwado Class Methods Fields Properties See Also Send Feedback

The MCwado type exposes the following members.

Methods

Name | Description
AddObject(Object, String) | Register a singletone Object of given name in MCwado object holder
AddObject(Object, Type) | Register a singletone Object of given Type in MCwado object holder
GetObject(String) | Gets a singletone Object of given name registered in MCwado object holder
GetObject(Type) | Gets a singletone Object of given Type registered in MCwado object holder
Init()()()() | Initializes MCwado singleton instance
Init(FileInfo) | Initializes MCwado singleton instance
Init(FileInfo, String) | Initializes MCwado singleton instance

Fields

Name | Description
Name | Class name "MCWADO"

Properties

Name | Description
BulkDataHandler | Gets and sets registered IMCbulkDataHandler object used to associate Bulk Data and Meta Data using unique BulkDataURI
Cache | Gets and sets registered DICOM cache service
DicomKeywords | Dictionary<(Of <(<'TKey, TValue>)>)> of DICOM tags and corresponding keywords
DicomRenderer | Gets and sets registered IMCdicomRenderer object to convert DICOM service response into an array of Stream objects
HttpConverter | Gets and sets registered IMChttpConverter object to convert DICOM streams into an array of HttpContent objects
HttpResponder | Gets and sets registered IMChttpResponder object to create HttpResponseMessage object from an array of HttpContent objects
Service | Gets and sets registered DICOM service
Settings | Dictionary<(Of <(<'TKey, TValue>)>)> of MCwado setting configuration - String Keys and corresponding String Values
ToolkitVersion | Mergecom Toolkit version

See Also

MCwado Class


MCwado Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado Fields
MCwado Class See Also Send Feedback

The MCwado type exposes the following members.

Fields

Name | Description
Name | Class name "MCWADO"

See Also

MCwado Class


Name Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..Name Field
MCwado Class See Also Send Feedback
Class name "MCWADO"

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string Name
Visual Basic
Public Shared ReadOnly Name As String
Visual C++
public:
static initonly String^ Name

See Also

MCwado Class
MCwado Members


MCwado Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado Methods
MCwado Class See Also Send Feedback

Methods

Name | Description
AddObject(Object, String) | Register a singletone Object of given name in MCwado object holder
AddObject(Object, Type) | Register a singletone Object of given Type in MCwado object holder
GetObject(String) | Gets a singletone Object of given name registered in MCwado object holder
GetObject(Type) | Gets a singletone Object of given Type registered in MCwado object holder
Init()()()() | Initializes MCwado singleton instance
Init(FileInfo) | Initializes MCwado singleton instance
Init(FileInfo, String) | Initializes MCwado singleton instance

See Also

MCwado Class


AddObject Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..AddObject Method
MCwado Class See Also Send Feedback

Overload List

Name | Description
AddObject(Object, String) | Register a singletone Object of given name in MCwado object holder
AddObject(Object, Type) | Register a singletone Object of given Type in MCwado object holder

See Also

MCwado Class
MCwado Members


AddObject Method (Object, String)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..AddObject Method (Object, String)
MCwado Class See Also Send Feedback
Register a singletone Object of given name in MCwado object holder

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static void AddObject(
    Object obj,
    string name
)
Visual Basic
Public Shared Sub AddObject ( _
    obj As Object, _
    name As String _
)
Visual C++
public:
static void AddObject(
    Object^ obj,
    String^ name
)

Parameters

obj
Type: System..::..Object
Object to register
name
Type: System..::..String
Name of registered object

See Also

MCwado Class
MCwado Members
AddObject Overload


AddObject Method (Object, Type)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..AddObject Method (Object, Type)
MCwado Class See Also Send Feedback
Register a singletone Object of given Type in MCwado object holder

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static void AddObject(
    Object obj,
    Type type
)
Visual Basic
Public Shared Sub AddObject ( _
    obj As Object, _
    type As Type _
)
Visual C++
public:
static void AddObject(
    Object^ obj,
    Type^ type
)

Parameters

obj
Type: System..::..Object
Object to register
type
Type: System..::..Type
Type of registered object

See Also

MCwado Class
MCwado Members
AddObject Overload


GetObject Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..GetObject Method
MCwado Class See Also Send Feedback

Overload List

Name | Description
GetObject(String) | Gets a singletone Object of given name registered in MCwado object holder
GetObject(Type) | Gets a singletone Object of given Type registered in MCwado object holder

See Also

MCwado Class
MCwado Members


GetObject Method (String)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..GetObject Method (String)
MCwado Class See Also Send Feedback
Gets a singletone Object of given name registered in MCwado object holder

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static Object GetObject(
    string name
)
Visual Basic
Public Shared Function GetObject ( _
    name As String _
) As Object
Visual C++
public:
static Object^ GetObject(
    String^ name
)

Parameters

name
Type: System..::..String
Name of requested object

Return Value

Object or null

See Also

MCwado Class
MCwado Members
GetObject Overload


GetObject Method (Type)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..GetObject Method (Type)
MCwado Class See Also Send Feedback
Gets a singletone Object of given Type registered in MCwado object holder

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static Object GetObject(
    Type type
)
Visual Basic
Public Shared Function GetObject ( _
    type As Type _
) As Object
Visual C++
public:
static Object^ GetObject(
    Type^ type
)

Parameters

type
Type: System..::..Type
Type of requested object

Return Value

Object or null

See Also

MCwado Class
MCwado Members
GetObject Overload


Init Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..Init Method
MCwado Class See Also Send Feedback

Overload List

Name | Description
Init()()()() | Initializes MCwado singleton instance
Init(FileInfo) | Initializes MCwado singleton instance
Init(FileInfo, String) | Initializes MCwado singleton instance

See Also

MCwado Class
MCwado Members


Init Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..Init Method
MCwado Class See Also Send Feedback
Initializes MCwado singleton instance

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static void Init()
Visual Basic
Public Shared Sub Init
Visual C++
public:
static void Init()

See Also

MCwado Class
MCwado Members
Init Overload


Init Method (FileInfo)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..Init Method (FileInfo)
MCwado Class See Also Send Feedback
Initializes MCwado singleton instance

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static void Init(
    FileInfo mergeInifile
)
Visual Basic
Public Shared Sub Init ( _
    mergeInifile As FileInfo _
)
Visual C++
public:
static void Init(
    FileInfo^ mergeInifile
)

Parameters

mergeInifile
Type: System.IO..::..FileInfo
FileInfo of MERGE.INI file

See Also

MCwado Class
MCwado Members
Init Overload


Init Method (FileInfo, String)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..Init Method (FileInfo, String)
MCwado Class See Also Send Feedback
Initializes MCwado singleton instance

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static void Init(
    FileInfo mergeInifile,
    string license
)
Visual Basic
Public Shared Sub Init ( _
    mergeInifile As FileInfo, _
    license As String _
)
Visual C++
public:
static void Init(
    FileInfo^ mergeInifile,
    String^ license
)

Parameters

mergeInifile
Type: System.IO..::..FileInfo
FileInfo of MERGE.INI file
license
Type: System..::..String
Mergecom Toolkit license

See Also

MCwado Class
MCwado Members
Init Overload


MCwado Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado Properties
MCwado Class See Also Send Feedback

The MCwado type exposes the following members.

Properties

Name | Description
BulkDataHandler | Gets and sets registered IMCbulkDataHandler object used to associate Bulk Data and Meta Data using unique BulkDataURI
Cache | Gets and sets registered DICOM cache service
DicomKeywords | Dictionary<(Of <(<'TKey, TValue>)>)> of DICOM tags and corresponding keywords
DicomRenderer | Gets and sets registered IMCdicomRenderer object to convert DICOM service response into an array of Stream objects
HttpConverter | Gets and sets registered IMChttpConverter object to convert DICOM streams into an array of HttpContent objects
HttpResponder | Gets and sets registered IMChttpResponder object to create HttpResponseMessage object from an array of HttpContent objects
Service | Gets and sets registered DICOM service
Settings | Dictionary<(Of <(<'TKey, TValue>)>)> of MCwado setting configuration - String Keys and corresponding String Values
ToolkitVersion | Mergecom Toolkit version

See Also

MCwado Class


BulkDataHandler Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..BulkDataHandler Property
MCwado Class See Also Send Feedback
Gets and sets registered IMCbulkDataHandler object used to associate Bulk Data and Meta Data using unique BulkDataURI

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IMCbulkDataHandler BulkDataHandler { get; set; }
Visual Basic
Public Shared Property BulkDataHandler As IMCbulkDataHandler
    Get
    Set
Visual C++
public:
static property IMCbulkDataHandler^ BulkDataHandler {
    IMCbulkDataHandler^ get ();
    void set (IMCbulkDataHandler^ value);
}

See Also

MCwado Class
MCwado Members


Cache Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..Cache Property
MCwado Class See Also Send Feedback
Gets and sets registered DICOM cache service

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IMCcache Cache { get; set; }
Visual Basic
Public Shared Property Cache As IMCcache
    Get
    Set
Visual C++
public:
static property IMCcache^ Cache {
    IMCcache^ get ();
    void set (IMCcache^ value);
}

See Also

MCwado Class
MCwado Members


DicomKeywords Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..DicomKeywords Property
MCwado Class See Also Send Feedback
Dictionary<(Of <(<'TKey, TValue>)>)> of DICOM tags and corresponding keywords

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static Dictionary<uint, string> DicomKeywords { get; }
Visual Basic
Public Shared ReadOnly Property DicomKeywords As Dictionary(Of UInteger, String)
    Get
Visual C++
public:
static property Dictionary<unsigned int, String^>^ DicomKeywords {
    Dictionary<unsigned int, String^>^ get ();
}

See Also

MCwado Class
MCwado Members


DicomRenderer Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..DicomRenderer Property
MCwado Class See Also Send Feedback
Gets and sets registered IMCdicomRenderer object to convert DICOM service response into an array of Stream objects

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IMCdicomRenderer DicomRenderer { get; set; }
Visual Basic
Public Shared Property DicomRenderer As IMCdicomRenderer
    Get
    Set
Visual C++
public:
static property IMCdicomRenderer^ DicomRenderer {
    IMCdicomRenderer^ get ();
    void set (IMCdicomRenderer^ value);
}

See Also

MCwado Class
MCwado Members


HttpConverter Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..HttpConverter Property
MCwado Class See Also Send Feedback
Gets and sets registered IMChttpConverter object to convert DICOM streams into an array of HttpContent objects

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IMChttpConverter HttpConverter { get; set; }
Visual Basic
Public Shared Property HttpConverter As IMChttpConverter
    Get
    Set
Visual C++
public:
static property IMChttpConverter^ HttpConverter {
    IMChttpConverter^ get ();
    void set (IMChttpConverter^ value);
}

See Also

MCwado Class
MCwado Members


HttpResponder Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..HttpResponder Property
MCwado Class See Also Send Feedback
Gets and sets registered IMChttpResponder object to create HttpResponseMessage object from an array of HttpContent objects

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IMChttpResponder HttpResponder { get; set; }
Visual Basic
Public Shared Property HttpResponder As IMChttpResponder
    Get
    Set
Visual C++
public:
static property IMChttpResponder^ HttpResponder {
    IMChttpResponder^ get ();
    void set (IMChttpResponder^ value);
}

See Also

MCwado Class
MCwado Members


Service Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..Service Property
MCwado Class See Also Send Feedback
Gets and sets registered DICOM service

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IMCservice Service { get; set; }
Visual Basic
Public Shared Property Service As IMCservice
    Get
    Set
Visual C++
public:
static property IMCservice^ Service {
    IMCservice^ get ();
    void set (IMCservice^ value);
}

See Also

MCwado Class
MCwado Members


Settings Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..Settings Property
MCwado Class See Also Send Feedback
Dictionary<(Of <(<'TKey, TValue>)>)> of MCwado setting configuration - String Keys and corresponding String Values

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IDictionary<string, string> Settings { get; }
Visual Basic
Public Shared ReadOnly Property Settings As IDictionary(Of String, String)
    Get
Visual C++
public:
static property IDictionary<String^, String^>^ Settings {
    IDictionary<String^, String^>^ get ();
}

See Also

MCwado Class
MCwado Members


ToolkitVersion Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..ToolkitVersion Property
MCwado Class See Also Send Feedback
Mergecom Toolkit version

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static string ToolkitVersion { get; private set; }
Visual Basic
Public Shared Property ToolkitVersion As String
    Get
    Private Set
Visual C++
public:
static property String^ ToolkitVersion {
    String^ get ();
    private: void set (String^ value);
}

See Also

MCwado Class
MCwado Members


MCwado.Configuration Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..Configuration Class
MCwado Class Members See Also Send Feedback
MCwado configuration settings

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static class Configuration
Visual Basic
Public NotInheritable Class Configuration
Visual C++
public ref class Configuration abstract sealed

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCwado..::..Configuration

See Also

MCwado..::..Configuration Members


MCwado.Configuration Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..Configuration Members
MCwado..::..Configuration Class Fields See Also Send Feedback

The MCwado..::..Configuration type exposes the following members.

Fields

Name | Description
Names | Available MCwado configuration settings
WADO_RESPONSE_TYPE | Specifies Content-Type of WADO response of DICOM service - DICOM, Native DICOM Xml or DICOM Json

See Also

MCwado..::..Configuration Class


MCwado.Configuration Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..Configuration Fields
MCwado..::..Configuration Class See Also Send Feedback

The MCwado..::..Configuration type exposes the following members.

Fields

Name | Description
Names | Available MCwado configuration settings
WADO_RESPONSE_TYPE | Specifies Content-Type of WADO response of DICOM service - DICOM, Native DICOM Xml or DICOM Json

See Also

MCwado..::..Configuration Class


Names Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..Configuration..::..Names Field
MCwado..::..Configuration Class See Also Send Feedback
Available MCwado configuration settings

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IEnumerable<string> Names
Visual Basic
Public Shared Names As IEnumerable(Of String)
Visual C++
public:
static IEnumerable<String^>^ Names

See Also

MCwado..::..Configuration Class
MCwado..::..Configuration Members


WADO_RESPONSE_TYPE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwado..::..Configuration..::..WADO_RESPONSE_TYPE Field
MCwado..::..Configuration Class See Also Send Feedback
Specifies Content-Type of WADO response of DICOM service - DICOM, Native DICOM Xml or DICOM Json

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string WADO_RESPONSE_TYPE
Visual Basic
Public Shared ReadOnly WADO_RESPONSE_TYPE As String
Visual C++
public:
static initonly String^ WADO_RESPONSE_TYPE

See Also

MCwado..::..Configuration Class
MCwado..::..Configuration Members


MCwadoRsRequest Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest Class
Members See Also Send Feedback
Converts and encapsulates HttpRequestMessage data from WADO-RS request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCwadoRsRequest : MCdicomRequest
Visual Basic
Public Class MCwadoRsRequest _
    Inherits MCdicomRequest
Visual C++
public ref class MCwadoRsRequest : public MCdicomRequest

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCdicomRequest
Mergecomws.Dicom..::..MCwadoRsRequest

See Also

MCwadoRsRequest Members


MCwadoRsRequest Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest Members
MCwadoRsRequest Class Methods Fields Properties See Also Send Feedback

The MCwadoRsRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Inherited from MCdicomRequest.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves WADO-RS MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Overrides MCdicomRequest..::..GetLevel()()()().)
Public method | GetMessages | Generates a list of MCabstractMessage based on MCparameter data (Inherited from MCdicomRequest.)
Public method | GetModel | Gets MCparameter list of WADO-RS model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Overrides MCdicomRequest..::..GetRoot()()()().)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Overrides MCdicomRequest..::..GetSegments()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Overrides MCdicomRequest..::..PopulateParameter(MCparameter, KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)).)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM WADO-RS request (Overrides MCdicomRequest..::..ValidateRequest()()()().)

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCwadoRsRequest Class


MCwadoRsRequest Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest Fields
MCwadoRsRequest Class See Also Send Feedback

The MCwadoRsRequest type exposes the following members.

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

See Also

MCwadoRsRequest Class


MCwadoRsRequest Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest Methods
MCwadoRsRequest Class See Also Send Feedback

The MCwadoRsRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Inherited from MCdicomRequest.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves WADO-RS MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Overrides MCdicomRequest..::..GetLevel()()()().)
Public method | GetMessages | Generates a list of MCabstractMessage based on MCparameter data (Inherited from MCdicomRequest.)
Public method | GetModel | Gets MCparameter list of WADO-RS model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Overrides MCdicomRequest..::..GetRoot()()()().)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Overrides MCdicomRequest..::..GetSegments()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Overrides MCdicomRequest..::..PopulateParameter(MCparameter, KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)).)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM WADO-RS request (Overrides MCdicomRequest..::..ValidateRequest()()()().)

See Also

MCwadoRsRequest Class


GetActionType Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest..::..GetActionType Method
MCwadoRsRequest Class See Also Send Feedback
Retrieves WADO-RS MCactionType from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetActionType()
Visual Basic
Protected Overrides Sub GetActionType
Visual C++
protected:
virtual void GetActionType() override

See Also

MCwadoRsRequest Class
MCwadoRsRequest Members


GetHeaders Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest..::..GetHeaders Method
MCwadoRsRequest Class See Also Send Feedback
Retrieves Http Header data from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetHeaders()
Visual Basic
Protected Overrides Sub GetHeaders
Visual C++
protected:
virtual void GetHeaders() override

See Also

MCwadoRsRequest Class
MCwadoRsRequest Members


GetLevel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest..::..GetLevel Method
MCwadoRsRequest Class See Also Send Feedback
Gets MCdicomLevel value of DICOM request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetLevel()
Visual Basic
Protected Overrides Sub GetLevel
Visual C++
protected:
virtual void GetLevel() override

See Also

MCwadoRsRequest Class
MCwadoRsRequest Members


GetModel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest..::..GetModel Method
MCwadoRsRequest Class See Also Send Feedback
Gets MCparameter list of WADO-RS model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override IList<MCparameter> GetModel()
Visual Basic
Public Overrides Function GetModel As IList(Of MCparameter)
Visual C++
public:
virtual IList<MCparameter^>^ GetModel() override

Return Value

MCparameter list

See Also

MCwadoRsRequest Class
MCwadoRsRequest Members


GetQueries Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest..::..GetQueries Method
MCwadoRsRequest Class See Also Send Feedback
Retrieves Http Query from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetQueries()
Visual Basic
Protected Overrides Sub GetQueries
Visual C++
protected:
virtual void GetQueries() override

See Also

MCwadoRsRequest Class
MCwadoRsRequest Members


GetRoot Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest..::..GetRoot Method
MCwadoRsRequest Class See Also Send Feedback
Gets MCdicomRoot value of DICOM request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetRoot()
Visual Basic
Protected Overrides Sub GetRoot
Visual C++
protected:
virtual void GetRoot() override

See Also

MCwadoRsRequest Class
MCwadoRsRequest Members


GetSegments Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest..::..GetSegments Method
MCwadoRsRequest Class See Also Send Feedback
Retrieves MCparameter from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetSegments()
Visual Basic
Protected Overrides Sub GetSegments
Visual C++
protected:
virtual void GetSegments() override

See Also

MCwadoRsRequest Class
MCwadoRsRequest Members


PopulateParameter Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest..::..PopulateParameter Method
MCwadoRsRequest Class See Also Send Feedback
Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override bool PopulateParameter(
    MCparameter parm,
    KeyValuePair<string, IEnumerable<string>> pair
)
Visual Basic
Protected Overrides Function PopulateParameter ( _
    parm As MCparameter, _
    pair As KeyValuePair(Of String, IEnumerable(Of String)) _
) As Boolean
Visual C++
protected:
virtual bool PopulateParameter(
    MCparameter^ parm,
    KeyValuePair<String^, IEnumerable<String^>^> pair
) override

Parameters

parm
Type: Mergecomws.Web..::..MCparameter
MCparameter object
pair
Type: System.Collections.Generic..::..KeyValuePair<(Of <(<'String, IEnumerable<(Of <(<'String>)>)>>)>)>
KeyValuePair<(Of <(<'TKey, TValue>)>)> pair

Return Value

CopyC#
True
 is successful

See Also

MCwadoRsRequest Class
MCwadoRsRequest Members


supportedMediaTypes Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest..::..supportedMediaTypes Method
MCwadoRsRequest Class See Also Send Feedback
Gets the list of supported MCmediaType of the current request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override IEnumerable<MCmediaType> supportedMediaTypes()
Visual Basic
Protected Overrides Function supportedMediaTypes As IEnumerable(Of MCmediaType)
Visual C++
protected:
virtual IEnumerable<MCmediaType^>^ supportedMediaTypes() override

Return Value

List of MCmediaType objects

See Also

MCwadoRsRequest Class
MCwadoRsRequest Members


ValidateRequest Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest..::..ValidateRequest Method
MCwadoRsRequest Class See Also Send Feedback
Validates DICOM WADO-RS request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override bool ValidateRequest()
Visual Basic
Public Overrides Function ValidateRequest As Boolean
Visual C++
public:
virtual bool ValidateRequest() override

Return Value

Returns True if MCwadoRsRequest has valid data and MCactionType

See Also

MCwadoRsRequest Class
MCwadoRsRequest Members


MCwadoRsRequest Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest Properties
MCwadoRsRequest Class See Also Send Feedback

The MCwadoRsRequest type exposes the following members.

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCwadoRsRequest Class


SupportedMediaTypes Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsRequest..::..SupportedMediaTypes Property
MCwadoRsRequest Class See Also Send Feedback
Gets and sets the list of supported MCmediaType for specific MCrequestType request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IEnumerable<MCmediaType> SupportedMediaTypes { get; protected set; }
Visual Basic
Public Shared Property SupportedMediaTypes As IEnumerable(Of MCmediaType)
    Get
    Protected Set
Visual C++
public:
static property IEnumerable<MCmediaType^>^ SupportedMediaTypes {
    IEnumerable<MCmediaType^>^ get ();
    protected: void set (IEnumerable<MCmediaType^>^ value);
}

See Also

MCwadoRsRequest Class
MCwadoRsRequest Members


MCwadoUriRequest Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriRequest Class
Members See Also Send Feedback
Converts and encapsulates HttpRequestMessage data from WADO-URI request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCwadoUriRequest : MCdicomRequest
Visual Basic
Public Class MCwadoUriRequest _
    Inherits MCdicomRequest
Visual C++
public ref class MCwadoUriRequest : public MCdicomRequest

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCdicomRequest
Mergecomws.Dicom..::..MCwadoUriRequest

See Also

MCwadoUriRequest Members


MCwadoUriRequest Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriRequest Members
MCwadoUriRequest Class Methods Fields Properties See Also Send Feedback

The MCwadoUriRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Inherited from MCdicomRequest.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves MCactionType from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Overrides MCdicomRequest..::..GetLevel()()()().)
Public method | GetMessages | Generates a list of MCabstractMessage based on MCparameter data (Inherited from MCdicomRequest.)
Public method | GetModel | Gets MCparameter list of WADO-URI model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Inherited from MCdicomRequest.)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Inherited from MCdicomRequest.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Overrides MCdicomRequest..::..PopulateParameter(MCparameter, KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)).)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM WADO-URI request (Overrides MCdicomRequest..::..ValidateRequest()()()().)

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCwadoUriRequest Class


MCwadoUriRequest Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriRequest Fields
MCwadoUriRequest Class See Also Send Feedback

The MCwadoUriRequest type exposes the following members.

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

See Also

MCwadoUriRequest Class


MCwadoUriRequest Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriRequest Methods
MCwadoUriRequest Class See Also Send Feedback

The MCwadoUriRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Inherited from MCdicomRequest.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves MCactionType from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Content from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object (Overrides MCdicomRequest..::..GetHeaders()()()().)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Overrides MCdicomRequest..::..GetLevel()()()().)
Public method | GetMessages | Generates a list of MCabstractMessage based on MCparameter data (Inherited from MCdicomRequest.)
Public method | GetModel | Gets MCparameter list of WADO-URI model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Inherited from MCdicomRequest.)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Inherited from MCdicomRequest.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Overrides MCdicomRequest..::..PopulateParameter(MCparameter, KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)).)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM WADO-URI request (Overrides MCdicomRequest..::..ValidateRequest()()()().)

See Also

MCwadoUriRequest Class


GetHeaders Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriRequest..::..GetHeaders Method
MCwadoUriRequest Class See Also Send Feedback
Retrieves Http Header data from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetHeaders()
Visual Basic
Protected Overrides Sub GetHeaders
Visual C++
protected:
virtual void GetHeaders() override

See Also

MCwadoUriRequest Class
MCwadoUriRequest Members


GetLevel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriRequest..::..GetLevel Method
MCwadoUriRequest Class See Also Send Feedback
Gets MCdicomLevel value of DICOM request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetLevel()
Visual Basic
Protected Overrides Sub GetLevel
Visual C++
protected:
virtual void GetLevel() override

See Also

MCwadoUriRequest Class
MCwadoUriRequest Members


GetModel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriRequest..::..GetModel Method
MCwadoUriRequest Class See Also Send Feedback
Gets MCparameter list of WADO-URI model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override IList<MCparameter> GetModel()
Visual Basic
Public Overrides Function GetModel As IList(Of MCparameter)
Visual C++
public:
virtual IList<MCparameter^>^ GetModel() override

Return Value

MCparameter list

See Also

MCwadoUriRequest Class
MCwadoUriRequest Members


GetQueries Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriRequest..::..GetQueries Method
MCwadoUriRequest Class See Also Send Feedback
Retrieves Http Query from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetQueries()
Visual Basic
Protected Overrides Sub GetQueries
Visual C++
protected:
virtual void GetQueries() override

See Also

MCwadoUriRequest Class
MCwadoUriRequest Members


PopulateParameter Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriRequest..::..PopulateParameter Method
MCwadoUriRequest Class See Also Send Feedback
Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override bool PopulateParameter(
    MCparameter parm,
    KeyValuePair<string, IEnumerable<string>> pair
)
Visual Basic
Protected Overrides Function PopulateParameter ( _
    parm As MCparameter, _
    pair As KeyValuePair(Of String, IEnumerable(Of String)) _
) As Boolean
Visual C++
protected:
virtual bool PopulateParameter(
    MCparameter^ parm,
    KeyValuePair<String^, IEnumerable<String^>^> pair
) override

Parameters

parm
Type: Mergecomws.Web..::..MCparameter
MCparameter object
pair
Type: System.Collections.Generic..::..KeyValuePair<(Of <(<'String, IEnumerable<(Of <(<'String>)>)>>)>)>
KeyValuePair<(Of <(<'TKey, TValue>)>)> pair

Return Value

CopyC#
True
 is successful

See Also

MCwadoUriRequest Class
MCwadoUriRequest Members


supportedMediaTypes Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriRequest..::..supportedMediaTypes Method
MCwadoUriRequest Class See Also Send Feedback
Gets the list of supported MCmediaType of the current request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override IEnumerable<MCmediaType> supportedMediaTypes()
Visual Basic
Protected Overrides Function supportedMediaTypes As IEnumerable(Of MCmediaType)
Visual C++
protected:
virtual IEnumerable<MCmediaType^>^ supportedMediaTypes() override

Return Value

List of MCmediaType objects

See Also

MCwadoUriRequest Class
MCwadoUriRequest Members


ValidateRequest Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriRequest..::..ValidateRequest Method
MCwadoUriRequest Class See Also Send Feedback
Validates DICOM WADO-URI request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override bool ValidateRequest()
Visual Basic
Public Overrides Function ValidateRequest As Boolean
Visual C++
public:
virtual bool ValidateRequest() override

Return Value

Returns True if MCwadoUriRequest has valid data and MCactionType

See Also

MCwadoUriRequest Class
MCwadoUriRequest Members


MCwadoUriRequest Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriRequest Properties
MCwadoUriRequest Class See Also Send Feedback

The MCwadoUriRequest type exposes the following members.

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCwadoUriRequest Class


SupportedMediaTypes Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriRequest..::..SupportedMediaTypes Property
MCwadoUriRequest Class See Also Send Feedback
Gets and sets the list of supported MCmediaType for specific MCrequestType request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IEnumerable<MCmediaType> SupportedMediaTypes { get; protected set; }
Visual Basic
Public Shared Property SupportedMediaTypes As IEnumerable(Of MCmediaType)
    Get
    Protected Set
Visual C++
public:
static property IEnumerable<MCmediaType^>^ SupportedMediaTypes {
    IEnumerable<MCmediaType^>^ get ();
    protected: void set (IEnumerable<MCmediaType^>^ value);
}

See Also

MCwadoUriRequest Class
MCwadoUriRequest Members


MCwadoWsDocument Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsDocument Class
Members See Also Send Feedback
Encapsulates and converts Soap WADO-WS message

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCwadoWsDocument
Visual Basic
Public Class MCwadoWsDocument
Visual C++
public ref class MCwadoWsDocument

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCwadoWsDocument

See Also

MCwadoWsDocument Members


MCwadoWsDocument Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsDocument Members
MCwadoWsDocument Class Constructors Methods See Also Send Feedback

The MCwadoWsDocument type exposes the following members.

Constructors

 | Name | Description
Public method | MCwadoWsDocument | Initializes a new instance of the MCwadoWsDocument class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRequestMessages | Generates an array of MCabstractMessage objects from MCwadoWsMessage data
 | GetResponseMessages | Generates MCwadoWsMessage object from DICOM service response using XML string of MCparameter request parameters
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCwadoWsDocument Class


MCwadoWsDocument Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsDocument Constructor
MCwadoWsDocument Class See Also Send Feedback
Initializes a new instance of the MCwadoWsDocument class

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCwadoWsDocument()
Visual Basic
Public Sub New
Visual C++
public:
MCwadoWsDocument()

See Also

MCwadoWsDocument Class
MCwadoWsDocument Members


MCwadoWsDocument Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsDocument Methods
MCwadoWsDocument Class See Also Send Feedback

The MCwadoWsDocument type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRequestMessages | Generates an array of MCabstractMessage objects from MCwadoWsMessage data
 | GetResponseMessages | Generates MCwadoWsMessage object from DICOM service response using XML string of MCparameter request parameters
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCwadoWsDocument Class


GetRequestMessages Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsDocument..::..GetRequestMessages Method
MCwadoWsDocument Class See Also Send Feedback
Generates an array of MCabstractMessage objects from MCwadoWsMessage data

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCabstractMessage[] GetRequestMessages(
    MCwadoWsMessage wadoWsMessage
)
Visual Basic
Public Shared Function GetRequestMessages ( _
    wadoWsMessage As MCwadoWsMessage _
) As MCabstractMessage()
Visual C++
public:
static array<MCabstractMessage^>^ GetRequestMessages(
    MCwadoWsMessage^ wadoWsMessage
)

Parameters

wadoWsMessage
Type: Mergecomws.Dicom..::..MCwadoWsMessage
MCwadoWsMessage object

Return Value

An array of MCabstractMessage objects

See Also

MCwadoWsDocument Class
MCwadoWsDocument Members


GetResponseMessages Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsDocument..::..GetResponseMessages Method
MCwadoWsDocument Class See Also Send Feedback
Generates MCwadoWsMessage object from DICOM service response using XML string of MCparameter request parameters

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCwadoWsMessage GetResponseMessages(
    MCabstractMessage[] response,
    string xmlRequestParameters,
    ref string xmlWadoResponse
)
Visual Basic
Public Shared Function GetResponseMessages ( _
    response As MCabstractMessage(), _
    xmlRequestParameters As String, _
    ByRef xmlWadoResponse As String _
) As MCwadoWsMessage
Visual C++
public:
static MCwadoWsMessage^ GetResponseMessages(
    array<MCabstractMessage^>^ response,
    String^ xmlRequestParameters,
    String^% xmlWadoResponse
)

Parameters

response
Type: array<MCabstractMessage>[]()[][]
DICOM service response
xmlRequestParameters
Type: System..::..String
XML string of MCparameter parameters used for WADO request
xmlWadoResponse
Type: System..::..String%
WADO response from DICOM service encoded as XML String

Return Value

MCwadoWsMessage object

See Also

MCwadoWsDocument Class
MCwadoWsDocument Members


MCwadoWsMessage Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage Class
Members See Also Send Feedback
MCwadoWsMessage class to encapsulate the properties of Soap WADO-WS request/response

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCwadoWsMessage
Visual Basic
Public Class MCwadoWsMessage
Visual C++
public ref class MCwadoWsMessage

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCwadoWsMessage

See Also

MCwadoWsMessage Members


MCwadoWsMessage Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage Members
MCwadoWsMessage Class Constructors Methods Properties See Also Send Feedback

The MCwadoWsMessage type exposes the following members.

Constructors

 | Name | Description
Public method | MCwadoWsMessage(Boolean) | Constructor of MCwadoWsMessage
Public method | MCwadoWsMessage(Boolean, String) | Constructor of MCwadoWsMessage

Methods

 | Name | Description
Public method | Clear | Clear the content of Soap WADO-WS message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the content of Soap WADO-WS message as a String (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Action | Gets and sets an action property of Soap WADO-WS message
Public property | ActionType | Returns MCactionType of Soap WADO-WS message
Public property | Body | Returns XmlNode Body element of Soap WADO-WS message
Public property | BodyContent | Gets and sets an Xml string content of Soap WADO-WS message
Public property | Envelope | Returns XmlNode Envelope element of Soap WADO-WS message
Public property | Header | Returns XmlNode Header element of Soap WADO-WS message
Public property | IsRequest | Returns True if message is Soap WADO-WS request
Public property | MessageID | Gets and sets a messageID property of Soap WADO-WS message
Public property | NamespaceManager | Returns XmlNamespaceManager namespace manager of Soap WADO-WS message
Public property | ReplyToAddress | Gets and sets an Http address property of Soap WADO-WS message is sent from
Public property | Root | Returns XmlDocument root element of Soap WADO-WS message
Public property | ToAddress | Gets and sets an Http address property of Soap WADO-WS message is sent to
Public property | XopDocuments | Returns an array of MCwadoWsMessage..::..XopDocument instances of current MCwadoWsMessage object

See Also

MCwadoWsMessage Class


MCwadoWsMessage Constructor

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage Constructor
MCwadoWsMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCwadoWsMessage(Boolean) | Constructor of MCwadoWsMessage
Public method | MCwadoWsMessage(Boolean, String) | Constructor of MCwadoWsMessage

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


MCwadoWsMessage Constructor (Boolean)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage Constructor (Boolean)
MCwadoWsMessage Class See Also Send Feedback
Constructor of MCwadoWsMessage

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCwadoWsMessage(
    bool isRequest
)
Visual Basic
Public Sub New ( _
    isRequest As Boolean _
)
Visual C++
public:
MCwadoWsMessage(
    bool isRequest
)

Parameters

isRequest
Type: System..::..Boolean
True if message is Soap WADO-WS request

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members
MCwadoWsMessage Overload


MCwadoWsMessage Constructor (Boolean, String)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage Constructor (Boolean, String)
MCwadoWsMessage Class See Also Send Feedback
Constructor of MCwadoWsMessage

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCwadoWsMessage(
    bool isRequest,
    string soapMessage
)
Visual Basic
Public Sub New ( _
    isRequest As Boolean, _
    soapMessage As String _
)
Visual C++
public:
MCwadoWsMessage(
    bool isRequest,
    String^ soapMessage
)

Parameters

isRequest
Type: System..::..Boolean
True if message is Soap WADO-WS request
soapMessage
Type: System..::..String
Xml String content of Soap WADO-WS message

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members
MCwadoWsMessage Overload


MCwadoWsMessage Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage Methods
MCwadoWsMessage Class See Also Send Feedback

The MCwadoWsMessage type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clear the content of Soap WADO-WS message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the content of Soap WADO-WS message as a String (Overrides Object..::..ToString()()()().)

See Also

MCwadoWsMessage Class


Clear Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Clear Method
MCwadoWsMessage Class See Also Send Feedback
Clear the content of Soap WADO-WS message

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


ToString Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..ToString Method
MCwadoWsMessage Class See Also Send Feedback
Returns the content of Soap WADO-WS message as a String

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string that represents the current object.

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


MCwadoWsMessage Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage Properties
MCwadoWsMessage Class See Also Send Feedback

The MCwadoWsMessage type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets and sets an action property of Soap WADO-WS message
Public property | ActionType | Returns MCactionType of Soap WADO-WS message
Public property | Body | Returns XmlNode Body element of Soap WADO-WS message
Public property | BodyContent | Gets and sets an Xml string content of Soap WADO-WS message
Public property | Envelope | Returns XmlNode Envelope element of Soap WADO-WS message
Public property | Header | Returns XmlNode Header element of Soap WADO-WS message
Public property | IsRequest | Returns True if message is Soap WADO-WS request
Public property | MessageID | Gets and sets a messageID property of Soap WADO-WS message
Public property | NamespaceManager | Returns XmlNamespaceManager namespace manager of Soap WADO-WS message
Public property | ReplyToAddress | Gets and sets an Http address property of Soap WADO-WS message is sent from
Public property | Root | Returns XmlDocument root element of Soap WADO-WS message
Public property | ToAddress | Gets and sets an Http address property of Soap WADO-WS message is sent to
Public property | XopDocuments | Returns an array of MCwadoWsMessage..::..XopDocument instances of current MCwadoWsMessage object

See Also

MCwadoWsMessage Class


Action Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Action Property
MCwadoWsMessage Class See Also Send Feedback
Gets and sets an action property of Soap WADO-WS message

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Action { get; set; }
Visual Basic
Public Property Action As String
    Get
    Set
Visual C++
public:
property String^ Action {
    String^ get ();
    void set (String^ value);
}

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


ActionType Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..ActionType Property
MCwadoWsMessage Class See Also Send Feedback
Returns MCactionType of Soap WADO-WS message

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCactionType ActionType { get; }
Visual Basic
Public ReadOnly Property ActionType As MCactionType
    Get
Visual C++
public:
property MCactionType^ ActionType {
    MCactionType^ get ();
}

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


Body Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Body Property
MCwadoWsMessage Class See Also Send Feedback
Returns XmlNode Body element of Soap WADO-WS message

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public XmlNode Body { get; }
Visual Basic
Public ReadOnly Property Body As XmlNode
    Get
Visual C++
public:
property XmlNode^ Body {
    XmlNode^ get ();
}

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


BodyContent Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..BodyContent Property
MCwadoWsMessage Class See Also Send Feedback
Gets and sets an Xml string content of Soap WADO-WS message

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string BodyContent { get; set; }
Visual Basic
Public Property BodyContent As String
    Get
    Set
Visual C++
public:
property String^ BodyContent {
    String^ get ();
    void set (String^ value);
}

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


Envelope Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Envelope Property
MCwadoWsMessage Class See Also Send Feedback
Returns XmlNode Envelope element of Soap WADO-WS message

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public XmlNode Envelope { get; }
Visual Basic
Public ReadOnly Property Envelope As XmlNode
    Get
Visual C++
public:
property XmlNode^ Envelope {
    XmlNode^ get ();
}

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


Header Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Header Property
MCwadoWsMessage Class See Also Send Feedback
Returns XmlNode Header element of Soap WADO-WS message

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public XmlNode Header { get; }
Visual Basic
Public ReadOnly Property Header As XmlNode
    Get
Visual C++
public:
property XmlNode^ Header {
    XmlNode^ get ();
}

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


IsRequest Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..IsRequest Property
MCwadoWsMessage Class See Also Send Feedback
Returns True if message is Soap WADO-WS request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public bool IsRequest { get; private set; }
Visual Basic
Public Property IsRequest As Boolean
    Get
    Private Set
Visual C++
public:
property bool IsRequest {
    bool get ();
    private: void set (bool value);
}

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


MessageID Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..MessageID Property
MCwadoWsMessage Class See Also Send Feedback
Gets and sets a messageID property of Soap WADO-WS message

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string MessageID { get; set; }
Visual Basic
Public Property MessageID As String
    Get
    Set
Visual C++
public:
property String^ MessageID {
    String^ get ();
    void set (String^ value);
}

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


NamespaceManager Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..NamespaceManager Property
MCwadoWsMessage Class See Also Send Feedback
Returns XmlNamespaceManager namespace manager of Soap WADO-WS message

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public XmlNamespaceManager NamespaceManager { get; private set; }
Visual Basic
Public Property NamespaceManager As XmlNamespaceManager
    Get
    Private Set
Visual C++
public:
property XmlNamespaceManager^ NamespaceManager {
    XmlNamespaceManager^ get ();
    private: void set (XmlNamespaceManager^ value);
}

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


ReplyToAddress Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..ReplyToAddress Property
MCwadoWsMessage Class See Also Send Feedback
Gets and sets an Http address property of Soap WADO-WS message is sent from

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string ReplyToAddress { get; set; }
Visual Basic
Public Property ReplyToAddress As String
    Get
    Set
Visual C++
public:
property String^ ReplyToAddress {
    String^ get ();
    void set (String^ value);
}

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


Root Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Root Property
MCwadoWsMessage Class See Also Send Feedback
Returns XmlDocument root element of Soap WADO-WS message

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public XmlDocument Root { get; private set; }
Visual Basic
Public Property Root As XmlDocument
    Get
    Private Set
Visual C++
public:
property XmlDocument^ Root {
    XmlDocument^ get ();
    private: void set (XmlDocument^ value);
}

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


ToAddress Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..ToAddress Property
MCwadoWsMessage Class See Also Send Feedback
Gets and sets an Http address property of Soap WADO-WS message is sent to

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string ToAddress { get; set; }
Visual Basic
Public Property ToAddress As String
    Get
    Set
Visual C++
public:
property String^ ToAddress {
    String^ get ();
    void set (String^ value);
}

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


XopDocuments Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..XopDocuments Property
MCwadoWsMessage Class See Also Send Feedback
Returns an array of MCwadoWsMessage..::..XopDocument instances of current MCwadoWsMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCwadoWsMessage..::..XopDocument[] XopDocuments { get; }
Visual Basic
Public ReadOnly Property XopDocuments As MCwadoWsMessage..::..XopDocument()
    Get
Visual C++
public:
property array<MCwadoWsMessage..::..XopDocument^>^ XopDocuments {
    array<MCwadoWsMessage..::..XopDocument^>^ get ();
}

See Also

MCwadoWsMessage Class
MCwadoWsMessage Members


MCwadoWsMessage.Names Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names Class
MCwadoWsMessage Class Members See Also Send Feedback
List of names used in WADO-WS XSD Schema PS3.18 2014c WebServices E.1 WADO WS XSD Schema (Informative)

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static class Names
Visual Basic
Public NotInheritable Class Names
Visual C++
public ref class Names abstract sealed

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCwadoWsMessage..::..Names

See Also

MCwadoWsMessage..::..Names Members


MCwadoWsMessage.Names Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names Members
MCwadoWsMessage..::..Names Class Fields See Also Send Feedback

The MCwadoWsMessage..::..Names type exposes the following members.

Fields

Name | Description
DOCUMENT | Document
DOCUMENT_REQUEST | DocumentRequest
DOCUMENT_RESPONSE | DocumentResponse
IMAGING_DOCUMENT_REQUEST | ImagingDocumentRequest
IMAGING_DOCUMENT_RESPONSE | ImagingDocumentResponse
INFORMATION_DOCUMENT_REQUEST | DocumentInformationRequest
INFORMATION_DOCUMENT_RESPONSE | DocumentInformationResponse
REGISTRY_RESPONSE | RegistryResponse
RENDERED_DOCUMENT_REQUEST | DocumentInformationRequest
RENDERED_DOCUMENT_RESPONSE | RenderedDocumentSetResponse
RETRIEVE_DOCUMENT_REQUEST | RetrieveDocumentSetRequest
RETRIEVE_DOCUMENT_RESPONSE | RetrieveDocumentSetResponse
RETRIEVE_IMAGING_DOCUMENT_REQUEST | RetrieveImagingDocumentSetRequest
RETRIEVE_INFORMATION_DOCUMENT_REQUEST | RetrieveImagingDocumentSetInformationRequest
RETRIEVE_INFORMATION_DOCUMENT_RESPONSE | RetrieveImagingDocumentSetInformationResponse
RETRIEVE_RENDERED_DOCUMENT_REQUEST | RetrieveRenderedImagingDocumentSetRequest
RETRIEVE_RENDERED_DOCUMENT_RESPONSE | RetrieveRenderedImagingDocumentSetResponse
SERIES_REQUEST | SeriesRequest
STUDY_REQUEST | StudyRequest

See Also

MCwadoWsMessage..::..Names Class


MCwadoWsMessage.Names Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names Fields
MCwadoWsMessage..::..Names Class See Also Send Feedback

The MCwadoWsMessage..::..Names type exposes the following members.

Fields

Name | Description
DOCUMENT | Document
DOCUMENT_REQUEST | DocumentRequest
DOCUMENT_RESPONSE | DocumentResponse
IMAGING_DOCUMENT_REQUEST | ImagingDocumentRequest
IMAGING_DOCUMENT_RESPONSE | ImagingDocumentResponse
INFORMATION_DOCUMENT_REQUEST | DocumentInformationRequest
INFORMATION_DOCUMENT_RESPONSE | DocumentInformationResponse
REGISTRY_RESPONSE | RegistryResponse
RENDERED_DOCUMENT_REQUEST | DocumentInformationRequest
RENDERED_DOCUMENT_RESPONSE | RenderedDocumentSetResponse
RETRIEVE_DOCUMENT_REQUEST | RetrieveDocumentSetRequest
RETRIEVE_DOCUMENT_RESPONSE | RetrieveDocumentSetResponse
RETRIEVE_IMAGING_DOCUMENT_REQUEST | RetrieveImagingDocumentSetRequest
RETRIEVE_INFORMATION_DOCUMENT_REQUEST | RetrieveImagingDocumentSetInformationRequest
RETRIEVE_INFORMATION_DOCUMENT_RESPONSE | RetrieveImagingDocumentSetInformationResponse
RETRIEVE_RENDERED_DOCUMENT_REQUEST | RetrieveRenderedImagingDocumentSetRequest
RETRIEVE_RENDERED_DOCUMENT_RESPONSE | RetrieveRenderedImagingDocumentSetResponse
SERIES_REQUEST | SeriesRequest
STUDY_REQUEST | StudyRequest

See Also

MCwadoWsMessage..::..Names Class


DOCUMENT Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..DOCUMENT Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
Document

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string DOCUMENT
Visual Basic
Public Shared ReadOnly DOCUMENT As String
Visual C++
public:
static initonly String^ DOCUMENT

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


DOCUMENT_REQUEST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..DOCUMENT_REQUEST Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
DocumentRequest

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string DOCUMENT_REQUEST
Visual Basic
Public Shared ReadOnly DOCUMENT_REQUEST As String
Visual C++
public:
static initonly String^ DOCUMENT_REQUEST

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


DOCUMENT_RESPONSE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..DOCUMENT_RESPONSE Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
DocumentResponse

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string DOCUMENT_RESPONSE
Visual Basic
Public Shared ReadOnly DOCUMENT_RESPONSE As String
Visual C++
public:
static initonly String^ DOCUMENT_RESPONSE

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


IMAGING_DOCUMENT_REQUEST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..IMAGING_DOCUMENT_REQUEST Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
ImagingDocumentRequest

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string IMAGING_DOCUMENT_REQUEST
Visual Basic
Public Shared ReadOnly IMAGING_DOCUMENT_REQUEST As String
Visual C++
public:
static initonly String^ IMAGING_DOCUMENT_REQUEST

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


IMAGING_DOCUMENT_RESPONSE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..IMAGING_DOCUMENT_RESPONSE Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
ImagingDocumentResponse

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string IMAGING_DOCUMENT_RESPONSE
Visual Basic
Public Shared ReadOnly IMAGING_DOCUMENT_RESPONSE As String
Visual C++
public:
static initonly String^ IMAGING_DOCUMENT_RESPONSE

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


INFORMATION_DOCUMENT_REQUEST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..INFORMATION_DOCUMENT_REQUEST Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
DocumentInformationRequest

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string INFORMATION_DOCUMENT_REQUEST
Visual Basic
Public Shared ReadOnly INFORMATION_DOCUMENT_REQUEST As String
Visual C++
public:
static initonly String^ INFORMATION_DOCUMENT_REQUEST

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


INFORMATION_DOCUMENT_RESPONSE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..INFORMATION_DOCUMENT_RESPONSE Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
DocumentInformationResponse

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string INFORMATION_DOCUMENT_RESPONSE
Visual Basic
Public Shared ReadOnly INFORMATION_DOCUMENT_RESPONSE As String
Visual C++
public:
static initonly String^ INFORMATION_DOCUMENT_RESPONSE

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


REGISTRY_RESPONSE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..REGISTRY_RESPONSE Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
RegistryResponse

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string REGISTRY_RESPONSE
Visual Basic
Public Shared ReadOnly REGISTRY_RESPONSE As String
Visual C++
public:
static initonly String^ REGISTRY_RESPONSE

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


RENDERED_DOCUMENT_REQUEST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..RENDERED_DOCUMENT_REQUEST Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
DocumentInformationRequest

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string RENDERED_DOCUMENT_REQUEST
Visual Basic
Public Shared ReadOnly RENDERED_DOCUMENT_REQUEST As String
Visual C++
public:
static initonly String^ RENDERED_DOCUMENT_REQUEST

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


RENDERED_DOCUMENT_RESPONSE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..RENDERED_DOCUMENT_RESPONSE Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
RenderedDocumentSetResponse

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string RENDERED_DOCUMENT_RESPONSE
Visual Basic
Public Shared ReadOnly RENDERED_DOCUMENT_RESPONSE As String
Visual C++
public:
static initonly String^ RENDERED_DOCUMENT_RESPONSE

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


RETRIEVE_DOCUMENT_REQUEST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..RETRIEVE_DOCUMENT_REQUEST Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
RetrieveDocumentSetRequest

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string RETRIEVE_DOCUMENT_REQUEST
Visual Basic
Public Shared ReadOnly RETRIEVE_DOCUMENT_REQUEST As String
Visual C++
public:
static initonly String^ RETRIEVE_DOCUMENT_REQUEST

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


RETRIEVE_DOCUMENT_RESPONSE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..RETRIEVE_DOCUMENT_RESPONSE Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
RetrieveDocumentSetResponse

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string RETRIEVE_DOCUMENT_RESPONSE
Visual Basic
Public Shared ReadOnly RETRIEVE_DOCUMENT_RESPONSE As String
Visual C++
public:
static initonly String^ RETRIEVE_DOCUMENT_RESPONSE

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


RETRIEVE_IMAGING_DOCUMENT_REQUEST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..RETRIEVE_IMAGING_DOCUMENT_REQUEST Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
RetrieveImagingDocumentSetRequest

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string RETRIEVE_IMAGING_DOCUMENT_REQUEST
Visual Basic
Public Shared ReadOnly RETRIEVE_IMAGING_DOCUMENT_REQUEST As String
Visual C++
public:
static initonly String^ RETRIEVE_IMAGING_DOCUMENT_REQUEST

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


RETRIEVE_INFORMATION_DOCUMENT_REQUEST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..RETRIEVE_INFORMATION_DOCUMENT_REQUEST Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
RetrieveImagingDocumentSetInformationRequest

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string RETRIEVE_INFORMATION_DOCUMENT_REQUEST
Visual Basic
Public Shared ReadOnly RETRIEVE_INFORMATION_DOCUMENT_REQUEST As String
Visual C++
public:
static initonly String^ RETRIEVE_INFORMATION_DOCUMENT_REQUEST

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


RETRIEVE_INFORMATION_DOCUMENT_RESPONSE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..RETRIEVE_INFORMATION_DOCUMENT_RESPONSE Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
RetrieveImagingDocumentSetInformationResponse

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string RETRIEVE_INFORMATION_DOCUMENT_RESPONSE
Visual Basic
Public Shared ReadOnly RETRIEVE_INFORMATION_DOCUMENT_RESPONSE As String
Visual C++
public:
static initonly String^ RETRIEVE_INFORMATION_DOCUMENT_RESPONSE

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


RETRIEVE_RENDERED_DOCUMENT_REQUEST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..RETRIEVE_RENDERED_DOCUMENT_REQUEST Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
RetrieveRenderedImagingDocumentSetRequest

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string RETRIEVE_RENDERED_DOCUMENT_REQUEST
Visual Basic
Public Shared ReadOnly RETRIEVE_RENDERED_DOCUMENT_REQUEST As String
Visual C++
public:
static initonly String^ RETRIEVE_RENDERED_DOCUMENT_REQUEST

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


RETRIEVE_RENDERED_DOCUMENT_RESPONSE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..RETRIEVE_RENDERED_DOCUMENT_RESPONSE Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
RetrieveRenderedImagingDocumentSetResponse

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string RETRIEVE_RENDERED_DOCUMENT_RESPONSE
Visual Basic
Public Shared ReadOnly RETRIEVE_RENDERED_DOCUMENT_RESPONSE As String
Visual C++
public:
static initonly String^ RETRIEVE_RENDERED_DOCUMENT_RESPONSE

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


SERIES_REQUEST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..SERIES_REQUEST Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
SeriesRequest

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string SERIES_REQUEST
Visual Basic
Public Shared ReadOnly SERIES_REQUEST As String
Visual C++
public:
static initonly String^ SERIES_REQUEST

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


STUDY_REQUEST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..Names..::..STUDY_REQUEST Field
MCwadoWsMessage..::..Names Class See Also Send Feedback
StudyRequest

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string STUDY_REQUEST
Visual Basic
Public Shared ReadOnly STUDY_REQUEST As String
Visual C++
public:
static initonly String^ STUDY_REQUEST

See Also

MCwadoWsMessage..::..Names Class
MCwadoWsMessage..::..Names Members


MCwadoWsMessage.XopDocument Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..XopDocument Class
MCwadoWsMessage Class Members See Also Send Feedback
XOP (XML-binary Optimized Packaging) document

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class XopDocument
Visual Basic
Public Class XopDocument
Visual C++
public ref class XopDocument

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCwadoWsMessage..::..XopDocument

See Also

MCwadoWsMessage..::..XopDocument Members


MCwadoWsMessage.XopDocument Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..XopDocument Members
MCwadoWsMessage..::..XopDocument Class Constructors Methods Properties See Also Send Feedback

The MCwadoWsMessage..::..XopDocument type exposes the following members.

Constructors

 | Name | Description
Public method | MCwadoWsMessage..::..XopDocument | Constructor

Methods

 | Name | Description
Public method | Clear | Reset instance content
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Data | Document binary data
Public property | DocumentUniqueId | Document unique ID
Public property | XopIncludeUid | GUID of xop:Include element
Public property | XopIncludeXml | xop:Include element

See Also

MCwadoWsMessage..::..XopDocument Class


MCwadoWsMessage.XopDocument Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..XopDocument Constructor
MCwadoWsMessage..::..XopDocument Class See Also Send Feedback
Constructor

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public XopDocument()
Visual Basic
Public Sub New
Visual C++
public:
XopDocument()

See Also

MCwadoWsMessage..::..XopDocument Class
MCwadoWsMessage..::..XopDocument Members


MCwadoWsMessage.XopDocument Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..XopDocument Methods
MCwadoWsMessage..::..XopDocument Class See Also Send Feedback

The MCwadoWsMessage..::..XopDocument type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Reset instance content
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCwadoWsMessage..::..XopDocument Class


Clear Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..XopDocument..::..Clear Method
MCwadoWsMessage..::..XopDocument Class See Also Send Feedback
Reset instance content

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

MCwadoWsMessage..::..XopDocument Class
MCwadoWsMessage..::..XopDocument Members


MCwadoWsMessage.XopDocument Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..XopDocument Properties
MCwadoWsMessage..::..XopDocument Class See Also Send Feedback

The MCwadoWsMessage..::..XopDocument type exposes the following members.

Properties

 | Name | Description
Public property | Data | Document binary data
Public property | DocumentUniqueId | Document unique ID
Public property | XopIncludeUid | GUID of xop:Include element
Public property | XopIncludeXml | xop:Include element

See Also

MCwadoWsMessage..::..XopDocument Class


Data Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..XopDocument..::..Data Property
MCwadoWsMessage..::..XopDocument Class See Also Send Feedback
Document binary data

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public byte[] Data { get; set; }
Visual Basic
Public Property Data As Byte()
    Get
    Set
Visual C++
public:
property array<unsigned char>^ Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

MCwadoWsMessage..::..XopDocument Class
MCwadoWsMessage..::..XopDocument Members


DocumentUniqueId Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..XopDocument..::..DocumentUniqueId Property
MCwadoWsMessage..::..XopDocument Class See Also Send Feedback
Document unique ID

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string DocumentUniqueId { get; set; }
Visual Basic
Public Property DocumentUniqueId As String
    Get
    Set
Visual C++
public:
property String^ DocumentUniqueId {
    String^ get ();
    void set (String^ value);
}

See Also

MCwadoWsMessage..::..XopDocument Class
MCwadoWsMessage..::..XopDocument Members


XopIncludeUid Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..XopDocument..::..XopIncludeUid Property
MCwadoWsMessage..::..XopDocument Class See Also Send Feedback
GUID of xop:Include element

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string XopIncludeUid { get; set; }
Visual Basic
Public Property XopIncludeUid As String
    Get
    Set
Visual C++
public:
property String^ XopIncludeUid {
    String^ get ();
    void set (String^ value);
}

See Also

MCwadoWsMessage..::..XopDocument Class
MCwadoWsMessage..::..XopDocument Members


XopIncludeXml Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsMessage..::..XopDocument..::..XopIncludeXml Property
MCwadoWsMessage..::..XopDocument Class See Also Send Feedback
xop:Include element

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string XopIncludeXml { get; set; }
Visual Basic
Public Property XopIncludeXml As String
    Get
    Set
Visual C++
public:
property String^ XopIncludeXml {
    String^ get ();
    void set (String^ value);
}

See Also

MCwadoWsMessage..::..XopDocument Class
MCwadoWsMessage..::..XopDocument Members


MCwadoWsRequest Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsRequest Class
Members See Also Send Feedback
Converts and encapsulates HttpRequestMessage data from WADO-WS request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCwadoWsRequest : MCdicomRequest
Visual Basic
Public Class MCwadoWsRequest _
    Inherits MCdicomRequest
Visual C++
public ref class MCwadoWsRequest : public MCdicomRequest

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCdicomRequest
Mergecomws.Dicom..::..MCwadoWsRequest

See Also

MCwadoWsRequest Members


MCwadoWsRequest Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsRequest Members
MCwadoWsRequest Class Methods Fields Properties See Also Send Feedback

The MCwadoWsRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Inherited from MCdicomRequest.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves WADO-WS MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Header data from HttpRequestMessage (Overrides MCdicomRequest..::..GetContent()()()().)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Overrides MCdicomRequest..::..GetLevel()()()().)
Public method | GetMessages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Overrides MCdicomRequest..::..GetMessages()()()().)
Public method | GetModel | Gets MCparameter list of WADO-WS model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Inherited from MCdicomRequest.)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Inherited from MCdicomRequest.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM request (Inherited from MCdicomRequest.)

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCwadoWsRequest Class


MCwadoWsRequest Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsRequest Fields
MCwadoWsRequest Class See Also Send Feedback

The MCwadoWsRequest type exposes the following members.

Fields

 | Name | Description
Protected field | httpContents | Contains the list of HttpContent objects of Http message (Inherited from MCdicomRequest.)
Protected field | messages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Inherited from MCdicomRequest.)

See Also

MCwadoWsRequest Class


MCwadoWsRequest Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsRequest Methods
MCwadoWsRequest Class See Also Send Feedback

The MCwadoWsRequest type exposes the following members.

Methods

 | Name | Description
Protected method | CheckStudyInstanceUID | Checks if DICOM messages contain valid MCdicom.STUDY_INSTANCE_UID attribute (Inherited from MCdicomRequest.)
Protected method | CompleteRequest | Updates and completes MCdimseMessage object from DICOM request model (Inherited from MCdicomRequest.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | FailRequest | Sets the error and status code of the current request, RequestActionType is set to Undefined. (Inherited from MCdicomRequest.)
Protected method | FillParameterAttributes | Complete the request MCdimseMessage object using the list of MCparameters and DICOM request model. (Inherited from MCdicomRequest.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetActionType | Retrieves WADO-WS MCactionType from HttpRequestMessage object (Overrides MCdicomRequest..::..GetActionType()()()().)
Protected method | GetAttribute | Gets MCrequestAttribute instance for given Attribute ID string (Inherited from MCdicomRequest.)
Protected method | GetContent()()()() | Retrieves Http Header data from HttpRequestMessage (Overrides MCdicomRequest..::..GetContent()()()().)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHeaders | Retrieves Http Header data from HttpRequestMessage object (Inherited from MCdicomRequest.)
Protected method | GetLevel | Gets MCdicomLevel value of DICOM request model (Overrides MCdicomRequest..::..GetLevel()()()().)
Public method | GetMessages | Generates a list of request MCabstractMessage based on HttpRequestMessage data (Overrides MCdicomRequest..::..GetMessages()()()().)
Public method | GetModel | Gets MCparameter list of WADO-WS model (Overrides MCdicomRequest..::..GetModel()()()().)
Protected method | GetParameter(KeyValuePair<(Of <<'(String, IEnumerable<(Of <<'(String>)>>)>)>>)) | Gets MCparameter instance for given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | GetParameter(MCrequestAttribute) | Gets MCparameter instance with given MCrequestAttribute objects (Inherited from MCdicomRequest.)
Protected method | GetQueries | Retrieves Http Query from HttpRequestMessage object (Overrides MCdicomRequest..::..GetQueries()()()().)
Protected method | GetResponseTypeParameter | Gets MCparameter instance for given MCdicomRequest (Inherited from MCdicomRequest.)
Protected method | GetRoot | Gets MCdicomRoot value of DICOM request model (Inherited from MCdicomRequest.)
Protected method | GetSegments | Retrieves MCparameter from HttpRequestMessage object (Inherited from MCdicomRequest.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlParameters | Encodes the list of MCparameter of current request into XML String (Inherited from MCdicomRequest.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseContent | Parses HTTP multipart content (Inherited from MCdicomRequest.)
Public method | Populate | Populates MCdicomRequest internal data with HttpRequestMessage object data (Inherited from MCdicomRequest.)
Protected method | PopulateParameter | Populates MCparameter object using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | ReadContentAsync | Asynchronously reads HTTP multi-part content (Inherited from MCdicomRequest.)
Protected method | SetAttribute | Sets MCrequestAttribute values using given KeyValuePair<(Of <(<'TKey, TValue>)>)> pair (Inherited from MCdicomRequest.)
Protected method | supportedMediaTypes | Gets the list of supported MCmediaType of the current request (Overrides MCdicomRequest..::..supportedMediaTypes()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateParameter | Validates MCparameter object (Inherited from MCdicomRequest.)
Public method | ValidateRequest | Validates DICOM request (Inherited from MCdicomRequest.)

See Also

MCwadoWsRequest Class


GetActionType Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsRequest..::..GetActionType Method
MCwadoWsRequest Class See Also Send Feedback
Retrieves WADO-WS MCactionType from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetActionType()
Visual Basic
Protected Overrides Sub GetActionType
Visual C++
protected:
virtual void GetActionType() override

See Also

MCwadoWsRequest Class
MCwadoWsRequest Members


GetContent Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsRequest..::..GetContent Method
MCwadoWsRequest Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetContent()()()() | Retrieves Http Header data from HttpRequestMessage (Overrides MCdicomRequest..::..GetContent()()()().)
Protected method | GetContent(HttpContent, IEnumerable<(Of <<'(MCmediaType>)>>)) | (Inherited from MCdicomRequest.)

See Also

MCwadoWsRequest Class
MCwadoWsRequest Members


GetContent Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsRequest..::..GetContent Method
MCwadoWsRequest Class See Also Send Feedback
Retrieves Http Header data from HttpRequestMessage

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetContent()
Visual Basic
Protected Overrides Sub GetContent
Visual C++
protected:
virtual void GetContent() override

See Also

MCwadoWsRequest Class
MCwadoWsRequest Members
GetContent Overload


GetLevel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsRequest..::..GetLevel Method
MCwadoWsRequest Class See Also Send Feedback
Gets MCdicomLevel value of DICOM request model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetLevel()
Visual Basic
Protected Overrides Sub GetLevel
Visual C++
protected:
virtual void GetLevel() override

See Also

MCwadoWsRequest Class
MCwadoWsRequest Members


GetMessages Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsRequest..::..GetMessages Method
MCwadoWsRequest Class See Also Send Feedback
Generates a list of request MCabstractMessage based on HttpRequestMessage data

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override IEnumerable<MCabstractMessage> GetMessages()
Visual Basic
Public Overrides Function GetMessages As IEnumerable(Of MCabstractMessage)
Visual C++
public:
virtual IEnumerable<MCabstractMessage^>^ GetMessages() override

Return Value

Collection of MCabstractMessage objects.

See Also

MCwadoWsRequest Class
MCwadoWsRequest Members


GetModel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsRequest..::..GetModel Method
MCwadoWsRequest Class See Also Send Feedback
Gets MCparameter list of WADO-WS model

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override IList<MCparameter> GetModel()
Visual Basic
Public Overrides Function GetModel As IList(Of MCparameter)
Visual C++
public:
virtual IList<MCparameter^>^ GetModel() override

Return Value

MCparameter list

See Also

MCwadoWsRequest Class
MCwadoWsRequest Members


GetQueries Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsRequest..::..GetQueries Method
MCwadoWsRequest Class See Also Send Feedback
Retrieves Http Query from HttpRequestMessage object

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override void GetQueries()
Visual Basic
Protected Overrides Sub GetQueries
Visual C++
protected:
virtual void GetQueries() override

See Also

MCwadoWsRequest Class
MCwadoWsRequest Members


supportedMediaTypes Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsRequest..::..supportedMediaTypes Method
MCwadoWsRequest Class See Also Send Feedback
Gets the list of supported MCmediaType of the current request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected override IEnumerable<MCmediaType> supportedMediaTypes()
Visual Basic
Protected Overrides Function supportedMediaTypes As IEnumerable(Of MCmediaType)
Visual C++
protected:
virtual IEnumerable<MCmediaType^>^ supportedMediaTypes() override

Return Value

List of MCmediaType objects

See Also

MCwadoWsRequest Class
MCwadoWsRequest Members


MCwadoWsRequest Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsRequest Properties
MCwadoWsRequest Class See Also Send Feedback

The MCwadoWsRequest type exposes the following members.

Properties

 | Name | Description
Protected property | HttpAccept | Gets the content of Accept field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCacheControl | Gets the content of Cache-Control field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpCharset | Gets the content of Charset field in Http header (Inherited from MCdicomRequest.)
Protected property | HttpContentLength | Gets the value of Content-Length field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpContentType | Gets the content of content-Type field in Http Header (Inherited from MCdicomRequest.)
Protected property | HttpProvider | Gets IMChttpProvider object of current request (Inherited from MCdicomRequest.)
Public property | HttpStatusCode | Gets and sets HttpStatusCode of current request to report any of the associated error and warning. (Inherited from MCdicomRequest.)
Public property | HttpStatusMessage | Gets and sets the error String content for HttpResponseMessage of current request (Inherited from MCdicomRequest.)
Protected property | HttpTransferEncoding | Gets the content of Transfer-Encoding field in Http Header (Inherited from MCdicomRequest.)
Public property | RequestActionType | Gets MCactionType of current request (Inherited from MCdicomRequest.)
Public property | RequestLevel | Gets and sets MCdicomLevel of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestParameters | Gets the list of MCparameter of current request (Inherited from MCdicomRequest.)
Public property | RequestRoot | Gets and sets MCdicomRoot of DICOM request model (Inherited from MCdicomRequest.)
Public property | RequestType | Gets MCrequestType of current request (Inherited from MCdicomRequest.)
 | SupportedMediaTypes | Gets and sets the list of supported MCmediaType for specific MCrequestType request

See Also

MCwadoWsRequest Class


SupportedMediaTypes Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsRequest..::..SupportedMediaTypes Property
MCwadoWsRequest Class See Also Send Feedback
Gets and sets the list of supported MCmediaType for specific MCrequestType request

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IEnumerable<MCmediaType> SupportedMediaTypes { get; protected set; }
Visual Basic
Public Shared Property SupportedMediaTypes As IEnumerable(Of MCmediaType)
    Get
    Protected Set
Visual C++
public:
static property IEnumerable<MCmediaType^>^ SupportedMediaTypes {
    IEnumerable<MCmediaType^>^ get ();
    protected: void set (IEnumerable<MCmediaType^>^ value);
}

See Also

MCwadoWsRequest Class
MCwadoWsRequest Members


MCwadoWsResponse Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse Class
Members See Also Send Feedback
Encapsulates and converts WADO-WS DICOM service response into HttpResponseMessage data

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCwadoWsResponse : MCdicomResponse
Visual Basic
Public Class MCwadoWsResponse _
    Inherits MCdicomResponse
Visual C++
public ref class MCwadoWsResponse : public MCdicomResponse

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCdicomResponse
Mergecomws.Dicom..::..MCwadoWsResponse

See Also

MCwadoWsResponse Members


MCwadoWsResponse Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse Members
MCwadoWsResponse Class Methods Fields Properties See Also Send Feedback

The MCwadoWsResponse type exposes the following members.

Methods

 | Name | Description
Public method | CreateHttpResponseMessage | Creates internal HttpResponseMessage object from DICOM service response (Inherited from MCdicomResponse.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHttpResponseMessage | Returns internal HttpResponseMessage object created from DICOM service response with CreateHttpResponseMessage(array<MCabstractMessage>[]()[][], String, String) (Inherited from MCdicomResponse.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name Description
Protected field httpResponseMessage
Internal HttpResponseMessage object created by
CopyC#
CreateHttpResponseMessage
 method
(Inherited from MCdicomResponse.)

Properties

 | Name | Description
Public property | DicomRenderer | Gets and sets DICOM renderer of DICOM service response (Inherited from MCdicomResponse.)
Public property | HttpConverter | Gets and sets Http converter of DICOM stream data from IMCdicomRenderer object (Inherited from MCdicomResponse.)
Public property | HttpResponder | Gets and sets Http response message creator which uses Http multipart content from IMChttpConverter object (Inherited from MCdicomResponse.)
Public property | RequestType | Gets MCrequestType for the current response (Inherited from MCdicomResponse.)

See Also

MCwadoWsResponse Class


MCwadoWsResponse Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse Fields
MCwadoWsResponse Class See Also Send Feedback

The MCwadoWsResponse type exposes the following members.

Fields

Name Description
Protected field httpResponseMessage
Internal HttpResponseMessage object created by
CopyC#
CreateHttpResponseMessage
 method
(Inherited from MCdicomResponse.)

See Also

MCwadoWsResponse Class


MCwadoWsResponse Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse Methods
MCwadoWsResponse Class See Also Send Feedback

The MCwadoWsResponse type exposes the following members.

Methods

 | Name | Description
Public method | CreateHttpResponseMessage | Creates internal HttpResponseMessage object from DICOM service response (Inherited from MCdicomResponse.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHttpResponseMessage | Returns internal HttpResponseMessage object created from DICOM service response with CreateHttpResponseMessage(array<MCabstractMessage>[]()[][], String, String) (Inherited from MCdicomResponse.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCwadoWsResponse Class


MCwadoWsResponse Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse Properties
MCwadoWsResponse Class See Also Send Feedback

The MCwadoWsResponse type exposes the following members.

Properties

 | Name | Description
Public property | DicomRenderer | Gets and sets DICOM renderer of DICOM service response (Inherited from MCdicomResponse.)
Public property | HttpConverter | Gets and sets Http converter of DICOM stream data from IMCdicomRenderer object (Inherited from MCdicomResponse.)
Public property | HttpResponder | Gets and sets Http response message creator which uses Http multipart content from IMChttpConverter object (Inherited from MCdicomResponse.)
Public property | RequestType | Gets MCrequestType for the current response (Inherited from MCdicomResponse.)

See Also

MCwadoWsResponse Class


MCwadoWsResponse.Error Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error Class
MCwadoWsResponse Class Members See Also Send Feedback
Describes WADO-WS response errors

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class Error
Visual Basic
Public Class Error
Visual C++
public ref class Error

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCwadoWsResponse..::..Error

See Also

MCwadoWsResponse..::..Error Members


MCwadoWsResponse.Error Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error Members
MCwadoWsResponse..::..Error Class Methods Fields Properties See Also Send Feedback

The MCwadoWsResponse..::..Error type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
WADO_0001 | Unable to anonymize the requested instance(s).
WADO_0002 | Web Server does not support anonymization.
WADO_0003 | The requested instance(s) are not immediately available, but can be made available by manual request.
WADO_0004 | Instance is no longer available, e.g., document retention rules have caused it to be removed or relocated.
WADO_0005 | The requested instance(s) cannot be returned because the size or count exceeds resource limits.
WADO_0006 | Web Server does not support the requested format or transfer syntax.
WADO_0007 | The requested instance(s) cannot be provided in the requested format or transfer syntax.
WADO_0008 | Single image format is not available for multi-frame images.
WADO_0009 | Identifier does not match SOP Class (see PS3.7 C-MOVE).
WADO_0010 | Inconsistent identifiers, e.g., Study and Series are correct but Series is in a different Study (see PS3.7 C-MOVE).
WADO_0011 | SOP Class not supported (see PS3.7 C-MOVE).
WADO_0012 | Invalid parameter value in request (see PS3.7 C-MOVE).
WADO_0013 | Unsupported parameter in request (see PS3.7 C-MOVE).
WADO_0014 | Processing Failure (see PS3.7 C-MOVE).
WADO_0015 | Study Instance UID not known.
WADO_0016 | Series Instance UID not known.
WADO_0017 | Document UID not known.
WADO_0018 | Out of range Frame number.
WADO_0019 | Presentation UID not known.
WADO_0020 | Presentation Series UID not known.

Properties

 | Name | Description
Public property | Code | Error code
Public property | Situation | Error situation

See Also

MCwadoWsResponse..::..Error Class


MCwadoWsResponse.Error Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error Fields
MCwadoWsResponse..::..Error Class See Also Send Feedback

The MCwadoWsResponse..::..Error type exposes the following members.

Fields

Name | Description
WADO_0001 | Unable to anonymize the requested instance(s).
WADO_0002 | Web Server does not support anonymization.
WADO_0003 | The requested instance(s) are not immediately available, but can be made available by manual request.
WADO_0004 | Instance is no longer available, e.g., document retention rules have caused it to be removed or relocated.
WADO_0005 | The requested instance(s) cannot be returned because the size or count exceeds resource limits.
WADO_0006 | Web Server does not support the requested format or transfer syntax.
WADO_0007 | The requested instance(s) cannot be provided in the requested format or transfer syntax.
WADO_0008 | Single image format is not available for multi-frame images.
WADO_0009 | Identifier does not match SOP Class (see PS3.7 C-MOVE).
WADO_0010 | Inconsistent identifiers, e.g., Study and Series are correct but Series is in a different Study (see PS3.7 C-MOVE).
WADO_0011 | SOP Class not supported (see PS3.7 C-MOVE).
WADO_0012 | Invalid parameter value in request (see PS3.7 C-MOVE).
WADO_0013 | Unsupported parameter in request (see PS3.7 C-MOVE).
WADO_0014 | Processing Failure (see PS3.7 C-MOVE).
WADO_0015 | Study Instance UID not known.
WADO_0016 | Series Instance UID not known.
WADO_0017 | Document UID not known.
WADO_0018 | Out of range Frame number.
WADO_0019 | Presentation UID not known.
WADO_0020 | Presentation Series UID not known.

See Also

MCwadoWsResponse..::..Error Class


WADO_0001 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0001 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Unable to anonymize the requested instance(s).

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0001
Visual Basic
Public Shared ReadOnly WADO_0001 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0001

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0002 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0002 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Web Server does not support anonymization.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0002
Visual Basic
Public Shared ReadOnly WADO_0002 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0002

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0003 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0003 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
The requested instance(s) are not immediately available, but can be made available by manual request.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0003
Visual Basic
Public Shared ReadOnly WADO_0003 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0003

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0004 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0004 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Instance is no longer available, e.g., document retention rules have caused it to be removed or relocated.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0004
Visual Basic
Public Shared ReadOnly WADO_0004 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0004

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0005 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0005 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
The requested instance(s) cannot be returned because the size or count exceeds resource limits.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0005
Visual Basic
Public Shared ReadOnly WADO_0005 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0005

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0006 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0006 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Web Server does not support the requested format or transfer syntax.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0006
Visual Basic
Public Shared ReadOnly WADO_0006 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0006

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0007 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0007 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
The requested instance(s) cannot be provided in the requested format or transfer syntax.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0007
Visual Basic
Public Shared ReadOnly WADO_0007 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0007

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0008 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0008 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Single image format is not available for multi-frame images.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0008
Visual Basic
Public Shared ReadOnly WADO_0008 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0008

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0009 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0009 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Identifier does not match SOP Class (see PS3.7 C-MOVE).

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0009
Visual Basic
Public Shared ReadOnly WADO_0009 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0009

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0010 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0010 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Inconsistent identifiers, e.g., Study and Series are correct but Series is in a different Study (see PS3.7 C-MOVE).

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0010
Visual Basic
Public Shared ReadOnly WADO_0010 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0010

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0011 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0011 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
SOP Class not supported (see PS3.7 C-MOVE).

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0011
Visual Basic
Public Shared ReadOnly WADO_0011 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0011

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0012 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0012 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Invalid parameter value in request (see PS3.7 C-MOVE).

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0012
Visual Basic
Public Shared ReadOnly WADO_0012 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0012

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0013 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0013 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Unsupported parameter in request (see PS3.7 C-MOVE).

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0013
Visual Basic
Public Shared ReadOnly WADO_0013 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0013

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0014 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0014 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Processing Failure (see PS3.7 C-MOVE).

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0014
Visual Basic
Public Shared ReadOnly WADO_0014 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0014

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0015 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0015 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Study Instance UID not known.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0015
Visual Basic
Public Shared ReadOnly WADO_0015 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0015

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0016 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0016 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Series Instance UID not known.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0016
Visual Basic
Public Shared ReadOnly WADO_0016 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0016

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0017 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0017 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Document UID not known.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0017
Visual Basic
Public Shared ReadOnly WADO_0017 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0017

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0018 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0018 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Out of range Frame number.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0018
Visual Basic
Public Shared ReadOnly WADO_0018 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0018

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0019 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0019 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Presentation UID not known.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0019
Visual Basic
Public Shared ReadOnly WADO_0019 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0019

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


WADO_0020 Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..WADO_0020 Field
MCwadoWsResponse..::..Error Class See Also Send Feedback
Presentation Series UID not known.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Error WADO_0020
Visual Basic
Public Shared ReadOnly WADO_0020 As MCwadoWsResponse..::..Error
Visual C++
public:
static initonly MCwadoWsResponse..::..Error^ WADO_0020

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


MCwadoWsResponse.Error Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error Methods
MCwadoWsResponse..::..Error Class See Also Send Feedback

The MCwadoWsResponse..::..Error type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCwadoWsResponse..::..Error Class


MCwadoWsResponse.Error Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error Properties
MCwadoWsResponse..::..Error Class See Also Send Feedback

The MCwadoWsResponse..::..Error type exposes the following members.

Properties

 | Name | Description
Public property | Code | Error code
Public property | Situation | Error situation

See Also

MCwadoWsResponse..::..Error Class


Code Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..Code Property
MCwadoWsResponse..::..Error Class See Also Send Feedback
Error code

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Code { get; private set; }
Visual Basic
Public Property Code As String
    Get
    Private Set
Visual C++
public:
property String^ Code {
    String^ get ();
    private: void set (String^ value);
}

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


Situation Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Error..::..Situation Property
MCwadoWsResponse..::..Error Class See Also Send Feedback
Error situation

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Situation { get; private set; }
Visual Basic
Public Property Situation As String
    Get
    Private Set
Visual C++
public:
property String^ Situation {
    String^ get ();
    private: void set (String^ value);
}

See Also

MCwadoWsResponse..::..Error Class
MCwadoWsResponse..::..Error Members


MCwadoWsResponse.Severity Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Severity Class
MCwadoWsResponse Class Members See Also Send Feedback
Describes WADO-WS error severity

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class Severity
Visual Basic
Public Class Severity
Visual C++
public ref class Severity

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCwadoWsResponse..::..Severity

See Also

MCwadoWsResponse..::..Severity Members


MCwadoWsResponse.Severity Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Severity Members
MCwadoWsResponse..::..Severity Class Methods Fields Properties See Also Send Feedback

The MCwadoWsResponse..::..Severity type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
ERROR | Error severity.
WARNING | Warning severity

Properties

 | Name | Description
Public property | Code | Error code

See Also

MCwadoWsResponse..::..Severity Class


MCwadoWsResponse.Severity Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Severity Fields
MCwadoWsResponse..::..Severity Class See Also Send Feedback

The MCwadoWsResponse..::..Severity type exposes the following members.

Fields

Name | Description
ERROR | Error severity.
WARNING | Warning severity

See Also

MCwadoWsResponse..::..Severity Class


ERROR Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Severity..::..ERROR Field
MCwadoWsResponse..::..Severity Class See Also Send Feedback
Error severity.

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Severity ERROR
Visual Basic
Public Shared ReadOnly ERROR As MCwadoWsResponse..::..Severity
Visual C++
public:
static initonly MCwadoWsResponse..::..Severity^ ERROR

See Also

MCwadoWsResponse..::..Severity Class
MCwadoWsResponse..::..Severity Members


WARNING Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Severity..::..WARNING Field
MCwadoWsResponse..::..Severity Class See Also Send Feedback
Warning severity

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Severity WARNING
Visual Basic
Public Shared ReadOnly WARNING As MCwadoWsResponse..::..Severity
Visual C++
public:
static initonly MCwadoWsResponse..::..Severity^ WARNING

See Also

MCwadoWsResponse..::..Severity Class
MCwadoWsResponse..::..Severity Members


MCwadoWsResponse.Severity Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Severity Methods
MCwadoWsResponse..::..Severity Class See Also Send Feedback

The MCwadoWsResponse..::..Severity type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCwadoWsResponse..::..Severity Class


MCwadoWsResponse.Severity Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Severity Properties
MCwadoWsResponse..::..Severity Class See Also Send Feedback

The MCwadoWsResponse..::..Severity type exposes the following members.

Properties

 | Name | Description
Public property | Code | Error code

See Also

MCwadoWsResponse..::..Severity Class


Code Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Severity..::..Code Property
MCwadoWsResponse..::..Severity Class See Also Send Feedback
Error code

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Code { get; private set; }
Visual Basic
Public Property Code As String
    Get
    Private Set
Visual C++
public:
property String^ Code {
    String^ get ();
    private: void set (String^ value);
}

See Also

MCwadoWsResponse..::..Severity Class
MCwadoWsResponse..::..Severity Members


MCwadoWsResponse.Status Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Status Class
MCwadoWsResponse Class Members See Also Send Feedback
Describes WADO-WS response status

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class Status
Visual Basic
Public Class Status
Visual C++
public ref class Status

Inheritance Hierarchy

System..::..Object
Mergecomws.Dicom..::..MCwadoWsResponse..::..Status

See Also

MCwadoWsResponse..::..Status Members


MCwadoWsResponse.Status Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Status Members
MCwadoWsResponse..::..Status Class Methods Fields Properties See Also Send Feedback

The MCwadoWsResponse..::..Status type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
FAILURE | Failure
PARTIAL_SUCCESS | Partial Success
SUCCESS | Success

Properties

 | Name | Description
Public property | Code | Status code

See Also

MCwadoWsResponse..::..Status Class


MCwadoWsResponse.Status Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Status Fields
MCwadoWsResponse..::..Status Class See Also Send Feedback

The MCwadoWsResponse..::..Status type exposes the following members.

Fields

Name | Description
FAILURE | Failure
PARTIAL_SUCCESS | Partial Success
SUCCESS | Success

See Also

MCwadoWsResponse..::..Status Class


FAILURE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Status..::..FAILURE Field
MCwadoWsResponse..::..Status Class See Also Send Feedback
Failure

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Status FAILURE
Visual Basic
Public Shared ReadOnly FAILURE As MCwadoWsResponse..::..Status
Visual C++
public:
static initonly MCwadoWsResponse..::..Status^ FAILURE

See Also

MCwadoWsResponse..::..Status Class
MCwadoWsResponse..::..Status Members


PARTIAL_SUCCESS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Status..::..PARTIAL_SUCCESS Field
MCwadoWsResponse..::..Status Class See Also Send Feedback
Partial Success

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Status PARTIAL_SUCCESS
Visual Basic
Public Shared ReadOnly PARTIAL_SUCCESS As MCwadoWsResponse..::..Status
Visual C++
public:
static initonly MCwadoWsResponse..::..Status^ PARTIAL_SUCCESS

See Also

MCwadoWsResponse..::..Status Class
MCwadoWsResponse..::..Status Members


SUCCESS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Status..::..SUCCESS Field
MCwadoWsResponse..::..Status Class See Also Send Feedback
Success

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly MCwadoWsResponse..::..Status SUCCESS
Visual Basic
Public Shared ReadOnly SUCCESS As MCwadoWsResponse..::..Status
Visual C++
public:
static initonly MCwadoWsResponse..::..Status^ SUCCESS

See Also

MCwadoWsResponse..::..Status Class
MCwadoWsResponse..::..Status Members


MCwadoWsResponse.Status Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Status Methods
MCwadoWsResponse..::..Status Class See Also Send Feedback

The MCwadoWsResponse..::..Status type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCwadoWsResponse..::..Status Class


MCwadoWsResponse.Status Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Status Properties
MCwadoWsResponse..::..Status Class See Also Send Feedback

The MCwadoWsResponse..::..Status type exposes the following members.

Properties

 | Name | Description
Public property | Code | Status code

See Also

MCwadoWsResponse..::..Status Class


Code Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsResponse..::..Status..::..Code Property
MCwadoWsResponse..::..Status Class See Also Send Feedback
Status code

Namespace: Mergecomws.Dicom
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Code { get; private set; }
Visual Basic
Public Property Code As String
    Get
    Private Set
Visual C++
public:
property String^ Code {
    String^ get ();
    private: void set (String^ value);
}

See Also

MCwadoWsResponse..::..Status Class
MCwadoWsResponse..::..Status Members


Mergecomws.Util Namespace

[image]

Merge DICOM Web Services .NET/C# Toolkit
Mergecomws.Util Namespace
Send Feedback
Utility classes.

Classes

 | Class | Description
Public class | MCutil | Mergecom WS Toolkit Utility class
Public class | MCutil..::..StreamReaderUtf8 | Implements a StreamReader that uses the UTF-8 character encoding.
Public class | MCutil..::..StreamWriterUtf8 | Implements a StreamWriter that uses the UTF-8 character encoding
Public class | MCutil..::..StringWriterUtf8 | Implements a StringWriter that uses the UTF-8 character encoding


MCutil Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil Class
Members See Also Send Feedback
Mergecom WS Toolkit Utility class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static class MCutil
Visual Basic
Public NotInheritable Class MCutil
Visual C++
public ref class MCutil abstract sealed

Inheritance Hierarchy

System..::..Object
Mergecomws.Util..::..MCutil

See Also

MCutil Members
Mergecomws.Util Namespace


MCutil Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil Members
MCutil Class Methods Properties See Also Send Feedback

The MCutil type exposes the following members.

Methods

Name | Description
GetActionType | Retrieves MCactionType object defined in the list of MCparameter request parameters
GetChildren | Returns an array of XmlNode children of given XmlNode parent.
GetRequestType | Returns MCrequestType of WADO request
ReadFileToMCabstractMessage | Read content of DICOM Part10 file into MCabstractMessage object
ReadStreamToMCabstractMessage | Read content of DICOM stream into MCabstractMessage object
WriteMCabstractMessageToFile | Write content of MCabstractMessage object to file
WriteMCabstractMessageToStream | Write content of MCabstractMessage object to DICOM stream

Properties

Name | Description
StreamBufferSize | Buffer size used for stream read/write operations (default value: 204800 bytes)

See Also

MCutil Class
Mergecomws.Util Namespace


MCutil Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil Methods
MCutil Class See Also Send Feedback

The MCutil type exposes the following members.

Methods

Name | Description
GetActionType | Retrieves MCactionType object defined in the list of MCparameter request parameters
GetChildren | Returns an array of XmlNode children of given XmlNode parent.
GetRequestType | Returns MCrequestType of WADO request
ReadFileToMCabstractMessage | Read content of DICOM Part10 file into MCabstractMessage object
ReadStreamToMCabstractMessage | Read content of DICOM stream into MCabstractMessage object
WriteMCabstractMessageToFile | Write content of MCabstractMessage object to file
WriteMCabstractMessageToStream | Write content of MCabstractMessage object to DICOM stream

See Also

MCutil Class
Mergecomws.Util Namespace


GetActionType Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..GetActionType Method
MCutil Class See Also Send Feedback
Retrieves MCactionType object defined in the list of MCparameter request parameters

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCactionType GetActionType(
    List<MCparameter> parameters
)
Visual Basic
Public Shared Function GetActionType ( _
    parameters As List(Of MCparameter) _
) As MCactionType
Visual C++
public:
static MCactionType^ GetActionType(
    List<MCparameter^>^ parameters
)

Parameters

parameters
Type: System.Collections.Generic..::..List<(Of <(<' MCparameter >)>)>
List of MCparameter request parameters

Return Value

MCactionType object

See Also

MCutil Class
MCutil Members
Mergecomws.Util Namespace


GetChildren Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..GetChildren Method
MCutil Class See Also Send Feedback
Returns an array of XmlNode children of given XmlNode parent.

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static XmlNode[] GetChildren(
    XmlNode parent,
    string name
)
Visual Basic
Public Shared Function GetChildren ( _
    parent As XmlNode, _
    name As String _
) As XmlNode()
Visual C++
public:
static array<XmlNode^>^ GetChildren(
    XmlNode^ parent,
    String^ name
)

Parameters

parent
Type: System.Xml..::..XmlNode
XmlNode element of SOAP WADO-WS message.
name
Type: System..::..String
Name of XmlNode child.

Return Value

Array of XmlNode children of given XmlNode parent matching name.

See Also

MCutil Class
MCutil Members
Mergecomws.Util Namespace


GetRequestType Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..GetRequestType Method
MCutil Class See Also Send Feedback
Returns MCrequestType of WADO request

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCrequestType GetRequestType(
    List<MCparameter> parameters
)
Visual Basic
Public Shared Function GetRequestType ( _
    parameters As List(Of MCparameter) _
) As MCrequestType
Visual C++
public:
static MCrequestType^ GetRequestType(
    List<MCparameter^>^ parameters
)

Parameters

parameters
Type: System.Collections.Generic..::..List<(Of <(<' MCparameter >)>)>
List of MCparameter objects

Return Value

MCrequestType of WADO request

See Also

MCutil Class
MCutil Members
Mergecomws.Util Namespace


ReadFileToMCabstractMessage Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..ReadFileToMCabstractMessage Method
MCutil Class See Also Send Feedback
Read content of DICOM Part10 file into MCabstractMessage object

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCabstractMessage ReadFileToMCabstractMessage(
    string path,
    Type type
)
Visual Basic
Public Shared Function ReadFileToMCabstractMessage ( _
    path As String, _
    type As Type _
) As MCabstractMessage
Visual C++
public:
static MCabstractMessage^ ReadFileToMCabstractMessage(
    String^ path,
    Type^ type
)

Parameters

path
Type: System..::..String
File path name
type
Type: System..::..Type
Specifies the type of resulting message - MCdimseMessage or MCfile

Return Value

MCabstractMessage object

See Also

MCutil Class
MCutil Members
Mergecomws.Util Namespace


ReadStreamToMCabstractMessage Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..ReadStreamToMCabstractMessage Method
MCutil Class See Also Send Feedback
Read content of DICOM stream into MCabstractMessage object

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCabstractMessage ReadStreamToMCabstractMessage(
    Stream stream,
    Type type
)
Visual Basic
Public Shared Function ReadStreamToMCabstractMessage ( _
    stream As Stream, _
    type As Type _
) As MCabstractMessage
Visual C++
public:
static MCabstractMessage^ ReadStreamToMCabstractMessage(
    Stream^ stream,
    Type^ type
)

Parameters

stream
Type: System.IO..::..Stream
DICOM data stream
type
Type: System..::..Type
Specifies the type of resulting message - MCdimseMessage or MCfile

Return Value

MCabstractMessage object

See Also

MCutil Class
MCutil Members
Mergecomws.Util Namespace


WriteMCabstractMessageToFile Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..WriteMCabstractMessageToFile Method
MCutil Class See Also Send Feedback
Write content of MCabstractMessage object to file

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static bool WriteMCabstractMessageToFile(
    MCabstractMessage message,
    string path,
    out string error
)
Visual Basic
Public Shared Function WriteMCabstractMessageToFile ( _
    message As MCabstractMessage, _
    path As String, _
    <OutAttribute> ByRef error As String _
) As Boolean
Visual C++
public:
static bool WriteMCabstractMessageToFile(
    MCabstractMessage^ message,
    String^ path,
    [OutAttribute] String^% error
)

Parameters

message
Type: MCabstractMessage
MCabstractMessage to write
path
Type: System..::..String
File path name
error
Type: System..::..String%
Returns an error message if write operation fails

Return Value

True if operation succeeded.

See Also

MCutil Class
MCutil Members
Mergecomws.Util Namespace


WriteMCabstractMessageToStream Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..WriteMCabstractMessageToStream Method
MCutil Class See Also Send Feedback
Write content of MCabstractMessage object to DICOM stream

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static bool WriteMCabstractMessageToStream(
    MCabstractMessage message,
    Stream stream,
    out string error
)
Visual Basic
Public Shared Function WriteMCabstractMessageToStream ( _
    message As MCabstractMessage, _
    stream As Stream, _
    <OutAttribute> ByRef error As String _
) As Boolean
Visual C++
public:
static bool WriteMCabstractMessageToStream(
    MCabstractMessage^ message,
    Stream^ stream,
    [OutAttribute] String^% error
)

Parameters

message
Type: MCabstractMessage
MCabstractMessage object
stream
Type: System.IO..::..Stream
DICOM stream
error
Type: System..::..String%
Returns an error message if write operation fails

Return Value

True if operation was successful.

See Also

MCutil Class
MCutil Members
Mergecomws.Util Namespace


MCutil Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil Properties
MCutil Class See Also Send Feedback

The MCutil type exposes the following members.

Properties

Name | Description
StreamBufferSize | Buffer size used for stream read/write operations (default value: 204800 bytes)

See Also

MCutil Class
Mergecomws.Util Namespace


StreamBufferSize Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamBufferSize Property
MCutil Class See Also Send Feedback
Buffer size used for stream read/write operations (default value: 204800 bytes)

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static uint StreamBufferSize { get; set; }
Visual Basic
Public Shared Property StreamBufferSize As UInteger
    Get
    Set
Visual C++
public:
static property unsigned int StreamBufferSize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

MCutil Class
MCutil Members
Mergecomws.Util Namespace


MCutil.StreamReaderUtf8 Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamReaderUtf8 Class
MCutil Class Members See Also Send Feedback
Implements a StreamReader that uses the UTF-8 character encoding.

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class StreamReaderUtf8 : StreamReader
Visual Basic
Public Class StreamReaderUtf8 _
    Inherits StreamReader
Visual C++
public ref class StreamReaderUtf8 : public StreamReader

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.IO..::..TextReader
System.IO..::..StreamReader
Mergecomws.Util..::..MCutil..::..StreamReaderUtf8

See Also

MCutil..::..StreamReaderUtf8 Members
Mergecomws.Util Namespace


MCutil.StreamReaderUtf8 Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamReaderUtf8 Members
MCutil..::..StreamReaderUtf8 Class Constructors Methods Properties See Also Send Feedback

The MCutil..::..StreamReaderUtf8 type exposes the following members.

Constructors

 | Name | Description
Public method | MCutil..::..StreamReaderUtf8(Stream) | Initializes a new instance of the MCutil..::..StreamReaderUtf8 class
Public method | MCutil..::..StreamReaderUtf8(String) | Initializes a new instance of the MCutil..::..StreamReaderUtf8 class
Public method | MCutil..::..StreamReaderUtf8(Stream, Boolean) | Initializes a new instance of the MCutil..::..StreamReaderUtf8 class
Public method | MCutil..::..StreamReaderUtf8(String, Boolean) | Initializes a new instance of the MCutil..::..StreamReaderUtf8 class
Public method | MCutil..::..StreamReaderUtf8(Stream, Boolean, Int32) | Initializes a new instance of the MCutil..::..StreamReaderUtf8 class
Public method | MCutil..::..StreamReaderUtf8(String, Boolean, Int32) | Initializes a new instance of the MCutil..::..StreamReaderUtf8 class
Public method | MCutil..::..StreamReaderUtf8(Stream, Boolean, Int32, Boolean) | Initializes a new instance of the MCutil..::..StreamReaderUtf8 class

Methods

 | Name | Description
Public method | Close | Closes the StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from StreamReader.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DiscardBufferedData | Clears the internal buffer. (Inherited from StreamReader.)
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Peek | Returns the next available character but does not consume it. (Inherited from StreamReader.)
Public method | Read()()()() | Reads the next character from the input stream and advances the character position by one character. (Inherited from StreamReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | Reads a specified maximum of characters from the current stream into a buffer, beginning at the specified index. (Inherited from StreamReader.)
Public method | ReadAsync | (Inherited from StreamReader.)
Public method | ReadBlock | (Inherited from StreamReader.)
Public method | ReadBlockAsync | (Inherited from StreamReader.)
Public method | ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from StreamReader.)
Public method | ReadLineAsync | (Inherited from StreamReader.)
Public method | ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from StreamReader.)
Public method | ReadToEndAsync | (Inherited from StreamReader.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BaseStream | Returns the underlying stream. (Inherited from StreamReader.)
Public property | CurrentEncoding | Gets the current character encoding that the current MCutil..::..StreamReaderUtf8 object is using. (Overrides StreamReader..::..CurrentEncoding.)
Public property | EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from StreamReader.)

See Also

MCutil..::..StreamReaderUtf8 Class
Mergecomws.Util Namespace


MCutil.StreamReaderUtf8 Constructor

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamReaderUtf8 Constructor
MCutil..::..StreamReaderUtf8 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCutil..::..StreamReaderUtf8(Stream) | Initializes a new instance of the MCutil..::..StreamReaderUtf8 class
Public method | MCutil..::..StreamReaderUtf8(String) | Initializes a new instance of the MCutil..::..StreamReaderUtf8 class
Public method | MCutil..::..StreamReaderUtf8(Stream, Boolean) | Initializes a new instance of the MCutil..::..StreamReaderUtf8 class
Public method | MCutil..::..StreamReaderUtf8(String, Boolean) | Initializes a new instance of the MCutil..::..StreamReaderUtf8 class
Public method | MCutil..::..StreamReaderUtf8(Stream, Boolean, Int32) | Initializes a new instance of the MCutil..::..StreamReaderUtf8 class
Public method | MCutil..::..StreamReaderUtf8(String, Boolean, Int32) | Initializes a new instance of the MCutil..::..StreamReaderUtf8 class
Public method | MCutil..::..StreamReaderUtf8(Stream, Boolean, Int32, Boolean) | Initializes a new instance of the MCutil..::..StreamReaderUtf8 class

See Also

MCutil..::..StreamReaderUtf8 Class
MCutil..::..StreamReaderUtf8 Members
Mergecomws.Util Namespace


MCutil.StreamReaderUtf8 Constructor (Stream)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamReaderUtf8 Constructor (Stream)
MCutil..::..StreamReaderUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StreamReaderUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StreamReaderUtf8(
    Stream stream
)
Visual Basic
Public Sub New ( _
    stream As Stream _
)
Visual C++
public:
StreamReaderUtf8(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The stream to be read.

See Also

MCutil..::..StreamReaderUtf8 Class
MCutil..::..StreamReaderUtf8 Members
MCutil..::..StreamReaderUtf8 Overload
Mergecomws.Util Namespace


MCutil.StreamReaderUtf8 Constructor (String)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamReaderUtf8 Constructor (String)
MCutil..::..StreamReaderUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StreamReaderUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StreamReaderUtf8(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)
Visual C++
public:
StreamReaderUtf8(
    String^ path
)

Parameters

path
Type: System..::..String
The complete file path to be read.

See Also

MCutil..::..StreamReaderUtf8 Class
MCutil..::..StreamReaderUtf8 Members
MCutil..::..StreamReaderUtf8 Overload
Mergecomws.Util Namespace


MCutil.StreamReaderUtf8 Constructor (Stream, Boolean)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamReaderUtf8 Constructor (Stream, Boolean)
MCutil..::..StreamReaderUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StreamReaderUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StreamReaderUtf8(
    Stream stream,
    bool detectEncodingFromByteOrderMarks
)
Visual Basic
Public Sub New ( _
    stream As Stream, _
    detectEncodingFromByteOrderMarks As Boolean _
)
Visual C++
public:
StreamReaderUtf8(
    Stream^ stream,
    bool detectEncodingFromByteOrderMarks
)

Parameters

stream
Type: System.IO..::..Stream
The stream to be read.
detectEncodingFromByteOrderMarks
Type: System..::..Boolean
Indicates whether to look for byte order marks at the beginning of the file.

See Also

MCutil..::..StreamReaderUtf8 Class
MCutil..::..StreamReaderUtf8 Members
MCutil..::..StreamReaderUtf8 Overload
Mergecomws.Util Namespace


MCutil.StreamReaderUtf8 Constructor (String, Boolean)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamReaderUtf8 Constructor (String, Boolean)
MCutil..::..StreamReaderUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StreamReaderUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StreamReaderUtf8(
    string path,
    bool detectEncodingFromByteOrderMarks
)
Visual Basic
Public Sub New ( _
    path As String, _
    detectEncodingFromByteOrderMarks As Boolean _
)
Visual C++
public:
StreamReaderUtf8(
    String^ path,
    bool detectEncodingFromByteOrderMarks
)

Parameters

path
Type: System..::..String
The complete file path to be read.
detectEncodingFromByteOrderMarks
Type: System..::..Boolean
Indicates whether to look for byte order marks at the beginning of the file.

See Also

MCutil..::..StreamReaderUtf8 Class
MCutil..::..StreamReaderUtf8 Members
MCutil..::..StreamReaderUtf8 Overload
Mergecomws.Util Namespace


MCutil.StreamReaderUtf8 Constructor (Stream, Boolean, Int32)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamReaderUtf8 Constructor (Stream, Boolean, Int32)
MCutil..::..StreamReaderUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StreamReaderUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StreamReaderUtf8(
    Stream stream,
    bool detectEncodingFromByteOrderMarks,
    int bufferSize
)
Visual Basic
Public Sub New ( _
    stream As Stream, _
    detectEncodingFromByteOrderMarks As Boolean, _
    bufferSize As Integer _
)
Visual C++
public:
StreamReaderUtf8(
    Stream^ stream,
    bool detectEncodingFromByteOrderMarks,
    int bufferSize
)

Parameters

stream
Type: System.IO..::..Stream
The stream to be read.
detectEncodingFromByteOrderMarks
Type: System..::..Boolean
Indicates whether to look for byte order marks at the beginning of the file.
bufferSize
Type: System..::..Int32
The minimum buffer size.

See Also

MCutil..::..StreamReaderUtf8 Class
MCutil..::..StreamReaderUtf8 Members
MCutil..::..StreamReaderUtf8 Overload
Mergecomws.Util Namespace


MCutil.StreamReaderUtf8 Constructor (String, Boolean, Int32)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamReaderUtf8 Constructor (String, Boolean, Int32)
MCutil..::..StreamReaderUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StreamReaderUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StreamReaderUtf8(
    string path,
    bool detectEncodingFromByteOrderMarks,
    int bufferSize
)
Visual Basic
Public Sub New ( _
    path As String, _
    detectEncodingFromByteOrderMarks As Boolean, _
    bufferSize As Integer _
)
Visual C++
public:
StreamReaderUtf8(
    String^ path,
    bool detectEncodingFromByteOrderMarks,
    int bufferSize
)

Parameters

path
Type: System..::..String
The complete file path to be read.
detectEncodingFromByteOrderMarks
Type: System..::..Boolean
Indicates whether to look for byte order marks at the beginning of the file.
bufferSize
Type: System..::..Int32
The minimum buffer size.

See Also

MCutil..::..StreamReaderUtf8 Class
MCutil..::..StreamReaderUtf8 Members
MCutil..::..StreamReaderUtf8 Overload
Mergecomws.Util Namespace


MCutil.StreamReaderUtf8 Constructor (Stream, Boolean, Int32, Boolean)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamReaderUtf8 Constructor (Stream, Boolean, Int32, Boolean)
MCutil..::..StreamReaderUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StreamReaderUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StreamReaderUtf8(
    Stream stream,
    bool detectEncodingFromByteOrderMarks,
    int bufferSize,
    bool leaveOpen
)
Visual Basic
Public Sub New ( _
    stream As Stream, _
    detectEncodingFromByteOrderMarks As Boolean, _
    bufferSize As Integer, _
    leaveOpen As Boolean _
)
Visual C++
public:
StreamReaderUtf8(
    Stream^ stream,
    bool detectEncodingFromByteOrderMarks,
    int bufferSize,
    bool leaveOpen
)

Parameters

stream
Type: System.IO..::..Stream
The stream to be read.
detectEncodingFromByteOrderMarks
Type: System..::..Boolean
Indicates whether to look for byte order marks at the beginning of the file.
bufferSize
Type: System..::..Int32
The minimum buffer size.
leaveOpen
Type: System..::..Boolean
true to leave the stream open after the MCutil..::..StreamReaderUtf8 object is disposed; otherwise, false.

See Also

MCutil..::..StreamReaderUtf8 Class
MCutil..::..StreamReaderUtf8 Members
MCutil..::..StreamReaderUtf8 Overload
Mergecomws.Util Namespace


MCutil.StreamReaderUtf8 Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamReaderUtf8 Methods
MCutil..::..StreamReaderUtf8 Class See Also Send Feedback

The MCutil..::..StreamReaderUtf8 type exposes the following members.

Methods

 | Name | Description
Public method | Close | Closes the StreamReader object and the underlying stream, and releases any system resources associated with the reader. (Inherited from StreamReader.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DiscardBufferedData | Clears the internal buffer. (Inherited from StreamReader.)
Public method | Dispose()()()() | Releases all resources used by the TextReader object. (Inherited from TextReader.)
Protected method | Dispose(Boolean) | Closes the underlying stream, releases the unmanaged resources used by the StreamReader, and optionally releases the managed resources. (Inherited from StreamReader.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Peek | Returns the next available character but does not consume it. (Inherited from StreamReader.)
Public method | Read()()()() | Reads the next character from the input stream and advances the character position by one character. (Inherited from StreamReader.)
Public method | Read(array<Char>[]()[][], Int32, Int32) | Reads a specified maximum of characters from the current stream into a buffer, beginning at the specified index. (Inherited from StreamReader.)
Public method | ReadAsync | (Inherited from StreamReader.)
Public method | ReadBlock | (Inherited from StreamReader.)
Public method | ReadBlockAsync | (Inherited from StreamReader.)
Public method | ReadLine | Reads a line of characters from the current stream and returns the data as a string. (Inherited from StreamReader.)
Public method | ReadLineAsync | (Inherited from StreamReader.)
Public method | ReadToEnd | Reads the stream from the current position to the end of the stream. (Inherited from StreamReader.)
Public method | ReadToEndAsync | (Inherited from StreamReader.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCutil..::..StreamReaderUtf8 Class
Mergecomws.Util Namespace


MCutil.StreamReaderUtf8 Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamReaderUtf8 Properties
MCutil..::..StreamReaderUtf8 Class See Also Send Feedback

The MCutil..::..StreamReaderUtf8 type exposes the following members.

Properties

 | Name | Description
Public property | BaseStream | Returns the underlying stream. (Inherited from StreamReader.)
Public property | CurrentEncoding | Gets the current character encoding that the current MCutil..::..StreamReaderUtf8 object is using. (Overrides StreamReader..::..CurrentEncoding.)
Public property | EndOfStream | Gets a value that indicates whether the current stream position is at the end of the stream. (Inherited from StreamReader.)

See Also

MCutil..::..StreamReaderUtf8 Class
Mergecomws.Util Namespace


CurrentEncoding Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamReaderUtf8..::..CurrentEncoding Property
MCutil..::..StreamReaderUtf8 Class See Also Send Feedback
Gets the current character encoding that the current MCutil..::..StreamReaderUtf8 object is using.

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override Encoding CurrentEncoding { get; }
Visual Basic
Public Overrides ReadOnly Property CurrentEncoding As Encoding
    Get
Visual C++
public:
virtual property Encoding^ CurrentEncoding {
    Encoding^ get () override;
}

See Also

MCutil..::..StreamReaderUtf8 Class
MCutil..::..StreamReaderUtf8 Members
Mergecomws.Util Namespace


MCutil.StreamWriterUtf8 Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamWriterUtf8 Class
MCutil Class Members See Also Send Feedback
Implements a StreamWriter that uses the UTF-8 character encoding

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class StreamWriterUtf8 : StreamWriter
Visual Basic
Public Class StreamWriterUtf8 _
    Inherits StreamWriter
Visual C++
public ref class StreamWriterUtf8 : public StreamWriter

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.IO..::..TextWriter
System.IO..::..StreamWriter
Mergecomws.Util..::..MCutil..::..StreamWriterUtf8

See Also

MCutil..::..StreamWriterUtf8 Members
Mergecomws.Util Namespace


MCutil.StreamWriterUtf8 Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamWriterUtf8 Members
MCutil..::..StreamWriterUtf8 Class Constructors Methods Fields Properties See Also Send Feedback

The MCutil..::..StreamWriterUtf8 type exposes the following members.

Constructors

 | Name | Description
Public method | MCutil..::..StreamWriterUtf8(Stream) | Initializes a new instance of the MCutil..::..StreamWriterUtf8 class
Public method | MCutil..::..StreamWriterUtf8(String) | Initializes a new instance of the MCutil..::..StreamWriterUtf8 class
Public method | MCutil..::..StreamWriterUtf8(Stream, Int32) | Initializes a new instance of the MCutil..::..StreamWriterUtf8 class
Public method | MCutil..::..StreamWriterUtf8(String, Boolean) | Initializes a new instance of the MCutil..::..StreamWriterUtf8 class
Public method | MCutil..::..StreamWriterUtf8(Stream, Int32, Boolean) | Initializes a new instance of the MCutil..::..StreamWriterUtf8 class
Public method | MCutil..::..StreamWriterUtf8(String, Boolean, Int32) | Initializes a new instance of the MCutil..::..StreamWriterUtf8 class

Methods

 | Name | Description
Public method | Close | Closes the current StreamWriter object and the underlying stream. (Inherited from StreamWriter.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the TextWriter object. (Inherited from TextWriter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the StreamWriter and optionally releases the managed resources. (Inherited from StreamWriter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying stream. (Inherited from StreamWriter.)
Public method | FlushAsync | (Inherited from StreamWriter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(Char) | Writes a character to the stream. (Inherited from StreamWriter.)
Public method | Write(array<Char>[]()[][]) | Writes a character array to the stream. (Inherited from StreamWriter.)
Public method | Write(String) | Writes a string to the stream. (Inherited from StreamWriter.)
Public method | Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from TextWriter.)
Public method | Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from TextWriter.)
Public method | Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Public method | Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from TextWriter.)
Public method | Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Public method | Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from TextWriter.)
Public method | Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from TextWriter.)
Public method | Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from TextWriter.)
Public method | Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from TextWriter.)
Public method | Write(String, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(String, array<Object>[]()[][]) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(array<Char>[]()[][], Int32, Int32) | Writes a subarray of characters to the stream. (Inherited from StreamWriter.)
Public method | Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteAsync(Char) | (Inherited from StreamWriter.)
Public method | WriteAsync(String) | (Inherited from StreamWriter.)
Public method | WriteAsync(array<Char>[]()[][]) | (Inherited from TextWriter.)
Public method | WriteAsync(array<Char>[]()[][], Int32, Int32) | (Inherited from StreamWriter.)
Public method | WriteLine()()()() | Writes a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(array<Char>[]()[][]) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(String, array<Object>[]()[][]) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(array<Char>[]()[][], Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLineAsync()()()() | (Inherited from StreamWriter.)
Public method | WriteLineAsync(Char) | (Inherited from StreamWriter.)
Public method | WriteLineAsync(String) | (Inherited from StreamWriter.)
Public method | WriteLineAsync(array<Char>[]()[][]) | (Inherited from TextWriter.)
Public method | WriteLineAsync(array<Char>[]()[][], Int32, Int32) | (Inherited from StreamWriter.)

Fields

 | Name | Description
Protected field | CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from TextWriter.)

Properties

 | Name | Description
Public property | AutoFlush | Gets or sets a value indicating whether the StreamWriter will flush its buffer to the underlying stream after every call to Write(Char). (Inherited from StreamWriter.)
Public property | BaseStream | Gets the underlying stream that interfaces with a backing store. (Inherited from StreamWriter.)
Public property | Encoding | Gets the current character encoding that the current MCutil..::..StreamWriterUtf8 object is using. (Overrides StreamWriter..::..Encoding.)
Public property | FormatProvider | Gets an object that controls formatting. (Inherited from TextWriter.)
Public property | NewLine | Gets or sets the line terminator string used by the current TextWriter. (Inherited from TextWriter.)

See Also

MCutil..::..StreamWriterUtf8 Class
Mergecomws.Util Namespace


MCutil.StreamWriterUtf8 Constructor

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamWriterUtf8 Constructor
MCutil..::..StreamWriterUtf8 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCutil..::..StreamWriterUtf8(Stream) | Initializes a new instance of the MCutil..::..StreamWriterUtf8 class
Public method | MCutil..::..StreamWriterUtf8(String) | Initializes a new instance of the MCutil..::..StreamWriterUtf8 class
Public method | MCutil..::..StreamWriterUtf8(Stream, Int32) | Initializes a new instance of the MCutil..::..StreamWriterUtf8 class
Public method | MCutil..::..StreamWriterUtf8(String, Boolean) | Initializes a new instance of the MCutil..::..StreamWriterUtf8 class
Public method | MCutil..::..StreamWriterUtf8(Stream, Int32, Boolean) | Initializes a new instance of the MCutil..::..StreamWriterUtf8 class
Public method | MCutil..::..StreamWriterUtf8(String, Boolean, Int32) | Initializes a new instance of the MCutil..::..StreamWriterUtf8 class

See Also

MCutil..::..StreamWriterUtf8 Class
MCutil..::..StreamWriterUtf8 Members
Mergecomws.Util Namespace


MCutil.StreamWriterUtf8 Constructor (Stream)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamWriterUtf8 Constructor (Stream)
MCutil..::..StreamWriterUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StreamWriterUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StreamWriterUtf8(
    Stream stream
)
Visual Basic
Public Sub New ( _
    stream As Stream _
)
Visual C++
public:
StreamWriterUtf8(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The stream to write to.

See Also

MCutil..::..StreamWriterUtf8 Class
MCutil..::..StreamWriterUtf8 Members
MCutil..::..StreamWriterUtf8 Overload
Mergecomws.Util Namespace


MCutil.StreamWriterUtf8 Constructor (String)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamWriterUtf8 Constructor (String)
MCutil..::..StreamWriterUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StreamWriterUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StreamWriterUtf8(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)
Visual C++
public:
StreamWriterUtf8(
    String^ path
)

Parameters

path
Type: System..::..String
The complete file path to write to. path can be a file name.

See Also

MCutil..::..StreamWriterUtf8 Class
MCutil..::..StreamWriterUtf8 Members
MCutil..::..StreamWriterUtf8 Overload
Mergecomws.Util Namespace


MCutil.StreamWriterUtf8 Constructor (Stream, Int32)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamWriterUtf8 Constructor (Stream, Int32)
MCutil..::..StreamWriterUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StreamWriterUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StreamWriterUtf8(
    Stream stream,
    int bufferSize
)
Visual Basic
Public Sub New ( _
    stream As Stream, _
    bufferSize As Integer _
)
Visual C++
public:
StreamWriterUtf8(
    Stream^ stream,
    int bufferSize
)

Parameters

stream
Type: System.IO..::..Stream
The stream to write to.
bufferSize
Type: System..::..Int32
Sets the buffer size.

See Also

MCutil..::..StreamWriterUtf8 Class
MCutil..::..StreamWriterUtf8 Members
MCutil..::..StreamWriterUtf8 Overload
Mergecomws.Util Namespace


MCutil.StreamWriterUtf8 Constructor (String, Boolean)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamWriterUtf8 Constructor (String, Boolean)
MCutil..::..StreamWriterUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StreamWriterUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StreamWriterUtf8(
    string path,
    bool append
)
Visual Basic
Public Sub New ( _
    path As String, _
    append As Boolean _
)
Visual C++
public:
StreamWriterUtf8(
    String^ path,
    bool append
)

Parameters

path
Type: System..::..String
The complete file path to write to. path can be a file name.
append
Type: System..::..Boolean
Determines whether data is to be appended to the file. If the file exists and append is false, the file is overwritten. If the file exists and append is true, the data is appended to the file. Otherwise, a new file is created.

See Also

MCutil..::..StreamWriterUtf8 Class
MCutil..::..StreamWriterUtf8 Members
MCutil..::..StreamWriterUtf8 Overload
Mergecomws.Util Namespace


MCutil.StreamWriterUtf8 Constructor (Stream, Int32, Boolean)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamWriterUtf8 Constructor (Stream, Int32, Boolean)
MCutil..::..StreamWriterUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StreamWriterUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StreamWriterUtf8(
    Stream stream,
    int bufferSize,
    bool leaveOpen
)
Visual Basic
Public Sub New ( _
    stream As Stream, _
    bufferSize As Integer, _
    leaveOpen As Boolean _
)
Visual C++
public:
StreamWriterUtf8(
    Stream^ stream,
    int bufferSize,
    bool leaveOpen
)

Parameters

stream
Type: System.IO..::..Stream
The stream to write to.
bufferSize
Type: System..::..Int32
Sets the buffer size.
leaveOpen
Type: System..::..Boolean
true to leave the stream open after the MCutil..::..StreamWriterUtf8 object is disposed; otherwise, false.

See Also

MCutil..::..StreamWriterUtf8 Class
MCutil..::..StreamWriterUtf8 Members
MCutil..::..StreamWriterUtf8 Overload
Mergecomws.Util Namespace


MCutil.StreamWriterUtf8 Constructor (String, Boolean, Int32)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamWriterUtf8 Constructor (String, Boolean, Int32)
MCutil..::..StreamWriterUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StreamWriterUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StreamWriterUtf8(
    string path,
    bool append,
    int bufferSize
)
Visual Basic
Public Sub New ( _
    path As String, _
    append As Boolean, _
    bufferSize As Integer _
)
Visual C++
public:
StreamWriterUtf8(
    String^ path,
    bool append,
    int bufferSize
)

Parameters

path
Type: System..::..String
The complete file path to write to. path can be a file name.
append
Type: System..::..Boolean
Determines whether data is to be appended to the file. If the file exists and append is false, the file is overwritten. If the file exists and append is true, the data is appended to the file. Otherwise, a new file is created.
bufferSize
Type: System..::..Int32
Sets the buffer size.

See Also

MCutil..::..StreamWriterUtf8 Class
MCutil..::..StreamWriterUtf8 Members
MCutil..::..StreamWriterUtf8 Overload
Mergecomws.Util Namespace


MCutil.StreamWriterUtf8 Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamWriterUtf8 Fields
MCutil..::..StreamWriterUtf8 Class See Also Send Feedback

The MCutil..::..StreamWriterUtf8 type exposes the following members.

Fields

 | Name | Description
Protected field | CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from TextWriter.)

See Also

MCutil..::..StreamWriterUtf8 Class
Mergecomws.Util Namespace


MCutil.StreamWriterUtf8 Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamWriterUtf8 Methods
MCutil..::..StreamWriterUtf8 Class See Also Send Feedback

The MCutil..::..StreamWriterUtf8 type exposes the following members.

Methods

 | Name | Description
Public method | Close | Closes the current StreamWriter object and the underlying stream. (Inherited from StreamWriter.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the TextWriter object. (Inherited from TextWriter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the StreamWriter and optionally releases the managed resources. (Inherited from StreamWriter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying stream. (Inherited from StreamWriter.)
Public method | FlushAsync | (Inherited from StreamWriter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(Char) | Writes a character to the stream. (Inherited from StreamWriter.)
Public method | Write(array<Char>[]()[][]) | Writes a character array to the stream. (Inherited from StreamWriter.)
Public method | Write(String) | Writes a string to the stream. (Inherited from StreamWriter.)
Public method | Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from TextWriter.)
Public method | Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from TextWriter.)
Public method | Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Public method | Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from TextWriter.)
Public method | Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Public method | Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from TextWriter.)
Public method | Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from TextWriter.)
Public method | Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from TextWriter.)
Public method | Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from TextWriter.)
Public method | Write(String, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(String, array<Object>[]()[][]) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(array<Char>[]()[][], Int32, Int32) | Writes a subarray of characters to the stream. (Inherited from StreamWriter.)
Public method | Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteAsync(Char) | (Inherited from StreamWriter.)
Public method | WriteAsync(String) | (Inherited from StreamWriter.)
Public method | WriteAsync(array<Char>[]()[][]) | (Inherited from TextWriter.)
Public method | WriteAsync(array<Char>[]()[][], Int32, Int32) | (Inherited from StreamWriter.)
Public method | WriteLine()()()() | Writes a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(array<Char>[]()[][]) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(String, array<Object>[]()[][]) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(array<Char>[]()[][], Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLineAsync()()()() | (Inherited from StreamWriter.)
Public method | WriteLineAsync(Char) | (Inherited from StreamWriter.)
Public method | WriteLineAsync(String) | (Inherited from StreamWriter.)
Public method | WriteLineAsync(array<Char>[]()[][]) | (Inherited from TextWriter.)
Public method | WriteLineAsync(array<Char>[]()[][], Int32, Int32) | (Inherited from StreamWriter.)

See Also

MCutil..::..StreamWriterUtf8 Class
Mergecomws.Util Namespace


MCutil.StreamWriterUtf8 Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamWriterUtf8 Properties
MCutil..::..StreamWriterUtf8 Class See Also Send Feedback

The MCutil..::..StreamWriterUtf8 type exposes the following members.

Properties

 | Name | Description
Public property | AutoFlush | Gets or sets a value indicating whether the StreamWriter will flush its buffer to the underlying stream after every call to Write(Char). (Inherited from StreamWriter.)
Public property | BaseStream | Gets the underlying stream that interfaces with a backing store. (Inherited from StreamWriter.)
Public property | Encoding | Gets the current character encoding that the current MCutil..::..StreamWriterUtf8 object is using. (Overrides StreamWriter..::..Encoding.)
Public property | FormatProvider | Gets an object that controls formatting. (Inherited from TextWriter.)
Public property | NewLine | Gets or sets the line terminator string used by the current TextWriter. (Inherited from TextWriter.)

See Also

MCutil..::..StreamWriterUtf8 Class
Mergecomws.Util Namespace


Encoding Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StreamWriterUtf8..::..Encoding Property
MCutil..::..StreamWriterUtf8 Class See Also Send Feedback
Gets the current character encoding that the current MCutil..::..StreamWriterUtf8 object is using.

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override Encoding Encoding { get; }
Visual Basic
Public Overrides ReadOnly Property Encoding As Encoding
    Get
Visual C++
public:
virtual property Encoding^ Encoding {
    Encoding^ get () override;
}

See Also

MCutil..::..StreamWriterUtf8 Class
MCutil..::..StreamWriterUtf8 Members
Mergecomws.Util Namespace


MCutil.StringWriterUtf8 Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StringWriterUtf8 Class
MCutil Class Members See Also Send Feedback
Implements a StringWriter that uses the UTF-8 character encoding

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class StringWriterUtf8 : StringWriter
Visual Basic
Public Class StringWriterUtf8 _
    Inherits StringWriter
Visual C++
public ref class StringWriterUtf8 : public StringWriter

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.IO..::..TextWriter
System.IO..::..StringWriter
Mergecomws.Util..::..MCutil..::..StringWriterUtf8

See Also

MCutil..::..StringWriterUtf8 Members
Mergecomws.Util Namespace


MCutil.StringWriterUtf8 Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StringWriterUtf8 Members
MCutil..::..StringWriterUtf8 Class Constructors Methods Fields Properties See Also Send Feedback

The MCutil..::..StringWriterUtf8 type exposes the following members.

Constructors

 | Name | Description
Public method | MCutil..::..StringWriterUtf8()()()() | Initializes a new instance of the MCutil..::..StringWriterUtf8 class
Public method | MCutil..::..StringWriterUtf8(IFormatProvider) | Initializes a new instance of the MCutil..::..StringWriterUtf8 class
Public method | MCutil..::..StringWriterUtf8(StringBuilder) | Initializes a new instance of the MCutil..::..StringWriterUtf8 class
Public method | MCutil..::..StringWriterUtf8(StringBuilder, IFormatProvider) | Initializes a new instance of the MCutil..::..StringWriterUtf8 class

Methods

 | Name | Description
Public method | Close | Closes the current StringWriter and the underlying stream. (Inherited from StringWriter.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the TextWriter object. (Inherited from TextWriter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the StringWriter and optionally releases the managed resources. (Inherited from StringWriter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (Inherited from TextWriter.)
Public method | FlushAsync | (Inherited from StringWriter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetStringBuilder | Returns the underlying StringBuilder. (Inherited from StringWriter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string containing the characters written to the current StringWriter so far. (Inherited from StringWriter.)
Public method | Write(Char) | Writes a character to this instance of the StringWriter. (Inherited from StringWriter.)
Public method | Write(String) | Writes a string to this instance of the StringWriter. (Inherited from StringWriter.)
Public method | Write(array<Char>[]()[][]) | Writes a character array to the text stream. (Inherited from TextWriter.)
Public method | Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from TextWriter.)
Public method | Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from TextWriter.)
Public method | Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Public method | Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from TextWriter.)
Public method | Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Public method | Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from TextWriter.)
Public method | Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from TextWriter.)
Public method | Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from TextWriter.)
Public method | Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from TextWriter.)
Public method | Write(String, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(String, array<Object>[]()[][]) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(array<Char>[]()[][], Int32, Int32) | Writes the specified region of a character array to this instance of the StringWriter. (Inherited from StringWriter.)
Public method | Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteAsync(Char) | (Inherited from StringWriter.)
Public method | WriteAsync(String) | (Inherited from StringWriter.)
Public method | WriteAsync(array<Char>[]()[][]) | (Inherited from TextWriter.)
Public method | WriteAsync(array<Char>[]()[][], Int32, Int32) | (Inherited from StringWriter.)
Public method | WriteLine()()()() | Writes a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(array<Char>[]()[][]) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(String, array<Object>[]()[][]) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(array<Char>[]()[][], Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLineAsync()()()() | (Inherited from TextWriter.)
Public method | WriteLineAsync(Char) | (Inherited from StringWriter.)
Public method | WriteLineAsync(String) | (Inherited from StringWriter.)
Public method | WriteLineAsync(array<Char>[]()[][]) | (Inherited from TextWriter.)
Public method | WriteLineAsync(array<Char>[]()[][], Int32, Int32) | (Inherited from StringWriter.)

Fields

 | Name | Description
Protected field | CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from TextWriter.)

Properties

 | Name | Description
Public property | Encoding | Gets the current character encoding that the current MCutil..::..StringWriterUtf8 object is using. (Overrides StringWriter..::..Encoding.)
Public property | FormatProvider | Gets an object that controls formatting. (Inherited from TextWriter.)
Public property | NewLine | Gets or sets the line terminator string used by the current TextWriter. (Inherited from TextWriter.)

See Also

MCutil..::..StringWriterUtf8 Class
Mergecomws.Util Namespace


MCutil.StringWriterUtf8 Constructor

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StringWriterUtf8 Constructor
MCutil..::..StringWriterUtf8 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCutil..::..StringWriterUtf8()()()() | Initializes a new instance of the MCutil..::..StringWriterUtf8 class
Public method | MCutil..::..StringWriterUtf8(IFormatProvider) | Initializes a new instance of the MCutil..::..StringWriterUtf8 class
Public method | MCutil..::..StringWriterUtf8(StringBuilder) | Initializes a new instance of the MCutil..::..StringWriterUtf8 class
Public method | MCutil..::..StringWriterUtf8(StringBuilder, IFormatProvider) | Initializes a new instance of the MCutil..::..StringWriterUtf8 class

See Also

MCutil..::..StringWriterUtf8 Class
MCutil..::..StringWriterUtf8 Members
Mergecomws.Util Namespace


MCutil.StringWriterUtf8 Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StringWriterUtf8 Constructor
MCutil..::..StringWriterUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StringWriterUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StringWriterUtf8()
Visual Basic
Public Sub New
Visual C++
public:
StringWriterUtf8()

See Also

MCutil..::..StringWriterUtf8 Class
MCutil..::..StringWriterUtf8 Members
MCutil..::..StringWriterUtf8 Overload
Mergecomws.Util Namespace


MCutil.StringWriterUtf8 Constructor (IFormatProvider)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StringWriterUtf8 Constructor (IFormatProvider)
MCutil..::..StringWriterUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StringWriterUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StringWriterUtf8(
    IFormatProvider fp
)
Visual Basic
Public Sub New ( _
    fp As IFormatProvider _
)
Visual C++
public:
StringWriterUtf8(
    IFormatProvider^ fp
)

Parameters

fp
Type: System..::..IFormatProvider
An IFormatProvider object that controls formatting.

See Also

MCutil..::..StringWriterUtf8 Class
MCutil..::..StringWriterUtf8 Members
MCutil..::..StringWriterUtf8 Overload
Mergecomws.Util Namespace


MCutil.StringWriterUtf8 Constructor (StringBuilder)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StringWriterUtf8 Constructor (StringBuilder)
MCutil..::..StringWriterUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StringWriterUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StringWriterUtf8(
    StringBuilder sb
)
Visual Basic
Public Sub New ( _
    sb As StringBuilder _
)
Visual C++
public:
StringWriterUtf8(
    StringBuilder^ sb
)

Parameters

sb
Type: System.Text..::..StringBuilder
The StringBuilder to write to.

See Also

MCutil..::..StringWriterUtf8 Class
MCutil..::..StringWriterUtf8 Members
MCutil..::..StringWriterUtf8 Overload
Mergecomws.Util Namespace


MCutil.StringWriterUtf8 Constructor (StringBuilder, IFormatProvider)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StringWriterUtf8 Constructor (StringBuilder, IFormatProvider)
MCutil..::..StringWriterUtf8 Class See Also Send Feedback
Initializes a new instance of the MCutil..::..StringWriterUtf8 class

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public StringWriterUtf8(
    StringBuilder sb,
    IFormatProvider fp
)
Visual Basic
Public Sub New ( _
    sb As StringBuilder, _
    fp As IFormatProvider _
)
Visual C++
public:
StringWriterUtf8(
    StringBuilder^ sb,
    IFormatProvider^ fp
)

Parameters

sb
Type: System.Text..::..StringBuilder
The StringBuilder to write to.
fp
Type: System..::..IFormatProvider
An IFormatProvider object that controls formatting.

See Also

MCutil..::..StringWriterUtf8 Class
MCutil..::..StringWriterUtf8 Members
MCutil..::..StringWriterUtf8 Overload
Mergecomws.Util Namespace


MCutil.StringWriterUtf8 Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StringWriterUtf8 Fields
MCutil..::..StringWriterUtf8 Class See Also Send Feedback

The MCutil..::..StringWriterUtf8 type exposes the following members.

Fields

 | Name | Description
Protected field | CoreNewLine | Stores the new line characters used for this TextWriter. (Inherited from TextWriter.)

See Also

MCutil..::..StringWriterUtf8 Class
Mergecomws.Util Namespace


MCutil.StringWriterUtf8 Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StringWriterUtf8 Methods
MCutil..::..StringWriterUtf8 Class See Also Send Feedback

The MCutil..::..StringWriterUtf8 type exposes the following members.

Methods

 | Name | Description
Public method | Close | Closes the current StringWriter and the underlying stream. (Inherited from StringWriter.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose()()()() | Releases all resources used by the TextWriter object. (Inherited from TextWriter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the StringWriter and optionally releases the managed resources. (Inherited from StringWriter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (Inherited from TextWriter.)
Public method | FlushAsync | (Inherited from StringWriter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetStringBuilder | Returns the underlying StringBuilder. (Inherited from StringWriter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string containing the characters written to the current StringWriter so far. (Inherited from StringWriter.)
Public method | Write(Char) | Writes a character to this instance of the StringWriter. (Inherited from StringWriter.)
Public method | Write(String) | Writes a string to this instance of the StringWriter. (Inherited from StringWriter.)
Public method | Write(array<Char>[]()[][]) | Writes a character array to the text stream. (Inherited from TextWriter.)
Public method | Write(Boolean) | Writes the text representation of a Boolean value to the text stream. (Inherited from TextWriter.)
Public method | Write(Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (Inherited from TextWriter.)
Public method | Write(UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Public method | Write(Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (Inherited from TextWriter.)
Public method | Write(UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (Inherited from TextWriter.)
Public method | Write(Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (Inherited from TextWriter.)
Public method | Write(Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (Inherited from TextWriter.)
Public method | Write(Decimal) | Writes the text representation of a decimal value to the text stream. (Inherited from TextWriter.)
Public method | Write(Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (Inherited from TextWriter.)
Public method | Write(String, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(String, array<Object>[]()[][]) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(array<Char>[]()[][], Int32, Int32) | Writes the specified region of a character array to this instance of the StringWriter. (Inherited from StringWriter.)
Public method | Write(String, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | Write(String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteAsync(Char) | (Inherited from StringWriter.)
Public method | WriteAsync(String) | (Inherited from StringWriter.)
Public method | WriteAsync(array<Char>[]()[][]) | (Inherited from TextWriter.)
Public method | WriteAsync(array<Char>[]()[][], Int32, Int32) | (Inherited from StringWriter.)
Public method | WriteLine()()()() | Writes a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Char) | Writes a character followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(array<Char>[]()[][]) | Writes an array of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String) | Writes a string followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(String, array<Object>[]()[][]) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(array<Char>[]()[][], Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (Inherited from TextWriter.)
Public method | WriteLine(String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLine(String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format(String, Object). (Inherited from TextWriter.)
Public method | WriteLineAsync()()()() | (Inherited from TextWriter.)
Public method | WriteLineAsync(Char) | (Inherited from StringWriter.)
Public method | WriteLineAsync(String) | (Inherited from StringWriter.)
Public method | WriteLineAsync(array<Char>[]()[][]) | (Inherited from TextWriter.)
Public method | WriteLineAsync(array<Char>[]()[][], Int32, Int32) | (Inherited from StringWriter.)

See Also

MCutil..::..StringWriterUtf8 Class
Mergecomws.Util Namespace


MCutil.StringWriterUtf8 Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StringWriterUtf8 Properties
MCutil..::..StringWriterUtf8 Class See Also Send Feedback

The MCutil..::..StringWriterUtf8 type exposes the following members.

Properties

 | Name | Description
Public property | Encoding | Gets the current character encoding that the current MCutil..::..StringWriterUtf8 object is using. (Overrides StringWriter..::..Encoding.)
Public property | FormatProvider | Gets an object that controls formatting. (Inherited from TextWriter.)
Public property | NewLine | Gets or sets the line terminator string used by the current TextWriter. (Inherited from TextWriter.)

See Also

MCutil..::..StringWriterUtf8 Class
Mergecomws.Util Namespace


Encoding Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCutil..::..StringWriterUtf8..::..Encoding Property
MCutil..::..StringWriterUtf8 Class See Also Send Feedback
Gets the current character encoding that the current MCutil..::..StringWriterUtf8 object is using.

Namespace: Mergecomws.Util
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override Encoding Encoding { get; }
Visual Basic
Public Overrides ReadOnly Property Encoding As Encoding
    Get
Visual C++
public:
virtual property Encoding^ Encoding {
    Encoding^ get () override;
}

See Also

MCutil..::..StringWriterUtf8 Class
MCutil..::..StringWriterUtf8 Members
Mergecomws.Util Namespace


Mergecomws.Web Namespace

[image]

Merge DICOM Web Services .NET/C# Toolkit
Mergecomws.Web Namespace
Send Feedback
Api Controllers for each type of WADO request.

Classes

 | Class | Description
Public class | MCcontroller | Abstract class inherited from ApiController
Public class | MChttpProvider | Implements IMChttpProvider interface
Public class | MCparameter | Defines a request parameter used in WADO request
Public class | MCparameter..::..HttpHeaderFields | List of available Http Header field names
Public class | MCparameter..::..Names | List of WADO parameters names
Public class | MCparameter..::..Requirements | Requirement property of MCparameter
Public class | MCparameter..::..Status | Status property of request operation
Public class | MCqidoController | Implements Http Get methods for DICOM QIDO-RS requests
Public class | MCrequest | Converts and encapsulates HttpRequestMessage object data
Public class | MCrequestAttribute | Specifies a DICOM attribute used in WADO request
Public class | MCrequestBinder | Implements IModelBinder interface
Public class | MCrequestBinderProvider | Implements ModelBinderProvider methods
Public class | MCrequestType | Describes DICOM request type
Public class | MCrsCapabilitiesController | Implements Http Get methods for DICOM QIDO-RS requests
Public class | MCrsNpiController | Implements Http Post methods for DICOM STOW-RS requests
Public class | MCstowController | Implements Http Post methods for DICOM STOW-RS requests
Public class | MCupsController | Implements Http Post, Get, Put and Delete methods for DICOM UPS-RS requests
Public class | MCwadoRsController | Implements Http Get methods for DICOM WADO-RS requests
Public class | MCwadoUriController | Implements Http Get methods for DICOM WADO-URI requests
Public class | MCwadoWsController | Implements Http Get methods for DICOM WADO-WS requests

Interfaces

 | Interface | Description
Public interface | IMChttpProvider | Provides access to HttpRequestMessage object data


IMChttpProvider Interface

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpProvider Interface
Members See Also Send Feedback
Provides access to HttpRequestMessage object data

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public interface IMChttpProvider
Visual Basic
Public Interface IMChttpProvider
Visual C++
public interface class IMChttpProvider

See Also

IMChttpProvider Members
Mergecomws.Web Namespace


IMChttpProvider Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpProvider Members
IMChttpProvider Interface Methods See Also Send Feedback

The IMChttpProvider type exposes the following members.

Methods

 | Name | Description
Public method | Content | Returns Http Content of HttpRequestMessage object
Public method | Headers | Returns Http Header fields of HttpRequestMessage object
Public method | Method | Returns HttpMethod object
Public method | Properties | Returns Http Dictionary<(Of <(<'TKey, TValue>)>)> properties
Public method | Queries | Returns Http Query of HttpRequestMessage object
Public method | RequestUri | Returns Http Uri object
Public method | Segments | Returns Http Segments of HttpRequestMessage object
Public method | Version | Returns Http Version()()()() object

See Also

IMChttpProvider Interface
Mergecomws.Web Namespace


IMChttpProvider Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpProvider Methods
IMChttpProvider Interface See Also Send Feedback

The IMChttpProvider type exposes the following members.

Methods

 | Name | Description
Public method | Content | Returns Http Content of HttpRequestMessage object
Public method | Headers | Returns Http Header fields of HttpRequestMessage object
Public method | Method | Returns HttpMethod object
Public method | Properties | Returns Http Dictionary<(Of <(<'TKey, TValue>)>)> properties
Public method | Queries | Returns Http Query of HttpRequestMessage object
Public method | RequestUri | Returns Http Uri object
Public method | Segments | Returns Http Segments of HttpRequestMessage object
Public method | Version | Returns Http Version()()()() object

See Also

IMChttpProvider Interface
Mergecomws.Web Namespace


Content Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpProvider..::..Content Method
IMChttpProvider Interface See Also Send Feedback
Returns Http Content of HttpRequestMessage object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
HttpContent Content()
Visual Basic
Function Content As HttpContent
Visual C++
HttpContent^ Content()

Return Value

HttpContent object

See Also

IMChttpProvider Interface
IMChttpProvider Members
Mergecomws.Web Namespace


Headers Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpProvider..::..Headers Method
IMChttpProvider Interface See Also Send Feedback
Returns Http Header fields of HttpRequestMessage object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
IEnumerable<KeyValuePair<string, IEnumerable<string>>> Headers()
Visual Basic
Function Headers As IEnumerable(Of KeyValuePair(Of String, IEnumerable(Of String)))
Visual C++
IEnumerable<KeyValuePair<String^, IEnumerable<String^>^>>^ Headers()

Return Value

List of pairs of Http Header fields and its values

See Also

IMChttpProvider Interface
IMChttpProvider Members
Mergecomws.Web Namespace


Method Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpProvider..::..Method Method
IMChttpProvider Interface See Also Send Feedback
Returns HttpMethod object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
HttpMethod Method()
Visual Basic
Function Method As HttpMethod
Visual C++
HttpMethod^ Method()

Return Value

HttpMethod object

See Also

IMChttpProvider Interface
IMChttpProvider Members
Mergecomws.Web Namespace


Properties Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpProvider..::..Properties Method
IMChttpProvider Interface See Also Send Feedback
Returns Http Dictionary<(Of <(<'TKey, TValue>)>)> properties

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
IDictionary<string, Object> Properties()
Visual Basic
Function Properties As IDictionary(Of String, Object)
Visual C++
IDictionary<String^, Object^>^ Properties()

Return Value

Dictionary<(Of <(<'TKey, TValue>)>)> properties

See Also

IMChttpProvider Interface
IMChttpProvider Members
Mergecomws.Web Namespace


Queries Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpProvider..::..Queries Method
IMChttpProvider Interface See Also Send Feedback
Returns Http Query of HttpRequestMessage object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
IEnumerable<KeyValuePair<string, IEnumerable<string>>> Queries()
Visual Basic
Function Queries As IEnumerable(Of KeyValuePair(Of String, IEnumerable(Of String)))
Visual C++
IEnumerable<KeyValuePair<String^, IEnumerable<String^>^>>^ Queries()

Return Value

List of pairs of Http Query parameters and its values

See Also

IMChttpProvider Interface
IMChttpProvider Members
Mergecomws.Web Namespace


RequestUri Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpProvider..::..RequestUri Method
IMChttpProvider Interface See Also Send Feedback
Returns Http Uri object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
Uri RequestUri()
Visual Basic
Function RequestUri As Uri
Visual C++
Uri^ RequestUri()

Return Value

Uri object

See Also

IMChttpProvider Interface
IMChttpProvider Members
Mergecomws.Web Namespace


Segments Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpProvider..::..Segments Method
IMChttpProvider Interface See Also Send Feedback
Returns Http Segments of HttpRequestMessage object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
IEnumerable<string> Segments()
Visual Basic
Function Segments As IEnumerable(Of String)
Visual C++
IEnumerable<String^>^ Segments()

Return Value

List of String segments

See Also

IMChttpProvider Interface
IMChttpProvider Members
Mergecomws.Web Namespace


Version Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
IMChttpProvider..::..Version Method
IMChttpProvider Interface See Also Send Feedback
Returns Http Version()()()() object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
Version Version()
Visual Basic
Function Version As Version
Visual C++
Version^ Version()

Return Value

Http Version()()()() object

See Also

IMChttpProvider Interface
IMChttpProvider Members
Mergecomws.Web Namespace


MCcontroller Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCcontroller Class
Members See Also Send Feedback
Abstract class inherited from ApiController

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public abstract class MCcontroller : ApiController
Visual Basic
Public MustInherit Class MCcontroller _
    Inherits ApiController
Visual C++
public ref class MCcontroller abstract : public ApiController

Inheritance Hierarchy

System..::..Object
ApiController
Mergecomws.Web..::..MCcontroller
Mergecomws.Web..::..MCqidoController
Mergecomws.Web..::..MCrsCapabilitiesController
Mergecomws.Web..::..MCrsNpiController
Mergecomws.Web..::..MCstowController
Mergecomws.Web..::..MCupsController
Mergecomws.Web..::..MCwadoRsController
Mergecomws.Web..::..MCwadoUriController
Mergecomws.Web..::..MCwadoWsController

See Also

MCcontroller Members
Mergecomws.Web Namespace


MCcontroller Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCcontroller Members
MCcontroller Class Constructors Methods Fields Properties See Also Send Feedback

The MCcontroller type exposes the following members.

Constructors

 | Name | Description
Protected method | MCcontroller | Initializes a new instance of the MCcontroller class

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

Fields

Name | Description
MCQIDO_ControllerName |
MCRSCAPABILITIES_ControllerName |
MCRSNPI_ControllerName |
MCSTOW_ControllerName |
MCUPS_ControllerName |
MCWADORS_ControllerName |
MCWADOURI_ControllerName |
MCWADOWS_ControllerName |

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes).
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCcontroller Class
Mergecomws.Web Namespace


MCcontroller Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCcontroller Constructor
MCcontroller Class See Also Send Feedback
Initializes a new instance of the MCcontroller class

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected MCcontroller()
Visual Basic
Protected Sub New
Visual C++
protected:
MCcontroller()

See Also

MCcontroller Class
MCcontroller Members
Mergecomws.Web Namespace


MCcontroller Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCcontroller Fields
MCcontroller Class See Also Send Feedback

The MCcontroller type exposes the following members.

Fields

Name | Description
MCQIDO_ControllerName |
MCRSCAPABILITIES_ControllerName |
MCRSNPI_ControllerName |
MCSTOW_ControllerName |
MCUPS_ControllerName |
MCWADORS_ControllerName |
MCWADOURI_ControllerName |
MCWADOWS_ControllerName |

See Also

MCcontroller Class
Mergecomws.Web Namespace


MCQIDO_ControllerName Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCcontroller..::..MCQIDO_ControllerName Field
MCcontroller Class See Also Send Feedback

[Missing <summary> documentation for "F:Mergecomws.Web.MCcontroller.MCQIDO_ControllerName"]

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static string MCQIDO_ControllerName
Visual Basic
Public Shared MCQIDO_ControllerName As String
Visual C++
public:
static String^ MCQIDO_ControllerName

See Also

MCcontroller Class
MCcontroller Members
Mergecomws.Web Namespace


MCRSCAPABILITIES_ControllerName Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCcontroller..::..MCRSCAPABILITIES_ControllerName Field
MCcontroller Class See Also Send Feedback

[Missing <summary> documentation for "F:Mergecomws.Web.MCcontroller.MCRSCAPABILITIES_ControllerName"]

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static string MCRSCAPABILITIES_ControllerName
Visual Basic
Public Shared MCRSCAPABILITIES_ControllerName As String
Visual C++
public:
static String^ MCRSCAPABILITIES_ControllerName

See Also

MCcontroller Class
MCcontroller Members
Mergecomws.Web Namespace


MCRSNPI_ControllerName Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCcontroller..::..MCRSNPI_ControllerName Field
MCcontroller Class See Also Send Feedback

[Missing <summary> documentation for "F:Mergecomws.Web.MCcontroller.MCRSNPI_ControllerName"]

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static string MCRSNPI_ControllerName
Visual Basic
Public Shared MCRSNPI_ControllerName As String
Visual C++
public:
static String^ MCRSNPI_ControllerName

See Also

MCcontroller Class
MCcontroller Members
Mergecomws.Web Namespace


MCSTOW_ControllerName Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCcontroller..::..MCSTOW_ControllerName Field
MCcontroller Class See Also Send Feedback

[Missing <summary> documentation for "F:Mergecomws.Web.MCcontroller.MCSTOW_ControllerName"]

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static string MCSTOW_ControllerName
Visual Basic
Public Shared MCSTOW_ControllerName As String
Visual C++
public:
static String^ MCSTOW_ControllerName

See Also

MCcontroller Class
MCcontroller Members
Mergecomws.Web Namespace


MCUPS_ControllerName Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCcontroller..::..MCUPS_ControllerName Field
MCcontroller Class See Also Send Feedback

[Missing <summary> documentation for "F:Mergecomws.Web.MCcontroller.MCUPS_ControllerName"]

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static string MCUPS_ControllerName
Visual Basic
Public Shared MCUPS_ControllerName As String
Visual C++
public:
static String^ MCUPS_ControllerName

See Also

MCcontroller Class
MCcontroller Members
Mergecomws.Web Namespace


MCWADORS_ControllerName Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCcontroller..::..MCWADORS_ControllerName Field
MCcontroller Class See Also Send Feedback

[Missing <summary> documentation for "F:Mergecomws.Web.MCcontroller.MCWADORS_ControllerName"]

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static string MCWADORS_ControllerName
Visual Basic
Public Shared MCWADORS_ControllerName As String
Visual C++
public:
static String^ MCWADORS_ControllerName

See Also

MCcontroller Class
MCcontroller Members
Mergecomws.Web Namespace


MCWADOURI_ControllerName Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCcontroller..::..MCWADOURI_ControllerName Field
MCcontroller Class See Also Send Feedback

[Missing <summary> documentation for "F:Mergecomws.Web.MCcontroller.MCWADOURI_ControllerName"]

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static string MCWADOURI_ControllerName
Visual Basic
Public Shared MCWADOURI_ControllerName As String
Visual C++
public:
static String^ MCWADOURI_ControllerName

See Also

MCcontroller Class
MCcontroller Members
Mergecomws.Web Namespace


MCWADOWS_ControllerName Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCcontroller..::..MCWADOWS_ControllerName Field
MCcontroller Class See Also Send Feedback

[Missing <summary> documentation for "F:Mergecomws.Web.MCcontroller.MCWADOWS_ControllerName"]

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static string MCWADOWS_ControllerName
Visual Basic
Public Shared MCWADOWS_ControllerName As String
Visual C++
public:
static String^ MCWADOWS_ControllerName

See Also

MCcontroller Class
MCcontroller Members
Mergecomws.Web Namespace


MCcontroller Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCcontroller Methods
MCcontroller Class See Also Send Feedback

The MCcontroller type exposes the following members.

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

See Also

MCcontroller Class
Mergecomws.Web Namespace


MCcontroller Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCcontroller Properties
MCcontroller Class See Also Send Feedback

The MCcontroller type exposes the following members.

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes).
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCcontroller Class
Mergecomws.Web Namespace


Name Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCcontroller..::..Name Property
MCcontroller Class See Also Send Feedback
Get/Set the name of the specific controller (see derived classes).

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Name { get; protected set; }
Visual Basic
Public Property Name As String
    Get
    Protected Set
Visual C++
public:
property String^ Name {
    String^ get ();
    protected: void set (String^ value);
}

See Also

MCcontroller Class
MCcontroller Members
Mergecomws.Web Namespace


MChttpProvider Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider Class
Members See Also Send Feedback
Implements IMChttpProvider interface

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MChttpProvider : IMChttpProvider
Visual Basic
Public Class MChttpProvider _
    Implements IMChttpProvider
Visual C++
public ref class MChttpProvider : IMChttpProvider

Inheritance Hierarchy

System..::..Object
Mergecomws.Web..::..MChttpProvider

See Also

MChttpProvider Members
Mergecomws.Web Namespace


MChttpProvider Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider Members
MChttpProvider Class Methods Properties See Also Send Feedback

The MChttpProvider type exposes the following members.

Methods

 | Name | Description
Public method | Content | Returns HttpContent object of current request
 | CreateInstance | Creates MChttpProvider object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Headers | Returns the list of Http Header pairs of fields and corrsponding values
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Method | Returns HttpMethod object of current request
Public method | Properties | Returns Dictionary<(Of <(<'TKey, TValue>)>)> properties of current request
Public method | Queries | Returns the list of Http Query pairs with keys and corresponding values
Public method | RequestUri | Returns Uri object of current request
Public method | Segments | Returns Http Segments of HttpRequestMessage object
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Version | Returns Http Version()()()() object of current request

Properties

 | Name | Description
Protected property | ActionContext | Gets HttpActionContext object of current request
Protected property | BindingContext | Gets ModelBindingContext object of current request
Protected property | HttpRequestMessage | Gets HttpRequestMessage object of current request

See Also

MChttpProvider Class
Mergecomws.Web Namespace


MChttpProvider Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider Methods
MChttpProvider Class See Also Send Feedback

The MChttpProvider type exposes the following members.

Methods

 | Name | Description
Public method | Content | Returns HttpContent object of current request
 | CreateInstance | Creates MChttpProvider object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Headers | Returns the list of Http Header pairs of fields and corrsponding values
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Method | Returns HttpMethod object of current request
Public method | Properties | Returns Dictionary<(Of <(<'TKey, TValue>)>)> properties of current request
Public method | Queries | Returns the list of Http Query pairs with keys and corresponding values
Public method | RequestUri | Returns Uri object of current request
Public method | Segments | Returns Http Segments of HttpRequestMessage object
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Version | Returns Http Version()()()() object of current request

See Also

MChttpProvider Class
Mergecomws.Web Namespace


Content Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider..::..Content Method
MChttpProvider Class See Also Send Feedback
Returns HttpContent object of current request

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpContent Content()
Visual Basic
Public Function Content As HttpContent
Visual C++
public:
virtual HttpContent^ Content() sealed

Return Value

HttpContent object

Implements

IMChttpProvider..::..Content()()()()

See Also

MChttpProvider Class
MChttpProvider Members
Mergecomws.Web Namespace


CreateInstance Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider..::..CreateInstance Method
MChttpProvider Class See Also Send Feedback
Creates MChttpProvider object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MChttpProvider CreateInstance(
    HttpRequestMessage httpRequestMessage
)
Visual Basic
Public Shared Function CreateInstance ( _
    httpRequestMessage As HttpRequestMessage _
) As MChttpProvider
Visual C++
public:
static MChttpProvider^ CreateInstance(
    HttpRequestMessage^ httpRequestMessage
)

Parameters

httpRequestMessage
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

MChttpProvider object

See Also

MChttpProvider Class
MChttpProvider Members
Mergecomws.Web Namespace


Headers Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider..::..Headers Method
MChttpProvider Class See Also Send Feedback
Returns the list of Http Header pairs of fields and corrsponding values

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public IEnumerable<KeyValuePair<string, IEnumerable<string>>> Headers()
Visual Basic
Public Function Headers As IEnumerable(Of KeyValuePair(Of String, IEnumerable(Of String)))
Visual C++
public:
virtual IEnumerable<KeyValuePair<String^, IEnumerable<String^>^>>^ Headers() sealed

Return Value

List of KeyValuePair<(Of <(<'TKey, TValue>)>)> Http Header pairs

Implements

IMChttpProvider..::..Headers()()()()

See Also

MChttpProvider Class
MChttpProvider Members
Mergecomws.Web Namespace


Method Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider..::..Method Method
MChttpProvider Class See Also Send Feedback
Returns HttpMethod object of current request

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpMethod Method()
Visual Basic
Public Function Method As HttpMethod
Visual C++
public:
virtual HttpMethod^ Method() sealed

Return Value

HttpMethod object

Implements

IMChttpProvider..::..Method()()()()

See Also

MChttpProvider Class
MChttpProvider Members
Mergecomws.Web Namespace


Properties Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider..::..Properties Method
MChttpProvider Class See Also Send Feedback
Returns Dictionary<(Of <(<'TKey, TValue>)>)> properties of current request

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public IDictionary<string, Object> Properties()
Visual Basic
Public Function Properties As IDictionary(Of String, Object)
Visual C++
public:
virtual IDictionary<String^, Object^>^ Properties() sealed

Return Value

Dictionary<(Of <(<'TKey, TValue>)>)> properties

Implements

IMChttpProvider..::..Properties()()()()

See Also

MChttpProvider Class
MChttpProvider Members
Mergecomws.Web Namespace


Queries Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider..::..Queries Method
MChttpProvider Class See Also Send Feedback
Returns the list of Http Query pairs with keys and corresponding values

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public IEnumerable<KeyValuePair<string, IEnumerable<string>>> Queries()
Visual Basic
Public Function Queries As IEnumerable(Of KeyValuePair(Of String, IEnumerable(Of String)))
Visual C++
public:
virtual IEnumerable<KeyValuePair<String^, IEnumerable<String^>^>>^ Queries() sealed

Return Value

List of KeyValuePair<(Of <(<'TKey, TValue>)>)> Http Query pairs

Implements

IMChttpProvider..::..Queries()()()()

See Also

MChttpProvider Class
MChttpProvider Members
Mergecomws.Web Namespace


RequestUri Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider..::..RequestUri Method
MChttpProvider Class See Also Send Feedback
Returns Uri object of current request

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public Uri RequestUri()
Visual Basic
Public Function RequestUri As Uri
Visual C++
public:
virtual Uri^ RequestUri() sealed

Return Value

Uri object

Implements

IMChttpProvider..::..RequestUri()()()()

See Also

MChttpProvider Class
MChttpProvider Members
Mergecomws.Web Namespace


Segments Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider..::..Segments Method
MChttpProvider Class See Also Send Feedback
Returns Http Segments of HttpRequestMessage object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public IEnumerable<string> Segments()
Visual Basic
Public Function Segments As IEnumerable(Of String)
Visual C++
public:
virtual IEnumerable<String^>^ Segments() sealed

Return Value

List of Http String Segments

Implements

IMChttpProvider..::..Segments()()()()

See Also

MChttpProvider Class
MChttpProvider Members
Mergecomws.Web Namespace


Version Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider..::..Version Method
MChttpProvider Class See Also Send Feedback
Returns Http Version()()()() object of current request

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public Version Version()
Visual Basic
Public Function Version As Version
Visual C++
public:
virtual Version^ Version() sealed

Return Value

Http Version()()()() object

Implements

IMChttpProvider..::..Version()()()()

See Also

MChttpProvider Class
MChttpProvider Members
Mergecomws.Web Namespace


MChttpProvider Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider Properties
MChttpProvider Class See Also Send Feedback

The MChttpProvider type exposes the following members.

Properties

 | Name | Description
Protected property | ActionContext | Gets HttpActionContext object of current request
Protected property | BindingContext | Gets ModelBindingContext object of current request
Protected property | HttpRequestMessage | Gets HttpRequestMessage object of current request

See Also

MChttpProvider Class
Mergecomws.Web Namespace


ActionContext Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider..::..ActionContext Property
MChttpProvider Class See Also Send Feedback
Gets HttpActionContext object of current request

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected HttpActionContext ActionContext { get; private set; }
Visual Basic
Protected Property ActionContext As HttpActionContext
    Get
    Private Set
Visual C++
protected:
property HttpActionContext^ ActionContext {
    HttpActionContext^ get ();
    private: void set (HttpActionContext^ value);
}

See Also

MChttpProvider Class
MChttpProvider Members
Mergecomws.Web Namespace


BindingContext Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider..::..BindingContext Property
MChttpProvider Class See Also Send Feedback
Gets ModelBindingContext object of current request

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected ModelBindingContext BindingContext { get; private set; }
Visual Basic
Protected Property BindingContext As ModelBindingContext
    Get
    Private Set
Visual C++
protected:
property ModelBindingContext^ BindingContext {
    ModelBindingContext^ get ();
    private: void set (ModelBindingContext^ value);
}

See Also

MChttpProvider Class
MChttpProvider Members
Mergecomws.Web Namespace


HttpRequestMessage Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MChttpProvider..::..HttpRequestMessage Property
MChttpProvider Class See Also Send Feedback
Gets HttpRequestMessage object of current request

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
protected HttpRequestMessage HttpRequestMessage { get; private set; }
Visual Basic
Protected Property HttpRequestMessage As HttpRequestMessage
    Get
    Private Set
Visual C++
protected:
property HttpRequestMessage^ HttpRequestMessage {
    HttpRequestMessage^ get ();
    private: void set (HttpRequestMessage^ value);
}

See Also

MChttpProvider Class
MChttpProvider Members
Mergecomws.Web Namespace


MCparameter Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter Class
Members See Also Send Feedback
Defines a request parameter used in WADO request

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCparameter
Visual Basic
Public Class MCparameter
Visual C++
public ref class MCparameter

Inheritance Hierarchy

System..::..Object
Mergecomws.Web..::..MCparameter

See Also

MCparameter Members
Mergecomws.Web Namespace


MCparameter Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter Members
MCparameter Class Constructors Methods Properties See Also Send Feedback

The MCparameter type exposes the following members.

Constructors

 | Name | Description
Public method | MCparameter | Class constructor

Methods

 | Name | Description
Public method | Clone | Returns a deep copy of MCparameter object
Public method | ContainTags | Checks if MCparameter object contains MCrequestAttribute object
Public method | Equals(Object) | Checks if MCparameter object is equal to Object (Overrides Object..::..Equals(Object).)
Public method | Equals(MCparameter) | Checks if MCparameter objects are equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode of MCparameter object (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseParametersToXml | Encode the list of MCparameter objects into XML string
 | ParseXmlToParameters | Decode XML String to the list of MCparameter objects
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateAttribute | Validates MCrequestAttribute object with UInt32 tag

Properties

 | Name | Description
Public property | Attributes | Gets and sets the list of MCrequestAttribute of MCparameter object
Public property | Name | Gets and sets MCparameter name
Public property | Requirement | Gets and sets requirement property of MCparameter object, OPTIONAL by default
Public property | UniqueId | Gets and sets MCparameter unique id
Public property | Values | Gets and sets the list of MCparameter values

See Also

MCparameter Class
Mergecomws.Web Namespace


MCparameter Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter Constructor
MCparameter Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCparameter()
Visual Basic
Public Sub New
Visual C++
public:
MCparameter()

See Also

MCparameter Class
MCparameter Members
Mergecomws.Web Namespace


MCparameter Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter Methods
MCparameter Class See Also Send Feedback

The MCparameter type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a deep copy of MCparameter object
Public method | ContainTags | Checks if MCparameter object contains MCrequestAttribute object
Public method | Equals(Object) | Checks if MCparameter object is equal to Object (Overrides Object..::..Equals(Object).)
Public method | Equals(MCparameter) | Checks if MCparameter objects are equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode of MCparameter object (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseParametersToXml | Encode the list of MCparameter objects into XML string
 | ParseXmlToParameters | Decode XML String to the list of MCparameter objects
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateAttribute | Validates MCrequestAttribute object with UInt32 tag

See Also

MCparameter Class
Mergecomws.Web Namespace


Clone Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Clone Method
MCparameter Class See Also Send Feedback
Returns a deep copy of MCparameter object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCparameter Clone()
Visual Basic
Public Function Clone As MCparameter
Visual C++
public:
MCparameter^ Clone()

Return Value

MCparameter object

See Also

MCparameter Class
MCparameter Members
Mergecomws.Web Namespace


ContainTags Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..ContainTags Method
MCparameter Class See Also Send Feedback
Checks if MCparameter object contains MCrequestAttribute object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public bool ContainTags(
    IEnumerable<uint> tags
)
Visual Basic
Public Function ContainTags ( _
    tags As IEnumerable(Of UInteger) _
) As Boolean
Visual C++
public:
bool ContainTags(
    IEnumerable<unsigned int>^ tags
)

Parameters

tags
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'UInt32>)>)>
List of DICOM attribute tags

Return Value

Returns True if MCparameter object contains at least one MCrequestAttribute object with a tag from the list

See Also

MCparameter Class
MCparameter Members
Mergecomws.Web Namespace


Equals Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Equals Method
MCparameter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Checks if MCparameter object is equal to Object (Overrides Object..::..Equals(Object).)
Public method | Equals(MCparameter) | Checks if MCparameter objects are equal

See Also

MCparameter Class
MCparameter Members
Mergecomws.Web Namespace


Equals Method (Object)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Equals Method (Object)
MCparameter Class See Also Send Feedback
Checks if MCparameter object is equal to Object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare with the current object.

Return Value

Returns True if objects are equal

See Also

MCparameter Class
MCparameter Members
Equals Overload
Mergecomws.Web Namespace


Equals Method (MCparameter)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Equals Method (MCparameter)
MCparameter Class See Also Send Feedback
Checks if MCparameter objects are equal

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public bool Equals(
    MCparameter rq
)
Visual Basic
Public Function Equals ( _
    rq As MCparameter _
) As Boolean
Visual C++
public:
bool Equals(
    MCparameter^ rq
)

Parameters

rq
Type: Mergecomws.Web..::..MCparameter
MCparameter object

Return Value

Returns True if objects Name are the same

See Also

MCparameter Class
MCparameter Members
Equals Overload
Mergecomws.Web Namespace


GetHashCode Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..GetHashCode Method
MCparameter Class See Also Send Feedback
Gets the hashcode of MCparameter object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

Returns a hashcode generated from Name

See Also

MCparameter Class
MCparameter Members
Mergecomws.Web Namespace


ParseParametersToXml Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..ParseParametersToXml Method
MCparameter Class See Also Send Feedback
Encode the list of MCparameter objects into XML string

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static string ParseParametersToXml(
    string name,
    IEnumerable<MCparameter> parameters
)
Visual Basic
Public Shared Function ParseParametersToXml ( _
    name As String, _
    parameters As IEnumerable(Of MCparameter) _
) As String
Visual C++
public:
static String^ ParseParametersToXml(
    String^ name,
    IEnumerable<MCparameter^>^ parameters
)

Parameters

name
Type: System..::..String
Name of XML Root node
parameters
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' MCparameter >)>)>
List of MCparameter objects

Return Value

XML String

See Also

MCparameter Class
MCparameter Members
Mergecomws.Web Namespace


ParseXmlToParameters Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..ParseXmlToParameters Method
MCparameter Class See Also Send Feedback
Decode XML String to the list of MCparameter objects

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static IEnumerable<MCparameter> ParseXmlToParameters(
    string xml
)
Visual Basic
Public Shared Function ParseXmlToParameters ( _
    xml As String _
) As IEnumerable(Of MCparameter)
Visual C++
public:
static IEnumerable<MCparameter^>^ ParseXmlToParameters(
    String^ xml
)

Parameters

xml
Type: System..::..String
XML String

Return Value

List of MCparameter objects

See Also

MCparameter Class
MCparameter Members
Mergecomws.Web Namespace


ValidateAttribute Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..ValidateAttribute Method
MCparameter Class See Also Send Feedback
Validates MCrequestAttribute object with UInt32 tag

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public bool ValidateAttribute(
    uint tag
)
Visual Basic
Public Function ValidateAttribute ( _
    tag As UInteger _
) As Boolean
Visual C++
public:
bool ValidateAttribute(
    unsigned int tag
)

Parameters

tag
Type: System..::..UInt32
DICOM UInt32 attribute tag

Return Value

Returns True if MCrequestAttribute object with a given tag and non-empty values exists

See Also

MCparameter Class
MCparameter Members
Mergecomws.Web Namespace


MCparameter Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter Properties
MCparameter Class See Also Send Feedback

The MCparameter type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets and sets the list of MCrequestAttribute of MCparameter object
Public property | Name | Gets and sets MCparameter name
Public property | Requirement | Gets and sets requirement property of MCparameter object, OPTIONAL by default
Public property | UniqueId | Gets and sets MCparameter unique id
Public property | Values | Gets and sets the list of MCparameter values

See Also

MCparameter Class
Mergecomws.Web Namespace


Attributes Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Attributes Property
MCparameter Class See Also Send Feedback
Gets and sets the list of MCrequestAttribute of MCparameter object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public IEnumerable<MCrequestAttribute> Attributes { get; set; }
Visual Basic
Public Property Attributes As IEnumerable(Of MCrequestAttribute)
    Get
    Set
Visual C++
public:
property IEnumerable<MCrequestAttribute^>^ Attributes {
    IEnumerable<MCrequestAttribute^>^ get ();
    void set (IEnumerable<MCrequestAttribute^>^ value);
}

See Also

MCparameter Class
MCparameter Members
Mergecomws.Web Namespace


Name Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Name Property
MCparameter Class See Also Send Feedback
Gets and sets MCparameter name

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

MCparameter Class
MCparameter Members
Mergecomws.Web Namespace


Requirement Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Requirement Property
MCparameter Class See Also Send Feedback
Gets and sets requirement property of MCparameter object, OPTIONAL by default

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Requirement { get; set; }
Visual Basic
Public Property Requirement As String
    Get
    Set
Visual C++
public:
property String^ Requirement {
    String^ get ();
    void set (String^ value);
}

See Also

MCparameter Class
MCparameter Members
Mergecomws.Web Namespace


UniqueId Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..UniqueId Property
MCparameter Class See Also Send Feedback
Gets and sets MCparameter unique id

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string UniqueId { get; set; }
Visual Basic
Public Property UniqueId As String
    Get
    Set
Visual C++
public:
property String^ UniqueId {
    String^ get ();
    void set (String^ value);
}

See Also

MCparameter Class
MCparameter Members
Mergecomws.Web Namespace


Values Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Values Property
MCparameter Class See Also Send Feedback
Gets and sets the list of MCparameter values

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public IEnumerable<string> Values { get; set; }
Visual Basic
Public Property Values As IEnumerable(Of String)
    Get
    Set
Visual C++
public:
property IEnumerable<String^>^ Values {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}

See Also

MCparameter Class
MCparameter Members
Mergecomws.Web Namespace


MCparameter.HttpHeaderFields Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..HttpHeaderFields Class
MCparameter Class Members See Also Send Feedback
List of available Http Header field names

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static class HttpHeaderFields
Visual Basic
Public NotInheritable Class HttpHeaderFields
Visual C++
public ref class HttpHeaderFields abstract sealed

Inheritance Hierarchy

System..::..Object
Mergecomws.Web..::..MCparameter..::..HttpHeaderFields

See Also

MCparameter..::..HttpHeaderFields Members
Mergecomws.Web Namespace


MCparameter.HttpHeaderFields Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..HttpHeaderFields Members
MCparameter..::..HttpHeaderFields Class Fields See Also Send Feedback

The MCparameter..::..HttpHeaderFields type exposes the following members.

Fields

Name | Description
ACCEPT | "Accept"
ACCEPT_CHARSET | "Accept-Charset"
CACHE_CONTROL | "Cache-Control"
CONTENT_ID | "Content-ID"
CONTENT_LENGTH | "Content-Length"
CONTENT_LOCATION | "Content-Location"
CONTENT_TRANSFER_ENCODING | "Content-Transfer-Encoding"
CONTENT_TYPE | "Content-Type"
HOST | "Host"
TRANSFER_ENCODING | "Transfer-Encoding"
USER_AGENT | "User-Agent"

See Also

MCparameter..::..HttpHeaderFields Class
Mergecomws.Web Namespace


MCparameter.HttpHeaderFields Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..HttpHeaderFields Fields
MCparameter..::..HttpHeaderFields Class See Also Send Feedback

The MCparameter..::..HttpHeaderFields type exposes the following members.

Fields

Name | Description
ACCEPT | "Accept"
ACCEPT_CHARSET | "Accept-Charset"
CACHE_CONTROL | "Cache-Control"
CONTENT_ID | "Content-ID"
CONTENT_LENGTH | "Content-Length"
CONTENT_LOCATION | "Content-Location"
CONTENT_TRANSFER_ENCODING | "Content-Transfer-Encoding"
CONTENT_TYPE | "Content-Type"
HOST | "Host"
TRANSFER_ENCODING | "Transfer-Encoding"
USER_AGENT | "User-Agent"

See Also

MCparameter..::..HttpHeaderFields Class
Mergecomws.Web Namespace


ACCEPT Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..HttpHeaderFields..::..ACCEPT Field
MCparameter..::..HttpHeaderFields Class See Also Send Feedback
"Accept"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string ACCEPT
Visual Basic
Public Shared ReadOnly ACCEPT As String
Visual C++
public:
static initonly String^ ACCEPT

See Also

MCparameter..::..HttpHeaderFields Class
MCparameter..::..HttpHeaderFields Members
Mergecomws.Web Namespace


ACCEPT_CHARSET Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..HttpHeaderFields..::..ACCEPT_CHARSET Field
MCparameter..::..HttpHeaderFields Class See Also Send Feedback
"Accept-Charset"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string ACCEPT_CHARSET
Visual Basic
Public Shared ReadOnly ACCEPT_CHARSET As String
Visual C++
public:
static initonly String^ ACCEPT_CHARSET

See Also

MCparameter..::..HttpHeaderFields Class
MCparameter..::..HttpHeaderFields Members
Mergecomws.Web Namespace


CACHE_CONTROL Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..HttpHeaderFields..::..CACHE_CONTROL Field
MCparameter..::..HttpHeaderFields Class See Also Send Feedback
"Cache-Control"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string CACHE_CONTROL
Visual Basic
Public Shared ReadOnly CACHE_CONTROL As String
Visual C++
public:
static initonly String^ CACHE_CONTROL

See Also

MCparameter..::..HttpHeaderFields Class
MCparameter..::..HttpHeaderFields Members
Mergecomws.Web Namespace


CONTENT_ID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..HttpHeaderFields..::..CONTENT_ID Field
MCparameter..::..HttpHeaderFields Class See Also Send Feedback
"Content-ID"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string CONTENT_ID
Visual Basic
Public Shared ReadOnly CONTENT_ID As String
Visual C++
public:
static initonly String^ CONTENT_ID

See Also

MCparameter..::..HttpHeaderFields Class
MCparameter..::..HttpHeaderFields Members
Mergecomws.Web Namespace


CONTENT_LENGTH Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..HttpHeaderFields..::..CONTENT_LENGTH Field
MCparameter..::..HttpHeaderFields Class See Also Send Feedback
"Content-Length"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string CONTENT_LENGTH
Visual Basic
Public Shared ReadOnly CONTENT_LENGTH As String
Visual C++
public:
static initonly String^ CONTENT_LENGTH

See Also

MCparameter..::..HttpHeaderFields Class
MCparameter..::..HttpHeaderFields Members
Mergecomws.Web Namespace


CONTENT_LOCATION Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..HttpHeaderFields..::..CONTENT_LOCATION Field
MCparameter..::..HttpHeaderFields Class See Also Send Feedback
"Content-Location"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string CONTENT_LOCATION
Visual Basic
Public Shared ReadOnly CONTENT_LOCATION As String
Visual C++
public:
static initonly String^ CONTENT_LOCATION

See Also

MCparameter..::..HttpHeaderFields Class
MCparameter..::..HttpHeaderFields Members
Mergecomws.Web Namespace


CONTENT_TRANSFER_ENCODING Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..HttpHeaderFields..::..CONTENT_TRANSFER_ENCODING Field
MCparameter..::..HttpHeaderFields Class See Also Send Feedback
"Content-Transfer-Encoding"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string CONTENT_TRANSFER_ENCODING
Visual Basic
Public Shared ReadOnly CONTENT_TRANSFER_ENCODING As String
Visual C++
public:
static initonly String^ CONTENT_TRANSFER_ENCODING

See Also

MCparameter..::..HttpHeaderFields Class
MCparameter..::..HttpHeaderFields Members
Mergecomws.Web Namespace


CONTENT_TYPE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..HttpHeaderFields..::..CONTENT_TYPE Field
MCparameter..::..HttpHeaderFields Class See Also Send Feedback
"Content-Type"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string CONTENT_TYPE
Visual Basic
Public Shared ReadOnly CONTENT_TYPE As String
Visual C++
public:
static initonly String^ CONTENT_TYPE

See Also

MCparameter..::..HttpHeaderFields Class
MCparameter..::..HttpHeaderFields Members
Mergecomws.Web Namespace


HOST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..HttpHeaderFields..::..HOST Field
MCparameter..::..HttpHeaderFields Class See Also Send Feedback
"Host"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string HOST
Visual Basic
Public Shared ReadOnly HOST As String
Visual C++
public:
static initonly String^ HOST

See Also

MCparameter..::..HttpHeaderFields Class
MCparameter..::..HttpHeaderFields Members
Mergecomws.Web Namespace


TRANSFER_ENCODING Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..HttpHeaderFields..::..TRANSFER_ENCODING Field
MCparameter..::..HttpHeaderFields Class See Also Send Feedback
"Transfer-Encoding"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string TRANSFER_ENCODING
Visual Basic
Public Shared ReadOnly TRANSFER_ENCODING As String
Visual C++
public:
static initonly String^ TRANSFER_ENCODING

See Also

MCparameter..::..HttpHeaderFields Class
MCparameter..::..HttpHeaderFields Members
Mergecomws.Web Namespace


USER_AGENT Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..HttpHeaderFields..::..USER_AGENT Field
MCparameter..::..HttpHeaderFields Class See Also Send Feedback
"User-Agent"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string USER_AGENT
Visual Basic
Public Shared ReadOnly USER_AGENT As String
Visual C++
public:
static initonly String^ USER_AGENT

See Also

MCparameter..::..HttpHeaderFields Class
MCparameter..::..HttpHeaderFields Members
Mergecomws.Web Namespace


MCparameter.Names Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names Class
MCparameter Class Members See Also Send Feedback
List of WADO parameters names

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static class Names
Visual Basic
Public NotInheritable Class Names
Visual C++
public ref class Names abstract sealed

Inheritance Hierarchy

System..::..Object
Mergecomws.Web..::..MCparameter..::..Names

See Also

MCparameter..::..Names Members
Mergecomws.Web Namespace


MCparameter.Names Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names Members
MCparameter..::..Names Class Fields See Also Send Feedback

The MCparameter..::..Names type exposes the following members.

Fields

Name | Description
ACCEPT | "accept"
ACTION_TYPE | "actionType"
AE_TITLE | "AETitle"
ANNOTATION | "annotation"
ANONYMIZE | "anonymize"
BULKDATA | "bulkdata"
CACHE_CONTROL | "cacheControl"
CANCEL_REQUEST | "cancelrequest"
CHARSET | "charset"
CHARSET_LIST | "charsetList"
COLOR_PALETTES | "color-palettes"
COLUMNS | "columns"
COMMITMENT | "commitment"
COMMITMENT_REQUEST | "commitment-request"
CONTENT_LENGTH | "contentLength"
CONTENT_LOCATION | "contentLocation"
CONTENT_TYPE | "contentType"
CONTENT_TYPE_LIST | "contentTypeList"
DEFINED_PROCEDURE_PROTOCOLS | "defined-procedure-protocols"
DELETION_LOCK | "deletionlock"
DOCUMENT_UNIQUE_ID | "documentUniqueId"
EMPTY_VALUE_MATCHING | "emptyvaluematching" If Empty Value Matching is true, and for Attributes with VR of AE, CS, DA, DT, LO, LT, PN, SH, ST, TM, UC, UR, or UT, a Key Attribute value of exactly two QUOTATION MARK characters (22H in the Default Character Repertoire) specified in a request shall indicate matching to an empty value. Such a match is successful to entities with a zero-length value for the corresponding Attribute, or for which the Attribute is not present. (see PS 3.4 C.2.2.2.7 "Empty Value Matching" for details)
FRAME_NUMBER | "frameNumber"
FRAMES | "frames"
FUZZY_MATCHING | "fuzzymatching"
HANGING_PROTOCOLS | "hanging-protocols"
HOME_COMMUNITY_ID | "homeCommunityId"
ICC_PROFILE | "iccprofile"
IMAGE_QUALITY | "imageQuality"
IMPLANT_TEMPLATES | "implant-templates"
INCLUDE_FIELD | "includefield"
INSTANCES | "instances"
INVENTORIES | "inventories"
LIMIT | "limit"
LOCKING_UID | "lockingUID"
MESSAGE_ID | "messageID"
METADATA | "metadata"
MIME_TYPE | "mimeType"
MULTIPLE_VALUE_MATCHING | "multiplevaluematching" If Multiple Value Matching is true, for Attributes with VR of AE, AS, AT, CS, LO, PN, SH, or UC and a defined VM greater than 1, a Key Attribute with multiple values specified in a request shall indicate matching to a multi-valued entity Attribute. Such a match is successful only if each and every value in the Key Attribute matches a value in the corresponding Attribute in the entity. (see PS 3.4 C.2.2.2.8 "Multiple Value Matching" for details)
OBJECT_UID | "objectUID"
OFFSET | "offset"
PIXELDATA | "pixeldata"
PRESENTATION_SERIES_UID | "presentationSeriesUID"
PRESENTATION_UID | "presentationUID"
QUALITY | "quality"
REGION | "region"
RENDERED | "rendered"
REPOSITORY_UNIQUE_ID | "repositoryUniqueId"
REQUEST_CONTENT | "requestContent"
REQUEST_TYPE | "requestType"
RESPONSE_STATUS | "responseStatus"
RESPONSE_TYPE | "responseType"
RETRIEVE | "retrieve"
ROWS | "rows"
SEARCH | "search"
SERIES | "series"
SERIES_INSTANCE_UID | "seriesInstanceUID"
SERIES_UID | "seriesUID"
SOURCE_DOCUMENT_UNIQUE_ID | "SourceDocumentUniqueId"
STATE | "state"
STORE | "store"
STUDIES | "studies"
STUDY_INSTANCE_UID | "studyInstanceUID"
STUDY_UID | "studyUID"
SUBSCRIBE | "subscribe"
SUBSCRIBERS | "subscribers"
SUSPEND | "suspend"
THUMBNAIL | "thumbnail"
TRANSACTION_UID | "TransactionUID"
TRANSFER_ENCODING | "transferEncoding"
TRANSFER_SYNTAX | "transferSyntax"
TRANSFER_SYNTAX_UID_LIST | "transferSyntaxUidList"
UPDATE | "update"
UPS_INSTANCE_UID | "UPSInstanceUID"
VIEWPORT | "viewport"
WADO | "wado"
WINDOW | "window"
WINDOW_CENTER | "windowCenter"
WINDOW_WIDTH | "windowWidth"
WORKITEMS | "workitems"
XOP_INCLUDE_UID_LIST | "XopIncludeUidList"
XPATH | "XPath"
XPATH_RESPONSE | "XPathResponse"
XPATH_RESPONSE_LIST | "XPathResponseList"

See Also

MCparameter..::..Names Class
Mergecomws.Web Namespace


MCparameter.Names Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names Fields
MCparameter..::..Names Class See Also Send Feedback

The MCparameter..::..Names type exposes the following members.

Fields

Name | Description
ACCEPT | "accept"
ACTION_TYPE | "actionType"
AE_TITLE | "AETitle"
ANNOTATION | "annotation"
ANONYMIZE | "anonymize"
BULKDATA | "bulkdata"
CACHE_CONTROL | "cacheControl"
CANCEL_REQUEST | "cancelrequest"
CHARSET | "charset"
CHARSET_LIST | "charsetList"
COLOR_PALETTES | "color-palettes"
COLUMNS | "columns"
COMMITMENT | "commitment"
COMMITMENT_REQUEST | "commitment-request"
CONTENT_LENGTH | "contentLength"
CONTENT_LOCATION | "contentLocation"
CONTENT_TYPE | "contentType"
CONTENT_TYPE_LIST | "contentTypeList"
DEFINED_PROCEDURE_PROTOCOLS | "defined-procedure-protocols"
DELETION_LOCK | "deletionlock"
DOCUMENT_UNIQUE_ID | "documentUniqueId"
EMPTY_VALUE_MATCHING | "emptyvaluematching" If Empty Value Matching is true, and for Attributes with VR of AE, CS, DA, DT, LO, LT, PN, SH, ST, TM, UC, UR, or UT, a Key Attribute value of exactly two QUOTATION MARK characters (22H in the Default Character Repertoire) specified in a request shall indicate matching to an empty value. Such a match is successful to entities with a zero-length value for the corresponding Attribute, or for which the Attribute is not present. (see PS 3.4 C.2.2.2.7 "Empty Value Matching" for details)
FRAME_NUMBER | "frameNumber"
FRAMES | "frames"
FUZZY_MATCHING | "fuzzymatching"
HANGING_PROTOCOLS | "hanging-protocols"
HOME_COMMUNITY_ID | "homeCommunityId"
ICC_PROFILE | "iccprofile"
IMAGE_QUALITY | "imageQuality"
IMPLANT_TEMPLATES | "implant-templates"
INCLUDE_FIELD | "includefield"
INSTANCES | "instances"
INVENTORIES | "inventories"
LIMIT | "limit"
LOCKING_UID | "lockingUID"
MESSAGE_ID | "messageID"
METADATA | "metadata"
MIME_TYPE | "mimeType"
MULTIPLE_VALUE_MATCHING | "multiplevaluematching" If Multiple Value Matching is true, for Attributes with VR of AE, AS, AT, CS, LO, PN, SH, or UC and a defined VM greater than 1, a Key Attribute with multiple values specified in a request shall indicate matching to a multi-valued entity Attribute. Such a match is successful only if each and every value in the Key Attribute matches a value in the corresponding Attribute in the entity. (see PS 3.4 C.2.2.2.8 "Multiple Value Matching" for details)
OBJECT_UID | "objectUID"
OFFSET | "offset"
PIXELDATA | "pixeldata"
PRESENTATION_SERIES_UID | "presentationSeriesUID"
PRESENTATION_UID | "presentationUID"
QUALITY | "quality"
REGION | "region"
RENDERED | "rendered"
REPOSITORY_UNIQUE_ID | "repositoryUniqueId"
REQUEST_CONTENT | "requestContent"
REQUEST_TYPE | "requestType"
RESPONSE_STATUS | "responseStatus"
RESPONSE_TYPE | "responseType"
RETRIEVE | "retrieve"
ROWS | "rows"
SEARCH | "search"
SERIES | "series"
SERIES_INSTANCE_UID | "seriesInstanceUID"
SERIES_UID | "seriesUID"
SOURCE_DOCUMENT_UNIQUE_ID | "SourceDocumentUniqueId"
STATE | "state"
STORE | "store"
STUDIES | "studies"
STUDY_INSTANCE_UID | "studyInstanceUID"
STUDY_UID | "studyUID"
SUBSCRIBE | "subscribe"
SUBSCRIBERS | "subscribers"
SUSPEND | "suspend"
THUMBNAIL | "thumbnail"
TRANSACTION_UID | "TransactionUID"
TRANSFER_ENCODING | "transferEncoding"
TRANSFER_SYNTAX | "transferSyntax"
TRANSFER_SYNTAX_UID_LIST | "transferSyntaxUidList"
UPDATE | "update"
UPS_INSTANCE_UID | "UPSInstanceUID"
VIEWPORT | "viewport"
WADO | "wado"
WINDOW | "window"
WINDOW_CENTER | "windowCenter"
WINDOW_WIDTH | "windowWidth"
WORKITEMS | "workitems"
XOP_INCLUDE_UID_LIST | "XopIncludeUidList"
XPATH | "XPath"
XPATH_RESPONSE | "XPathResponse"
XPATH_RESPONSE_LIST | "XPathResponseList"

See Also

MCparameter..::..Names Class
Mergecomws.Web Namespace


ACCEPT Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..ACCEPT Field
MCparameter..::..Names Class See Also Send Feedback
"accept"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string ACCEPT
Visual Basic
Public Shared ReadOnly ACCEPT As String
Visual C++
public:
static initonly String^ ACCEPT

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


ACTION_TYPE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..ACTION_TYPE Field
MCparameter..::..Names Class See Also Send Feedback
"actionType"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string ACTION_TYPE
Visual Basic
Public Shared ReadOnly ACTION_TYPE As String
Visual C++
public:
static initonly String^ ACTION_TYPE

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


AE_TITLE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..AE_TITLE Field
MCparameter..::..Names Class See Also Send Feedback
"AETitle"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string AE_TITLE
Visual Basic
Public Shared ReadOnly AE_TITLE As String
Visual C++
public:
static initonly String^ AE_TITLE

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


ANNOTATION Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..ANNOTATION Field
MCparameter..::..Names Class See Also Send Feedback
"annotation"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string ANNOTATION
Visual Basic
Public Shared ReadOnly ANNOTATION As String
Visual C++
public:
static initonly String^ ANNOTATION

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


ANONYMIZE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..ANONYMIZE Field
MCparameter..::..Names Class See Also Send Feedback
"anonymize"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string ANONYMIZE
Visual Basic
Public Shared ReadOnly ANONYMIZE As String
Visual C++
public:
static initonly String^ ANONYMIZE

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


BULKDATA Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..BULKDATA Field
MCparameter..::..Names Class See Also Send Feedback
"bulkdata"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string BULKDATA
Visual Basic
Public Shared ReadOnly BULKDATA As String
Visual C++
public:
static initonly String^ BULKDATA

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


CACHE_CONTROL Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..CACHE_CONTROL Field
MCparameter..::..Names Class See Also Send Feedback
"cacheControl"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string CACHE_CONTROL
Visual Basic
Public Shared ReadOnly CACHE_CONTROL As String
Visual C++
public:
static initonly String^ CACHE_CONTROL

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


CANCEL_REQUEST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..CANCEL_REQUEST Field
MCparameter..::..Names Class See Also Send Feedback
"cancelrequest"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string CANCEL_REQUEST
Visual Basic
Public Shared ReadOnly CANCEL_REQUEST As String
Visual C++
public:
static initonly String^ CANCEL_REQUEST

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


CHARSET Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..CHARSET Field
MCparameter..::..Names Class See Also Send Feedback
"charset"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string CHARSET
Visual Basic
Public Shared ReadOnly CHARSET As String
Visual C++
public:
static initonly String^ CHARSET

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


CHARSET_LIST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..CHARSET_LIST Field
MCparameter..::..Names Class See Also Send Feedback
"charsetList"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string CHARSET_LIST
Visual Basic
Public Shared ReadOnly CHARSET_LIST As String
Visual C++
public:
static initonly String^ CHARSET_LIST

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


COLOR_PALETTES Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..COLOR_PALETTES Field
MCparameter..::..Names Class See Also Send Feedback
"color-palettes"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string COLOR_PALETTES
Visual Basic
Public Shared ReadOnly COLOR_PALETTES As String
Visual C++
public:
static initonly String^ COLOR_PALETTES

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


COLUMNS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..COLUMNS Field
MCparameter..::..Names Class See Also Send Feedback
"columns"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string COLUMNS
Visual Basic
Public Shared ReadOnly COLUMNS As String
Visual C++
public:
static initonly String^ COLUMNS

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


COMMITMENT Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..COMMITMENT Field
MCparameter..::..Names Class See Also Send Feedback
"commitment"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string COMMITMENT
Visual Basic
Public Shared ReadOnly COMMITMENT As String
Visual C++
public:
static initonly String^ COMMITMENT

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


COMMITMENT_REQUEST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..COMMITMENT_REQUEST Field
MCparameter..::..Names Class See Also Send Feedback
"commitment-request"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string COMMITMENT_REQUEST
Visual Basic
Public Shared ReadOnly COMMITMENT_REQUEST As String
Visual C++
public:
static initonly String^ COMMITMENT_REQUEST

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


CONTENT_LENGTH Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..CONTENT_LENGTH Field
MCparameter..::..Names Class See Also Send Feedback
"contentLength"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string CONTENT_LENGTH
Visual Basic
Public Shared ReadOnly CONTENT_LENGTH As String
Visual C++
public:
static initonly String^ CONTENT_LENGTH

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


CONTENT_LOCATION Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..CONTENT_LOCATION Field
MCparameter..::..Names Class See Also Send Feedback
"contentLocation"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string CONTENT_LOCATION
Visual Basic
Public Shared ReadOnly CONTENT_LOCATION As String
Visual C++
public:
static initonly String^ CONTENT_LOCATION

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


CONTENT_TYPE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..CONTENT_TYPE Field
MCparameter..::..Names Class See Also Send Feedback
"contentType"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string CONTENT_TYPE
Visual Basic
Public Shared ReadOnly CONTENT_TYPE As String
Visual C++
public:
static initonly String^ CONTENT_TYPE

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


CONTENT_TYPE_LIST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..CONTENT_TYPE_LIST Field
MCparameter..::..Names Class See Also Send Feedback
"contentTypeList"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string CONTENT_TYPE_LIST
Visual Basic
Public Shared ReadOnly CONTENT_TYPE_LIST As String
Visual C++
public:
static initonly String^ CONTENT_TYPE_LIST

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


DEFINED_PROCEDURE_PROTOCOLS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..DEFINED_PROCEDURE_PROTOCOLS Field
MCparameter..::..Names Class See Also Send Feedback
"defined-procedure-protocols"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string DEFINED_PROCEDURE_PROTOCOLS
Visual Basic
Public Shared ReadOnly DEFINED_PROCEDURE_PROTOCOLS As String
Visual C++
public:
static initonly String^ DEFINED_PROCEDURE_PROTOCOLS

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


DELETION_LOCK Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..DELETION_LOCK Field
MCparameter..::..Names Class See Also Send Feedback
"deletionlock"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string DELETION_LOCK
Visual Basic
Public Shared ReadOnly DELETION_LOCK As String
Visual C++
public:
static initonly String^ DELETION_LOCK

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


DOCUMENT_UNIQUE_ID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..DOCUMENT_UNIQUE_ID Field
MCparameter..::..Names Class See Also Send Feedback
"documentUniqueId"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string DOCUMENT_UNIQUE_ID
Visual Basic
Public Shared ReadOnly DOCUMENT_UNIQUE_ID As String
Visual C++
public:
static initonly String^ DOCUMENT_UNIQUE_ID

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


EMPTY_VALUE_MATCHING Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..EMPTY_VALUE_MATCHING Field
MCparameter..::..Names Class See Also Send Feedback
"emptyvaluematching"

If Empty Value Matching is true, and for Attributes with VR of AE, CS, DA, DT, LO, LT, PN, SH, ST, TM, UC, UR, or UT, a Key Attribute value of exactly two QUOTATION MARK characters (22H in the Default Character Repertoire) specified in a request shall indicate matching to an empty value.

Such a match is successful to entities with a zero-length value for the corresponding Attribute, or for which the Attribute is not present. (see PS 3.4 C.2.2.2.7 "Empty Value Matching" for details)

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string EMPTY_VALUE_MATCHING
Visual Basic
Public Shared ReadOnly EMPTY_VALUE_MATCHING As String
Visual C++
public:
static initonly String^ EMPTY_VALUE_MATCHING

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


FRAME_NUMBER Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..FRAME_NUMBER Field
MCparameter..::..Names Class See Also Send Feedback
"frameNumber"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string FRAME_NUMBER
Visual Basic
Public Shared ReadOnly FRAME_NUMBER As String
Visual C++
public:
static initonly String^ FRAME_NUMBER

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


FRAMES Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..FRAMES Field
MCparameter..::..Names Class See Also Send Feedback
"frames"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string FRAMES
Visual Basic
Public Shared ReadOnly FRAMES As String
Visual C++
public:
static initonly String^ FRAMES

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


FUZZY_MATCHING Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..FUZZY_MATCHING Field
MCparameter..::..Names Class See Also Send Feedback
"fuzzymatching"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string FUZZY_MATCHING
Visual Basic
Public Shared ReadOnly FUZZY_MATCHING As String
Visual C++
public:
static initonly String^ FUZZY_MATCHING

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


HANGING_PROTOCOLS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..HANGING_PROTOCOLS Field
MCparameter..::..Names Class See Also Send Feedback
"hanging-protocols"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string HANGING_PROTOCOLS
Visual Basic
Public Shared ReadOnly HANGING_PROTOCOLS As String
Visual C++
public:
static initonly String^ HANGING_PROTOCOLS

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


HOME_COMMUNITY_ID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..HOME_COMMUNITY_ID Field
MCparameter..::..Names Class See Also Send Feedback
"homeCommunityId"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string HOME_COMMUNITY_ID
Visual Basic
Public Shared ReadOnly HOME_COMMUNITY_ID As String
Visual C++
public:
static initonly String^ HOME_COMMUNITY_ID

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


ICC_PROFILE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..ICC_PROFILE Field
MCparameter..::..Names Class See Also Send Feedback
"iccprofile"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string ICC_PROFILE
Visual Basic
Public Shared ReadOnly ICC_PROFILE As String
Visual C++
public:
static initonly String^ ICC_PROFILE

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


IMAGE_QUALITY Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..IMAGE_QUALITY Field
MCparameter..::..Names Class See Also Send Feedback
"imageQuality"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string IMAGE_QUALITY
Visual Basic
Public Shared ReadOnly IMAGE_QUALITY As String
Visual C++
public:
static initonly String^ IMAGE_QUALITY

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


IMPLANT_TEMPLATES Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..IMPLANT_TEMPLATES Field
MCparameter..::..Names Class See Also Send Feedback
"implant-templates"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string IMPLANT_TEMPLATES
Visual Basic
Public Shared ReadOnly IMPLANT_TEMPLATES As String
Visual C++
public:
static initonly String^ IMPLANT_TEMPLATES

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


INCLUDE_FIELD Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..INCLUDE_FIELD Field
MCparameter..::..Names Class See Also Send Feedback
"includefield"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string INCLUDE_FIELD
Visual Basic
Public Shared ReadOnly INCLUDE_FIELD As String
Visual C++
public:
static initonly String^ INCLUDE_FIELD

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


INSTANCES Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..INSTANCES Field
MCparameter..::..Names Class See Also Send Feedback
"instances"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string INSTANCES
Visual Basic
Public Shared ReadOnly INSTANCES As String
Visual C++
public:
static initonly String^ INSTANCES

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


INVENTORIES Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..INVENTORIES Field
MCparameter..::..Names Class See Also Send Feedback
"inventories"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string INVENTORIES
Visual Basic
Public Shared ReadOnly INVENTORIES As String
Visual C++
public:
static initonly String^ INVENTORIES

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


LIMIT Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..LIMIT Field
MCparameter..::..Names Class See Also Send Feedback
"limit"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string LIMIT
Visual Basic
Public Shared ReadOnly LIMIT As String
Visual C++
public:
static initonly String^ LIMIT

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


LOCKING_UID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..LOCKING_UID Field
MCparameter..::..Names Class See Also Send Feedback
"lockingUID"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string LOCKING_UID
Visual Basic
Public Shared ReadOnly LOCKING_UID As String
Visual C++
public:
static initonly String^ LOCKING_UID

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


MESSAGE_ID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..MESSAGE_ID Field
MCparameter..::..Names Class See Also Send Feedback
"messageID"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string MESSAGE_ID
Visual Basic
Public Shared ReadOnly MESSAGE_ID As String
Visual C++
public:
static initonly String^ MESSAGE_ID

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


METADATA Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..METADATA Field
MCparameter..::..Names Class See Also Send Feedback
"metadata"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string METADATA
Visual Basic
Public Shared ReadOnly METADATA As String
Visual C++
public:
static initonly String^ METADATA

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


MIME_TYPE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..MIME_TYPE Field
MCparameter..::..Names Class See Also Send Feedback
"mimeType"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string MIME_TYPE
Visual Basic
Public Shared ReadOnly MIME_TYPE As String
Visual C++
public:
static initonly String^ MIME_TYPE

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


MULTIPLE_VALUE_MATCHING Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..MULTIPLE_VALUE_MATCHING Field
MCparameter..::..Names Class See Also Send Feedback
"multiplevaluematching"

If Multiple Value Matching is true, for Attributes with VR of AE, AS, AT, CS, LO, PN, SH, or UC and a defined VM greater than 1, a Key Attribute with multiple values specified in a request shall indicate matching to a multi-valued entity Attribute.

Such a match is successful only if each and every value in the Key Attribute matches a value in the corresponding Attribute in the entity. (see PS 3.4 C.2.2.2.8 "Multiple Value Matching" for details)

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string MULTIPLE_VALUE_MATCHING
Visual Basic
Public Shared ReadOnly MULTIPLE_VALUE_MATCHING As String
Visual C++
public:
static initonly String^ MULTIPLE_VALUE_MATCHING

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


OBJECT_UID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..OBJECT_UID Field
MCparameter..::..Names Class See Also Send Feedback
"objectUID"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string OBJECT_UID
Visual Basic
Public Shared ReadOnly OBJECT_UID As String
Visual C++
public:
static initonly String^ OBJECT_UID

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


OFFSET Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..OFFSET Field
MCparameter..::..Names Class See Also Send Feedback
"offset"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string OFFSET
Visual Basic
Public Shared ReadOnly OFFSET As String
Visual C++
public:
static initonly String^ OFFSET

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


PIXELDATA Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..PIXELDATA Field
MCparameter..::..Names Class See Also Send Feedback
"pixeldata"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string PIXELDATA
Visual Basic
Public Shared ReadOnly PIXELDATA As String
Visual C++
public:
static initonly String^ PIXELDATA

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


PRESENTATION_SERIES_UID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..PRESENTATION_SERIES_UID Field
MCparameter..::..Names Class See Also Send Feedback
"presentationSeriesUID"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string PRESENTATION_SERIES_UID
Visual Basic
Public Shared ReadOnly PRESENTATION_SERIES_UID As String
Visual C++
public:
static initonly String^ PRESENTATION_SERIES_UID

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


PRESENTATION_UID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..PRESENTATION_UID Field
MCparameter..::..Names Class See Also Send Feedback
"presentationUID"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string PRESENTATION_UID
Visual Basic
Public Shared ReadOnly PRESENTATION_UID As String
Visual C++
public:
static initonly String^ PRESENTATION_UID

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


QUALITY Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..QUALITY Field
MCparameter..::..Names Class See Also Send Feedback
"quality"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string QUALITY
Visual Basic
Public Shared ReadOnly QUALITY As String
Visual C++
public:
static initonly String^ QUALITY

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


REGION Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..REGION Field
MCparameter..::..Names Class See Also Send Feedback
"region"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string REGION
Visual Basic
Public Shared ReadOnly REGION As String
Visual C++
public:
static initonly String^ REGION

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


RENDERED Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..RENDERED Field
MCparameter..::..Names Class See Also Send Feedback
"rendered"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string RENDERED
Visual Basic
Public Shared ReadOnly RENDERED As String
Visual C++
public:
static initonly String^ RENDERED

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


REPOSITORY_UNIQUE_ID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..REPOSITORY_UNIQUE_ID Field
MCparameter..::..Names Class See Also Send Feedback
"repositoryUniqueId"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string REPOSITORY_UNIQUE_ID
Visual Basic
Public Shared ReadOnly REPOSITORY_UNIQUE_ID As String
Visual C++
public:
static initonly String^ REPOSITORY_UNIQUE_ID

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


REQUEST_CONTENT Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..REQUEST_CONTENT Field
MCparameter..::..Names Class See Also Send Feedback
"requestContent"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string REQUEST_CONTENT
Visual Basic
Public Shared ReadOnly REQUEST_CONTENT As String
Visual C++
public:
static initonly String^ REQUEST_CONTENT

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


REQUEST_TYPE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..REQUEST_TYPE Field
MCparameter..::..Names Class See Also Send Feedback
"requestType"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string REQUEST_TYPE
Visual Basic
Public Shared ReadOnly REQUEST_TYPE As String
Visual C++
public:
static initonly String^ REQUEST_TYPE

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


RESPONSE_STATUS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..RESPONSE_STATUS Field
MCparameter..::..Names Class See Also Send Feedback
"responseStatus"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string RESPONSE_STATUS
Visual Basic
Public Shared ReadOnly RESPONSE_STATUS As String
Visual C++
public:
static initonly String^ RESPONSE_STATUS

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


RESPONSE_TYPE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..RESPONSE_TYPE Field
MCparameter..::..Names Class See Also Send Feedback
"responseType"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string RESPONSE_TYPE
Visual Basic
Public Shared ReadOnly RESPONSE_TYPE As String
Visual C++
public:
static initonly String^ RESPONSE_TYPE

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


RETRIEVE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..RETRIEVE Field
MCparameter..::..Names Class See Also Send Feedback
"retrieve"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string RETRIEVE
Visual Basic
Public Shared ReadOnly RETRIEVE As String
Visual C++
public:
static initonly String^ RETRIEVE

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


ROWS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..ROWS Field
MCparameter..::..Names Class See Also Send Feedback
"rows"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string ROWS
Visual Basic
Public Shared ReadOnly ROWS As String
Visual C++
public:
static initonly String^ ROWS

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


SEARCH Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..SEARCH Field
MCparameter..::..Names Class See Also Send Feedback
"search"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string SEARCH
Visual Basic
Public Shared ReadOnly SEARCH As String
Visual C++
public:
static initonly String^ SEARCH

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


SERIES Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..SERIES Field
MCparameter..::..Names Class See Also Send Feedback
"series"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string SERIES
Visual Basic
Public Shared ReadOnly SERIES As String
Visual C++
public:
static initonly String^ SERIES

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


SERIES_INSTANCE_UID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..SERIES_INSTANCE_UID Field
MCparameter..::..Names Class See Also Send Feedback
"seriesInstanceUID"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string SERIES_INSTANCE_UID
Visual Basic
Public Shared ReadOnly SERIES_INSTANCE_UID As String
Visual C++
public:
static initonly String^ SERIES_INSTANCE_UID

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


SERIES_UID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..SERIES_UID Field
MCparameter..::..Names Class See Also Send Feedback
"seriesUID"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string SERIES_UID
Visual Basic
Public Shared ReadOnly SERIES_UID As String
Visual C++
public:
static initonly String^ SERIES_UID

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


SOURCE_DOCUMENT_UNIQUE_ID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..SOURCE_DOCUMENT_UNIQUE_ID Field
MCparameter..::..Names Class See Also Send Feedback
"SourceDocumentUniqueId"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string SOURCE_DOCUMENT_UNIQUE_ID
Visual Basic
Public Shared ReadOnly SOURCE_DOCUMENT_UNIQUE_ID As String
Visual C++
public:
static initonly String^ SOURCE_DOCUMENT_UNIQUE_ID

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


STATE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..STATE Field
MCparameter..::..Names Class See Also Send Feedback
"state"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string STATE
Visual Basic
Public Shared ReadOnly STATE As String
Visual C++
public:
static initonly String^ STATE

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


STORE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..STORE Field
MCparameter..::..Names Class See Also Send Feedback
"store"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string STORE
Visual Basic
Public Shared ReadOnly STORE As String
Visual C++
public:
static initonly String^ STORE

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


STUDIES Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..STUDIES Field
MCparameter..::..Names Class See Also Send Feedback
"studies"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string STUDIES
Visual Basic
Public Shared ReadOnly STUDIES As String
Visual C++
public:
static initonly String^ STUDIES

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


STUDY_INSTANCE_UID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..STUDY_INSTANCE_UID Field
MCparameter..::..Names Class See Also Send Feedback
"studyInstanceUID"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string STUDY_INSTANCE_UID
Visual Basic
Public Shared ReadOnly STUDY_INSTANCE_UID As String
Visual C++
public:
static initonly String^ STUDY_INSTANCE_UID

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


STUDY_UID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..STUDY_UID Field
MCparameter..::..Names Class See Also Send Feedback
"studyUID"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string STUDY_UID
Visual Basic
Public Shared ReadOnly STUDY_UID As String
Visual C++
public:
static initonly String^ STUDY_UID

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


SUBSCRIBE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..SUBSCRIBE Field
MCparameter..::..Names Class See Also Send Feedback
"subscribe"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string SUBSCRIBE
Visual Basic
Public Shared ReadOnly SUBSCRIBE As String
Visual C++
public:
static initonly String^ SUBSCRIBE

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


SUBSCRIBERS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..SUBSCRIBERS Field
MCparameter..::..Names Class See Also Send Feedback
"subscribers"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string SUBSCRIBERS
Visual Basic
Public Shared ReadOnly SUBSCRIBERS As String
Visual C++
public:
static initonly String^ SUBSCRIBERS

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


SUSPEND Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..SUSPEND Field
MCparameter..::..Names Class See Also Send Feedback
"suspend"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string SUSPEND
Visual Basic
Public Shared ReadOnly SUSPEND As String
Visual C++
public:
static initonly String^ SUSPEND

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


THUMBNAIL Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..THUMBNAIL Field
MCparameter..::..Names Class See Also Send Feedback
"thumbnail"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string THUMBNAIL
Visual Basic
Public Shared ReadOnly THUMBNAIL As String
Visual C++
public:
static initonly String^ THUMBNAIL

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


TRANSACTION_UID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..TRANSACTION_UID Field
MCparameter..::..Names Class See Also Send Feedback
"TransactionUID"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string TRANSACTION_UID
Visual Basic
Public Shared ReadOnly TRANSACTION_UID As String
Visual C++
public:
static initonly String^ TRANSACTION_UID

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


TRANSFER_ENCODING Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..TRANSFER_ENCODING Field
MCparameter..::..Names Class See Also Send Feedback
"transferEncoding"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string TRANSFER_ENCODING
Visual Basic
Public Shared ReadOnly TRANSFER_ENCODING As String
Visual C++
public:
static initonly String^ TRANSFER_ENCODING

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


TRANSFER_SYNTAX Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..TRANSFER_SYNTAX Field
MCparameter..::..Names Class See Also Send Feedback
"transferSyntax"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string TRANSFER_SYNTAX
Visual Basic
Public Shared ReadOnly TRANSFER_SYNTAX As String
Visual C++
public:
static initonly String^ TRANSFER_SYNTAX

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


TRANSFER_SYNTAX_UID_LIST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..TRANSFER_SYNTAX_UID_LIST Field
MCparameter..::..Names Class See Also Send Feedback
"transferSyntaxUidList"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string TRANSFER_SYNTAX_UID_LIST
Visual Basic
Public Shared ReadOnly TRANSFER_SYNTAX_UID_LIST As String
Visual C++
public:
static initonly String^ TRANSFER_SYNTAX_UID_LIST

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


UPDATE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..UPDATE Field
MCparameter..::..Names Class See Also Send Feedback
"update"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string UPDATE
Visual Basic
Public Shared ReadOnly UPDATE As String
Visual C++
public:
static initonly String^ UPDATE

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


UPS_INSTANCE_UID Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..UPS_INSTANCE_UID Field
MCparameter..::..Names Class See Also Send Feedback
"UPSInstanceUID"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string UPS_INSTANCE_UID
Visual Basic
Public Shared ReadOnly UPS_INSTANCE_UID As String
Visual C++
public:
static initonly String^ UPS_INSTANCE_UID

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


VIEWPORT Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..VIEWPORT Field
MCparameter..::..Names Class See Also Send Feedback
"viewport"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string VIEWPORT
Visual Basic
Public Shared ReadOnly VIEWPORT As String
Visual C++
public:
static initonly String^ VIEWPORT

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


WADO Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..WADO Field
MCparameter..::..Names Class See Also Send Feedback
"wado"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string WADO
Visual Basic
Public Shared ReadOnly WADO As String
Visual C++
public:
static initonly String^ WADO

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


WINDOW Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..WINDOW Field
MCparameter..::..Names Class See Also Send Feedback
"window"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string WINDOW
Visual Basic
Public Shared ReadOnly WINDOW As String
Visual C++
public:
static initonly String^ WINDOW

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


WINDOW_CENTER Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..WINDOW_CENTER Field
MCparameter..::..Names Class See Also Send Feedback
"windowCenter"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string WINDOW_CENTER
Visual Basic
Public Shared ReadOnly WINDOW_CENTER As String
Visual C++
public:
static initonly String^ WINDOW_CENTER

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


WINDOW_WIDTH Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..WINDOW_WIDTH Field
MCparameter..::..Names Class See Also Send Feedback
"windowWidth"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string WINDOW_WIDTH
Visual Basic
Public Shared ReadOnly WINDOW_WIDTH As String
Visual C++
public:
static initonly String^ WINDOW_WIDTH

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


WORKITEMS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..WORKITEMS Field
MCparameter..::..Names Class See Also Send Feedback
"workitems"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string WORKITEMS
Visual Basic
Public Shared ReadOnly WORKITEMS As String
Visual C++
public:
static initonly String^ WORKITEMS

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


XOP_INCLUDE_UID_LIST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..XOP_INCLUDE_UID_LIST Field
MCparameter..::..Names Class See Also Send Feedback
"XopIncludeUidList"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string XOP_INCLUDE_UID_LIST
Visual Basic
Public Shared ReadOnly XOP_INCLUDE_UID_LIST As String
Visual C++
public:
static initonly String^ XOP_INCLUDE_UID_LIST

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


XPATH Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..XPATH Field
MCparameter..::..Names Class See Also Send Feedback
"XPath"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string XPATH
Visual Basic
Public Shared ReadOnly XPATH As String
Visual C++
public:
static initonly String^ XPATH

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


XPATH_RESPONSE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..XPATH_RESPONSE Field
MCparameter..::..Names Class See Also Send Feedback
"XPathResponse"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string XPATH_RESPONSE
Visual Basic
Public Shared ReadOnly XPATH_RESPONSE As String
Visual C++
public:
static initonly String^ XPATH_RESPONSE

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


XPATH_RESPONSE_LIST Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Names..::..XPATH_RESPONSE_LIST Field
MCparameter..::..Names Class See Also Send Feedback
"XPathResponseList"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string XPATH_RESPONSE_LIST
Visual Basic
Public Shared ReadOnly XPATH_RESPONSE_LIST As String
Visual C++
public:
static initonly String^ XPATH_RESPONSE_LIST

See Also

MCparameter..::..Names Class
MCparameter..::..Names Members
Mergecomws.Web Namespace


MCparameter.Requirements Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Requirements Class
MCparameter Class Members See Also Send Feedback
Requirement property of MCparameter

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static class Requirements
Visual Basic
Public NotInheritable Class Requirements
Visual C++
public ref class Requirements abstract sealed

Inheritance Hierarchy

System..::..Object
Mergecomws.Web..::..MCparameter..::..Requirements

See Also

MCparameter..::..Requirements Members
Mergecomws.Web Namespace


MCparameter.Requirements Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Requirements Members
MCparameter..::..Requirements Class Fields See Also Send Feedback

The MCparameter..::..Requirements type exposes the following members.

Fields

Name | Description
OPTIONAL | "optional"
REQUIRED | "required"

See Also

MCparameter..::..Requirements Class
Mergecomws.Web Namespace


MCparameter.Requirements Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Requirements Fields
MCparameter..::..Requirements Class See Also Send Feedback

The MCparameter..::..Requirements type exposes the following members.

Fields

Name | Description
OPTIONAL | "optional"
REQUIRED | "required"

See Also

MCparameter..::..Requirements Class
Mergecomws.Web Namespace


OPTIONAL Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Requirements..::..OPTIONAL Field
MCparameter..::..Requirements Class See Also Send Feedback
"optional"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string OPTIONAL
Visual Basic
Public Shared ReadOnly OPTIONAL As String
Visual C++
public:
static initonly String^ OPTIONAL

See Also

MCparameter..::..Requirements Class
MCparameter..::..Requirements Members
Mergecomws.Web Namespace


REQUIRED Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Requirements..::..REQUIRED Field
MCparameter..::..Requirements Class See Also Send Feedback
"required"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string REQUIRED
Visual Basic
Public Shared ReadOnly REQUIRED As String
Visual C++
public:
static initonly String^ REQUIRED

See Also

MCparameter..::..Requirements Class
MCparameter..::..Requirements Members
Mergecomws.Web Namespace


MCparameter.Status Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Status Class
MCparameter Class Members See Also Send Feedback
Status property of request operation

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static class Status
Visual Basic
Public NotInheritable Class Status
Visual C++
public ref class Status abstract sealed

Inheritance Hierarchy

System..::..Object
Mergecomws.Web..::..MCparameter..::..Status

See Also

MCparameter..::..Status Members
Mergecomws.Web Namespace


MCparameter.Status Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Status Members
MCparameter..::..Status Class Fields See Also Send Feedback

The MCparameter..::..Status type exposes the following members.

Fields

Name | Description
FAILURE | "FAILURE"
PARTIAL_SUCCESS | "PARTIAL_SUCCESS"
SUCCESS | "SUCCESS"

See Also

MCparameter..::..Status Class
Mergecomws.Web Namespace


MCparameter.Status Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Status Fields
MCparameter..::..Status Class See Also Send Feedback

The MCparameter..::..Status type exposes the following members.

Fields

Name | Description
FAILURE | "FAILURE"
PARTIAL_SUCCESS | "PARTIAL_SUCCESS"
SUCCESS | "SUCCESS"

See Also

MCparameter..::..Status Class
Mergecomws.Web Namespace


FAILURE Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Status..::..FAILURE Field
MCparameter..::..Status Class See Also Send Feedback
"FAILURE"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string FAILURE
Visual Basic
Public Shared ReadOnly FAILURE As String
Visual C++
public:
static initonly String^ FAILURE

See Also

MCparameter..::..Status Class
MCparameter..::..Status Members
Mergecomws.Web Namespace


PARTIAL_SUCCESS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Status..::..PARTIAL_SUCCESS Field
MCparameter..::..Status Class See Also Send Feedback
"PARTIAL_SUCCESS"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string PARTIAL_SUCCESS
Visual Basic
Public Shared ReadOnly PARTIAL_SUCCESS As String
Visual C++
public:
static initonly String^ PARTIAL_SUCCESS

See Also

MCparameter..::..Status Class
MCparameter..::..Status Members
Mergecomws.Web Namespace


SUCCESS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCparameter..::..Status..::..SUCCESS Field
MCparameter..::..Status Class See Also Send Feedback
"SUCCESS"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static readonly string SUCCESS
Visual Basic
Public Shared ReadOnly SUCCESS As String
Visual C++
public:
static initonly String^ SUCCESS

See Also

MCparameter..::..Status Class
MCparameter..::..Status Members
Mergecomws.Web Namespace


MCqidoController Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoController Class
Members See Also Send Feedback
Implements Http Get methods for DICOM QIDO-RS requests

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCqidoController : MCcontroller
Visual Basic
Public Class MCqidoController _
    Inherits MCcontroller
Visual C++
public ref class MCqidoController : public MCcontroller

Inheritance Hierarchy

System..::..Object
ApiController
Mergecomws.Web..::..MCcontroller
Mergecomws.Web..::..MCqidoController

See Also

MCqidoController Members
Mergecomws.Web Namespace


MCqidoController Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoController Members
MCqidoController Class Constructors Methods Properties See Also Send Feedback

The MCqidoController type exposes the following members.

Constructors

 | Name | Description
Public method | MCqidoController | Class constructor

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(HttpRequestMessage) | Http Get method
Public method | Get(MCrequest) | Http Get method
Public method | Get(HttpRequestMessage, String) | Http Get method
Public method | Get(HttpRequestMessage, String, String) | Http Get method
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCqidoController Class
Mergecomws.Web Namespace


MCqidoController Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoController Constructor
MCqidoController Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCqidoController()
Visual Basic
Public Sub New
Visual C++
public:
MCqidoController()

See Also

MCqidoController Class
MCqidoController Members
Mergecomws.Web Namespace


MCqidoController Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoController Methods
MCqidoController Class See Also Send Feedback

The MCqidoController type exposes the following members.

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(HttpRequestMessage) | Http Get method
Public method | Get(MCrequest) | Http Get method
Public method | Get(HttpRequestMessage, String) | Http Get method
Public method | Get(HttpRequestMessage, String, String) | Http Get method
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

See Also

MCqidoController Class
Mergecomws.Web Namespace


Get Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoController..::..Get Method
MCqidoController Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get(HttpRequestMessage) | Http Get method
Public method | Get(MCrequest) | Http Get method
Public method | Get(HttpRequestMessage, String) | Http Get method
Public method | Get(HttpRequestMessage, String, String) | Http Get method

See Also

MCqidoController Class
MCqidoController Members
Mergecomws.Web Namespace


Get Method (HttpRequestMessage)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoController..::..Get Method (HttpRequestMessage)
MCqidoController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    HttpRequestMessage request
)
Visual Basic
Public Function Get ( _
    request As HttpRequestMessage _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    HttpRequestMessage^ request
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

HttpResponseMessage object

See Also

MCqidoController Class
MCqidoController Members
Get Overload
Mergecomws.Web Namespace


Get Method (MCrequest)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoController..::..Get Method (MCrequest)
MCqidoController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    MCrequest request
)
Visual Basic
Public Function Get ( _
    request As MCrequest _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    MCrequest^ request
)

Parameters

request
Type: Mergecomws.Web..::..MCrequest
MCrequest oject

Return Value

HttpResponseMessage object

See Also

MCqidoController Class
MCqidoController Members
Get Overload
Mergecomws.Web Namespace


Get Method (HttpRequestMessage, String)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoController..::..Get Method (HttpRequestMessage, String)
MCqidoController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    HttpRequestMessage request,
    string studyInstanceUid
)
Visual Basic
Public Function Get ( _
    request As HttpRequestMessage, _
    studyInstanceUid As String _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    HttpRequestMessage^ request,
    String^ studyInstanceUid
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object
studyInstanceUid
Type: System..::..String
StudyInstanceUID parameter

Return Value

HttpResponseMessage object

See Also

MCqidoController Class
MCqidoController Members
Get Overload
Mergecomws.Web Namespace


Get Method (HttpRequestMessage, String, String)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoController..::..Get Method (HttpRequestMessage, String, String)
MCqidoController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    HttpRequestMessage request,
    string studyInstanceUid,
    string seriesInstanceUid
)
Visual Basic
Public Function Get ( _
    request As HttpRequestMessage, _
    studyInstanceUid As String, _
    seriesInstanceUid As String _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    HttpRequestMessage^ request,
    String^ studyInstanceUid,
    String^ seriesInstanceUid
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object
studyInstanceUid
Type: System..::..String
StudyInstanceUID parameter
seriesInstanceUid
Type: System..::..String
SeriesInstanceUID parameter

Return Value

HttpResponseMessage object

See Also

MCqidoController Class
MCqidoController Members
Get Overload
Mergecomws.Web Namespace


MCqidoController Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCqidoController Properties
MCqidoController Class See Also Send Feedback

The MCqidoController type exposes the following members.

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCqidoController Class
Mergecomws.Web Namespace


MCrequest Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequest Class
Members See Also Send Feedback
Converts and encapsulates HttpRequestMessage object data

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCrequest
Visual Basic
Public Class MCrequest
Visual C++
public ref class MCrequest

Inheritance Hierarchy

System..::..Object
Mergecomws.Web..::..MCrequest

See Also

MCrequest Members
Mergecomws.Web Namespace


MCrequest Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequest Members
MCrequest Class Constructors Methods Properties See Also Send Feedback

The MCrequest type exposes the following members.

Constructors

 | Name | Description
Public method | MCrequest(HttpRequestMessage, MCrequestType) | Class constructor
Public method | MCrequest(HttpActionContext, MCrequestType) | Class constructor
Public method | MCrequest(HttpRequestMessage, MCrequestType, array<MCparameter>[]()[][]) | Class constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDicomRequest | Creates MCdicomRequest object of specific MCrequestType from HttpRequestMessage data and MCparameter parameters
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Submit | Submits WADO MCrequest to DICOM service
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HttpRequestMessage | Gets HttpRequestMessage object of MCrequest object
Public property | Parameters | Gets and sets the list of MCparameter of MCrequest object
Public property | RequestType | Gets MCrequestType of MCrequest object

See Also

MCrequest Class
Mergecomws.Web Namespace


MCrequest Constructor

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequest Constructor
MCrequest Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MCrequest(HttpRequestMessage, MCrequestType) | Class constructor
Public method | MCrequest(HttpActionContext, MCrequestType) | Class constructor
Public method | MCrequest(HttpRequestMessage, MCrequestType, array<MCparameter>[]()[][]) | Class constructor

See Also

MCrequest Class
MCrequest Members
Mergecomws.Web Namespace


MCrequest Constructor (HttpRequestMessage, MCrequestType)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequest Constructor (HttpRequestMessage, MCrequestType)
MCrequest Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrequest(
    HttpRequestMessage httpRequestMessage,
    MCrequestType requestType
)
Visual Basic
Public Sub New ( _
    httpRequestMessage As HttpRequestMessage, _
    requestType As MCrequestType _
)
Visual C++
public:
MCrequest(
    HttpRequestMessage^ httpRequestMessage,
    MCrequestType^ requestType
)

Parameters

httpRequestMessage
Type: HttpRequestMessage
HttpRequestMessage object
requestType
Type: Mergecomws.Web..::..MCrequestType
MCrequestType of current request

See Also

MCrequest Class
MCrequest Members
MCrequest Overload
Mergecomws.Web Namespace


MCrequest Constructor (HttpActionContext, MCrequestType)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequest Constructor (HttpActionContext, MCrequestType)
MCrequest Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrequest(
    HttpActionContext actionContext,
    MCrequestType requestType
)
Visual Basic
Public Sub New ( _
    actionContext As HttpActionContext, _
    requestType As MCrequestType _
)
Visual C++
public:
MCrequest(
    HttpActionContext^ actionContext,
    MCrequestType^ requestType
)

Parameters

actionContext
Type: HttpActionContext
HttpActionContext of current request
requestType
Type: Mergecomws.Web..::..MCrequestType
MCrequestType of current request

See Also

MCrequest Class
MCrequest Members
MCrequest Overload
Mergecomws.Web Namespace


MCrequest Constructor (HttpRequestMessage, MCrequestType, MCparameter[])

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequest Constructor (HttpRequestMessage, MCrequestType, array<MCparameter>[]()[][])
MCrequest Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrequest(
    HttpRequestMessage httpRequestMessage,
    MCrequestType requestType,
    MCparameter[] parms
)
Visual Basic
Public Sub New ( _
    httpRequestMessage As HttpRequestMessage, _
    requestType As MCrequestType, _
    parms As MCparameter() _
)
Visual C++
public:
MCrequest(
    HttpRequestMessage^ httpRequestMessage,
    MCrequestType^ requestType,
    array<MCparameter^>^ parms
)

Parameters

httpRequestMessage
Type: HttpRequestMessage
HttpRequestMessage object
requestType
Type: Mergecomws.Web..::..MCrequestType
MCrequestType of current request
parms
Type: array< Mergecomws.Web..::..MCparameter >[]()[][]
List of MCparameter of current request

See Also

MCrequest Class
MCrequest Members
MCrequest Overload
Mergecomws.Web Namespace


MCrequest Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequest Methods
MCrequest Class See Also Send Feedback

The MCrequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDicomRequest | Creates MCdicomRequest object of specific MCrequestType from HttpRequestMessage data and MCparameter parameters
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Submit | Submits WADO MCrequest to DICOM service
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCrequest Class
Mergecomws.Web Namespace


GetDicomRequest Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequest..::..GetDicomRequest Method
MCrequest Class See Also Send Feedback
Creates MCdicomRequest object of specific MCrequestType from HttpRequestMessage data and MCparameter parameters

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCdicomRequest GetDicomRequest()
Visual Basic
Public Function GetDicomRequest As MCdicomRequest
Visual C++
public:
MCdicomRequest^ GetDicomRequest()

Return Value

MCdicomRequest object

See Also

MCrequest Class
MCrequest Members
Mergecomws.Web Namespace


Submit Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequest..::..Submit Method
MCrequest Class See Also Send Feedback
Submits WADO MCrequest to DICOM service

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Submit()
Visual Basic
Public Function Submit As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Submit()

Return Value

HttpResponseMessage response

See Also

MCrequest Class
MCrequest Members
Mergecomws.Web Namespace


MCrequest Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequest Properties
MCrequest Class See Also Send Feedback

The MCrequest type exposes the following members.

Properties

 | Name | Description
Public property | HttpRequestMessage | Gets HttpRequestMessage object of MCrequest object
Public property | Parameters | Gets and sets the list of MCparameter of MCrequest object
Public property | RequestType | Gets MCrequestType of MCrequest object

See Also

MCrequest Class
Mergecomws.Web Namespace


HttpRequestMessage Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequest..::..HttpRequestMessage Property
MCrequest Class See Also Send Feedback
Gets HttpRequestMessage object of MCrequest object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpRequestMessage HttpRequestMessage { get; private set; }
Visual Basic
Public Property HttpRequestMessage As HttpRequestMessage
    Get
    Private Set
Visual C++
public:
property HttpRequestMessage^ HttpRequestMessage {
    HttpRequestMessage^ get ();
    private: void set (HttpRequestMessage^ value);
}

See Also

MCrequest Class
MCrequest Members
Mergecomws.Web Namespace


Parameters Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequest..::..Parameters Property
MCrequest Class See Also Send Feedback
Gets and sets the list of MCparameter of MCrequest object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCparameter[] Parameters { get; set; }
Visual Basic
Public Property Parameters As MCparameter()
    Get
    Set
Visual C++
public:
property array<MCparameter^>^ Parameters {
    array<MCparameter^>^ get ();
    void set (array<MCparameter^>^ value);
}

See Also

MCrequest Class
MCrequest Members
Mergecomws.Web Namespace


RequestType Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequest..::..RequestType Property
MCrequest Class See Also Send Feedback
Gets MCrequestType of MCrequest object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrequestType RequestType { get; private set; }
Visual Basic
Public Property RequestType As MCrequestType
    Get
    Private Set
Visual C++
public:
property MCrequestType^ RequestType {
    MCrequestType^ get ();
    private: void set (MCrequestType^ value);
}

See Also

MCrequest Class
MCrequest Members
Mergecomws.Web Namespace


MCrequestAttribute Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestAttribute Class
Members See Also Send Feedback
Specifies a DICOM attribute used in WADO request

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCrequestAttribute
Visual Basic
Public Class MCrequestAttribute
Visual C++
public ref class MCrequestAttribute

Inheritance Hierarchy

System..::..Object
Mergecomws.Web..::..MCrequestAttribute

See Also

MCrequestAttribute Members
Mergecomws.Web Namespace


MCrequestAttribute Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestAttribute Members
MCrequestAttribute Class Constructors Methods Properties See Also Send Feedback

The MCrequestAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | MCrequestAttribute | Class constructor

Methods

 | Name | Description
Public method | Clone | Returns a deep copy of MCrequestAttribute object
Public method | Contains | Checks if MCrequestAttribute object or its children contain MCrequestAttribute with a given tag
Public method | CreateMCattribute | Creates MCattribute object from internal data
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeAttributes | Merges the internal data of MCrequestAttribute source with the data of MCrequestAttribute destination object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Children | Gets a list of MCrequestAttribute children which belong to MCrequestAttribute object
Public property | Extensions | Gets and sets the list of String user defined values
Public property | Item | DICOM keyword alias
Public property | Keyword | DICOM keyword
Public property | Tag | DICOM attribute tag
Public property | Values | Gets and sets the list of String values

See Also

MCrequestAttribute Class
Mergecomws.Web Namespace


MCrequestAttribute Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestAttribute Constructor
MCrequestAttribute Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrequestAttribute()
Visual Basic
Public Sub New
Visual C++
public:
MCrequestAttribute()

See Also

MCrequestAttribute Class
MCrequestAttribute Members
Mergecomws.Web Namespace


MCrequestAttribute Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestAttribute Methods
MCrequestAttribute Class See Also Send Feedback

The MCrequestAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a deep copy of MCrequestAttribute object
Public method | Contains | Checks if MCrequestAttribute object or its children contain MCrequestAttribute with a given tag
Public method | CreateMCattribute | Creates MCattribute object from internal data
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeAttributes | Merges the internal data of MCrequestAttribute source with the data of MCrequestAttribute destination object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCrequestAttribute Class
Mergecomws.Web Namespace


Clone Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestAttribute..::..Clone Method
MCrequestAttribute Class See Also Send Feedback
Returns a deep copy of MCrequestAttribute object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrequestAttribute Clone()
Visual Basic
Public Function Clone As MCrequestAttribute
Visual C++
public:
MCrequestAttribute^ Clone()

Return Value

MCrequestAttribute object

See Also

MCrequestAttribute Class
MCrequestAttribute Members
Mergecomws.Web Namespace


Contains Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestAttribute..::..Contains Method
MCrequestAttribute Class See Also Send Feedback
Checks if MCrequestAttribute object or its children contain MCrequestAttribute with a given tag

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public bool Contains(
    uint tag
)
Visual Basic
Public Function Contains ( _
    tag As UInteger _
) As Boolean
Visual C++
public:
bool Contains(
    unsigned int tag
)

Parameters

tag
Type: System..::..UInt32
DICOM attribute tag

Return Value

Returns True if MCrequestAttribute object or its children contain MCrequestAttribute with a given tag

See Also

MCrequestAttribute Class
MCrequestAttribute Members
Mergecomws.Web Namespace


CreateMCattribute Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestAttribute..::..CreateMCattribute Method
MCrequestAttribute Class See Also Send Feedback
Creates MCattribute object from internal data

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCattribute CreateMCattribute(
    string privateCode
)
Visual Basic
Public Function CreateMCattribute ( _
    privateCode As String _
) As MCattribute
Visual C++
public:
MCattribute^ CreateMCattribute(
    String^ privateCode
)

Parameters

privateCode
Type: System..::..String
Creator Code of the private group attribute

Return Value

MCattribute object

See Also

MCrequestAttribute Class
MCrequestAttribute Members
Mergecomws.Web Namespace


MergeAttributes Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestAttribute..::..MergeAttributes Method
MCrequestAttribute Class See Also Send Feedback
Merges the internal data of MCrequestAttribute source with the data of MCrequestAttribute destination object.

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static bool MergeAttributes(
    MCrequestAttribute dst,
    MCrequestAttribute src
)
Visual Basic
Public Shared Function MergeAttributes ( _
    dst As MCrequestAttribute, _
    src As MCrequestAttribute _
) As Boolean
Visual C++
public:
static bool MergeAttributes(
    MCrequestAttribute^ dst,
    MCrequestAttribute^ src
)

Parameters

dst
Type: Mergecomws.Web..::..MCrequestAttribute
MCrequestAttribute destination object
src
Type: Mergecomws.Web..::..MCrequestAttribute
MCrequestAttribute source object

Return Value

true if the merge operation succeeds, false otherwise.

See Also

MCrequestAttribute Class
MCrequestAttribute Members
Mergecomws.Web Namespace


MCrequestAttribute Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestAttribute Properties
MCrequestAttribute Class See Also Send Feedback

The MCrequestAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Children | Gets a list of MCrequestAttribute children which belong to MCrequestAttribute object
Public property | Extensions | Gets and sets the list of String user defined values
Public property | Item | DICOM keyword alias
Public property | Keyword | DICOM keyword
Public property | Tag | DICOM attribute tag
Public property | Values | Gets and sets the list of String values

See Also

MCrequestAttribute Class
Mergecomws.Web Namespace


Children Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestAttribute..::..Children Property
MCrequestAttribute Class See Also Send Feedback
Gets a list of MCrequestAttribute children which belong to MCrequestAttribute object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public List<MCrequestAttribute> Children { get; private set; }
Visual Basic
Public Property Children As List(Of MCrequestAttribute)
    Get
    Private Set
Visual C++
public:
property List<MCrequestAttribute^>^ Children {
    List<MCrequestAttribute^>^ get ();
    private: void set (List<MCrequestAttribute^>^ value);
}

See Also

MCrequestAttribute Class
MCrequestAttribute Members
Mergecomws.Web Namespace


Extensions Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestAttribute..::..Extensions Property
MCrequestAttribute Class See Also Send Feedback
Gets and sets the list of String user defined values

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public IEnumerable<string> Extensions { get; set; }
Visual Basic
Public Property Extensions As IEnumerable(Of String)
    Get
    Set
Visual C++
public:
property IEnumerable<String^>^ Extensions {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}

See Also

MCrequestAttribute Class
MCrequestAttribute Members
Mergecomws.Web Namespace


Item Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestAttribute..::..Item Property
MCrequestAttribute Class See Also Send Feedback
DICOM keyword alias

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Item { get; set; }
Visual Basic
Public Property Item As String
    Get
    Set
Visual C++
public:
property String^ Item {
    String^ get ();
    void set (String^ value);
}

See Also

MCrequestAttribute Class
MCrequestAttribute Members
Mergecomws.Web Namespace


Keyword Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestAttribute..::..Keyword Property
MCrequestAttribute Class See Also Send Feedback
DICOM keyword

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Keyword { get; set; }
Visual Basic
Public Property Keyword As String
    Get
    Set
Visual C++
public:
property String^ Keyword {
    String^ get ();
    void set (String^ value);
}

See Also

MCrequestAttribute Class
MCrequestAttribute Members
Mergecomws.Web Namespace


Tag Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestAttribute..::..Tag Property
MCrequestAttribute Class See Also Send Feedback
DICOM attribute tag

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public uint Tag { get; set; }
Visual Basic
Public Property Tag As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Tag {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

MCrequestAttribute Class
MCrequestAttribute Members
Mergecomws.Web Namespace


Values Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestAttribute..::..Values Property
MCrequestAttribute Class See Also Send Feedback
Gets and sets the list of String values

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public IEnumerable<string> Values { get; set; }
Visual Basic
Public Property Values As IEnumerable(Of String)
    Get
    Set
Visual C++
public:
property IEnumerable<String^>^ Values {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}

See Also

MCrequestAttribute Class
MCrequestAttribute Members
Mergecomws.Web Namespace


MCrequestBinder Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestBinder Class
Members See Also Send Feedback
Implements IModelBinder interface

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCrequestBinder : IModelBinder
Visual Basic
Public Class MCrequestBinder _
    Implements IModelBinder
Visual C++
public ref class MCrequestBinder : IModelBinder

Inheritance Hierarchy

System..::..Object
Mergecomws.Web..::..MCrequestBinder

See Also

MCrequestBinder Members
Mergecomws.Web Namespace


MCrequestBinder Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestBinder Members
MCrequestBinder Class Constructors Methods See Also Send Feedback

The MCrequestBinder type exposes the following members.

Constructors

 | Name | Description
Public method | MCrequestBinder | Class constructor

Methods

 | Name | Description
Public method | BindModel | Creates MCrequest object from Http request and binds it to ModelBindingContext
 | CreateInstance | Creates MCrequestBinder object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCrequestBinder Class
Mergecomws.Web Namespace


MCrequestBinder Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestBinder Constructor
MCrequestBinder Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrequestBinder()
Visual Basic
Public Sub New
Visual C++
public:
MCrequestBinder()

See Also

MCrequestBinder Class
MCrequestBinder Members
Mergecomws.Web Namespace


MCrequestBinder Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestBinder Methods
MCrequestBinder Class See Also Send Feedback

The MCrequestBinder type exposes the following members.

Methods

 | Name | Description
Public method | BindModel | Creates MCrequest object from Http request and binds it to ModelBindingContext
 | CreateInstance | Creates MCrequestBinder object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCrequestBinder Class
Mergecomws.Web Namespace


BindModel Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestBinder..::..BindModel Method
MCrequestBinder Class See Also Send Feedback
Creates MCrequest object from Http request and binds it to ModelBindingContext

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public bool BindModel(
    HttpActionContext actionContext,
    ModelBindingContext bindingContext
)
Visual Basic
Public Function BindModel ( _
    actionContext As HttpActionContext, _
    bindingContext As ModelBindingContext _
) As Boolean
Visual C++
public:
virtual bool BindModel(
    HttpActionContext^ actionContext,
    ModelBindingContext^ bindingContext
) sealed

Parameters

actionContext
Type: HttpActionContext
HttpActionContext object
bindingContext
Type: ModelBindingContext
ModelBindingContext object

Return Value

true if model binding is successful; otherwise, false.

Implements

IModelBinderBindModel(HttpActionContext, ModelBindingContext)

See Also

MCrequestBinder Class
MCrequestBinder Members
Mergecomws.Web Namespace


CreateInstance Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestBinder..::..CreateInstance Method
MCrequestBinder Class See Also Send Feedback
Creates MCrequestBinder object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCrequestBinder CreateInstance()
Visual Basic
Public Shared Function CreateInstance As MCrequestBinder
Visual C++
public:
static MCrequestBinder^ CreateInstance()

Return Value

MCrequestBinder object

See Also

MCrequestBinder Class
MCrequestBinder Members
Mergecomws.Web Namespace


MCrequestBinderProvider Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestBinderProvider Class
Members See Also Send Feedback
Implements ModelBinderProvider methods

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCrequestBinderProvider : ModelBinderProvider
Visual Basic
Public Class MCrequestBinderProvider _
    Inherits ModelBinderProvider
Visual C++
public ref class MCrequestBinderProvider : public ModelBinderProvider

Inheritance Hierarchy

System..::..Object
ModelBinderProvider
Mergecomws.Web..::..MCrequestBinderProvider

See Also

MCrequestBinderProvider Members
Mergecomws.Web Namespace


MCrequestBinderProvider Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestBinderProvider Members
MCrequestBinderProvider Class Constructors Methods See Also Send Feedback

The MCrequestBinderProvider type exposes the following members.

Constructors

 | Name | Description
Public method | MCrequestBinderProvider | Initializes a new instance of the MCrequestBinderProvider class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBinder | Creates IModelBinder object (Overrides ModelBinderProviderGetBinder(HttpConfiguration, Type).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCrequestBinderProvider Class
Mergecomws.Web Namespace


MCrequestBinderProvider Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestBinderProvider Constructor
MCrequestBinderProvider Class See Also Send Feedback
Initializes a new instance of the MCrequestBinderProvider class

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrequestBinderProvider()
Visual Basic
Public Sub New
Visual C++
public:
MCrequestBinderProvider()

See Also

MCrequestBinderProvider Class
MCrequestBinderProvider Members
Mergecomws.Web Namespace


MCrequestBinderProvider Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestBinderProvider Methods
MCrequestBinderProvider Class See Also Send Feedback

The MCrequestBinderProvider type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBinder | Creates IModelBinder object (Overrides ModelBinderProviderGetBinder(HttpConfiguration, Type).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCrequestBinderProvider Class
Mergecomws.Web Namespace


GetBinder Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestBinderProvider..::..GetBinder Method
MCrequestBinderProvider Class See Also Send Feedback
Creates IModelBinder object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override IModelBinder GetBinder(
    HttpConfiguration configuration,
    Type modelType
)
Visual Basic
Public Overrides Function GetBinder ( _
    configuration As HttpConfiguration, _
    modelType As Type _
) As IModelBinder
Visual C++
public:
virtual IModelBinder^ GetBinder(
    HttpConfiguration^ configuration,
    Type^ modelType
) override

Parameters

configuration
Type: HttpConfiguration
HttpConfiguration object
modelType
Type: System..::..Type
Type of model object

Return Value

A model binder implementing IModelBinder.

See Also

MCrequestBinderProvider Class
MCrequestBinderProvider Members
Mergecomws.Web Namespace


MCrequestType Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType Class
Members See Also Send Feedback
Describes DICOM request type

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCrequestType
Visual Basic
Public Class MCrequestType
Visual C++
public ref class MCrequestType

Inheritance Hierarchy

System..::..Object
Mergecomws.Web..::..MCrequestType

See Also

MCrequestType Members
Mergecomws.Web Namespace


MCrequestType Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType Members
MCrequestType Class Methods Fields Properties See Also Send Feedback

The MCrequestType type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Checks if MCrequestType object is equal to Object (Overrides Object..::..Equals(Object).)
Public method | Equals(MCrequestType) | Checks if MCrequestType objects are equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode of MCrequestType object (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
Qido | Qido MCrequestType
RsCapabilities | RS Capabilities MCrequestType
RsNpi | Qido MCrequestType
Stow | Stow MCrequestType
StowCommitment | Stow CommitmentMCrequestType
Unknown | Unknown MCrequestType
UpsRS | UpsRS MCrequestType
WadoRS | WadoRS MCrequestType
WadoURI | WadoURI MCrequestType
WadoWS | WadoWS MCrequestType

Properties

 | Name | Description
Public property | Name | Gets MCrequestType Name, might be "WADOURI", "WADORS", "WADOWS", "STOW", "QIDO", "RSCAPABILITIES", "QIDO" or "UNKNOWN"

See Also

MCrequestType Class
Mergecomws.Web Namespace


MCrequestType Fields

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType Fields
MCrequestType Class See Also Send Feedback

The MCrequestType type exposes the following members.

Fields

Name | Description
Qido | Qido MCrequestType
RsCapabilities | RS Capabilities MCrequestType
RsNpi | Qido MCrequestType
Stow | Stow MCrequestType
StowCommitment | Stow CommitmentMCrequestType
Unknown | Unknown MCrequestType
UpsRS | UpsRS MCrequestType
WadoRS | WadoRS MCrequestType
WadoURI | WadoURI MCrequestType
WadoWS | WadoWS MCrequestType

See Also

MCrequestType Class
Mergecomws.Web Namespace


Qido Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType..::..Qido Field
MCrequestType Class See Also Send Feedback
Qido MCrequestType

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCrequestType Qido
Visual Basic
Public Shared Qido As MCrequestType
Visual C++
public:
static MCrequestType^ Qido

See Also

MCrequestType Class
MCrequestType Members
Mergecomws.Web Namespace


RsCapabilities Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType..::..RsCapabilities Field
MCrequestType Class See Also Send Feedback
RS Capabilities MCrequestType

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCrequestType RsCapabilities
Visual Basic
Public Shared RsCapabilities As MCrequestType
Visual C++
public:
static MCrequestType^ RsCapabilities

See Also

MCrequestType Class
MCrequestType Members
Mergecomws.Web Namespace


RsNpi Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType..::..RsNpi Field
MCrequestType Class See Also Send Feedback
Qido MCrequestType

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCrequestType RsNpi
Visual Basic
Public Shared RsNpi As MCrequestType
Visual C++
public:
static MCrequestType^ RsNpi

See Also

MCrequestType Class
MCrequestType Members
Mergecomws.Web Namespace


Stow Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType..::..Stow Field
MCrequestType Class See Also Send Feedback
Stow MCrequestType

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCrequestType Stow
Visual Basic
Public Shared Stow As MCrequestType
Visual C++
public:
static MCrequestType^ Stow

See Also

MCrequestType Class
MCrequestType Members
Mergecomws.Web Namespace


StowCommitment Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType..::..StowCommitment Field
MCrequestType Class See Also Send Feedback
Stow CommitmentMCrequestType

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCrequestType StowCommitment
Visual Basic
Public Shared StowCommitment As MCrequestType
Visual C++
public:
static MCrequestType^ StowCommitment

See Also

MCrequestType Class
MCrequestType Members
Mergecomws.Web Namespace


Unknown Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType..::..Unknown Field
MCrequestType Class See Also Send Feedback
Unknown MCrequestType

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCrequestType Unknown
Visual Basic
Public Shared Unknown As MCrequestType
Visual C++
public:
static MCrequestType^ Unknown

See Also

MCrequestType Class
MCrequestType Members
Mergecomws.Web Namespace


UpsRS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType..::..UpsRS Field
MCrequestType Class See Also Send Feedback
UpsRS MCrequestType

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCrequestType UpsRS
Visual Basic
Public Shared UpsRS As MCrequestType
Visual C++
public:
static MCrequestType^ UpsRS

See Also

MCrequestType Class
MCrequestType Members
Mergecomws.Web Namespace


WadoRS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType..::..WadoRS Field
MCrequestType Class See Also Send Feedback
WadoRS MCrequestType

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCrequestType WadoRS
Visual Basic
Public Shared WadoRS As MCrequestType
Visual C++
public:
static MCrequestType^ WadoRS

See Also

MCrequestType Class
MCrequestType Members
Mergecomws.Web Namespace


WadoURI Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType..::..WadoURI Field
MCrequestType Class See Also Send Feedback
WadoURI MCrequestType

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCrequestType WadoURI
Visual Basic
Public Shared WadoURI As MCrequestType
Visual C++
public:
static MCrequestType^ WadoURI

See Also

MCrequestType Class
MCrequestType Members
Mergecomws.Web Namespace


WadoWS Field

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType..::..WadoWS Field
MCrequestType Class See Also Send Feedback
WadoWS MCrequestType

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public static MCrequestType WadoWS
Visual Basic
Public Shared WadoWS As MCrequestType
Visual C++
public:
static MCrequestType^ WadoWS

See Also

MCrequestType Class
MCrequestType Members
Mergecomws.Web Namespace


MCrequestType Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType Methods
MCrequestType Class See Also Send Feedback

The MCrequestType type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | Checks if MCrequestType object is equal to Object (Overrides Object..::..Equals(Object).)
Public method | Equals(MCrequestType) | Checks if MCrequestType objects are equal
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode of MCrequestType object (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MCrequestType Class
Mergecomws.Web Namespace


Equals Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType..::..Equals Method
MCrequestType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Checks if MCrequestType object is equal to Object (Overrides Object..::..Equals(Object).)
Public method | Equals(MCrequestType) | Checks if MCrequestType objects are equal

See Also

MCrequestType Class
MCrequestType Members
Mergecomws.Web Namespace


Equals Method (Object)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType..::..Equals Method (Object)
MCrequestType Class See Also Send Feedback
Checks if MCrequestType object is equal to Object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare with the current object.

Return Value

Returns True if objects are equal

See Also

MCrequestType Class
MCrequestType Members
Equals Overload
Mergecomws.Web Namespace


Equals Method (MCrequestType)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType..::..Equals Method (MCrequestType)
MCrequestType Class See Also Send Feedback
Checks if MCrequestType objects are equal

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public bool Equals(
    MCrequestType rqt
)
Visual Basic
Public Function Equals ( _
    rqt As MCrequestType _
) As Boolean
Visual C++
public:
bool Equals(
    MCrequestType^ rqt
)

Parameters

rqt
Type: Mergecomws.Web..::..MCrequestType
The MCrequestType object to compare with the current object.

Return Value

Returns True if objects Name are the same

See Also

MCrequestType Class
MCrequestType Members
Equals Overload
Mergecomws.Web Namespace


GetHashCode Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType..::..GetHashCode Method
MCrequestType Class See Also Send Feedback
Gets the hashcode of MCrequestType object

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

Returns a hashcode generated from Name

See Also

MCrequestType Class
MCrequestType Members
Mergecomws.Web Namespace


MCrequestType Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType Properties
MCrequestType Class See Also Send Feedback

The MCrequestType type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets MCrequestType Name, might be "WADOURI", "WADORS", "WADOWS", "STOW", "QIDO", "RSCAPABILITIES", "QIDO" or "UNKNOWN"

See Also

MCrequestType Class
Mergecomws.Web Namespace


Name Property

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrequestType..::..Name Property
MCrequestType Class See Also Send Feedback
Gets MCrequestType Name, might be "WADOURI", "WADORS", "WADOWS", "STOW", "QIDO", "RSCAPABILITIES", "QIDO" or "UNKNOWN"

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set
Visual C++
public:
property String^ Name {
    String^ get ();
    private: void set (String^ value);
}

See Also

MCrequestType Class
MCrequestType Members
Mergecomws.Web Namespace


MCrsCapabilitiesController Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesController Class
Members See Also Send Feedback
Implements Http Get methods for DICOM QIDO-RS requests

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCrsCapabilitiesController : MCcontroller
Visual Basic
Public Class MCrsCapabilitiesController _
    Inherits MCcontroller
Visual C++
public ref class MCrsCapabilitiesController : public MCcontroller

Inheritance Hierarchy

System..::..Object
ApiController
Mergecomws.Web..::..MCcontroller
Mergecomws.Web..::..MCrsCapabilitiesController

See Also

MCrsCapabilitiesController Members
Mergecomws.Web Namespace


MCrsCapabilitiesController Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesController Members
MCrsCapabilitiesController Class Constructors Methods Properties See Also Send Feedback

The MCrsCapabilitiesController type exposes the following members.

Constructors

 | Name | Description
Public method | MCrsCapabilitiesController | Class constructor

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Public method | Options(HttpRequestMessage) | Http Options method
Public method | Options(MCrequest) | Http Options method
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCrsCapabilitiesController Class
Mergecomws.Web Namespace


MCrsCapabilitiesController Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesController Constructor
MCrsCapabilitiesController Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrsCapabilitiesController()
Visual Basic
Public Sub New
Visual C++
public:
MCrsCapabilitiesController()

See Also

MCrsCapabilitiesController Class
MCrsCapabilitiesController Members
Mergecomws.Web Namespace


MCrsCapabilitiesController Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesController Methods
MCrsCapabilitiesController Class See Also Send Feedback

The MCrsCapabilitiesController type exposes the following members.

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Public method | Options(HttpRequestMessage) | Http Options method
Public method | Options(MCrequest) | Http Options method
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

See Also

MCrsCapabilitiesController Class
Mergecomws.Web Namespace


Options Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesController..::..Options Method
MCrsCapabilitiesController Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Options(HttpRequestMessage) | Http Options method
Public method | Options(MCrequest) | Http Options method

See Also

MCrsCapabilitiesController Class
MCrsCapabilitiesController Members
Mergecomws.Web Namespace


Options Method (HttpRequestMessage)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesController..::..Options Method (HttpRequestMessage)
MCrsCapabilitiesController Class See Also Send Feedback
Http Options method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Options(
    HttpRequestMessage request
)
Visual Basic
Public Function Options ( _
    request As HttpRequestMessage _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Options(
    HttpRequestMessage^ request
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

HttpResponseMessage object

See Also

MCrsCapabilitiesController Class
MCrsCapabilitiesController Members
Options Overload
Mergecomws.Web Namespace


Options Method (MCrequest)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesController..::..Options Method (MCrequest)
MCrsCapabilitiesController Class See Also Send Feedback
Http Options method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Options(
    MCrequest request
)
Visual Basic
Public Function Options ( _
    request As MCrequest _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Options(
    MCrequest^ request
)

Parameters

request
Type: Mergecomws.Web..::..MCrequest
MCrequest oject

Return Value

HttpResponseMessage object

See Also

MCrsCapabilitiesController Class
MCrsCapabilitiesController Members
Options Overload
Mergecomws.Web Namespace


MCrsCapabilitiesController Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsCapabilitiesController Properties
MCrsCapabilitiesController Class See Also Send Feedback

The MCrsCapabilitiesController type exposes the following members.

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCrsCapabilitiesController Class
Mergecomws.Web Namespace


MCrsNpiController Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiController Class
Members See Also Send Feedback
Implements Http Post methods for DICOM STOW-RS requests

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCrsNpiController : MCcontroller
Visual Basic
Public Class MCrsNpiController _
    Inherits MCcontroller
Visual C++
public ref class MCrsNpiController : public MCcontroller

Inheritance Hierarchy

System..::..Object
ApiController
Mergecomws.Web..::..MCcontroller
Mergecomws.Web..::..MCrsNpiController

See Also

MCrsNpiController Members
Mergecomws.Web Namespace


MCrsNpiController Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiController Members
MCrsNpiController Class Constructors Methods Properties See Also Send Feedback

The MCrsNpiController type exposes the following members.

Constructors

 | Name | Description
Public method | MCrsNpiController | Class constructor

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(HttpRequestMessage) | Http Get method
Public method | Get(HttpRequestMessage, String) | Http Get method
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Public method | Options | Http Options method
Public method | Post(HttpRequestMessage) | Http Post method
Public method | Post(HttpRequestMessage, String) | Http Post method
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCrsNpiController Class
Mergecomws.Web Namespace


MCrsNpiController Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiController Constructor
MCrsNpiController Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCrsNpiController()
Visual Basic
Public Sub New
Visual C++
public:
MCrsNpiController()

See Also

MCrsNpiController Class
MCrsNpiController Members
Mergecomws.Web Namespace


MCrsNpiController Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiController Methods
MCrsNpiController Class See Also Send Feedback

The MCrsNpiController type exposes the following members.

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(HttpRequestMessage) | Http Get method
Public method | Get(HttpRequestMessage, String) | Http Get method
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Public method | Options | Http Options method
Public method | Post(HttpRequestMessage) | Http Post method
Public method | Post(HttpRequestMessage, String) | Http Post method
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

See Also

MCrsNpiController Class
Mergecomws.Web Namespace


Get Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiController..::..Get Method
MCrsNpiController Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get(HttpRequestMessage) | Http Get method
Public method | Get(HttpRequestMessage, String) | Http Get method

See Also

MCrsNpiController Class
MCrsNpiController Members
Mergecomws.Web Namespace


Get Method (HttpRequestMessage)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiController..::..Get Method (HttpRequestMessage)
MCrsNpiController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    HttpRequestMessage request
)
Visual Basic
Public Function Get ( _
    request As HttpRequestMessage _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    HttpRequestMessage^ request
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

HttpResponseMessage object

See Also

MCrsNpiController Class
MCrsNpiController Members
Get Overload
Mergecomws.Web Namespace


Get Method (HttpRequestMessage, String)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiController..::..Get Method (HttpRequestMessage, String)
MCrsNpiController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    HttpRequestMessage request,
    string sopInstanceUid
)
Visual Basic
Public Function Get ( _
    request As HttpRequestMessage, _
    sopInstanceUid As String _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    HttpRequestMessage^ request,
    String^ sopInstanceUid
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object
sopInstanceUid
Type: System..::..String
SopInstanceUID parameter

Return Value

HttpResponseMessage object

See Also

MCrsNpiController Class
MCrsNpiController Members
Get Overload
Mergecomws.Web Namespace


Options Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiController..::..Options Method
MCrsNpiController Class See Also Send Feedback
Http Options method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Options(
    HttpRequestMessage request
)
Visual Basic
Public Function Options ( _
    request As HttpRequestMessage _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Options(
    HttpRequestMessage^ request
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

HttpResponseMessage object

See Also

MCrsNpiController Class
MCrsNpiController Members
Mergecomws.Web Namespace


Post Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiController..::..Post Method
MCrsNpiController Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Post(HttpRequestMessage) | Http Post method
Public method | Post(HttpRequestMessage, String) | Http Post method

See Also

MCrsNpiController Class
MCrsNpiController Members
Mergecomws.Web Namespace


Post Method (HttpRequestMessage)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiController..::..Post Method (HttpRequestMessage)
MCrsNpiController Class See Also Send Feedback
Http Post method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Post(
    HttpRequestMessage request
)
Visual Basic
Public Function Post ( _
    request As HttpRequestMessage _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Post(
    HttpRequestMessage^ request
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

HttpResponseMessage object

See Also

MCrsNpiController Class
MCrsNpiController Members
Post Overload
Mergecomws.Web Namespace


Post Method (HttpRequestMessage, String)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiController..::..Post Method (HttpRequestMessage, String)
MCrsNpiController Class See Also Send Feedback
Http Post method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Post(
    HttpRequestMessage request,
    string sopInstanceUid
)
Visual Basic
Public Function Post ( _
    request As HttpRequestMessage, _
    sopInstanceUid As String _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Post(
    HttpRequestMessage^ request,
    String^ sopInstanceUid
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object
sopInstanceUid
Type: System..::..String
SopInstanceUID parameter

Return Value

HttpResponseMessage object

See Also

MCrsNpiController Class
MCrsNpiController Members
Post Overload
Mergecomws.Web Namespace


MCrsNpiController Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCrsNpiController Properties
MCrsNpiController Class See Also Send Feedback

The MCrsNpiController type exposes the following members.

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCrsNpiController Class
Mergecomws.Web Namespace


MCstowController Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowController Class
Members See Also Send Feedback
Implements Http Post methods for DICOM STOW-RS requests

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCstowController : MCcontroller
Visual Basic
Public Class MCstowController _
    Inherits MCcontroller
Visual C++
public ref class MCstowController : public MCcontroller

Inheritance Hierarchy

System..::..Object
ApiController
Mergecomws.Web..::..MCcontroller
Mergecomws.Web..::..MCstowController

See Also

MCstowController Members
Mergecomws.Web Namespace


MCstowController Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowController Members
MCstowController Class Constructors Methods Properties See Also Send Feedback

The MCstowController type exposes the following members.

Constructors

 | Name | Description
Public method | MCstowController | Class constructor

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCommitment | Http Get method
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Public method | Post(HttpRequestMessage) | Http Post method
Public method | Post(MCrequest) | Http Post method
Public method | Post(HttpRequestMessage, String) | Http Post method
Public method | PostCommitment | Http Post method
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCstowController Class
Mergecomws.Web Namespace


MCstowController Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowController Constructor
MCstowController Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCstowController()
Visual Basic
Public Sub New
Visual C++
public:
MCstowController()

See Also

MCstowController Class
MCstowController Members
Mergecomws.Web Namespace


MCstowController Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowController Methods
MCstowController Class See Also Send Feedback

The MCstowController type exposes the following members.

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCommitment | Http Get method
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Public method | Post(HttpRequestMessage) | Http Post method
Public method | Post(MCrequest) | Http Post method
Public method | Post(HttpRequestMessage, String) | Http Post method
Public method | PostCommitment | Http Post method
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

See Also

MCstowController Class
Mergecomws.Web Namespace


GetCommitment Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowController..::..GetCommitment Method
MCstowController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage GetCommitment(
    HttpRequestMessage request
)
Visual Basic
Public Function GetCommitment ( _
    request As HttpRequestMessage _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ GetCommitment(
    HttpRequestMessage^ request
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

HttpResponseMessage object

See Also

MCstowController Class
MCstowController Members
Mergecomws.Web Namespace


Post Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowController..::..Post Method
MCstowController Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Post(HttpRequestMessage) | Http Post method
Public method | Post(MCrequest) | Http Post method
Public method | Post(HttpRequestMessage, String) | Http Post method

See Also

MCstowController Class
MCstowController Members
Mergecomws.Web Namespace


Post Method (HttpRequestMessage)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowController..::..Post Method (HttpRequestMessage)
MCstowController Class See Also Send Feedback
Http Post method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Post(
    HttpRequestMessage request
)
Visual Basic
Public Function Post ( _
    request As HttpRequestMessage _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Post(
    HttpRequestMessage^ request
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

HttpResponseMessage object

See Also

MCstowController Class
MCstowController Members
Post Overload
Mergecomws.Web Namespace


Post Method (MCrequest)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowController..::..Post Method (MCrequest)
MCstowController Class See Also Send Feedback
Http Post method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Post(
    MCrequest request
)
Visual Basic
Public Function Post ( _
    request As MCrequest _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Post(
    MCrequest^ request
)

Parameters

request
Type: Mergecomws.Web..::..MCrequest
MCrequest oject

Return Value

HttpResponseMessage object

See Also

MCstowController Class
MCstowController Members
Post Overload
Mergecomws.Web Namespace


Post Method (HttpRequestMessage, String)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowController..::..Post Method (HttpRequestMessage, String)
MCstowController Class See Also Send Feedback
Http Post method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Post(
    HttpRequestMessage request,
    string studyInstanceUid
)
Visual Basic
Public Function Post ( _
    request As HttpRequestMessage, _
    studyInstanceUid As String _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Post(
    HttpRequestMessage^ request,
    String^ studyInstanceUid
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object
studyInstanceUid
Type: System..::..String
StudyInstanceUID parameter

Return Value

HttpResponseMessage object

See Also

MCstowController Class
MCstowController Members
Post Overload
Mergecomws.Web Namespace


PostCommitment Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowController..::..PostCommitment Method
MCstowController Class See Also Send Feedback
Http Post method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage PostCommitment(
    HttpRequestMessage request
)
Visual Basic
Public Function PostCommitment ( _
    request As HttpRequestMessage _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ PostCommitment(
    HttpRequestMessage^ request
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

HttpResponseMessage object

See Also

MCstowController Class
MCstowController Members
Mergecomws.Web Namespace


MCstowController Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCstowController Properties
MCstowController Class See Also Send Feedback

The MCstowController type exposes the following members.

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCstowController Class
Mergecomws.Web Namespace


MCupsController Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsController Class
Members See Also Send Feedback
Implements Http Post, Get, Put and Delete methods for DICOM UPS-RS requests

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCupsController : MCcontroller
Visual Basic
Public Class MCupsController _
    Inherits MCcontroller
Visual C++
public ref class MCupsController : public MCcontroller

Inheritance Hierarchy

System..::..Object
ApiController
Mergecomws.Web..::..MCcontroller
Mergecomws.Web..::..MCupsController

See Also

MCupsController Members
Mergecomws.Web Namespace


MCupsController Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsController Members
MCupsController Class Constructors Methods Properties See Also Send Feedback

The MCupsController type exposes the following members.

Constructors

 | Name | Description
Public method | MCupsController | Class constructor

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Delete | Http Delete method
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Http Get method
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Public method | Post(HttpRequestMessage) | Http Post method
Public method | Post(MCrequest) | Http Post method
Public method | Put | Http Put method
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCupsController Class
Mergecomws.Web Namespace


MCupsController Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsController Constructor
MCupsController Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCupsController()
Visual Basic
Public Sub New
Visual C++
public:
MCupsController()

See Also

MCupsController Class
MCupsController Members
Mergecomws.Web Namespace


MCupsController Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsController Methods
MCupsController Class See Also Send Feedback

The MCupsController type exposes the following members.

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Delete | Http Delete method
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Http Get method
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Public method | Post(HttpRequestMessage) | Http Post method
Public method | Post(MCrequest) | Http Post method
Public method | Put | Http Put method
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

See Also

MCupsController Class
Mergecomws.Web Namespace


Delete Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsController..::..Delete Method
MCupsController Class See Also Send Feedback
Http Delete method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Delete(
    HttpRequestMessage request
)
Visual Basic
Public Function Delete ( _
    request As HttpRequestMessage _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Delete(
    HttpRequestMessage^ request
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

HttpResponseMessage object

See Also

MCupsController Class
MCupsController Members
Mergecomws.Web Namespace


Get Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsController..::..Get Method
MCupsController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    HttpRequestMessage request
)
Visual Basic
Public Function Get ( _
    request As HttpRequestMessage _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    HttpRequestMessage^ request
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

HttpResponseMessage object

See Also

MCupsController Class
MCupsController Members
Mergecomws.Web Namespace


Post Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsController..::..Post Method
MCupsController Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Post(HttpRequestMessage) | Http Post method
Public method | Post(MCrequest) | Http Post method

See Also

MCupsController Class
MCupsController Members
Mergecomws.Web Namespace


Post Method (HttpRequestMessage)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsController..::..Post Method (HttpRequestMessage)
MCupsController Class See Also Send Feedback
Http Post method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Post(
    HttpRequestMessage request
)
Visual Basic
Public Function Post ( _
    request As HttpRequestMessage _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Post(
    HttpRequestMessage^ request
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

HttpResponseMessage object

See Also

MCupsController Class
MCupsController Members
Post Overload
Mergecomws.Web Namespace


Post Method (MCrequest)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsController..::..Post Method (MCrequest)
MCupsController Class See Also Send Feedback
Http Post method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Post(
    MCrequest request
)
Visual Basic
Public Function Post ( _
    request As MCrequest _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Post(
    MCrequest^ request
)

Parameters

request
Type: Mergecomws.Web..::..MCrequest
MCrequest oject

Return Value

HttpResponseMessage object

See Also

MCupsController Class
MCupsController Members
Post Overload
Mergecomws.Web Namespace


Put Method

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsController..::..Put Method
MCupsController Class See Also Send Feedback
Http Put method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Put(
    HttpRequestMessage request
)
Visual Basic
Public Function Put ( _
    request As HttpRequestMessage _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Put(
    HttpRequestMessage^ request
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

HttpResponseMessage object

See Also

MCupsController Class
MCupsController Members
Mergecomws.Web Namespace


MCupsController Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCupsController Properties
MCupsController Class See Also Send Feedback

The MCupsController type exposes the following members.

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCupsController Class
Mergecomws.Web Namespace


MCwadoRsController Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsController Class
Members See Also Send Feedback
Implements Http Get methods for DICOM WADO-RS requests

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCwadoRsController : MCcontroller
Visual Basic
Public Class MCwadoRsController _
    Inherits MCcontroller
Visual C++
public ref class MCwadoRsController : public MCcontroller

Inheritance Hierarchy

System..::..Object
ApiController
Mergecomws.Web..::..MCcontroller
Mergecomws.Web..::..MCwadoRsController

See Also

MCwadoRsController Members
Mergecomws.Web Namespace


MCwadoRsController Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsController Members
MCwadoRsController Class Constructors Methods Properties See Also Send Feedback

The MCwadoRsController type exposes the following members.

Constructors

 | Name | Description
Public method | MCwadoRsController | Class constructor

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(HttpRequestMessage) | Http Get method
Public method | Get(MCrequest) | Http Get method
Public method | Get(HttpRequestMessage, String) | Http Get method
Public method | Get(HttpRequestMessage, Uri) | Http Get method
Public method | Get(HttpRequestMessage, String, Object) | Http Get method
Public method | Get(HttpRequestMessage, String, String) | Http Get method
Public method | Get(HttpRequestMessage, String, String, String) | Http Get method
Public method | Get(HttpRequestMessage, String, String, String, String) | Http Get method
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCwadoRsController Class
Mergecomws.Web Namespace


MCwadoRsController Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsController Constructor
MCwadoRsController Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCwadoRsController()
Visual Basic
Public Sub New
Visual C++
public:
MCwadoRsController()

See Also

MCwadoRsController Class
MCwadoRsController Members
Mergecomws.Web Namespace


MCwadoRsController Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsController Methods
MCwadoRsController Class See Also Send Feedback

The MCwadoRsController type exposes the following members.

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(HttpRequestMessage) | Http Get method
Public method | Get(MCrequest) | Http Get method
Public method | Get(HttpRequestMessage, String) | Http Get method
Public method | Get(HttpRequestMessage, Uri) | Http Get method
Public method | Get(HttpRequestMessage, String, Object) | Http Get method
Public method | Get(HttpRequestMessage, String, String) | Http Get method
Public method | Get(HttpRequestMessage, String, String, String) | Http Get method
Public method | Get(HttpRequestMessage, String, String, String, String) | Http Get method
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

See Also

MCwadoRsController Class
Mergecomws.Web Namespace


Get Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsController..::..Get Method
MCwadoRsController Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get(HttpRequestMessage) | Http Get method
Public method | Get(MCrequest) | Http Get method
Public method | Get(HttpRequestMessage, String) | Http Get method
Public method | Get(HttpRequestMessage, Uri) | Http Get method
Public method | Get(HttpRequestMessage, String, Object) | Http Get method
Public method | Get(HttpRequestMessage, String, String) | Http Get method
Public method | Get(HttpRequestMessage, String, String, String) | Http Get method
Public method | Get(HttpRequestMessage, String, String, String, String) | Http Get method

See Also

MCwadoRsController Class
MCwadoRsController Members
Mergecomws.Web Namespace


Get Method (HttpRequestMessage)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsController..::..Get Method (HttpRequestMessage)
MCwadoRsController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    HttpRequestMessage request
)
Visual Basic
Public Function Get ( _
    request As HttpRequestMessage _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    HttpRequestMessage^ request
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

HttpResponseMessage object

See Also

MCwadoRsController Class
MCwadoRsController Members
Get Overload
Mergecomws.Web Namespace


Get Method (MCrequest)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsController..::..Get Method (MCrequest)
MCwadoRsController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    MCrequest request
)
Visual Basic
Public Function Get ( _
    request As MCrequest _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    MCrequest^ request
)

Parameters

request
Type: Mergecomws.Web..::..MCrequest
MCrequest oject

Return Value

HttpResponseMessage object

See Also

MCwadoRsController Class
MCwadoRsController Members
Get Overload
Mergecomws.Web Namespace


Get Method (HttpRequestMessage, String)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsController..::..Get Method (HttpRequestMessage, String)
MCwadoRsController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    HttpRequestMessage request,
    string studyInstanceUid
)
Visual Basic
Public Function Get ( _
    request As HttpRequestMessage, _
    studyInstanceUid As String _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    HttpRequestMessage^ request,
    String^ studyInstanceUid
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object
studyInstanceUid
Type: System..::..String
StudyInstanceUID parameter

Return Value

HttpResponseMessage object

See Also

MCwadoRsController Class
MCwadoRsController Members
Get Overload
Mergecomws.Web Namespace


Get Method (HttpRequestMessage, Uri)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsController..::..Get Method (HttpRequestMessage, Uri)
MCwadoRsController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    HttpRequestMessage request,
    Uri uri
)
Visual Basic
Public Function Get ( _
    request As HttpRequestMessage, _
    uri As Uri _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    HttpRequestMessage^ request,
    Uri^ uri
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object
uri
Type: System..::..Uri
URI for bulk data

Return Value

HttpResponseMessage object

See Also

MCwadoRsController Class
MCwadoRsController Members
Get Overload
Mergecomws.Web Namespace


Get Method (HttpRequestMessage, String, Object)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsController..::..Get Method (HttpRequestMessage, String, Object)
MCwadoRsController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    HttpRequestMessage request,
    string studyInstanceUid,
    Object metadata
)
Visual Basic
Public Function Get ( _
    request As HttpRequestMessage, _
    studyInstanceUid As String, _
    metadata As Object _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    HttpRequestMessage^ request,
    String^ studyInstanceUid,
    Object^ metadata
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object
studyInstanceUid
Type: System..::..String
StudyInstanceUID parameter
metadata
Type: System..::..Object
Metadata parameter, might be null

Return Value

HttpResponseMessage object

See Also

MCwadoRsController Class
MCwadoRsController Members
Get Overload
Mergecomws.Web Namespace


Get Method (HttpRequestMessage, String, String)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsController..::..Get Method (HttpRequestMessage, String, String)
MCwadoRsController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    HttpRequestMessage request,
    string studyInstanceUid,
    string seriesInstanceUid
)
Visual Basic
Public Function Get ( _
    request As HttpRequestMessage, _
    studyInstanceUid As String, _
    seriesInstanceUid As String _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    HttpRequestMessage^ request,
    String^ studyInstanceUid,
    String^ seriesInstanceUid
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object
studyInstanceUid
Type: System..::..String
StudyInstanceUID parameter
seriesInstanceUid
Type: System..::..String
SeriesInstanceUID parameter

Return Value

HttpResponseMessage object

See Also

MCwadoRsController Class
MCwadoRsController Members
Get Overload
Mergecomws.Web Namespace


Get Method (HttpRequestMessage, String, String, String)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsController..::..Get Method (HttpRequestMessage, String, String, String)
MCwadoRsController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    HttpRequestMessage request,
    string studyInstanceUid,
    string seriesInstanceUid,
    string sopInstanceUid
)
Visual Basic
Public Function Get ( _
    request As HttpRequestMessage, _
    studyInstanceUid As String, _
    seriesInstanceUid As String, _
    sopInstanceUid As String _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    HttpRequestMessage^ request,
    String^ studyInstanceUid,
    String^ seriesInstanceUid,
    String^ sopInstanceUid
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object
studyInstanceUid
Type: System..::..String
StudyInstanceUID parameter
seriesInstanceUid
Type: System..::..String
SeriesInstanceUID parameter
sopInstanceUid
Type: System..::..String
SopInstanceUID parameter

Return Value

HttpResponseMessage object

See Also

MCwadoRsController Class
MCwadoRsController Members
Get Overload
Mergecomws.Web Namespace


Get Method (HttpRequestMessage, String, String, String, String)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsController..::..Get Method (HttpRequestMessage, String, String, String, String)
MCwadoRsController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    HttpRequestMessage request,
    string studyInstanceUid,
    string seriesInstanceUid,
    string sopInstanceUid,
    string frameList
)
Visual Basic
Public Function Get ( _
    request As HttpRequestMessage, _
    studyInstanceUid As String, _
    seriesInstanceUid As String, _
    sopInstanceUid As String, _
    frameList As String _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    HttpRequestMessage^ request,
    String^ studyInstanceUid,
    String^ seriesInstanceUid,
    String^ sopInstanceUid,
    String^ frameList
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object
studyInstanceUid
Type: System..::..String
StudyInstanceUID parameter
seriesInstanceUid
Type: System..::..String
SeriesInstanceUID parameter
sopInstanceUid
Type: System..::..String
SopInstanceUID parameter
frameList
Type: System..::..String
SimpleFrameList parameter

Return Value

HttpResponseMessage object

See Also

MCwadoRsController Class
MCwadoRsController Members
Get Overload
Mergecomws.Web Namespace


MCwadoRsController Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoRsController Properties
MCwadoRsController Class See Also Send Feedback

The MCwadoRsController type exposes the following members.

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCwadoRsController Class
Mergecomws.Web Namespace


MCwadoUriController Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriController Class
Members See Also Send Feedback
Implements Http Get methods for DICOM WADO-URI requests

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCwadoUriController : MCcontroller
Visual Basic
Public Class MCwadoUriController _
    Inherits MCcontroller
Visual C++
public ref class MCwadoUriController : public MCcontroller

Inheritance Hierarchy

System..::..Object
ApiController
Mergecomws.Web..::..MCcontroller
Mergecomws.Web..::..MCwadoUriController

See Also

MCwadoUriController Members
Mergecomws.Web Namespace


MCwadoUriController Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriController Members
MCwadoUriController Class Constructors Methods Properties See Also Send Feedback

The MCwadoUriController type exposes the following members.

Constructors

 | Name | Description
Public method | MCwadoUriController | Class constructor

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(HttpRequestMessage) | Http Get method
Public method | Get(MCrequest) | Http Get method
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCwadoUriController Class
Mergecomws.Web Namespace


MCwadoUriController Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriController Constructor
MCwadoUriController Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCwadoUriController()
Visual Basic
Public Sub New
Visual C++
public:
MCwadoUriController()

See Also

MCwadoUriController Class
MCwadoUriController Members
Mergecomws.Web Namespace


MCwadoUriController Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriController Methods
MCwadoUriController Class See Also Send Feedback

The MCwadoUriController type exposes the following members.

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(HttpRequestMessage) | Http Get method
Public method | Get(MCrequest) | Http Get method
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

See Also

MCwadoUriController Class
Mergecomws.Web Namespace


Get Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriController..::..Get Method
MCwadoUriController Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get(HttpRequestMessage) | Http Get method
Public method | Get(MCrequest) | Http Get method

See Also

MCwadoUriController Class
MCwadoUriController Members
Mergecomws.Web Namespace


Get Method (HttpRequestMessage)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriController..::..Get Method (HttpRequestMessage)
MCwadoUriController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    HttpRequestMessage request
)
Visual Basic
Public Function Get ( _
    request As HttpRequestMessage _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    HttpRequestMessage^ request
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

HttpResponseMessage object

See Also

MCwadoUriController Class
MCwadoUriController Members
Get Overload
Mergecomws.Web Namespace


Get Method (MCrequest)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriController..::..Get Method (MCrequest)
MCwadoUriController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Get(
    MCrequest request
)
Visual Basic
Public Function Get ( _
    request As MCrequest _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Get(
    MCrequest^ request
)

Parameters

request
Type: Mergecomws.Web..::..MCrequest
MCrequest oject

Return Value

HttpResponseMessage object

See Also

MCwadoUriController Class
MCwadoUriController Members
Get Overload
Mergecomws.Web Namespace


MCwadoUriController Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoUriController Properties
MCwadoUriController Class See Also Send Feedback

The MCwadoUriController type exposes the following members.

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCwadoUriController Class
Mergecomws.Web Namespace


MCwadoWsController Class

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsController Class
Members See Also Send Feedback
Implements Http Get methods for DICOM WADO-WS requests

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public class MCwadoWsController : MCcontroller
Visual Basic
Public Class MCwadoWsController _
    Inherits MCcontroller
Visual C++
public ref class MCwadoWsController : public MCcontroller

Inheritance Hierarchy

System..::..Object
ApiController
Mergecomws.Web..::..MCcontroller
Mergecomws.Web..::..MCwadoWsController

See Also

MCwadoWsController Members
Mergecomws.Web Namespace


MCwadoWsController Members

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsController Members
MCwadoWsController Class Constructors Methods Properties See Also Send Feedback

The MCwadoWsController type exposes the following members.

Constructors

 | Name | Description
Public method | MCwadoWsController | Class constructor

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Public method | Post(HttpRequestMessage) | Http Post method
Public method | Post(MCrequest) | Http Get method
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCwadoWsController Class
Mergecomws.Web Namespace


MCwadoWsController Constructor

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsController Constructor
MCwadoWsController Class See Also Send Feedback
Class constructor

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public MCwadoWsController()
Visual Basic
Public Sub New
Visual C++
public:
MCwadoWsController()

See Also

MCwadoWsController Class
MCwadoWsController Members
Mergecomws.Web Namespace


MCwadoWsController Methods

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsController Methods
MCwadoWsController Class See Also Send Feedback

The MCwadoWsController type exposes the following members.

Methods

 | Name | Description
Protected method | BadRequest()()()() | (Inherited from ApiController.)
Protected method | BadRequest(String) | (Inherited from ApiController.)
Protected method | BadRequest(ModelStateDictionary) | (Inherited from ApiController.)
Protected method | Conflict | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, String) | (Inherited from ApiController.)
Protected method | Content``1(HttpStatusCode, UMP, MediaTypeFormatter, MediaTypeHeaderValue) | (Inherited from ApiController.)
Protected method | Created``1(String, UMP) | (Inherited from ApiController.)
Protected method | Created``1(Uri, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, Object, UMP) | (Inherited from ApiController.)
Protected method | CreatedAtRoute``1(String, IDictionary<(Of <<'(String, Object>)>>), UMP) | (Inherited from ApiController.)
Public method | Dispose()()()() | (Inherited from ApiController.)
Protected method | Dispose(Boolean) | (Inherited from ApiController.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAsync | (Inherited from ApiController.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | (Inherited from ApiController.)
Protected method | InternalServerError()()()() | (Inherited from ApiController.)
Protected method | InternalServerError(Exception) | (Inherited from ApiController.)
Protected method | Json``1(UMP) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings) | (Inherited from ApiController.)
Protected method | Json``1(UMP, JsonSerializerSettings, Encoding) | (Inherited from ApiController.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotFound | (Inherited from ApiController.)
Protected method | Ok()()()() | (Inherited from ApiController.)
Protected method | Ok``1(UMP) | (Inherited from ApiController.)
Public method | Post(HttpRequestMessage) | Http Post method
Public method | Post(MCrequest) | Http Get method
Protected method | Redirect(String) | (Inherited from ApiController.)
Protected method | Redirect(Uri) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, Object) | (Inherited from ApiController.)
Protected method | RedirectToRoute(String, IDictionary<(Of <<'(String, Object>)>>)) | (Inherited from ApiController.)
Protected method | ResponseMessage | (Inherited from ApiController.)
Protected method | StatusCode | (Inherited from ApiController.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unauthorized(array<AuthenticationHeaderValue>[]()[][]) | (Inherited from ApiController.)
Protected method | Unauthorized(IEnumerable<(Of <<'(AuthenticationHeaderValue>)>>)) | (Inherited from ApiController.)
Public method | Validate``1(UMP) | (Inherited from ApiController.)
Public method | Validate``1(UMP, String) | (Inherited from ApiController.)

See Also

MCwadoWsController Class
Mergecomws.Web Namespace


Post Method

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsController..::..Post Method
MCwadoWsController Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Post(HttpRequestMessage) | Http Post method
Public method | Post(MCrequest) | Http Get method

See Also

MCwadoWsController Class
MCwadoWsController Members
Mergecomws.Web Namespace


Post Method (HttpRequestMessage)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsController..::..Post Method (HttpRequestMessage)
MCwadoWsController Class See Also Send Feedback
Http Post method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Post(
    HttpRequestMessage request
)
Visual Basic
Public Function Post ( _
    request As HttpRequestMessage _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Post(
    HttpRequestMessage^ request
)

Parameters

request
Type: HttpRequestMessage
HttpRequestMessage object

Return Value

HttpResponseMessage object

See Also

MCwadoWsController Class
MCwadoWsController Members
Post Overload
Mergecomws.Web Namespace


Post Method (MCrequest)

[image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsController..::..Post Method (MCrequest)
MCwadoWsController Class See Also Send Feedback
Http Get method

Namespace: Mergecomws.Web
Assembly: Mergecomws (in Mergecomws.dll) Version: 5.20.0.0 (5.20.0.0)

Syntax

C#
public HttpResponseMessage Post(
    MCrequest request
)
Visual Basic
Public Function Post ( _
    request As MCrequest _
) As HttpResponseMessage
Visual C++
public:
HttpResponseMessage^ Post(
    MCrequest^ request
)

Parameters

request
Type: Mergecomws.Web..::..MCrequest
MCrequest oject

Return Value

HttpResponseMessage object

See Also

MCwadoWsController Class
MCwadoWsController Members
Post Overload
Mergecomws.Web Namespace


MCwadoWsController Properties

[image] [image]

Merge DICOM Web Services .NET/C# Toolkit
MCwadoWsController Properties
MCwadoWsController Class See Also Send Feedback

The MCwadoWsController type exposes the following members.

Properties

 | Name | Description
Public property | ActionContext | (Inherited from ApiController.)
Public property | Configuration | (Inherited from ApiController.)
Public property | ControllerContext | (Inherited from ApiController.)
Public property | ModelState | (Inherited from ApiController.)
Public property | Name | Get/Set the name of the specific controller (see derived classes). (Inherited from MCcontroller.)
Public property | Request | (Inherited from ApiController.)
Public property | RequestContext | (Inherited from ApiController.)
Public property | Url | (Inherited from ApiController.)
Public property | User | (Inherited from ApiController.)

See Also

MCwadoWsController Class
Mergecomws.Web Namespace